(Topic ID: 172247)

BTTF Issues


By Hammerhead

3 years ago



Topic Stats

  • 9 posts
  • 2 Pinsiders participating
  • Latest reply 2 years ago by Hammerhead
  • Topic is favorited by 1 Pinsider

You

Linked Games

#1 3 years ago

I was replacing the bulbs in the backbox with LEDs and now approximately half of the bulbs and flashers don't work. Not sure what happened.

Also, the previous owner replaced the alpha-numeric display, and I've noticed that the 1/4 amp fuse at F3 of the PS board is missing. Is this an issue?

#2 3 years ago
Quoted from Hammerhead:

Also, the previous owner replaced the alpha-numeric display, and I've noticed that the 1/4 amp fuse at F3 of the PS board is missing. Is this an issue?

Is the replacement display LED? If so, the 1/4 amp fuse was removed since the high voltage circuit is no longer used.

1 week later
#3 3 years ago

It is an XPin display, so I guess those are LED, right?

#4 3 years ago
Quoted from Hammerhead:

It is an XPin display, so I guess those are LED, right?

Yep, XPin = LED.

Did you check the fuses on the PPB?

Looks like this..
http://www.marcospecialties.com//images/products/520-5021-00/large.jpg

#5 3 years ago

I just checked and F4 on the PPB board is blown, but I have no spare 5A SB fuses. That said, if it was a bad fuse I would expect no backbox lights to work, but as it is half the bulbs work.

#6 3 years ago
Quoted from Hammerhead:

I just checked and F4 on the PPB board is blown, but I have no spare 5A SB fuses. That said, if it was a bad fuse I would expect no backbox lights to work, but as it is half the bulbs work.

Backbox GI might be split between two fuses? I'd tell you to try swapping one of the other 5A fuses from the fuse holders in there, but whatever caused the fuse to blow in the first place could still be present? So it might blow another fuse and you'd have more lights out

1 week later
#7 3 years ago

Changing the fuse made no difference.

The MPU board has the remnants of a lot of alkaline corrosion. I was hoping that past repairs had isolated it, but it doesn't look like it (see my other thread), and I expect that also has something to do with the backbox lighting.

Looks like a new MPU board is in my future

1 month later
#8 2 years ago

Just finished installing the new MPU board and while it fixed my other issues, the backbox lighting still has not been corrected.

2 months later
#9 2 years ago

Ended up replacing the power driver board as it was hacked to hell - everything back up and running.

Now if I could only get the backglass to come down fully so it doesn't partially block the displays - needs to come down another 1/2"

Promoted items from the Pinside Marketplace
From: $ 18.00
Apparel - Men
Pinside Shop
4,200
Machine - For Sale
Orange Park, FL
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
From: $ 19.99
From: $ 40.00
Lighting - Interactive
Professor Pinball
$ 24.00
$ 10.00
Cabinet - Sound/Speakers
Gweem's Mods
From: $ 16.95
From: $ 20.00
Cabinet - Other
Rock Custom Pinball
From: $ 9.99
Eproms
Matt's Basement Arcade
$ 9.99
Eproms
Matt's Basement Arcade
$ 22.00
From: $ 20.00
Playfield - Toys/Add-ons
ModFather Pinball Mods
$ 22.00
Electronics
Yorktown Parts and Equip
$ 40.99
Lighting - Interactive
Lee's Parts

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside