BSD Mistball Opto Issues

(Topic ID: 213749)

BSD Mistball Opto Issues


By HighTower

4 months ago



Topic Stats

  • 5 posts
  • 5 Pinsiders participating
  • Latest reply 4 months ago by pinmike
  • Topic is favorited by 2 Pinsiders

You

Linked Games

Topic Gallery

There have been 5 images uploaded to this topic. (View topic image gallery).

20180403_003450 (resized).jpg
20180403_003453 (resized).jpg
20180403_003458 (resized).jpg
20180403_003501 (resized).jpg
20180403_003505 (resized).jpg

#1 4 months ago

So I finished the playfield part of my resto of a BS Dracula on 1 April and it fired up with "no errors" and played well (April fools on me for thinking no issues were to come)

After an hour or so of intermitent play the mistball multiball started acting weird and Id get multiball for no apparent reason. Games would cut short then next game I'd get 2 balls straight up.

After running a full test I got a unload error for magnet/mistball.

I started googling and checking here...Ive been through all the tests everyone suggests and it seems to be the long opto beam. Its active when it shouldnt be.

Ive tried the tv remote trick and mobile phone camera to check both sender and receiver optos are working and they appear to be but the long mistball opto beam seems to think there is a ball there when there isnt...and yes Ive removed the gates to avoid any interference. It was working fine one minute, gone haywire the next so Im stumped. Also cleaned all the optos out and they are sparkling clean.

Also at the same time Ive had some flipper switches go a bit weird now showing issues when testing but when I manually test these in the single switch test mode they all seem to work fine, Im guessing maybe related to the opto issue? The coincidence is rather odd.

Ive attached some pics of the other switch issues besides the long opto beam for mist ball.

Anyhelp would be much appreciated.

20180403_003505 (resized).jpg

20180403_003501 (resized).jpg

20180403_003458 (resized).jpg

20180403_003453 (resized).jpg

20180403_003450 (resized).jpg

#2 4 months ago

If you found all that, you probably ran across the 24 opto board. Chances are, that's your issue.

https://www.johns-arcade.com/product-page/a-15646-24-opto-board-wms-bram-stokers-dracula

#3 4 months ago

The one thing both those issues would have in common is the opto supply voltage so I would check that.

#4 4 months ago
Quoted from terryb:

The one thing both those issues would have in common is the opto supply voltage so I would check that.

If LED7 is off, you can test TP1, which should be 13v or higher. If not, then test F116 to see if it is blown.

#5 4 months ago

Also,Power off the game and try reseating the connectors on the Fliptronics board(in backbox)..Flipper boards for left and right flippers(under playfield one board on the right and one board on the left)..And the opto board(under playfield).

Promoted items from the Pinside Marketplace
$ 28.00
$ 12.95
€ 95.00
Lighting - Led
FlipperLED
$ 128.00
Playfield - Other
ModFather Pinball Mods
$ 999.00
Flipper Parts
Mircoplayfields
$ 209.99
From: $ 99.99
Cabinet - Other
Lighted Pinball Mods
$ 159.99
$ 5.00
$ 45.99
Lighting - Interactive
Lee's Parts
$ 90.00
Lighting - Under Cabinet
Rock Custom Pinball
$ 129.00
Lighting - Led
LED OCD
3,000 (Firm)
Sale Pending!
Wellfleet, MA
From: $ 16.95
$ 5.00
From: $ 79.99
Playfield - Toys/Add-ons
Medisinyl Mods
2,000 (Firm)
Machine - For Sale
Bagnatica, LOMBARDIA
From: $ 24.99
Lighting - Led
Lee's Parts
From: $ 369.95
Boards
PinSound
From: $ 9.95
Playfield - Toys/Add-ons
ULEKstore
$ 229.99
$ 29.99
Cabinet - Sound/Speakers
Lighted Pinball Mods
From: $ 29.00
Boards
KAHR.US Circuits
$ 29.99
Cabinet - Sound/Speakers
Lighted Pinball Mods
Hey modders!
Your shop name here

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside