(Topic ID: 58977)

BSD, mist multiball and strange ground issue


By systemlcp

6 years ago



Topic Stats

  • 17 posts
  • 9 Pinsiders participating
  • Latest reply 6 years ago by systemlcp
  • Topic is favorited by 4 Pinsiders

You

Linked Games

Topic Gallery

One image has been uploaded to this topic. (View topic image gallery).

a.JPG.jpeg

#1 6 years ago

Picked up BSD with some issues, got most worked out. Only thing left is the magnet for the mist multiball is being weird. I replaced all the optos as they were old and yellowed, afterwards I got the unload test to carry the ball all the way across and back to the middle before dropping the ball once. Now it just makes it half way and drops it for the unload. for the load ball test nothing happens. Going to start rebuilding the boards under the PF unless someone has a more pointed suggestion.

Also, occasionally if I have the glass off and happen to touch to metal parts at the same time, like the rail and the metal ramp, I get shocked. Looked all over for a grounded out wire but haven't found one yet.

#2 6 years ago

hi system,check pinball rehab he did a vid on mist ball test maybe that will help you out also try to google the problem.look on you tube for bram stokers Dracula repair. for the ground prob. check the cord does it have a grnd. pin? is the outlet it's plugged into grounded? check cont.between the grnd.pin on the cord and grnd. in the game. g.l. joe

#3 6 years ago

Can you be more specific when you say 'nothing happens'? If the 'unload' works chances are darn near everything in the Mist system is working fine. The unload process basically uses every component of Mist with maybe the except of one of the gates opening and it's corresponding OPto.

The unload test 'should' drop the ball in about the middle

Make sure the 2 OPs that detect which side the ball is on are working in the switch test menu

My best guess would be there's a problem with the mist harness or possibly the OPto opposite the said of the unload test. There might be a break in the hardness and possibly still making a connection until the motor hits a certain point...or in your case the right side gate for 'load'

#4 6 years ago

Happened to mine and it was a wire inside the cable that was faulty. Easy to check continuity there first before re building boards. Sometimes it would make it all the way across, sometimes not as the connection was intermittent

Pete

#5 6 years ago

The shocking is likely something touching a coil lug hot, could be the bracket the coil sits on, which I have seen a couple times with the coil is turned in the bracket. Your arm across the rail grounds this an completes the path.

As for mist not loading, does the shooter lane up/down ramp work right?

#6 6 years ago

nothing happens = after it unloads the ball and get to the load magnet test, instead of a ball poping out and the ramp lifting up to fire a ball up to the shooter lane side opto, it just sits there doing nothing. The ramp lifts and when you fire the game up so I don't think it's bad.

As for the shock issue, I found a coil that has partially unwound, but nothing else (see pic) would this cause the issue?

a.JPG.jpeg

#7 6 years ago

also,
If I put it in switch test in the menu and block the optos with my finger the ball holder one seems to open and close, but the long range opto (one on each side of the PF) doesn't show any activity when I block it. I've already replaced the emitter and receiver.

#8 6 years ago
Quoted from systemlcp:

also,
the long range opto (one on each side of the PF) doesn't show any activity when I block it. I've already replaced the emitter and receiver.

I had the same problems, replaced the optos first too, just like you. The L1 inductor on the long range opto board is known to be flaky and/or disconnect. Make sure to check that. Replacements are cheap (http://www.mouser.com/ProductDetail/Fastron/11P-103J-50/?qs=3%2fphUcBLEfYP2myhlJxBuUUG3Wp%252bHNZwB8RgLrLg3l4%3d). I replaced mine and it fixed the problems for a while, but it eventually failed again. After that I broke down and purchased the redesigned board made by Homepin. Haven't had any problems since.

Here are some threads documenting my troubles:

http://pinside.com/pinball/forum/topic/bsd-opto-assembly
http://pinside.com/pinball/forum/topic/another-bsd-mist-help-thread

#9 6 years ago

Awesome, was just reading about L1 in the pinrehab article. Ordered the homepin board, I'll let y'all know if that resolves it.

Can someone chime in on that pic of the unwinding coil? would that cause my electro shock issue (only seems to happen when I touch two metal objects on the PF, i.e. rails + metal ramp, etc.

#10 6 years ago

The homepin board is quality, should solve your problems.

As for the electrical issues, I'm not an expert by any means, but a coil is just wire wrapped around a spool. Unless the insulation has been compromised and the wire is touching something metal, I don't see how that is causing your electrical issues.

#11 6 years ago

you can't really tell from the picture but, the coil wire that has loosened up is touching the metal bracket behind it. Ordering a new one. I'll be back if that homepin board doesn't do the trick.

#12 6 years ago
Quoted from systemlcp:

you can't really tell from the picture but, the coil wire that has loosened up is touching the metal bracket behind it. Ordering a new one. I'll be back if that homepin board doesn't do the trick.

The insulation has probably worn off the coil wire, and is shorting to the bracket. Pull the coil. Wrap with electrical tape. Reinstall.
--
Chris Hibler - CARGPB #31
http://www.Team-EM.com
http://webpages.charter.net/chibler/Pinball/index.htm
http://www.PinWiki.com - The new place for pinball repair info

#13 6 years ago

The homepin board is excellent , it fixed my intermittant mist ball issue .

#14 6 years ago

Sweet, that worked for the stuff on the left side. Then I found one of the wires from the launcher solenoid was touching the bracket for the stuff on the right side. Now just have to wait on that card and see if it resolves my issue with the long opto. I'll replace L1 and test it (to keep as a spare) on the existing card to confirm that was the issue as well.

2 weeks later
#15 6 years ago

Home pin board resolved my issue. Still have to figure out why the castle lock 2 opto is going off randomly though, about to replace the opts up there since they're the only one's I haven't.

#16 6 years ago

awesome!

1 week later
#17 6 years ago

Fixed the castle opto, connector in the wrong place on the cpu board.
Plays perfect, only remaining issue is the coil for the 1 drop target in the game fires 3-4 times randomly even though the target comes up on the 1st fire. new microswitch didn't resolve the issue. only happens when you complete video mode anyway so not that often...

Promoted items from the Pinside Marketplace
From: $ 130.20
Cabinet - Sound/Speakers
PinWoofer
Wanted
Machine - Wanted
Upper Freehold, NJ
From: $ 24.99
Lighting - Led
Lee's Parts

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside