(Topic ID: 262816)

BSD flipper has no holding power


By supermatt

3 months ago



Topic Stats

  • 28 posts
  • 7 Pinsiders participating
  • Latest reply 62 days ago by supermatt
  • No one calls this topic a favorite

You

Linked Games

Topic Gallery

There have been 3 images uploaded to this topic. (View topic image gallery).

683721A3-9B6F-473B-BE76-F93987891D2D (resized).jpeg
57121B88-EF7B-41B4-9942-EA3FF1DF8116 (resized).jpeg
996AC61C-2DF0-450A-877B-AA45FCB937DA (resized).jpeg

#1 3 months ago

The right flipper on my Dracula will not stay up and cradle a ball. I have searched the forum for ideas on what can be causing it. I have checked solder joints on cabinet and eos switches and all seem fine. Fuse is good too. The only thing I tried was to reverse the wiring on the eos switch because it looked like it didn't match the other flipper but that didn't do anything. This game also has leaf switches substituted for cabinet opto switches. I've had the same problem on other games before but it's always been just a popped off wire or bad solder joint. Any other ideas what I can try? Thanks

#2 3 months ago

Forget EOS.

Most likely the problem lies at the coil lugs. Broken wire or cold solder joint to coil lug. Or the thin wire from the coil itself to the coil lug has a crack or break - dig around them to find.

Could be a bad coil too.

LTG : )

#3 3 months ago

Thanks Lloyd, I did check the coil lugs as well and all the joints seemed ok but I will definitely take a lot closer look at them tomorrow.

#4 3 months ago

You could swap the left and right flipper coils. If problem moves then you know it's the coil.

LTG : )

#5 3 months ago

Check that you don't have a cracked diode or broken leg too.

LTG : )

#6 3 months ago

Thanks, I will

#7 3 months ago

POST DELETED * MY BAD ADVICE HAS BEEN CORRECTED BELOW * (Thank you, ltg)

#8 3 months ago
Quoted from Gogojohnnyquack:

What does the switch test say for the EOS? Have you cleaned the EOS?

His game is fliptronics. EOS has nothing to do with his problem.

Quoted from Gogojohnnyquack:

It's not the transistor since it is the same for both the high and low power windings on the coil,

Not on fliptronics. One for power one for hold.

LTG : )

#9 3 months ago

Check the coil stop while you're swapping the coils.

#10 3 months ago
Quoted from Billc479:

Check the coil stop while you're swapping the coils.

Had already checked that before and it was fine. I’m going to dig into it more tonight

#11 3 months ago
Quoted from supermatt:

Had already checked that before and it was fine. I’m going to dig into it more tonight

I don't think he was suggesting it was the problem, just that if you had it apart you might as well swap it.

I'm willing to be this is a bad coil.

#12 3 months ago

<TL:DR>

I would approach this problem by trying to determine where the failure in the system is. It is easier to find that failure if the normal operation of the system is understood.

There are (at least) five parts to the system.

1) The flipper cabinet buttons (leaf or opt).
2) The drive transistors for the power stroke and the hold stroke (fliptronic board).
3) The solenoid that creates the magnetic field corresponding to the power stroke and the hold stroke (FL-15411).
4) The wiring connecting all the components (wires and ribbon cable).
5) The (CPU) program logic connecting the inputs (switches) to the outputs (drive transistors).

Each of these parts can be tested to determine the source of the problem.

1) Enter tests and select T1 (switch edges). Press the flipper cabinet buttons and ensure the program logic detects the switch closures.
2) Enter tests and select T12 (flippers). Make sure the test is either RUNNING or REPEAT (if repeat advance manually).
3) Measure resistance across the solenoid lugs to ensure that the resistance is in the appropriate range. BSD should be FL-15411. The power wiring should have a resistance around 4 Ohms. The hold wiring should have a resistance around the 100+ (from memory) Ohm range.
4) Continuity between the appropriate points should be measured to check wiring.
5) This is unlikely because if this were the problem you'd have bigger issues than you're reporting.

Based on your description of the power stroke functioning but the hold stroke not functioning it's more than likely to be electrical. Check the drive transistor (TIP102) on the Fliptronic board. Test T12 should also confirm this.

Notice that I did NOT mention the EOS. It has nothing to do with powering the hold stroke. The EOS is used to re-enable the power stroke if necessary.

</TL:DR>

#13 3 months ago

Got around to swapping the coils tonight and the problem didn't follow so I guess this rules out a bad coil. I did run the T12 flipper test and that played out as just what's happening. Power and hold work on the left and just power and no hold on the right. I guess I'll start looking closer at the fliptronic board. Any other ideas?

#14 3 months ago
Quoted from supermatt:

I'll start looking closer at the fliptronic board. Any other ideas?

Find the hold transistor. Then check traces and solder joints from it's legs to the connector.

LTG : )

#15 3 months ago
Quoted from supermatt:

Any other ideas?

If nothing obvious on the board. Try swapping the one from your Getaway in it, so you know board issue or wiring from fliptronics board to the coil.

LTG : )

#16 3 months ago

I did pull the board a couple of days ago and didn't see anything obvious but I will check again and also try swapping the boards to see if that does anything. Thanks

#17 3 months ago

I tried swapping the fliptronic boards tonight. First when removing the board from Dracula I did see a couple of spots of what looks like solder splash on the traces. Would that be enough to cause the flipper problem? Second, after putting Getaway board in Dracula I started it up and it wouldn’t boot and the DMD was just a half screen of solid dots. This same thing happened the first time I took the board out a few days ago but after reseating some connectors it corrected itself. No such luck tonight though. Here are some pics of the solder spots and the DMD. What can I try?

57121B88-EF7B-41B4-9942-EA3FF1DF8116 (resized).jpeg683721A3-9B6F-473B-BE76-F93987891D2D (resized).jpeg996AC61C-2DF0-450A-877B-AA45FCB937DA (resized).jpeg
#18 3 months ago

Solved the dmd issue anyway. One of the ribbon cables wasn't in right. Now just have to figure out this flipper.

#19 3 months ago

So what is the result of the Getaway fliptronic board in your BSD?

#20 3 months ago

Never got a result because when I put it in it had the dmd problem and the game wouldn’t boot. I put the Dracula board back in and that’s when I solved the display problem. I will have to try again. What about solder on traces? Would that cause flipper problem?

#21 3 months ago
Quoted from supermatt:

What about solder on traces? Would that cause flipper problem?

No.

#22 3 months ago

If you have the BSD board out you can just do a diode test on the transistor to at least see if it's measuring "bad". If it measures "bad" then it's bad. If it measures "good" it's not necessarily good.

#23 3 months ago

I did the board swap again today with the Getaway board and the flipper worked correctly. I believe from checking the manuel that Q11 on the board has to do with the right flipper hold power. Testing isn't exactly my strong suit. Can someone walk me through what to do? Thanks

#24 3 months ago
Quoted from supermatt:

Can someone walk me through what to do?

Youtube has short videos on how to check transistors with a meter.

LTG : )

#25 3 months ago

Thanks I will check that out

1 week later
#27 85 days ago

Had a very interesting development occur with this. After reading the guides in the previous post I pulled the board again and tested the transistors. As far as I could tell everything seemed to be in the normal range but the flipper still didn't work. At this point I figured my options were either send out the board to be tested and repaired or just buy a Rottendog replacement board which would most likely be the cheaper option in the end. I decided on going with the replacement board as I thought that would be the easiest option all the way around. The board is on order and last night I tore down a section of the playfield to clean and change some rubbers and bulbs. I put everything back together and called it a night. This morning I figured I would play a game before work and the flipper was functioning normal again. I couldn't believe it. It can't be a result of anything I did last night. So now I have a board coming that I may or may not need but I'm just glad it's working again. Thanks for everyone's help with this.

3 weeks later
#28 62 days ago

Just wanted to bring some closure to this thread. The original board working correctly again was very short lived. Maybe a couple of days before it went back to the flipper not holding. I installed the Rottendog board and it's been working perfect ever since. At least I still have the original board and can have it repaired in the future when more convenient. Thanks

Promoted items from the Pinside Marketplace
Wanted
Machine - Wanted
Asheville, NC
$ 279.95
Lighting - Led
Pin Stadium Pinball LEDs
$ 9.99
Eproms
Matt's Basement Arcade
From: $ 233.10
$ 999.00
Flipper Parts
Mircoplayfields
From: $ 24.99
Lighting - Led
Lee's Parts
$ 128.00
Playfield - Other
ModFather Pinball Mods
From: $ 18.00
Apparel - Men
Pinside Shop
$ 5.00
From: $ 11.95
Playfield - Toys/Add-ons
ULEKstore
$ 11.00
From: $ 369.95
Boards
PinSound
$ 45.99
Lighting - Interactive
Lee's Parts
From: $ 27.00
Boards
KAHR.US Circuits
$ 50.00
$ 99.00
Playfield - Other
Arcade Upkeep
From: $ 130.20
Cabinet - Sound/Speakers
PinWoofer
$ 279.95
Lighting - Led
Pin Stadium Pinball LEDs
Trade
Machine - For Trade
Rochester, MN
3,500 (OBO)
Machine - For Sale
Winchester, VA
$ 35.00
Cabinet - Other
Arcade Upkeep

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside