(Topic ID: 257332)

BSD Dracula - Launch button wiring photo needed


By Barakawins1

76 days ago



Topic Stats

  • 6 posts
  • 3 Pinsiders participating
  • Latest reply 75 days ago by Barakawins1
  • No one calls this topic a favorite

You

Linked Games

Topic Gallery

One image has been uploaded to this topic. (View topic image gallery).

1623E599-40AD-4618-845F-2E2CBAE8E832 (resized).jpeg

#1 76 days ago

Can anyone verify if this wiring is correct on the ball launch button? If wrong what am I missing?

1623E599-40AD-4618-845F-2E2CBAE8E832 (resized).jpeg
#2 76 days ago

Does the switch work ? Does the light work ? What isn't working ?

You can always check the switch and lamp matrix in the manual for wire colors and position.

LTG : )
Disclaimer : I don't have the game to snap you a picture.

#3 76 days ago

I have the game,it looks fine. As LTG says what is actually wrong? Switches like that do fail. Especially nowadays. They are aging like all of us. lol
Post back and lets get ya fixed up.

#4 76 days ago

After further discovery, I've found that I have an entire column out which includes the launch button switch. I'll have to dive into this tonight. I have a funny
feeling I have a trace on the mpu out. I'll need to perform the switch/column test with a diode. I'll report back when the problem is found.

Any a side note, does anyone recall which IC on the mpu would control Column #3?

#5 76 days ago
Quoted from Barakawins1:

does anyone recall which IC on the mpu would control Column #3?

U20 Columns. LM339's are Rows.

LTG : )

#6 75 days ago

Fixed... Column J206/J207 pin #3 was dead. Bad trace to resistor R70. All good now.

Promoted items from the Pinside Marketplace
$ 128.00
Playfield - Other
ModFather Pinball Mods
3,100 (Firm)
Machine - For Sale
Zamora, CL

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside