(Topic ID: 194506)

Bride of Pinbot - Left flipper woes


By Jodannar

2 years ago



Topic Stats

  • 20 posts
  • 9 Pinsiders participating
  • Latest reply 1 year ago by Deadlander
  • No one calls this topic a favorite

You

Linked Games

Topic Gallery

There have been 3 images uploaded to this topic. (View topic image gallery).

ADD651C8-6C60-4ED9-A02E-AD1657DD17D1 (resized).jpeg
IMG_2671 (resized).JPG
Screen Shot 2017-07-28 at 6.50.49 AM (resized).png

You're currently viewing posts by Pinsider Jodannar.
Click here to go back to viewing the entire thread.

#1 2 years ago

HI All,
I recently acquired a Bride of Pinbot in average condition. Cabinet has been nicely redone, but the play field and ramps need a work. All is registering and working electrically; except the left flipper. Left flipper switch does not register in switch test mode, all other switches register correctly. The left flipper specific fuse is good, and I have replaced it to be sure. At some point in its life, it has had its flipper mechs updated to use the more modern wpc style; i noticed that on the left flipper the EOS switch isn't engaged when the flipper is extended. This would effect the life of the coil, but doesn't explain why the left flipper cabinet switch does not register.
Any ideas? I am stumped.

Thanks in advance

#3 2 years ago

Thanks Fatdirk
I have reseated all the connectors. No change. Flippers are still pre-fliprtonics if that wasn't clear.

#5 2 years ago

No. No flipper operation, no switch registration in switch edge test mode. Coil plunger moves freely by hand.

#7 2 years ago

Had a better look at this tonight without being exhausted. Exhausted brains do not work properly and this is evidence as such. Re-tested fuses, F101 blown. Replaced fuse, flipper button registers, engages coil and blows fuse. Will get diodes and fuses on the weekend, resolver coil and continue. Suspect bad solder join and blown diode on flipper coil.

#12 2 years ago

Replaced coil diodes (yes correct band direction). New fuse; flipper fires on button press and blow fuse immediately. Ideas? All other functions work

#14 2 years ago

No I didn't Travish. Will tonight. It's quite possible with the eos never being engaged due to the wrong pawl on the flipper

IMG_2671 (resized).JPG

#17 2 years ago

I know about the pawl. Stated it's wrong in the first post. Will be replaced with next parts order.

#18 2 years ago

Bingo! Shorted coil. Reading of 1 ohm

Promoted items from the Pinside Marketplace
$ 10.00
Cabinet - Sound/Speakers
Gweem's Mods
$ 209.99
$ 44.95
Playfield - Toys/Add-ons
PinBoss Mods
From: $ 18.00
Apparel - Men
Pinside Shop

You're currently viewing posts by Pinsider Jodannar.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside