(Topic ID: 102693)

Breakshot club, members only...?


By DefaultGen

5 years ago



Topic Stats

  • 536 posts
  • 68 Pinsiders participating
  • Latest reply 9 days ago by Caviel
  • Topic is favorited by 30 Pinsiders

You

Linked Games

Topic Gallery

There have been 159 images uploaded to this topic. (View topic image gallery).

2019-10-22 09_20_26-Breakshot club, members only..._ _ All clubs (...members only!) _ Pinside.com -  (resized).png
088365452374b3173ad2c32176c5b0d15f82a750.jpeg (resized).jpg
2019-10-20 00_49_28-Internet Pinball Machine Database_ Capcom 'Breakshot' Images (resized).png
43A3DBBD-D1A4-48BA-99CF-E72158DDAEE4 (resized).jpeg
IMG_20191015_120851 (resized).jpg
IMG_20191015_120106 (resized).jpg
IMG_20191015_082527 (resized).jpg
75437516-0AFC-4DC8-880E-45B22C77ACBA (resized).jpeg
0023FE7D-5B64-4690-959E-DF17305DA5E6 (resized).jpeg
IMG_20190925_102606 (resized).jpg
15701634690371060323036833947584 (resized).jpg
pasted_image (resized).png
pasted_image (resized).png
2019-09-30 22.41.44 (resized).jpg
2019-09-30 22.40.20 (resized).jpg
2019-09-30 22.41.38 (resized).jpg

There are 536 posts in this topic. You are on page 5 of 11.
#201 1 year ago

http://www.marcospecialties.com/pinball-parts/RC00103-1

Looks like the main description is wrong on the webpage, but it is correct one stating 26 pin in the body of the ad. I'll email Marco about it.

Oops... I forgot that my Pinball Magic is out on loan. Might be a bit tough getting to my friends house to look into other possible sound issues. Was there something you touched earlier to make the sound come on?

#202 1 year ago

No, sound never came on. Don't trouble yourself, I wont be turning back on until new ribbon cable gets here. But I have been Googling the hell outta "Capcom pinball no sound" and have yet to find anything worth a shit.

#203 1 year ago
Quoted from PinballManiac40:

If you have LEDs in the pop bumpers, it will not matter there is thinner gage wire since LEDs draw less current. I have yet to hear of anyone having any issues with thinner gage wire with regular bulbs in any Capcom pin.

It's the fact that they break so easily. The wiring to the sockets is horrible. I replaced them.

#204 1 year ago

So no sound but been playin this all night. Haven't taken glass off for shots yet (yes I took off and cleaned pf goddamnit) but everything seems to be ok. All drops and scoops functioning. Was worried about center post/saucers but so far so good.
This machine rules!

#205 1 year ago
Quoted from Gryszzz:

So no sound but been playin this all night. Haven't taken glass off for shots yet but everything seems to be ok. All drops and scoops functioning. Was worried about center post/saucers but so far so good.
This machine rules!

I love my breakshot... Still haven't gotten mine 100% yet... I have an issue with the kicker and the bankshot switches... I think I'm just going to replace them, as I think its metal fatigue as I can get them to work just fine for about 8-15 minutes... But, then they stop working and need to be adjusted again... Or worse, they'll work sometimes and then not... It's just the switch isn't being pressed down fully... So I am hoping new switches will fix that...

I do have one more minor issue... My machine sometimes restarts after its been on and playing for like 5-15 minutes... Doesn't happen everytime... And once it restarts I can play it for 30-90 minutes without it restarting on me again... Is this something I should worry about... Or is it no big deal.

#206 1 year ago

Does the sound board led blink at all?

There’s diagnostic codes for it.

#207 1 year ago

Dio if you read through this thread you will see, as many have pointed out, that the capacitors on power board are GIGANTIC and too heavy for the vertically mounted board. When they start to loosen, the game resets. But you bring up a valid point. Are there swappable capacitors that are smaller? Since 2 of mine were replaced at some point, I'm "guessing" yes. Not sure. Will defer that question to someone more familiar with Capcom.

#208 1 year ago
Quoted from Boat:

Does the sound board led blink at all?
There’s diagnostic codes for it.

Thanks Boat. Yes, it blinks. I ran the "reset sound board?" diagnostic and it said this:
20180424_180515 (resized).jpg
On a good note, all switches are working and only a few lights out.

#209 1 year ago
Quoted from Gryszzz:

Thanks Boat. Yes, it blinks. I ran the "reset sound board?" diagnostic and it said this:

How many times does the LED on the sound board blink, pause then repeats?

#210 1 year ago

It is a constant pulse. No pausing. Just a steady blinking.

#211 1 year ago

Hmm super odd, pasting the sound board bulletin just in case.

http://pfutz.us/Capcom/bulletin/bul11.htm

#212 1 year ago

Good find, Boat. I'll need to throw that in with my PM manual for future reference.

#213 1 year ago

Later I'll try to figure out how to take a short vid of sound board. Right now it's hot moms in yoga pants time.

#214 1 year ago

Help! Need some good pics of the Power Driver Board wiring from a good working game. Started a topic on it here: https://pinside.com/pinball/forum/topic/breakshot-pd-board-wiring-issue#post-4363122

#215 1 year ago

The new phonebooks are here!
20180426_150705 (resized).jpg
Marco is fast!

#216 1 year ago

Here is a Breakshot promo trade show hat:

a31 (resized).JPG

1 week later
#217 1 year ago

Just joined the club. Is there breakshot custom rule cards out there anywhere. I google searched the normal places but came up empty.

IMG_20180507_202302018 (resized).jpg

#218 1 year ago

Welcome! not that I know of. I have asked my wife to add it to her list of projects. Don't hold your breath!

#219 1 year ago
Quoted from Boat:

Welcome! not that I know of. I have asked my wife to add it to her list of projects. Don't hold your breath!

Actually I found one.

http://www.pinballshark.com/?p=88

#220 1 year ago

Yes, I brought this old dog back to life as well. There was a time that I actually considered cutting my losses but glad I stuck with it. It had a lot of problems and the person before me seemed to be in over their head....put a lot of things back together incorrectly which made things more difficult than they should have been...ugh. I still have a few little things to do and have an order in with Marco to finish things off but I'm playin'! Glad I was able to do this game justice and put it back into circulation...there aren't that many of them out there.

20180502_125615 (resized).jpg

#221 1 year ago

Added LEDs to the GI today. I might go back to incandescent bulbs. The game suits them.

Printing custom cards tomorrow.

IMG_20180508_203038311 (resized).jpg

#222 1 year ago

Try Sunlight leds from Comet. Very close to incandescent.

#223 1 year ago

Sorry if I'm doubling up on a previous post but what ROM version are most guys running? I see a Beta 1.05 and but not sure if it's worth trying?

#224 1 year ago
Quoted from Boat:

New update on this.
Background: The previous owner replaced the large 15000uf filter caps, and still had reset issues. Very intermittent
Heres what I did:
-I tested the BR's and the filter caps, all tested fine
-I replaced the C96 capacitor (you should test yours, this could be the root cause)
- I replaced the LT1084 voltage regulator - still did not fix, and cause more problems
Resolution/Workaround:
- I ended up removing the LT1084 and R408 and R409 resistors, and installing a 5v linear power supply with a molex connector on J3 on the driver board. Power supply plugs into the service box in the cabinet. I keep the cabinet on switch engaged and turn on/off the machine with a power bar.
The game has absolutely no resets now and plays great. I know there are people that frown upon these fixes but replacement boards are very hard to come by and Clive from coin op cauldron mentioned servicing these boards can cost alot! Also, spare parts australia has quite a few boards that are returned and likely not working.
If you don't want to do what I did - I would suggest sending your board to Clive and just eat the cost

I actually spoke with Clive about my game rebooting and was going to send my board in to him but he convinced me to first try the wick trick to connect the front and back traces for the capacitors. He was very busy and was sure my problem was because the capacitors had delaminated and were only intermitently connecting causing reboots. After spending most of the day carefully fixing my board, it worked like a charm! Here's a link with detailed instructions on what I did for those who are interested: https://pinside.com/pinball/forum/topic/capcom-breakshot-capacitor-fix

#225 1 year ago
Quoted from earflaps:

Sorry if I'm doubling up on a previous post but what ROM version are most guys running? I see a Beta 1.05 and but not sure if it's worth trying?

I'm 1.3 which I think is the newest Rom.

#226 1 year ago
Quoted from Diospinball:

I'm 1.3 which I think is the newest Rom.

I have 1.3 as well.

Chris

#227 1 year ago

So I have 1.5 and have noticed the sound bite for extra ball is missing, might be a few others missing, maybe I should get 1.3? Or is the problem in a sound rom? Anybody have any idea?

IMG_1005 (resized).JPG

#228 1 year ago

Sounds like 1.3 is the ROM that's the most stable. I'll burn that one when I get a chance. It has the matching Sound ROM as well I presume?

#229 1 year ago
Quoted from beepnutz:

So I have 1.5 and have noticed the sound bite for extra ball is missing, might be a few others missing, maybe I should get 1.3? Or is the problem in a sound rom? Anybody have any idea?

The v.B.1.5 appears you are running the beta version. Marco shows v1.3 as the latest game ROM and v1.1 sound ROMs.
http://www.marcospecialties.com/pinball-parts/950?S_CAT1=ELEC

There should be printed labels on your sound ROMs so you should be able to tell what you currently have installed.

#230 1 year ago

Does B1.5 have the cutthroat countdown high score board? I know my older version did not. I am rolling 1.3 now and it does.

#231 1 year ago
Quoted from Pinballocks:

Try Sunlight leds from Comet. Very close to incandescent.

sunlight should be nowhere close to incandescent.

#232 1 year ago

If someone in Europe is intrested ... I sell my BS with clearcoated playfield in perfect condition for 3300 Euro.

#233 1 year ago

I'll try this again as I already posted but didn't register for some reason??

What is the purpose of the Redemption and why does version 1.2 seem to be dedicated to it??

#234 1 year ago

CT's retro's were the closest LED to incandescent I could find. I put them in my EM's. They are not perfect but, work.

#235 1 year ago

Mine is running 1.0. is there a difference?
And is it worth upgrading?
Opinions?
Thanks.
This pin is great. It doesn't get the credit it deserves. Having a blast playing it.

#236 1 year ago
Quoted from erak:

Mine is running 1.0. is there a difference?
And is it worth upgrading?
Opinions?
Thanks.
This pin is great. It doesn't get the credit it deserves. Having a blast playing it.

Which chip or what is running 1.0? The game rom is at 4, but there is a sound, and display rom as well. Alll my boards are out for repair or I’d boot the game and see where you can tell

#237 1 year ago
Quoted from northvibe:

Which chip or what is running 1.0? The game rom is at 4, but there is a sound, and display rom as well. Alll my boards are out for repair or I’d boot the game and see where you can tell

All my chips have 1.0.0 stickers. Supposedly it was a huo game, audits have low plays. Not sure if it's true but it does look like it is.
Game is minty.

May upgrade the ROMs if it's worth it. Or it adds anything.

#238 1 year ago
Quoted from erak:

All my chips have 1.0.0 stickers. Supposedly it was a huo game, audits have low plays. Not sure if it's true but it does look like it is.
Game is minty.
May upgrade the ROMs if it's worth it. Or it adds anything.

Oh sorry wrong thread, I thought this was baywatch. I’m not sure what rom version is best but 1.3 is on ipdb

http://www.ipdb.org/search.pl?any=Breakshot&search=Search+Database&searchtype=quick#3784

1 week later
#239 1 year ago

I downloaded the 1.3 ROMs from ipdb. No change log though. Does anyone know what the actual differences are from 1.0 to 1.3.

Still wondering if I should upgrade?

1 week later
#240 1 year ago

Standup Problem:
I haven't seen this posted yet so I'll ask it here. Behind the each set of drop-targets is a single standup target. When I knock down all the drop-targets, the standups don't register once they are hit...and I tried manually pushing them firmly as well. I know they're registering as I am able to easily trigger them in the Diagnostics Switch Test. Any ideas...is it a EPROM thing...I'm running the version 1.0.

#241 1 year ago
Quoted from earflaps:

Standup Problem:

During play the game won't register a stand up target hit unless it knows all the drop targets are down. Sounds like a switch problem on the drop target bank.

#242 1 year ago
Quoted from IN_Pins:

During play the game won't register a stand up target hit unless it knows all the drop targets are down. Sounds like a switch problem on the drop target bank.

Hmmm...never thought of that. I presumed they were all working as I just replaced all my targets and noticed the DMD animation when hitting a drop target, but you're right, it would only take 1 switch in each bank to fail throwing everything out of whack. I'm going to check that at lunch...thanks for the direction IN_Pins.

#243 1 year ago
Quoted from earflaps:

Standup Problem:

Solved:
Yes, there were a couple of broken wires on the Drop-Targets. Of course you have to knock them all down before the Standup Targets will register so stands to reason why my Standups didn't work in game play but worked in the Switch Test.

Kind of a simple problem but it had me stumped. Thanks for providing the direction on where to look first, IN_Pins.

2 weeks later
#244 1 year ago

Hi. I'm wondering if anyone else has come across this?

I have 1.0.0 ROMs and the ferrite ring service bulletin is done.

I still sometimes get the odd "slam" on power up.
A quick power cycle and it's fine. And other times it boots right away.

Is this a old code issue. Or a problem somewhere else?

Suggestions?
Thanks, Eric.

#245 1 year ago
Quoted from erak:

Hi. I'm wondering if anyone else has come across this?
I have 1.0.0 ROMs and the ferrite ring service bulletin is done.
I still sometimes get the odd "slam" on power up.
A quick power cycle and it's fine. And other times it boots right away.
Is this a old code issue. Or a problem somewhere else?
Suggestions?
Thanks, Eric.

That does not sound like a code issue.
Is your slam switch contacts too close on the coin door? I would spread the leaf switch out to be sure.
You can even go into the switch edge test and tap on the coin door to see if it registers and to see if any random switches register after a few minutes.

#246 1 year ago
Quoted from PinballManiac40:

That does not sound like a code issue.
Is your slam switch contacts too close on the coin door? I would spread the leaf switch out to be sure.
You can even go into the switch edge test and tap on the coin door to see if it registers and to see if any random switches register after a few minutes.

Thanks for the reply.

It's not a contact issue whatsoever. It's the slam error on power up that is a known factory bug issue.
Just to be sure even before doing the service mod. Itested all the switches. And checked for any grounding issues.

There is a service bulletin to fix this. I installed the ferrite ring and it's not every time now. Maybe 1 out of 5 times I turn it on. So It did solve the problem intermittent.

But it still happens sometimes when I turn the game on. But it was happening every time on power up. And took a few tries, before I did the bulletin.
Now if it happens, one quick on/off and it's fine.

I'm just wondering if they maybe fixed this in 1.3 code?
Screenshot_20180615-001902 (resized).pngScreenshot_20180615-001910 (resized).png

#247 1 year ago

I service 2 Breakshots for my friends, which their games have v1.0 and never have experienced this issue at power up.

Put the game in switch edge test and let it set for 30 minutes and come back to see if it registered any random intermittent switches. I had to do this on my Pinball Magic to track down an intermittent issue I had in the game. Turned out I had intermittent connectors at J6, J7, J9 at the CPU board on the .100" wired connectors. I was able to wiggle the wires there and cause the issue more often.

1 week later
#248 1 year ago

Hey guys - Not sure if I am allowed to sell in this thread... but I have various capcom parts that I would like to sell. Willing to ship anywhere, buyer pays shipping. I will test any of the boards before I send out. Pm me if you are interested.

A0017703/4 - Breakshot power driver board - Tested works
A0017704 - Breakshot power driver board - "Says it was tested and good in 97... haven't tested yet.

A0015004 - Sound Board - works on all capcom - Haven't tested. Can test

Various mechs pulled from a capcom flipper football, fits most capcom.

A-00153 - 3 bank drop target assembly
A-00155-L - left flipper assembly
A-00155-R - right flipper assembly
A-00476-R Star bumper assembly
A-006540-1 - Slingshot assembly
A-00546-1 Single ball ejector assembly

Added 17 months ago:

All mechs, sound board, and 1 drive board is spoken for. I have one more power driver board that I will likely be posting on the market once I test it.

#249 1 year ago

Pm sent. My Breakshot has actually been turning on first try this week. Normally it's 3-5 tries before it boots. So it plays, just no sound still. I just haven't really played anything but Maiden and ACDC lately.

#250 1 year ago

Gonna buy that sound board, but Boat told me my no sound issue could also be sound roms.
Anyway I can test the roms to see?
I do have a multimeter and I'm only slightly afraid to use it.

Promoted items from the Pinside Marketplace
$ 10.00
Cabinet - Sound/Speakers
Gweem's Mods
From: $ 22.95
Cabinet - Shooter Rods
Super Skill Shot Shop
Wanted
Machine - Wanted
Phoenix, AZ
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
From: $ 18.00
Apparel - Men
Pinside Shop
2,400 (OBO)
Machine - For Sale
Charlotte, NC
From: $ 20.00
Cabinet - Other
Rock Custom Pinball
2,200 (OBO)
Machine - For Sale
Fremont, MI
$ 125.00
Cabinet - Toppers
Sparky Pinball
$ 25.00
Cabinet Parts
Flashinstinct
$ 48.00
Cabinet - Other
ModFather Pinball Mods
$ 1,099.00
Flipper Parts
Mircoplayfields
$ 12.00
Playfield - Decals
Flashinstinct
$ 7.50
Playfield - Decals
Doc's Pinball Shop
$ 4.49
Electronics
Yorktown Parts and Equip
$ 159.00
Playfield - Toys/Add-ons
Sparky Pinball
There are 536 posts in this topic. You are on page 5 of 11.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside