(Topic ID: 29878)

Bram Stokers Dracula Club....Welcome to the Carpathians


By shacklersrevenge

6 years ago



Topic Stats

  • 6,929 posts
  • 574 Pinsiders participating
  • Latest reply 46 minutes ago by kermit24
  • Topic is favorited by 222 Pinsiders

You

Linked Games

Topic Gallery

There have been 2,122 images uploaded to this topic. (View topic image gallery).

IMG_20190920_175215 (resized).jpg
IMG_20190920_174611 (resized).jpg
bsdglass3 (resized).jpg
bsdglassmirror (resized).jpg
bsdcpr (resized).jpg
20190831_104258 (resized).jpg
20190906_164519 (resized).jpg
20190803_052132 (resized).jpg
Capture (resized).JPG
20190802_194328 (resized).jpg
Capture (resized).JPG
20190803_051548 (resized).jpg
20190803_051543 (resized).jpg
20190811_180226 (resized).jpg
bsdd (resized).jpg
IMG_20190918_090005 (resized).jpg

Topic index (key posts)

31 key posts have been marked in this topic, showing the first 20

Post #15 Coin reject image Posted by tomdotcom (6 years ago)

Post #16 Strategy Posted by tomdotcom (6 years ago)

Post #37 Easter Eggs Posted by pinster68 (6 years ago)

Post #78 Easter Egg - SUN (High Score) Posted by DeathHimself (6 years ago)

Post #124 Moon - Green Lit Insert - Diverter is Active Posted by Rum-Z (6 years ago)

Post #145 Castle Lock Ramp Adjustment Posted by Doot77 (6 years ago)

Post #158 PAPA video tutorial Posted by DeathHimself (6 years ago)

Post #266 Prototype Slingshot Plastics - Hex installed (Photos) Posted by GRB1959 (6 years ago)

Post #306 Left side Castle plastic - For Sale Posted by GRB1959 (6 years ago)

Post #378 BSD backbox LED chart Posted by MrBellMan (6 years ago)

Post #416 Plunger rebuild parts. Posted by vintage4life (6 years ago)

Post #483 Gameplay / Instruction cards Posted by tilted81 (6 years ago)

Post #563 Playfield Protector Posted by phishrace (6 years ago)

Post #677 Mystery Hole rewards Posted by Jodester (6 years ago)

Post #701 Coffin Ramp Rejecting fix - Clear plastic under headstone Posted by 27dnast (5 years ago)

Post #890 Pinball Rebel Instruction cards Posted by aobrien5 (5 years ago)

Post #958 Mounting the prototype plastics Posted by Drano (5 years ago)

Post #975 Mist Gate Troubleshooting Posted by Bryan_Kelly (5 years ago)

Post #1002 Making a Left Mist Gate? - Click the link Posted by aobrien5 (5 years ago)

Post #1065 BSD Shop Out Guide Posted by gtown (5 years ago)


Topic indices are generated from key posts and maintained by Pinside Editors. For more information, or to become an editor yourself read this post!

You're currently viewing posts by Pinsider tktlwyr.
Click here to go back to viewing the entire thread.

#4752 2 years ago
Quoted from kvan99:

As far as your other error U.L and U.R that's upper right and upper left flipper switch on BSD, there are no upper flipper but the lane change switches I'm guessing is what it's referring to. Put the game in switch mode and hit the flipper buttons are they registering correctly? You should 3 switches close for left flipper and 3 for the right when the button is held down.

UL and UR flipper are use in this game, just not as flippers. The Fliptronics board in BSD, in addition to LL and LR flippers, controls solenoid numbers 33 through 36 which include the gates for the Mist ball and is probably the source of at least some of the error.

Start by checking the fuses in the Fliptronics and go from there.

#4755 2 years ago
Quoted from waspinat0r:

Well, I opened up the backbox and seem to have fixed the mist multiball for now, but the UL flipper is throwing a problem at switch F8. Still not sure about that one.
edit: mist not working again -- it's gotta be an opto problem.

If it's an opto issue, you should be able to observe the problem in the "Switch Edges" test in the test menu. I recently picked up a BSD and have just been this.

Any three of these opts can cause the Magnet Unload Error:

Ball on Magnet: Switch 82
Magnet Right: Switch 83
(If you want to check it while you're in there, Magnet Left tis Switch 81).

The error can also be caused by the right gate (solenoid 34) or left gate (solenoid 36) not functioning, which are controlled by the Fliptronics as I indicated earlier. This would cause the upper flipper credit dot errors you are seeing.

#4759 2 years ago
Quoted from waspinat0r:

The right and left gate function every time, and mist multiball will function up until the point to which I knock the ball off of the magnet...it never recognizes that the ball left the magnet, so if I'm in multiball, and drain, the game drains as if I drained in single ball play, kills the flippers, and ends the ball altogether.

Since the gates work correctly, it may just be a problem with the optos on the flipper opto boards causing the the UR/UL errors. Despite them not being needed on this game, they're still there, active and will show in the Switch Edges test by pressing the flipper buttons all the way. If they're not working, it should show the error but it shouldn't affect gameplay. Being an anal bastard, I'd fix it because I don't like credit dots. ?

Quoted from waspinat0r:

Magnet unload error: I ran through the test which you'll have to see the picture which I'm enclosing the long opto appears to be one dot long -- it seems the long opto is blocked or not working at all?

Your picture shows the "Load Magnet" part of the Magnet Test. If you look on the left side of the test screen, you can see the gates on the top part of the screen (left gate closed, right gate open). Below that is one lone dot. This is the left pocket opto and shows no ball in the left pocket at the time the picture was taken. If you go to the bottom, you've got a ball on the outhole switch and three others in the trough, so no ball on the magnet at that point. Since you essentially have four balls in the trough, you should have a line of dots below left pocket opto showing that there is no ball on the magnet. You do not have that line which means either a bad set of optos for the long opto or a problem with the long opto board.

Please follow up after you get the new board in.

IMG_1034 (resized).JPG

#4761 2 years ago
Quoted from waspinat0r:

It's not BSD without fully functioning mist!

No, it's not.

When I got mine a month ago, it had Mist and Castle Lock issues. The Castle Lock had two bad optos. The Mist long opto was flakey and you could see it flickering in the Switch Edges test with no ball in either pocket. Finally, the driver board was missing +20VDC, so the magnet wasn't holding the ball. The previous owner was having fits and thought he had done everything he could to fix it. Some basic troubleshooting had it figured out 20 minutes after I got it home, aside from the flakey long opto. Once I understood how the entire Mist system and magnet test worked, it wasn't too difficult.

I look forward to your update later.

#4763 2 years ago

Replace the opto transmitter and receiver. The ones available from Pinball Life work perfect!

#4767 2 years ago
Quoted from waspinat0r:

Is there anything else I should buy in case these don't work either? Are they hard to change out?

The right is the transmitter and can be done by loosening the ramp to get under it. Do this first, as it’s the transmitter that usually fails and that will probably get you up and running.

IIRC, the receiver on the left is a little more complicated but it’s not difficult. You can verify it’s operation by going into Switch Edges test mode and shining a flashlight into the pocket and watch for switch 82 to activate (it’ll also probably activate switch 52 (opto magnet left pocket) but you’re specifically looking for it to activate 82).

Solder 2 wires on both the transmitter and receiver.

3 weeks later
#4811 2 years ago

The PinBits pieces are stainless. I just replaced all of mine. Worth the cost to me since I was a complete tear down and rebuild shop job.

#4814 2 years ago
Quoted from Elicash:

thanks. Do you recall what size rivets you used for the coffin ramp flap?

No, sorry. I've got a press and a box of various rivet sizes..

#4816 1 year ago
Quoted from waspinat0r:

Hey everyone! I'm actually exiting the club soon, and I want to make sure the new owner gets the game in as good of shape as possible. That being said, I'm still getting the UL flipper credit dot thrown at switch F8 and I'm not sure what steps to take to get rid of that. The game works 100% and the credit dot doesn't affect gameplay but I still would like it gone. any suggestions?

Quoted from tktlwyr:

Since the gates work correctly, it may just be a problem with the optos on the flipper opto boards causing the the UR/UL errors. Despite them not being needed on this game, they're still there, active and will show in the Switch Edges test by pressing the flipper buttons all the way. If they're not working, it should show the error but it shouldn't affect gameplay. Being an anal bastard, I'd fix it because I don't like credit dots. ?

Have you checked the opto on the left flipper board like I previously mentioned? Switch F8 is the upper left flipper button.

#4818 1 year ago
Quoted from waspinat0r:

If that were the problem what steps would you suggest to fix? New optos?

I could be dirty. Try cleaning it with a Q-tip and Windex and test. It could also be that the interruptor is not moving enough/blocking the opto to the point it isn't registering.

If that doesn't rectify the problem, a new opto on the flipper board OR a new flipper board.

5 months later
#5170 1 year ago
Quoted from Kas24:

How did you get magnet to pass with no errors? I keep getting a "power error". I replaced both optos and 24 opto board with no change. When the gate opens the ball drops down the magnet doesn't work. Even in test mode I get a "power error". Any help would be very much appreciated.

Sounds like either a main power driver board (PDB) or high current driver assembly (HCDA) issue. On the driver board, J107-1 powers both the magnet (not the motor, but the hold of the magnet) and the drop target. For the magnet, it attaches to the HCDA at J1-6. The driving transistor would Q22 through J1-4 on the HCDA to connector J122-3 on the PDB and ultimately Q22.

The HCDA also has a ground at J1-1 that attaches to the PDB at J103-1.

Is the drop target working? This will slightly narrow down where few need to look.

Quoted from Kas24:

Ok, installed new magnet and checked continuity of wires. All good but still no power.... The motor is working, magnet runs back and forth and the light works.

See above. Motor runs on a different circuit and is powered by J107-6.

1 year later
#6428 4 months ago
Quoted from smcclain65:

Does anyone have any pics of the legs and lockdown bar plated. And the exact color, I have a powder coating place near me and just need to know the color used.

These were stainless from the factory and not plated.

3 weeks later
#6598 3 months ago
Quoted from Jodannar:

Does anyone get a hollow knock noise when a ball hits their rear Playfield backboard above the lanes?

Dracula is stuck in his coffin. Please let him out.

2 months later
#6808 38 days ago
Quoted from weaverj:

i think i'm okay now. coffin lock ramp was going up without me hitting the shot 5 times, but i noticed you get one credited shot at the start of each ball. going to keep an eye on it though.

Each time you hit the skill shot, you are credited with both a Coffin ramp shot (if it's not already open) and a werewolf V-I-D-E-O letter. This is not a game malfunction.

As for the fuses, locked on coils, etc, power for the coils and power for the sound are on different circuits and are probably not related.

#6811 38 days ago
Quoted from weaverj:

i put the original board back in and everything is fine. why is that?

I can't tell you without knowing what fuses blew and you didn't indicate. In terms of electrical signal, you've got +12V (fuse F115), ground and 2 lines out, one for the backbox and one for the cabinet speakers.

Quoted from smcclain65:

I have had this game for about a year and did not know you get credit for the ramp shot for a skill shot. That makes the skill shot that more important. I have been just disregarding the skill shot because the points are pretty small when your going for a billion or so.

I've got some friends who are top ranked players who weren't even a way of this until I showed them. Why only going for a billion?

#6816 38 days ago
Quoted from weaverj:

my bad. f104, 105 and 112.

Those 3 fuses all deal with solenoids and all 3 are on the same electrical path as each other.

According to the schematic, the sound board gets its power from a completely different and unrelated electrical path.

Since the WPC PinSound boards use the same electrical connections as the OEM board, my bet is that you may have shorted something or installed something incorrectly.

#6819 36 days ago
Quoted from weaverj:

wouldn't a short blow fuses immediately? i didn't start blowing fuses until day 2 of troubleshooting.

Depends on the short.

#6823 36 days ago
Quoted from hawknole:

Thanks, any idea what the part number for the long beam opto is?

According to the manual, the part numbers are the same as the other optos in the game, A-14315 and A-14316.

I also don’t recall having to track down different optos when I tore my game down.

#6838 30 days ago
Quoted from TDEX:

Hello everyone here’s my latest problem.
The “D” and the “A” in dracula wont light up at all. I re soldered the light bar to build up where the light makes contact
And re soldered the coresponding pin in the connector. I’m not an electrician but i think i did a pretty good job with the soldering. Any help would be appreciated.

Could be diode issue on the lamp board. I don't have time to give instructions now, but I'll check in later.

#6841 29 days ago
Quoted from TDEX:

Thanks that would be great

Which "A" in Dracula won't light?

Also, are the bulbs LEDs or incandescent?

#6852 26 days ago
Quoted from TDEX:

the last "A" and yes they are led's

I would start to be suspicious of cold solder joints on the driver board. Neither of the lights is on the same row or column otherwise you'd have other lights that didn't work, so it doesn't appear to be a logic issue.

The 4 header pin areas I would look at next on the power driver board are J133-4, J133-9, J137-2 and J137-4.

Report back.

#6866 25 days ago
Quoted from TDEX:

ok I used the alligator clips and found the "A" had current very positional. I think I have to build up solder on the light board.
it works for a bit then when I move table back down it goes out. The "D" however doesn't have current. I used the DMM for voltage and got nothing. the "R" next to it registered voltage. not sure what I am looking for with the header pins. cracks?

Connector J133 drives the lamp board and is interchangeable with J134 and J135 and complete the path to ground. Swap the connector on J133 to either J134 or J135 and see if there’s any change on the “D”. If ”D” now lights, reflow some solder on the back side of the header pins for J133. I’d probably carefully flow solder on all three sets of header pins since they are interchangeable and I’m not sure if these connectors are on their properly numbered headers on the board. This may fix the “A”, as well.

Connector J137 powers the lamp board. This connector is interchangeable with J138. If “A” is still lighting due to playfield position, swap J137 with J138. If this fixes “A”, reflow on J137 and J138 as above.

Report back.

#6868 24 days ago
Quoted from weaverj:

well, my saga continues over here. i was in the backbox last night, preparing to install my new game rom. i started checking connectors, since everyone was saying i had a short possibly with the pinsound fun the other day. noticed several connectors, maybe more, that were real loose. i got all pushed in the whole way and fired up the game. did not swap roms, btw.
i immediately notice that all my inserts are brighter. i can even feel heat over the dracula letters. some bulbs weren't working at all, but they're not burnt out. i can swap lights on the same board underneath and the out is at the socket, not the bulb. i tried playing a game and i'm getting massive ghosting. it's not even ghosting, honestly. inserts are fully lit, coming on and off. game is basically unplayable, imo. they work fine in test, but the out sockets are still off.
so i'm going to try some different bulbs first. i have the cheapest bulbs i own in there currently: comet flattops. if i still get the same behavior from 5050's, do you think it would be worth trying some non-ghosting? i never bought any of those. if you have any other ideas, let me know, please.
one thing i do know, i'm probably going to run the other way the next time i see a game with replacement boards. maybe i'm overreacting, and there's a proverbial hump i'll get over at some point, but this has been a nightmare. definitely more than i thought i was getting into. hopefully i can get through the issues, because i'll get smoked if i try to get rid of it. i paid a lot. ugh.

Unless you have the patched ROM file or LED OCD, you will have ghosting/flickering/strobing with LEDs. I am not familiar with Comet "flattops". It could also be a diode issue in the lamp matrix that's exasperating the situation. If it's a diode issue, lamps would be on all the time and most likely on more than one lamp. Any flickering/strobing is probably just the LEDs.

We can chase the bulbs that are out similar to what I am explaining to TDEX, however, this probably won't fix the ghosting/flickering/strobing. You would need to take additional steps on your end to narrow the ghosting/flickering/strobing issue down. Some video may help diagnose the situation (BTW, I highly recommend the LED OCD boards in this game. I have both the LED OCD and GI OCD in mine and have ZERO regrets).

What bulbs are out? Do regular bulbs react the same way as LEDs or do they work properly? What replacement boards are you running since the PinSound board is out of the game? Was this an issue when you purchased the game or have you changed things leading to the problem, i.e. adding the Comet LEDs?

Since you had loose connectors, I'd start with the manual and make sure all the connectors are on their proper headers on their respective boards and snug, including the ribbon cables. Ribbon cables installed off a row/column can wreak havoc.

#6871 24 days ago
Quoted from weaverj:

i had very minor ghosting before last night, but i would happily play the game. like i said, it's unplayable in its current state. you have no idea of your progress of any game features.
it's like pushing in these connectors turned the brightness up on everything. only thing i can think of is i was getting 3-4 volts before from the loose connections, but now i'm getting the full 5, and the bulbs don't like it. the full on/off ghosting is basically all inserts. way more than one.
i have the same bulbs in my TOM. no issues. i've actually used these on almost every pin i've owned. no issues. a little ghosting on my sterns, but wpc's love em. i've never needed to install an ocd board.
all boards except the sound board are rottendog replacements. lights were fine before last night, except a very small ghost flicker. i'd say i've had it almost two months now. all i did was tighten connectors.

Controlled lamps are on the +18VDC circuit that strobes many times per second to get the voltage down to down to +6 volts. If a transistor has shorted on, a row or column of lamps will be turned on for a longer time, and hence be brighter.

What lamps are on all the time? Go into single lamp test mode and test each controlled lamp. What lamps don’t work? Do certain lamps light multiple lamps in the test mode? If so, which ones?

#6873 24 days ago

Williams_1993_Bram_Stoker_s_Dracula_English_Manual.pdf

#6880 24 days ago
Quoted from weaverj:

yeah, things are deteriorating.
i went into single bulb test. first thing, 01 unused, i have 7 inserts lighting: left skill, left coffin lock, video-v, dracula-c, rat hole, right inlane and the coffin manikin head bulb. i can give you more examples, if needed. same behavior through the entire list of bulbs basically.
also, test reported 2 balls missing. i found one in the top left popper, which isn't working anymore. bottom jet is out, too. so either i blew more fuses or i'm blowing transistors. fml...

Let's get the lamps sorted out and then we can work on the solenoids which sounds like it may be switch issues.

All those lamps are in the same row. Start looking at Q90. If a transistor shorts on in the lamp matrix, it can make all the lamps in that row or column appear permanently on and very bright. To test a TIP102 transistor make sure the game is off and set up DMM to test continuity. Put one lead on the ground strap in the backbox. Touch the other lead to the metal tab on the TIP102 transistor at Q90. If getting zero ohms/buzz/beep, the transistor is shorted on and bad.

#6883 24 days ago
Quoted from weaverj:

i tried that q90 test and didn't get anything. actually i got nothing to any transistor i tried. are you sure that's how you test those?

Per Clay Harrell:

A lamp row is either very bright or dead:

The TIP102 for that row is most likely dead or locked on. The LM339 comparator is the next component to check. Occasionally the 74LS74 can cause a problem. Hint: a fast way to tell if the TIP102 transistor is defective is to ground the tab of the transistor. If grounding the tab and nothing happens, the transistor is probably good. If grounding the tab and the row lights, the transistor is probably bad.

So if the transistor is good, we have other places to look.

Promoted items from the Pinside Marketplace
3,500
Machine - For Sale
San Antonio, TX
From: $ 40.00
Cabinet - Other
Rock Custom Pinball

You're currently viewing posts by Pinsider tktlwyr.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside