(Topic ID: 29878)

Bram Stokers Dracula Club....Welcome to the Carpathians


By shacklersrevenge

7 years ago



Topic Stats

  • 7,074 posts
  • 582 Pinsiders participating
  • Latest reply 2 days ago by PinballWizard666
  • Topic is favorited by 226 Pinsiders

You

Linked Games

Topic Gallery

There have been 2,164 images uploaded to this topic. (View topic image gallery).

448746-i (resized).jpg
20191201_152342 (resized).jpg
60CB2AC9-FB91-4FF5-BF21-2F0FDEA4EF08 (resized).jpeg
image (resized).jpg
image (resized).jpg
image (resized).jpg
3FCBDE80-5B20-4A0E-83E1-7E2F656F7D3D (resized).jpeg
07EB1F94-8220-49F1-827C-7D4F7055A033 (resized).png
45b57485-6e3c-43a4-a4a3-99d7e1b9310b.jpg
IMG_1184 (resized).jpeg
IMG_0426 (resized).JPEG
6A1B4B38-F3E8-4A39-A314-3CC6AB7CA6B2 (resized).jpeg
BB8D3338-DC72-453A-88D0-B443CEA784A8 (resized).jpeg
FB7F8BCC-4D6E-429B-8902-8E0640006127 (resized).jpeg
C3CC27C2-5CC4-4CA2-8E5F-A22E8855EBB5 (resized).jpeg
88F4B865-9ABC-4878-A4AB-1AF4A23A2738 (resized).jpeg

Topic index (key posts)

31 key posts have been marked in this topic, showing the first 20

Post #15 Coin reject image Posted by tomdotcom (7 years ago)

Post #16 Strategy Posted by tomdotcom (7 years ago)

Post #37 Easter Eggs Posted by pinster68 (7 years ago)

Post #78 Easter Egg - SUN (High Score) Posted by DeathHimself (7 years ago)

Post #124 Moon - Green Lit Insert - Diverter is Active Posted by Rum-Z (7 years ago)

Post #145 Castle Lock Ramp Adjustment Posted by Doot77 (7 years ago)

Post #158 PAPA video tutorial Posted by DeathHimself (7 years ago)

Post #266 Prototype Slingshot Plastics - Hex installed (Photos) Posted by GRB1959 (6 years ago)

Post #306 Left side Castle plastic - For Sale Posted by GRB1959 (6 years ago)

Post #378 BSD backbox LED chart Posted by MrBellMan (6 years ago)

Post #416 Plunger rebuild parts. Posted by vintage4life (6 years ago)

Post #483 Gameplay / Instruction cards Posted by tilted81 (6 years ago)

Post #563 Playfield Protector Posted by phishrace (6 years ago)

Post #677 Mystery Hole rewards Posted by Jodester (6 years ago)

Post #701 Coffin Ramp Rejecting fix - Clear plastic under headstone Posted by 27dnast (6 years ago)

Post #890 Pinball Rebel Instruction cards Posted by aobrien5 (5 years ago)

Post #958 Mounting the prototype plastics Posted by Drano (5 years ago)

Post #975 Mist Gate Troubleshooting Posted by Bryan_Kelly (5 years ago)

Post #1002 Making a Left Mist Gate? - Click the link Posted by aobrien5 (5 years ago)

Post #1065 BSD Shop Out Guide Posted by gtown (5 years ago)


Topic indices are generated from key posts and maintained by Pinside Editors. For more information, or to become an editor yourself read this post!

You're currently viewing posts by Pinsider tjprice222.
Click here to go back to viewing the entire thread.

#3033 4 years ago
Quoted from RGAires:

Finally is finished...

Looks great!! Which LEDs did you use? I need to increase the brightness of mine around the slings.

dracula.jpg

#3039 4 years ago

Whoops! iPhone jacked up my block quote:

Quoted from RGAires:

Finally is finished...

dracula.jpg

Looks great!! Which LEDs did you use? I need to increase the brightness of mine around the slings. Anyone else have any recommendations for bright LEDs at the slings and general playfield illumination?

6 months later
#3364 3 years ago

Hey all, I'm curious to hear how 'Bats' goes for everyone here. More often than not, I drain before completing the switch hits or end up with a crappy bats bonus - less than 20mil or so. It's rare that I end up with the full 50 or complete it on ball 1. Is this normal or is it me?

#3378 3 years ago

Anyone else care to weigh in on my 'Bats' question from earlier?

Quoted from tjprice222:

Hey all, I'm curious to hear how 'Bats' goes for everyone here. More often than not, I drain before completing the switch hits or end up with a crappy bats bonus - less than 20mil or so. It's rare that I end up with the full 50 or complete it on ball 1. Is this normal or is it me?

#3384 3 years ago

Speaking of the mist motor. Is there any speed setting or way to modify it? Mine literally flies across the playfield where other games I've played seem to take longer to get across. I should take a video of it.

1 year later
#4585 2 years ago

shock_me I had a very similar issue and I searched everywhere for help on it. Turned out one of my boards was missing a capacitor that a lot of these games shipped without. Got the right one, soldered it in and mist hasn't emptied on start up since then.

#4589 2 years ago

aobrien5 I'm not the only one who had success. My BSD would eject the mist ball at every power on and go through some weird sequence of the motor going back forth before reloading. It also would fail the magnet test because the gate would close at the wrong time in test mode only - not in a real game. This C2 capicitor fixed all of that:

https://pinside.com/pinball/forum/topic/bsd-mist-gates-issue

Hope it helps!

1 year later
#5928 1 year ago
Quoted from dudah:

This plastic next to the bumpers was missing on my game. I remade it along with a fluorescent protector! Have a couple extras, anyone in need?
[quoted image]

Yes please! Mine is cracked in half. PM with what you need. Thanks!

1 month later
#6113 10 months ago
Quoted from gliebig:

Nevermind. It's the ramp opto. Hard to trace the wire. Any ideas?

I’ve been messing with my ramp diverter as well. It wasn’t returning to full up position resulting in diverted balls when they should have made a full loop. Made getting bats freaking impossible! Anyway, a good cleaning of everything and replacing the spring took care of mine.

Regarding the opto, I’m pretty certain the opto wire goes straight below the playfield and has a molex connector like the one in the photo. Make sure the opto is registering in switch test. If not, check this connector. That should be a start. Good luck!

9E8832E3-B1D3-49F5-ADEE-282623959FAC (resized).jpeg
#6118 10 months ago

Nice job! Glad to hear you got it working. Now go for that thiiiiiirty millllllion!!

4 weeks later
#6165 9 months ago
Quoted from Yesh23:

I’m getting magnet unload error. Does anyone know what that means or where to start?

I had some mist issues early on. Check back at my post #4589 - it has a link to a weird issue that fixed it for me. Hopefully it helps you.

4 months later
#6599 5 months ago
Quoted from Jakemate:

Hello from Portugal
I've picked up a poorly bsd last month, never had a pinball before but I've managed to strip down the playfield, clean it up, replace rubbers and lamps and it's a lot happier.
I wouldn't have managed it if it wasn't for reading posts on this forum from great knowledgeable people on here.
Unfortunately I have a couple of issues that I haven't resolved.
Even when I hit plenty of left ramp shots the diverter doesn't drop down even though it tests fine in the test menu.
Also what might be linked but I'm not sure is if you hit a weak left ramp shot (diverter doesn't drop) and the ball drop down into the castle lock area it locks but then the solenoid drops the bar and releases it into the launch lane and also loads another ball causing two balls to be launched.
I've checked castle lock optos which test fine, can anyone help!
Many thanks in advance

Congrats on picking up a great game! To verify and troubleshoot the diverter, put the game in switch test mode and confirm that the opto on the left ramp is registering hits with an actual ball. This opto triggers the diverter to drop.

For the two ball load, I would test and confirm your trough switches are working. It could also be the optos on the castle lock wire ramp. I would start with those and work from there.

Good luck!

Promoted items from the Pinside Marketplace
$ 45.99
Lighting - Interactive
Lee's Parts
$ 5.00

You're currently viewing posts by Pinsider tjprice222.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside