New! Dark mode!

Browsing Pinside at night? Getting tired of all the white? Switch to dark mode using the button in the top right (or CTRL-B)!

(Topic ID: 29878)

Bram Stokers Dracula Club....Welcome to the Carpathians


By shacklersrevenge

7 years ago



Topic Stats

  • 7,517 posts
  • 622 Pinsiders participating
  • Latest reply 43 minutes ago by PinballWizard666
  • Topic is favorited by 243 Pinsiders

You

Linked Games

Topic Gallery

There have been 2,341 images uploaded to this topic. (View topic image gallery).

image (resized).png
image (resized).jpg
BSD01 (resized).jpg
097325fd00492438923e621018ba9ac7a7d7e45e (resized).jpg
IMG_8258 (resized).JPG
Resized_20200816_205943 (resized).jpeg
IMG_0388 (resized).jpg
IMG_0387 (resized).jpg
448746-i (resized).jpg
20200714_162825 (resized).jpg
bsd001 (resized).jpg
bsd003 (resized).jpg
bsd002 (resized).jpg
BSD Score (resized).jpg
D13759A0-40C3-4579-AEEE-E113D7FE453B (resized).jpeg
808B0692-1345-4644-BA30-276CDB3496C1 (resized).jpeg

Topic index (key posts)

31 key posts have been marked in this topic, showing the first 10 items.

Display key post list sorted by: Post date | Keypost summary | User name

Post #15 Coin reject image Posted by tomdotcom (7 years ago)

Post #16 Strategy Posted by tomdotcom (7 years ago)

Post #37 Easter Eggs Posted by pinster68 (7 years ago)

Post #78 Easter Egg - SUN (High Score) Posted by DeathHimself (7 years ago)

Post #124 Moon - Green Lit Insert - Diverter is Active Posted by Rum-Z (7 years ago)

Post #145 Castle Lock Ramp Adjustment Posted by Doot77 (7 years ago)

Post #158 PAPA video tutorial Posted by DeathHimself (7 years ago)

Post #266 Prototype Slingshot Plastics - Hex installed (Photos) Posted by GRB1959 (7 years ago)

Post #306 Left side Castle plastic - For Sale Posted by GRB1959 (7 years ago)

Post #378 BSD backbox LED chart Posted by MrBellMan (7 years ago)


Topic indices are generated from key posts and maintained by Pinside Editors. For more information, or to become an editor yourself read this post!

You're currently viewing posts by Pinsider nthack.
Click here to go back to viewing the entire thread.

#607 7 years ago

Could anyone post a picture of the left side gate please? Need to see the coil, spring and gate.

Cheers

#618 7 years ago

I'm sure it's been covered before, but I need help with Mist problems. I get a "Magnet unload" error on startup and then eratic Mistball during play, with magnet crossing the playfield several times. Sometimes the magnet holds the ball, sometimes not. Both gates operating correctly. I'm new to this, so could do with some step by step guidance. Maybe Opto related. Multi meter at the ready.

Thanks in advance.

#623 7 years ago
Quoted from TomGWI:

Run the magnet test through the coin door service buttons and let us know what errors you get.

On first pressing of the Test button, I get Magnet unload error. Then on Test 15 - Magnet, it fails the first test. Magnet Unload Error. It then seems to run through all the other tests OK.

#627 7 years ago
Quoted from TomGWI:

Go into the switch matrix test and then look at the switch matrix table in your manual (or download from ipdb.com). Test all optos and make sure they are working properly.

Tom. I've tried every test I can find. All optos seem OK, except 82, which is the long beam opto. This is permanently closed and nothing happens when you block its path. Voltage at transmitter is 0.9v, where the manual says it should be 1.4v. I'm a bit out of my depth now but pressing on. I can't see how you can line up the receiver and transmitter. When running the magnet tests, there sould be a dotted line showing the path on the display. This doesn't appear.
What confuses me as well, is when the game is running, the ball travels across the pf very well. If you don't hit it, it drops into the opposite gate perfectly.

#635 7 years ago
Quoted from Almost4200hp:

I would check the alignment of the long beam opto emitter before anything else - the manual suggests it should be adjusted towards the front of the game and if its not the receiver may not be picking it up

Yes, but how do you adjust it? It sits in a slot and cannot be moved either way. I think I may be missing something here.

#641 7 years ago

It seems to me that everybody and his dog has got Dracula mist problems and rarely get them sorted. Terryb's article helps to point in the right direction but is a little complicated. Like Jodester, I have ordered a new Aussie opto card, plus a set of emitter and receiver optos. Whole table is in bits now, will have to wait until new parts arrive then have another go.

#650 7 years ago

I got a bit carried away when replacing parts and cleaning my BSD. My record keeping wasn't as good as it should have been and my memory is poor as well. I have these parts which I'm not sure where they go. I'm sure someone can help a novice. Many thanks in advance.

20131009_164100_1.jpg
#655 7 years ago
Quoted from Jodester:

My BSD is partially torn down so I can take some pics when I get home from work tonight if nobody beats me to it.

Thanks Jodester, like you I'm waiting for the new Aussie board. Confident this will solve all my mist problems. Just need to put it all back together properly.

#661 7 years ago
Quoted from Crash:

Here they are. The little triangle looking piece fits over the right mist trail opto to the left of the shooter lane.

fr_816.jpg 2 MB

fr_773.jpg 3 MB

fr_806.jpg 3 MB

fr_835.jpg 3 MB

Thanks for everyones's help. I still have one more part I can't identify. A scruffy bit of clear(ish) plastic with two screw holes.

20131010_171131.jpg
#670 7 years ago
Quoted from Jodester:

One of the posts is 3.5 inches and the other is 2.5 inches....
Anybody ever order the long opto board from Homepin? I sent the paypal payment Sunday and never got any word from them that the order was received or when it will be shipped...

I ordered mine on Sunday too. Had thank you email same day. Said it would be despatched Monday and usually takes 15 days to UK.

1 month later
#732 6 years ago

Hello again. More magnet test problems here in UK. I have installed a new long opto board from Homepin in Australia without any problems. Everything now works fine except when during T15 magnet tests, I get repeated Opto Check faults with a "Lamp Interference" note. Doesn't happen every time, usually on Opto Check 1 or 2. I have removed about 20 bulbs in the area, but still no luck. Is there a particular bulb which may cause this problem? Or is it something else?

Many thanks for any help.

#733 6 years ago

Oh, and one more thing that I have noticed. It seems to only fail the Opto Test when there is a ball in the right pocket.

#735 6 years ago

Thanks for the reply Robert. No, the magnet is working fine and holding the ball going both ways. I do have LEDs, but have removed every one that is anywhere near. Pretty sure the long range opto is aligned OK. It seems odd that it only seems to happen when there is a ball in the right pocket.

#738 6 years ago
Quoted from MrSanRamon:

So it's a magnet test issue, not a game play issue?
If so, I'd just forget about it and play the game.
I had a "magnet upload" error for about 4 years, and the game played fine. I did a factory reset (and nothing else) and the error went away.
Not saying that will occur here, but if the game works I wouldn't worry about it. There are a lot of issues with the mist magnet.
Robert

It does affect the game significantly. There is confusion throughout with the machine getting in a pickle and not knowing where the balls are. Sometimes two balls in the right pocket. Sometimes repeatedly upping the ramp and shooting balls in to the pocket, then the gate opening and dropping the ball out. Sometimes no ball in either gate when the mist starts. The Test Error message at start up is "Magnet Load Error."

#746 6 years ago
Quoted from ChoppaCade:

I had similar problems to this as well, I replaced the opto board from homepin and still had problems. In the end it was the right side ball sitting in front of the opto. It wasn't sitting high enough up in front of the opto. I gently bent the piece of metal under it so it would sit higher and "Hey Presto" it worked again.

I shall have a look tomorrow and report back. Don't have a photo do you Choppa?

Promoted items from the Pinside Marketplace
$ 63.50
$ 35.00
Cabinet - Other
Arcade Upkeep

You're currently viewing posts by Pinsider nthack.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside