New! Dark mode!

Browsing Pinside at night? Getting tired of all the white? Switch to dark mode using the button in the top right (or CTRL-B)!

(Topic ID: 29878)

Bram Stokers Dracula Club....Welcome to the Carpathians


By shacklersrevenge

7 years ago



Topic Stats

  • 7,510 posts
  • 620 Pinsiders participating
  • Latest reply 2 days ago by PinballWizard666
  • Topic is favorited by 243 Pinsiders

You

Linked Games

Topic Gallery

There have been 2,341 images uploaded to this topic. (View topic image gallery).

image (resized).png
image (resized).jpg
BSD01 (resized).jpg
097325fd00492438923e621018ba9ac7a7d7e45e (resized).jpg
IMG_8258 (resized).JPG
Resized_20200816_205943 (resized).jpeg
IMG_0388 (resized).jpg
IMG_0387 (resized).jpg
448746-i (resized).jpg
20200714_162825 (resized).jpg
bsd001 (resized).jpg
bsd003 (resized).jpg
bsd002 (resized).jpg
BSD Score (resized).jpg
D13759A0-40C3-4579-AEEE-E113D7FE453B (resized).jpeg
808B0692-1345-4644-BA30-276CDB3496C1 (resized).jpeg

Topic index (key posts)

31 key posts have been marked in this topic, showing the first 10 items.

Display key post list sorted by: Post date | Keypost summary | User name

Post #15 Coin reject image Posted by tomdotcom (7 years ago)

Post #16 Strategy Posted by tomdotcom (7 years ago)

Post #37 Easter Eggs Posted by pinster68 (7 years ago)

Post #78 Easter Egg - SUN (High Score) Posted by DeathHimself (7 years ago)

Post #124 Moon - Green Lit Insert - Diverter is Active Posted by Rum-Z (7 years ago)

Post #145 Castle Lock Ramp Adjustment Posted by Doot77 (7 years ago)

Post #158 PAPA video tutorial Posted by DeathHimself (7 years ago)

Post #266 Prototype Slingshot Plastics - Hex installed (Photos) Posted by GRB1959 (7 years ago)

Post #306 Left side Castle plastic - For Sale Posted by GRB1959 (7 years ago)

Post #378 BSD backbox LED chart Posted by MrBellMan (7 years ago)


Topic indices are generated from key posts and maintained by Pinside Editors. For more information, or to become an editor yourself read this post!

You're currently viewing posts by Pinsider almost4200hp.
Click here to go back to viewing the entire thread.

#96 7 years ago

Only had my BSD 5 days and hooked already. Needs a lot of cosmetic work and a good clean but loving it. Nasty looking crack in the lift ramp though - anyone got any for sale to ship to UK?

2 weeks later
#183 7 years ago
Quoted from DeathHimself:

If your handy, you can make one from very thick lexan or a thin piece of plexi glass just need to rivet the flap back on.

Thanks, I'll given it a try!

#184 7 years ago
Quoted from DeathHimself:

If your handy, you can make one from very thick lexan or a thin piece of plexi glass just need to rivet the flap back on.

Thanks, I'll given it a try!

1 month later
#228 7 years ago
Quoted from Kcpinballfan:

Thats the type of scores I get with mine with lightning flippers, im sure others kick its ass but its a tough game so thats a respectable score.

850million with lightning flippers and factory settings. Mind you, I played the thing non stop for about a month and even then my next game was 10 million !

#235 7 years ago

Coffin multiball definitely easier, often go for the castle ramp amd watch the ball get halfway up then come right back and drain down the middle "I feel like a blundering novice" !!

1 month later
#249 7 years ago
Quoted from pinster68:

Note to self ... measure each and every post I take out during a shop.
Thanks to this oversight I got to teardown BSD twice.
(Yes, those are three different lengths, and can't get mixed up!)

Could you tell me which size posts go where ? I had a problem with mine bouncing shots up the lift ramp because there was a step at the top - looks like a previous owner had got them mixed up..

1 week later
#262 7 years ago
Quoted from Fintan_Stack:

Could one of you kind BSD owners please take a close up pic of how your proto sling plastics are installed? I have some but I'm trying to work out the best way to fit them. Would really appreciate it. Thanks.

2nd picture on the first page of this thread has a reasonable shot of them

Pete

3 months later
#341 7 years ago

The opto receiver voltage increases when the beam is broken ( 11 - 13v I believe) I would start by checking the wiring from that receiver to make sure there are no shorts anywhere. Also check the connectors to Mae sure they're seated correctly i.e. not one row along
Pete

3 weeks later
#387 7 years ago

Tech challenge guys. Pops and slings sometimes don't work at all them burst into life, sometimes halfway through a game. Only recently started happening. Any ideas as to cause?

1 week later
#427 7 years ago

another likely candidate is the looped wire cord to the magnet - could be a break inside the cord somewhere giving intermittent contact as the magnet moves. Happened on mine.

1 month later
#488 7 years ago
Quoted from DMachine:

New Owner Here!
Just got the game set up yesterday - no problems really, except for one:
It's very hard to get the ball up the right ramp, usually the ball goes up the ramp and sort of rattles at the top like it's getting caught by something, but I don't see anything blocking it. Maybe the ramp needs to be realigned, but I'm not sure what to adjust. If the ball goes up more slowly it usually makes it around the bend.
Any ideas?

This can happen if the ramp is misaligned. The ball goes up the first (lift ramp) piece then hits the lip of the main plastic ramp. It bounces up into the rubber stop that fits to the back of Drac's coffin end cover. When the ball goes up more slowly it doesn't bounce as much and misses the rubber.

There are three hex posts supporting Drac's coffin, and believe it or not they are all different (tho very similar) lengths. It's really easy to get them mixed up when shopping the pin and you end up with a lip at the top of the lift ramp.

Have a look at the top if the lift ramp and if its higher on one side than the other it's likely the hex posts are mixed up

Pete

#511 7 years ago

Do you know the appropriate order? I definitely have a lip there.

Sorry, I asked the same question when I discovered the problem and no one was able to help - I'd already put mine back together with them in the wrong place but the game is U/S because of a board issue (no 5v power...) so I haven't got round to stripping it down and trying to correct it yet. Here's a photo of them side by side, posted earlier in this thread by another pinsider. Shows how close they are!

image.jpg

1 week later
#576 7 years ago

I have posted this several times but its worth doing again

image.jpg

1 week later
#617 7 years ago
Quoted from NorCalRealtor:

Thanks, Joe! That screw on the top piece did need tightening, but the glass is still dragging the front piece of the tombstone. You know, the cross-shaped one with the lamps. Is it possible to lower that thing?

It's possible that this is related to the earlier post about the hex post sizes. There are three hex posts supporting the back of the coffin and the adjacent ramp. They are all different lengths but only by a few millimeters. If they've been put back in the wrong places it can lead to the glass touching the top of the coffin tombstone.

Pete

#634 7 years ago
Quoted from Jodester:

Well, I was having intermittent issues with the mist multiball. It seemed to work fine after the machine was on a while. I replaced both the emitter and the receiver and now something is wrong. The magnet goes back and forth constantly as it thinks a ball is stuck on the magnet since the long opto is screwy. I did actually see that the emitter is working via the camera test. I get 7 volts at the emitter now and about 13.5 at the receiver. I can't get the remote to trigger the receiver in test mode but when I put a meter on the receiver I can see a 1 volt drop when I sent a tv remote signal to it. Any ideas? New board?

I would check the alignment of the long beam opto emitter before anything else - the manual suggests it should be adjusted towards the front of the game and if its not the receiver may not be picking it up

1 month later
#781 6 years ago
Quoted from thetallman:

Proud owner reporting here. My left slingshot has never worked though, it had the associated tip 102 taken out by the previous owner (an arcade operator) and whenever I've put one in, the coil locks on as soon as it's tripped. Any ideas how I can finally get her fixed? Thanks.

have you tested for switch faults? good to rule that out before anything else. I'd also replace the 2n5401 pre driver for the tip 102.

test the resistance on the coil itself- if it's got hot because it was locked on for a period of time it can burn the insulation on the coil windings and lower the resistance, effectively shorting it which in turn will blow the transistors

if all that's ok then probably time to replace the 74ls374 logic chip on the power driver board - can't remember which one it is for the left sling (U1 - U5) I'm afraid but you should be able to trace it

Pete

Promoted items from the Pinside Marketplace
$ 49.95
Lighting - Led
Pin Stadium Pinball Mods
$ 19.95
Playfield - Protection
SilverBall Designs
$ 5.00
From: $ 27.00
Boards
KAHR.US Circuits
$ 14.95
$ 9.99
Eproms
Matt's Basement Arcade

You're currently viewing posts by Pinsider almost4200hp.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside