(Topic ID: 29878)

Bram Stokers Dracula Club....Welcome to the Carpathians


By shacklersrevenge

7 years ago



Topic Stats

  • 7,137 posts
  • 586 Pinsiders participating
  • Latest reply 17 hours ago by Thor-NL
  • Topic is favorited by 226 Pinsiders

You

Linked Games

Topic Gallery

There have been 2,196 images uploaded to this topic. (View topic image gallery).

IMG_1217 (resized).jpg
20190813_172824 (resized).jpg
20190803_052132 (resized).jpg
20190804_130029 (resized).jpg
20190810_152719 (resized).jpg
Capture (resized).JPG
20190802_194328 (resized).jpg
Capture (resized).JPG
20190831_104258 (resized).jpg
20190811_180226 (resized).jpg
38D534DB-4855-4BA4-B2F7-6CC28DAD4669 (resized).jpeg
BSD WIP 02 (resized).jpg
C92DE705-09B5-42D5-8129-63ACE7094B13 (resized).jpeg
A19C8FD2-12C3-4A20-9515-EFC73A91095F (resized).jpeg
FF844DED-E143-4435-BF39-C741351F3286 (resized).jpeg
08BEDA9D-BCA3-4AF0-B754-B11A3ECA39F2 (resized).jpeg

Topic index (key posts)

31 key posts have been marked in this topic, showing the first 20 (Show topic index)

There are 7137 posts in this topic. You are on page 68 of 143.
#3351 3 years ago

Of all my pins I've had BSD the longest. I love how brutal it plays.

#3352 3 years ago

Looking for one in the buffalo ny area

#3353 3 years ago
Quoted from wolfy:

This game is a must have in any collection over 3 pins. It is under-rated at 32. Should be around 8-12. Out of 53 pins the only game that i re- bought and it is staying this time .

Wolfy said it. The fact that half his collection mirrors mine must mean something.

#3354 3 years ago

I was playing some BSD tonight and noticed a strange.. electrical.. whirring (?) from the left hand side while I was in multiball, but there were no issues with the game other than that noise. It was not the mist resetting/moving; any ideas? Sorry for the generalities, I just don't want to break something that's struggling.

EDIT: Evidently this got downvoted. Strange. It was a clicking/whirring. Is there a gearbox I should check / lube / clean / etc?

#3355 3 years ago

Another cool thing about BSD (maybe other Williams pins also) is you can shine a black light on the playfield around the DRACULA inserts and see a serial number glowing. Kinda cool and my friends always like it when I show them! LOVE this pin it's the best, soooo difficult!

#3356 3 years ago
Quoted from zrbrt:

I was playing some BSD tonight and noticed a strange.. electrical.. whirring (?) from the left hand side while I was in multiball, but there were no issues with the game other than that noise. It was not the mist resetting/moving; any ideas? Sorry for the generalities, I just don't want to break something that's struggling.
EDIT: Evidently this got downvoted. Strange. It was a clicking/whirring. Is there a gearbox I should check / lube / clean / etc?

Remove the glass and test play your game with your hands. Start all major feature sets. Listen closely. The only "whirring" functionality is the mist multiball motor assembly in operation and in reset mode (including game startup). It is possible the gearbox was slipping or the game did not think the ball was properly reset. It It does it again, you will know the cause.

#3357 3 years ago

The lights under the graveyard on my BSD dont seem to be getting full power. The leds all blink but very faintly. Has anybody experienced this and knows an easy fix?

#3358 3 years ago
Quoted from roachmcguirk:

The lights under the graveyard on my BSD dont seem to be getting full power. The leds all blink but very faintly. Has anybody experienced this and knows an easy fix?

Check your connectors in the backbox...that's step one. Look to see if they're crispy or perhaps just loose. Also check your bulbs. Are they tight in the sockets?

#3359 3 years ago
Quoted from roachmcguirk:

The lights under the graveyard on my BSD dont seem to be getting full power. The leds all blink but very faintly. Has anybody experienced this and knows an easy fix?

Step 1: GI wire connection under playfield for cuts, colder solder joints or breaks, they are "daisy chained"
Step 2: GI bayonet socket oxidation corrosion and rust removal
Step 3: 5V test point on the PDB for proper specification range, may require rebuild
Step 4: IDC 0.156" connector and pins for burns, hacks, and loose wires.

It is one or all reasons.
Remember this game is over 20 years old.

#3360 3 years ago

Before and after a shop job and LED conversion. Plus blood red flippers.

bsd_ba_(resized).jpg

#3361 3 years ago

Is there a flasher in the graveyard?

I have one in there from the wood at the back but it does not work and I can not find it in the manual or the test menu.

Just wondering if this was a mod someone did to my machine years back.

#3362 3 years ago

I joined the BSD owners' club on Thursday! I've got a few adjustments to make, but the game's in decent shape and plays great. A handful of things I need to fix (and I'll scan this thread to see if there are easy fixes described for these):

1) The drop target doesn't always stay up when it's supposed to, so shots go straight through and get ejected from the asylum instead of being stopped and falling into the pops.
2) The diverter needs adjustment - it sends the ball to secret passage most of the time instead of letting it pass all the way around.
3) The pops don't light up or flash (maybe a connector issue?).
4) There are a couple flaky LEDs that don't want to stay lit (again, connectors). Should be easy to fix.

Other than that, I've got Pinball Customs' coffin mod in hand (#5 of the first 20) and ready to install - phenomenal work and a MASSIVE upgrade over the hedgehog.

Already put about 100 plays on it and loving it! The thunder and Drac's laughter sounds amazing with the Flipper Fidelity kit.

image_(resized).jpeg

#3363 3 years ago
Quoted from DoubleDanger:

1) The drop target doesn't always stay up when it's supposed to, so shots go straight through and get ejected from the asylum instead of being stopped and falling into the pops.
2) The diverter needs adjustment - it sends the ball to secret passage most of the time instead of letting it pass all the way around.
3) The pops don't light up or flash (maybe a connector issue?).
4) There are a couple flaky LEDs that don't want to stay lit (again, connectors). Should be easy to fix.

1 and 2, get that PF up and clean those mech's, normaly a good clean and some mild tuning changes games from night to day
3. pops are GI and should lightup all the time, if they are not modified to flashers, probably burned out if normal lamps

#3364 3 years ago

Hey all, I'm curious to hear how 'Bats' goes for everyone here. More often than not, I drain before completing the switch hits or end up with a crappy bats bonus - less than 20mil or so. It's rare that I end up with the full 50 or complete it on ball 1. Is this normal or is it me?

#3365 3 years ago
Quoted from tjprice222:

Hey all, I'm curious to hear how 'Bats' goes for everyone here. More often than not, I drain before completing the switch hits or end up with a crappy bats bonus - less than 20mil or so. It's rare that I end up with the full 50 or complete it on ball 1. Is this normal or is it me?

I think some of the tourney players like to get multiball before starting Bats. It helps to ensure the full 50 but you'd want to do it on ball 1. Otherwise I try to keep feeding the pops in single ball. The best way is by hitting the right orbit.

#3366 3 years ago

Any one have a problem with the ball coming out of the shooter lane and hitting the upper ramp? It only happens when it auto-plunges like with ball save. I cringe every time. I think it's because the ball isn't settled and the plunger fires it in the air. Any suggestions where to adjust?

#3367 3 years ago
Quoted from dmbjunky:

Any one have a problem with the ball coming out of the shooter lane and hitting the upper ramp? It only happens when it auto-plunges like with ball save. I cringe every time. I think it's because the ball isn't settled and the plunger fires it in the air. Any suggestions where to adjust?

Do hou have the clear plastic at the top of the ramp? Its there to stop that from happening

#3368 3 years ago
Quoted from bigd1979:

Do hou have the clear plastic at the top of the ramp? Its there to stop that from happening

No, I guess not. I don't see the piece in pics on IPDB either.

#3369 3 years ago

This one? Screenshot_2016-05-11-01-00-34-1.png

#3370 3 years ago

Thanks. I'm gonna have to find something to put there. I'm afraid it's gonna break my ramp.

#3371 3 years ago
Quoted from dmbjunky:

Thanks. I'm gonna have to find something to put there. I'm afraid it's gonna break my ramp.

U can buy the 3 piece clear plastic set somewhere bc thats what I did. It was someone on here that makes them

#3373 3 years ago
Quoted from dmbjunky:

I think some of the tourney players like to get multiball before starting Bats. It helps to ensure the full 50 but you'd want to do it on ball 1. Otherwise I try to keep feeding the pops in single ball. The best way is by hitting the right orbit.

Another way to do it is qualify coffin locks... Then start bats... That gives you two shots to the right with direct feed to the pops

#3374 3 years ago

https://i1.pinside.com/e/ad/ead74ef8555a54d2f1fe5bbc6bb71a32d2997dd3/resized/320/ead74ef8555a54d2f1fe5bbc6bb71a32d2997dd3.png.jpg

I think this plastic should be reversed and postioned partly over the lift gate towards the front of the machine. I've seen them mounted both ways. I went back thru the thread to verify and most pics show it this way.

36_G_sized_(resized).jpg

#3375 3 years ago
Quoted from neverahighscore:

https://i1.pinside.com/e/ad/ead74ef8555a54d2f1fe5bbc6bb71a32d2997dd3/resized/320/ead74ef8555a54d2f1fe5bbc6bb71a32d2997dd3.png.jpg
I think this plastic should be reversed and postioned partly over the lift gate towards the front of the machine. I've seen them mounted both ways. I went back thru the thread to verify and most pics show it this way.

This is correct. Mine was originally the other way, and it didn't work nearly as well.

#3376 3 years ago
Quoted from neverahighscore:

I think this plastic should be reversed and postioned partly over the lift gate towards the front of the machine. I've seen them mounted both ways. I went back thru the thread to verify and most pics show it this way.

Sorry, for clarification, meant to say lift ramp not lift gate.

#3377 3 years ago
Quoted from neverahighscore:

https://i1.pinside.com/e/ad/ead74ef8555a54d2f1fe5bbc6bb71a32d2997dd3/resized/320/ead74ef8555a54d2f1fe5bbc6bb71a32d2997dd3.png.jpg
I think this plastic should be reversed and postioned partly over the lift gate towards the front of the machine. I've seen them mounted both ways. I went back thru the thread to verify and most pics show it this way.

Yea I agree and just wanted to show op the plastic in question ...that was a stock picture I found on Google. Mine is correct on my pin

#3378 3 years ago

Anyone else care to weigh in on my 'Bats' question from earlier?

Quoted from tjprice222:

Hey all, I'm curious to hear how 'Bats' goes for everyone here. More often than not, I drain before completing the switch hits or end up with a crappy bats bonus - less than 20mil or so. It's rare that I end up with the full 50 or complete it on ball 1. Is this normal or is it me?

#3379 3 years ago
Quoted from tjprice222:

Hey all, I'm curious to hear how 'Bats' goes for everyone here. More often than not, I drain before completing the switch hits or end up with a crappy bats bonus - less than 20mil or so. It's rare that I end up with the full 50 or complete it on ball 1. Is this normal or is it me?

It's you!

#3380 3 years ago

I agree with 27dnast: Get the coffin open and you've got an easy shot to send into the middle of the pops. I wouldn't worry too much about trying to max out bats the first time through. If you hit enough ramps, you'll get another opportunity anyway, and doing it with stacked multiballs makes it worth much more (and easier to complete).

#3381 3 years ago

Just got a BSD that is cosmetically beautiful, 8/10. Board is clean (9/10).

The Mist mode work as I tested it. It does seem extremely loud. I'm not sure if it's the Motor or what.
I've read that they are not maintainable. Is this true. Marco Specialties is out.

Any tips on making the Motor run more quietly?

#3382 3 years ago

It's supposed to be tough to finish bats, let alone for 50 million. Drac is a mean vampire.

#3383 3 years ago
Quoted from TechnicalSteam:

Just got a BSD that is cosmetically beautiful, 8/10. Board is clean (9/10).
The Mist mode work as I tested it. It does seem extremely loud. I'm not sure if it's the Motor or what.
I've read that they are not maintainable. Is this true. Marco Specialties is out.
Any tips on making the Motor run more quietly?

I think I remember reading there are some gears you can grease to help it out but I've never done it. That won't help the noise but maybe it will last a little longer.

#3384 3 years ago

Speaking of the mist motor. Is there any speed setting or way to modify it? Mine literally flies across the playfield where other games I've played seem to take longer to get across. I should take a video of it.

#3385 3 years ago
Quoted from TechnicalSteam:

Just got a BSD that is cosmetically beautiful, 8/10. Board is clean (9/10).
The Mist mode work as I tested it. It does seem extremely loud. I'm not sure if it's the Motor or what.
I've read that they are not maintainable. Is this true. Marco Specialties is out.
Any tips on making the Motor run more quietly?

It's loud. Mine is loud. Drac is loud. The MIST call out is loud.

Deal.

Nuff' said.

#3386 3 years ago

Hi is it possible to buy a full insert decal sheet for dracula? Im having a go at clearcoating mine so it would be nice to put on new insert decals?

Thanks

#3387 3 years ago

Finding it difficult to find cliffy's for BSD. Anyone know who has them? Thanks.

#3388 3 years ago

Cliffy has them
email him

#3389 3 years ago
Quoted from PjM:

Finding it difficult to find cliffy's for BSD. Anyone know who has them? Thanks.

http://www.passionforpinball.com/bsd.htm

#3390 3 years ago

Anybody found insert decals for sale??

#3391 3 years ago
Quoted from markandsophie:

Anybody found insert decals for sale??

You're probably gonna have to make them yourself.

#3392 3 years ago
Quoted from Thor-NL:

3. pops are GI and should lightup all the time, if they are not modified to flashers, probably burned out if normal lamps

I think I got issues 1 and 2 fixed (thank god that roller pin hadn't fallen out of the diverter assembly), but I'm still stumped by my lighting issue with the pop bumpers. I've replaced the bulbs with brand new ones but still never see any light. I can't even find which wires these are supposed to be when I look at the lamp matrix - I don't see anything listed for the pops. Can anyone offer any assistance? I would love to be able to track this down and fix it. Without them the upper playfield is pretty dark.

#3393 3 years ago

The pop-bumper lights are GI, so they are not in the lamp-matrix.
The are connected in one of three General Illumination strings.

Follow these strings for breaks or shortning.
The fuses on the powerboard are oke?

#3394 3 years ago

Considering putting mine on the market but looking for info on pricing. It's clearcoated with better than average cabinet. Seen pricing all over the place and frankly need to get as much out of it as I can. Thoughts?

#3395 3 years ago

low 3k? Maybe that's a really good deal with a cleared playfield.

#3396 3 years ago
Quoted from TaylorVA:

Considering putting mine on the market but looking for info on pricing. It's clearcoated with better than average cabinet. Seen pricing all over the place and frankly need to get as much out of it as I can. Thoughts?

I assume your awesome rails are installed? Pm sent

#3397 3 years ago
Quoted from mollyspub:

I assume your awesome rails are installed? Pm sent

Actually has original metal rails. I was under the assumption all BSDs had the metal rails until I was sent some from HEP to replicate.

#3398 3 years ago
Quoted from Thor-NL:

The pop-bumper lights are GI, so they are not in the lamp-matrix.
The are connected in one of three General Illumination strings.
Follow these strings for breaks or shortning.
The fuses on the powerboard are oke?

Thanks Thor, I hadn't thought about them being GI and not in the matrix. I'll take a closer look at the GI strings and see if I notice anything strange. I don't think there's any problem with the fuses.

#3399 3 years ago

For the pop bumbers, I had an issue like that with my WH2O. Most frustrated but turned out I had the wrong kind of bulb. Make sure you have the bulb with connection on both sides not just opposite.

1 week later
#3400 3 years ago

I have a weird issue... on my third castle lock the game just sits 15 seconds until a ball search kicks-in and eventually starts castle multi-ball.

I checked the optos in the castle...all three are working and register.

Anyone else experience anything like this?

Promoted items from the Pinside Marketplace
$ 279.95
Lighting - Led
Pin Stadium Pinball LEDs
From: $ 129.10
Cabinet - Sound/Speakers
PinWoofer
There are 7137 posts in this topic. You are on page 68 of 143.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside