(Topic ID: 29878)

Bram Stokers Dracula Club....Welcome to the Carpathians


By shacklersrevenge

6 years ago



Topic Stats

  • 6,356 posts
  • 550 Pinsiders participating
  • Latest reply 11 hours ago by Tuxedomask23
  • Topic is favorited by 216 Pinsiders

You

Linked Games

Topic Gallery

There have been 1,924 images uploaded to this topic. (View topic image gallery).

15587378635763326964669413919300 (resized).jpg
15587378246508738198248089800620 (resized).jpg
IMG_8884 (resized).jpg
IMG_0276 (resized).jpg
IMG_0275 (resized).jpg
IMG_0272 (resized).jpg
IMG_0271 (resized).jpg
IMG_0265 (resized).jpg
IMG_0264 (resized).jpg
IMG_0261 (resized).jpg
IMG_0246 (resized).jpg
IMG_0243 (resized).jpg
Screen Shot 2019-05-17 at 2.01.13 PM (resized).png
image (resized).jpeg
2D65D415-2484-490B-B7D9-91B304349B67.jpeg
92EA66D3-B9CB-44B2-9908-270F62309016.jpeg

There are 6356 posts in this topic. You are on page 127 of 128.
#6301 34 days ago
Quoted from pinball_customs:

Good news, all! I pre-sold 3 of my ORIGINAL Dracula mods, and decided to make 3 more at the same time. So I have 3 Dracula mods boxed and looking for addresses to be shipped to!!

#6302 34 days ago

I'm also willing to make a few more unpainted for those who are interested in a different paint scheme

#6303 34 days ago

Those drac mods are OUTSTANDING. Damn I wish I had this game

#6304 33 days ago
Quoted from PsychoPsonic:

Rules goals: Start Castle mb, start video mode, start Coffin mb, score 30m jackpot

I wouldn't consider Castle MB the easiest of those goals. I would probably consider it 3rd hardest. I'd swap castle and coffin in your list.

#6305 33 days ago
Quoted from aobrien5:

I wouldn't consider Castle MB the easiest of those goals. I would probably consider it 3rd hardest. I'd swap castle and coffin in your list.

30m jackpot meaning stack all 3 multiballs at once is a pretty significant goal. I'd at least put in a 20m jackpot goal, achievable by ant 2 of 3 stacked mbs.

#6306 33 days ago
Quoted from pinball_customs:

This one
[quoted image]

Was lucky enough to have one of these on my machine when I bought it....stunning!!!!

#6307 33 days ago
Quoted from MK6PIN:

Was lucky enough to have one of these on my machine when I bought it....stunning!!!!

Thanks man!

#6308 33 days ago

Been wanting one of these for awhile. how much are you asking?

#6309 33 days ago
Quoted from TDEX:

Been wanting one of these for awhile. how much are you asking?

They're $180 shipped in North America. Can ship Tuesday (our postal services are down tomorrow in Canada)

#6310 29 days ago

Hi new BSD owner. Anyone know the exact color of the light blue on the cabinet next to the coin door? Thanks!

#6311 27 days ago
Quoted from garbr95:

Hi new BSD owner. Anyone know the exact color of the light blue on the cabinet next to the coin door? Thanks!

These are decals, so it's unlikely. Also, with age, every one will be a little different at this point. You're going to have to get something close and color match it yourself.

#6312 25 days ago

this its cool the coolest would be that somebody photoshop out the old drac and put the red armored drac on the original translite...and would be AMAZING

#6313 24 days ago
Quoted from Metzu:

this its cool the coolest would be that somebody photoshop out the old drac and put the red armored drac on the original translite...and would be AMAZING

Sounds like a good idea as most don't like the look of old Dracula.
Ill post pics once i get the new translite on my game.

#6314 22 days ago
Quoted from aobrien5:

These are decals, so it's unlikely. Also, with age, every one will be a little different at this point. You're going to have to get something close and color match it yourself.

Thanks for the info! What’s the best way to polish the dull looking lower playfield area by the flippers? I’ve heard that Williams machines don’t have a clear coat on them from the factory. The upper playfield is glossy but the lower is not. Tried Novus 2 but no luck. It’s not dirty just real hazy.

#6315 21 days ago

I have two Dracula mods left for sale. $180usd shipped in North America, $220 overseas. 50% deposit required now, remainder due when you get your tracking info. I won’t be making these again for a while.. they take about 7hrs each to produce.

PM if interested!

Screenshot_2019-05-03-20-51-56(1) (resized).png
#6316 21 days ago
Quoted from garbr95:

Thanks for the info! What’s the best way to polish the dull looking lower playfield area by the flippers? I’ve heard that Williams machines don’t have a clear coat on them from the factory. The upper playfield is glossy but the lower is not. Tried Novus 2 but no luck. It’s not dirty just real hazy.

Wax is about your only option. Learn about the right way to do it here. https://pinside.com/pinball/forum/topic/cleaning-and-waxing-pinball-machines-vids-guide/

1 week later
#6317 12 days ago

I joined the club this weekend. Loving the challenge so far.

The only problem is that the launch ball button will not work. The settings have to be set to launch ball with the flipper buttons. Can anyone confirm that my launch button is wired correctly?
6523F807-A84B-4D49-98BA-947A9FE26B07.jpeg6383C920-D56A-437F-A7FC-81D12CAF27BB.jpeg82E3418E-8FC4-42B1-AD63-2808B481795F.jpeg

#6318 12 days ago
Quoted from Jakers:

launch button is wired correctly?

Wiring looks fine. Check that the switch is seated in the housing. When you press the button it needs to activate the switch.

#6319 12 days ago

looks like the diode is not touching the metal, re solder those points.

#6320 12 days ago

The switch is definitely seated correctly and all connections are solid. When I press the button I can hear the "click" of the switch. Where in the backbox do the start button wires connect?

#6321 12 days ago

Does it actually activate in switch test?

#6322 12 days ago
Quoted from aobrien5:

Does it actually activate in switch test?

It does not. It’s what’s causing my credit dot, which in turn causes my OCD to explode. Haha

#6323 11 days ago
Quoted from Jakers:

It does not. It’s what’s causing my credit dot, which in turn causes my OCD to explode. Haha

Short the switch with a piece of wire in switch edge test....does it register? That will determine if it is a switch or wiring/mpu issue.

#6324 11 days ago

Not mine, don't know the seller, but seems like a good deal for a nice BSD in Atlanta. ebay.com link » 1993 Williams Bram Stokers Dracula Pinball Machine

#6325 11 days ago
Quoted from robertmee:

Not mine, don't know the seller, but seems like a good deal for a nice BSD in Atlanta. ebay.com link » 1993 Williams Bram Stokers Dracula Pinball Machine

Looks to be a great deal indeed. Includes a Pinsound board (usually about $400?) and has new optos/opto board. I Imagine it won't last long at all (sort of thing that would have been gone in minutes if posted on FL's Village BBS [eBay is never on my radar with how pricing there usually is]).

#6326 11 days ago

I’ve tried shorting the launch ball switch in switch test mode. It doesn’t register. Can someone tell me where the launch ball button wires connect to the board? I’m guessing it’s J212 but I’d like confirmation.

Thanks.

#6327 10 days ago

Below is a PDF of the switch matrix chart for BSD and a PDF of the CPU board layout. According to the switch matrix chart the 'Launch Ball' button connects to the following two points on the CPU board for Row 4 Column 3.

J209-4 White-Yellow Wire
J207-3 Green-Orange Wire

You may also need to investigate to see if there is a broken wire somewhere in your row/column chain.

Gord

BSD_Switch_Matrix.pdf
BSD_CPU_Board.pdf

#6328 10 days ago
Quoted from GRB1959:

Below is a PDF of the switch matrix chart for BSD and a PDF of
the CPU board layout. According to the switch matrix chart
the
'Launch
Ball' button connects to the following two points on the CPU
board for Row 4 Column 3. You may also need to investigate to
see
if there is a broken wire somewhere in your row/column chain.
J209-4 White-Yellow Wire
J207-3 Green-Orange Wire
Gord
[quoted image]
[quoted image]

Pull those two connectors on the board, go into switch test, and
with a paperclip or short jumper, short pin j209-4 to j207-3
on the board. Does
Ball Launch register? If so, board is good, and issue is a
broken
wire/diode in the PF on that column/row. If it doesn't
register,
then board issue.

Also, if it doesn't register, continue shorting the rest of J209-4 to J207 (each pin, one at a time). Then J207-3 to each of J209 (each pin, one at a time). See if an entire row or column is out.

#6329 10 days ago
Quoted from robertmee:

Pull those two connectors on the board, go into switch test, and
with a paperclip or short jumper, short pin j209-4 to j207-3
on the board. Does
Ball Launch register? If so, board is good, and issue is a
broken
wire/diode in the PF on that column/row. If it doesn't
register,
then board issue.
Also, if it doesn't register, continue shorting the rest of
J209-4 to J207 (each pin, one at a time). Then J207-3 to each of
J209 (each pin, one at a time). See if an entire row or column is
out.

Ok, now I’m really confused. There is nothing plugged into my j207 or j209 on the board.

Everything on the game works except for the launch ball button.

This is a re-import from Germany. Would that make any difference in the wiring??

51973193-D814-4216-A5A0-FA95B08AA126.jpeg971E1D8D-AEC1-4914-8874-BDDA97EE1AC3.jpeg0A5E4E17-F02B-47B5-9D95-56F641645B7A.jpeg
#6330 10 days ago

J206 and J208 are equivalent

#6331 10 days ago
Quoted from dr_nybble:

J206 and J208 are equivalent

So you’re saying I can unplug j206 and j208...then plug them into j207 and j209? What is the reason for having equivalent connections?

#6332 9 days ago
Quoted from Jakers:

So you’re saying I can unplug j206 and j208...then plug them into j207 and j209? What is the reason for having equivalent connections?

Yup you can see that documented here: http://pinwiki.com/wiki/index.php?title=Williams_WPC at section 6.24.3 Switch Matrix Problems

I guess it is to supply redundancy but not really sure

#6333 9 days ago

I just had a playfield swap done, installing a new Mirco playfield and I'm working the bugs out and when you turn the machine on the mist motor runs continuously and reverses at the ends but doesn't stop, also the magnet drops the ball 1/3 of the way thru it's travel, I checked the gap under the playfield and have about a 1/8" uniform gap between the magnet and cutout in the playfield. The other issue is that when you turn the machine on the shooter lane ramp does not go up in order to shoot the ball up into the right side gate where the opto is, it's solonoid #8 and works fine in test mode, what initiates it being energized?

#6334 9 days ago
Quoted from tomtest:

mist motor runs continuously and reverses at the ends but doesn't stop

pretty sure there's a home leaf switch at the end of the tract, might need adjusting when it comes back to home.

Quoted from tomtest:

magnet drops the ball 1/3 of the way thru it's travel

probably the long opto transmitter and/or receiver, or the opto board might be having problems. if the optos are mounted too high or low across from another, they won't work...its a long opto beam. also, the copper gates might need adjusting so that they don't block it...lots of fine tuning.

Quoted from tomtest:

machine on the shooter lane ramp does not go up in order to shoot the ball up into the right side gate

could be related to the home switch on the magnetic track, or mist opto issues. the entire mist multiball system is kind of a PIA. I'm thinking one of those switches that isn't working for you is the fault for triggering the coil. have you tried to test the machine with the mist service test?

that's what i have for you, hope it helps. i haven't had to deal with my mist problems for 3 years THANK GOD.

#6335 9 days ago
Quoted from dr_nybble:

Yup you can see that documented here: http://pinwiki.com/wiki/index.php?title=Williams_WPC at section 6.24.3 Switch Matrix Problems
I guess it is to supply redundancy but not really sure

Correct...if you note, the traces on the board go from one connector right to the next one. So they are redundant. Remember, Williams built these boards to service a multitude of games. So additional unused connectors on a particular game is not uncommon.

#6336 9 days ago
Quoted from Jakers:

Ok, now I’m really confused. There is nothing plugged into my j207 or j209 on the board.
Everything on the game works except for the launch ball button.
This is a re-import from Germany. Would that make any difference in the wiring??[quoted image][quoted image][quoted image]

I think we've covered your connector question....But no, re-import from Germany shouldn't have any effect on the switch matrix that I'm aware of.

#6337 9 days ago
Quoted from robertmee:

I think we've covered your connector question....But no, re-import from Germany shouldn't have any effect on the switch matrix that I'm aware of.

Thank you for that link. I haven’t dealt with tracking down a switch matrix issue before but that link is pretty easy to understand.

I jumpered the pins that correspond to the launch ball switch and it registers. So, I assume that means my issue is under the playfield with either a broken diode or a broken wire?

#6338 9 days ago

I’ve took a paper clip and jumpered the launch ball switch at the connector of the launch button. It registers in switch test mode. So, I have either a faulty switch or it is wired wrong. Can someone please visually compare my switch wiring to theirs?

92EA66D3-B9CB-44B2-9908-270F62309016.jpeg9E49DFCC-D243-4E66-81BD-E722E2748C76.jpegD7F856A6-3F4A-4510-8BF8-8611ED3EC36B.jpeg
#6339 9 days ago
Quoted from Jakers:

I’ve took a paper clip and jumpered the launch ball switch at the connector of the launch button. It registers in switch test mode. So, I have either a faulty switch or it is wired wrong. Can someone please visually compare my switch wiring to theirs?
[quoted image][quoted image][quoted image]

I suggested earlier to jumper the switch and you responded that it didn't register. Is that true? That it registers at the connector with a jumper but not at the switch with a jumper? If so that would suggest the connector is faulty.

#6340 9 days ago

Oh, and the switch is wired correctly.

#6341 9 days ago

I found my launch ball switch problem. The non banded side of the diode wasn't a solid connection to the WHT/YEL wire. I desoldered, cleaned and soldered it back together. It seems to be working fine now. Thanks robertmee for all your help.

However, the credit dot remains. I have a “check switch f6 UR flipper but” error. The previous owner told me about this but what does it mean and can I get rid of this error?

2D65D415-2484-490B-B7D9-91B304349B67.jpeg
#6342 9 days ago
Quoted from Ballsofsteel:

pretty sure there's a home leaf switch at the end of the tract, might need adjusting when it comes back to home.

probably the long opto transmitter and/or receiver, or the opto board might be having problems. if the optos are mounted too high or low across from another, they won't work...its a long opto beam. also, the copper gates might need adjusting so that they don't block it...lots of fine tuning.

could be related to the home switch on the magnetic track, or mist opto issues. the entire mist multiball system is kind of a PIA. I'm thinking one of those switches that isn't working for you is the fault for triggering the coil. have you tried to test the machine with the mist service test?
that's what i have for you, hope it helps. i haven't had to deal with my mist problems for 3 years THANK GOD.

Thanks ballsof steel, I'll try what you suggested, what initiates the shooter lane ramp to go up at start?

#6343 9 days ago
Quoted from Jakers:

However, the credit dot remains. I have a “check switch f6 UR flipper but” error. The previous owner told me about this but what does it mean and can I get rid of this error?

Check the opto's on the flipper-board (cabinet behind the fhysical button) clean and adjust by bending it in or out.

#6344 8 days ago

Here's the newest alt translite for BSD !
I'm happy to say that I was able to work with Hassanchop here on Pinside on the design ! Think it came out great! Haven't changed the colors of the LEDs yet so the colors are a bit off.

image (resized).jpeg
#6345 7 days ago

Are these going to available?
Price?

Thanks,

RM

#6346 7 days ago
Quoted from RussMyers:

Are these going to available?
Price?
Thanks,
RM

Pm sent

#6347 7 days ago

We have family visiting tonight through the weekend and I wanted to play some pins with everyone. I went to play BSD last night, and after getting coffin and castle MB's going, I started Mist and noticed the magnet wasn't activating. I then drain the balls and finally noticed that several lights are actually out, realized the magnet never tested itself upon power up and the coffin ramp never went back down after the drains.

I'm assuming a short, but I haven't removed the glass or messed with anything since playing full games just the other day. Here's an image of the exact row of lamps out, and then include the coffin ramp staying open and magnet not activating, even in test mode. Everything else seems to work fine.

Test reports: Mag Left Error, Mag Right Error, Top Right Ramp Up Error

If anyone has a quick thought for a last second save, otherwise, I'll try to investigate further after the fam leaves.

I can't decide if the tragedy of all this is that of course an error gremlin pops up hours before visitors, or if that amazingly comfortable and controlled triple stack never came to fruition. It would've been a doozy of a game, too! Ugh...

Screen Shot 2019-05-17 at 2.01.13 PM (resized).png

#6348 7 days ago

I would double check that you didn't blow a fuse on the power driver board first. its the simplest thing. look to the leds

#6349 7 days ago
Quoted from wugly:

I would double check that you didn't blow a fuse on the power driver board first. its the simplest thing. look to the leds

Great call. I will do that first upon arrival. I wouldn't have thought to check there first so thank you.

It sucks I couldn't dive into it last night and have been away from the house all day. On the way to the airport now so it will be a fly-by approach to the fix before moving onto hosting duties and playing Mystery Castle all night instead.

#6350 6 days ago

painted my stuff...

IMG_0243 (resized).jpgIMG_0246 (resized).jpgIMG_0261 (resized).jpgIMG_0264 (resized).jpgIMG_0265 (resized).jpgIMG_0271 (resized).jpgIMG_0272 (resized).jpgIMG_0275 (resized).jpgIMG_0276 (resized).jpgIMG_8884 (resized).jpg
Promoted items from the Pinside Marketplace
Wanted
Machine - Wanted
Steamboat Springs, CO
From: $ 29.00
Boards
KAHR.US Circuits
From: $ 24.99
Lighting - Led
Lee's Parts
$ 5.00
$ 90.00
Lighting - Under Cabinet
Rock Custom Pinball
$ 129.00
Lighting - Led
LED OCD
From: $ 99.99
Cabinet - Other
Lighted Pinball Mods
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
From: $ 20.00
Cabinet - Other
Rock Custom Pinball
$ 40.00
Lighting - Other
Rock Custom Pinball
$ 999.00
Flipper Parts
Mircoplayfields
$ 180.00
Playfield - Toys/Add-ons
Pinball Customs
$ 45.00
Gameroom - Decorations
Pinball Photos
$ 209.99
$ 14.95
Wanted
Machine - Wanted
Fort Lauderdale, FL
4,000
Machine - For Sale
Buckner, MO
$ 28.00
$ 29.99
Cabinet - Sound/Speakers
Lighted Pinball Mods
From: $ 16.95
$ 29.99
Cabinet - Sound/Speakers
Lighted Pinball Mods
$ 10.00
Cabinet - Sound/Speakers
Gweem's Mods
Trade
Sale Pending!
Radford, VA
€ 95.00
Lighting - Led
FlipperLED
Hey modders!
Your shop name here
There are 6356 posts in this topic. You are on page 127 of 128.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside