(Topic ID: 41035)

Bought a Flight 2000 and Panthera


By Whitebuffalo

6 years ago



Topic Stats

  • 73 posts
  • 19 Pinsiders participating
  • Latest reply 6 years ago by Whitebuffalo
  • Topic is favorited by 2 Pinsiders

You

Linked Games

Topic Gallery

There have been 10 images uploaded to this topic. (View topic image gallery).

0305131930.jpg
DSC02058.JPG
DSC02060.JPG
DSC02061.JPG
0305131009.jpg
0304131043.jpg
DSC01923.JPG
DSC01922.JPG
0222131000a.jpg
0222131000.jpg

There are 73 posts in this topic. You are on page 2 of 2.
#51 6 years ago

Got it powered up, but doesn't start a game. The game does boot up. It just doesn't take a credit and the GI doesn't light up.

#52 6 years ago

Here is a photo of it lighting up.

0305131930.jpg

#53 6 years ago

reseated J1 and now the GI is lighting!

#54 6 years ago

I forgot to mention that you will need re-pin J1 as they take alot of heat. I don't see any switched lamps lit in your pic. Is game going into attract mode? I see garbage in the displays which indicates that the memory could need to be cleared. This may also help with the credit issue. Does the game chime when booting? It should chime 7 times and then go to attract.

#55 6 years ago

I had the GI lighting and credits taking this morning, but now I only get two or three chimes.

#56 6 years ago

The game won't coin up if it's not booting all the way. Chimes are a good indication that your sound board is working. Each time it chimes(LED on MPU blinks with the chime)is another step in the boot process. You can find out what each one means on Pinwiki or clays guides. IIRC only 2 chimes means bad 5101 ram(s). The MPU -200 uses 2 5101 chips as opposed to only 1 on bally games. The 5101 has to be atleast 3 nano seconds or faster. Is there any signs of battery leakage on the MPU?
Rich

#57 6 years ago

It varies sometimes it will fully boot (with 7 chimes), but now the displays won't turn on.

#58 6 years ago

You probably have flaky connectors. Typical of these old solid state games. So the MPU is clean? Try re-seating the mpu and solenoid driver connectors. You might have inconsistent voltages for the 5v and 12V needed to run the mpu. If you can get the game to boot fully and the displays are showing garbage, try to clear the audits. This is done thru the coin door switch test and using s33 on the mpu. Also run the self tests, lamps, coils, displays, etc.
I'm leaving for work so I can't reply until tomorrow, good luck,
Rich

#59 6 years ago
Quoted from Whitebuffalo:

Does anybody know if it is suppose to be there?

That looks like it could be the bottom board from a game such as Galaxy with a GI relay on it.

#60 6 years ago
Quoted from sysprog:

That looks like it could be the bottom board from a game such as Galaxy with a GI relay on it.

Good guess but F2K doesn't have a GI relay.

#61 6 years ago

Order the two IC 5101 from Marco. They should be here in a couple days.

#62 6 years ago

Also ordered all new drops targets for Flight 2000 and LED's for Panthera. Starting to think about what LED's I'm going to use in Flight 2000. First, though, got to get the thing working! IC's should come Monday. After that I'll have to see on what the next step is in the restore process.

#63 6 years ago

The 5101 is very sensitive to static. Handle them carefully and as little as possible. Did you get the rectifier board installed yet? Reading back on this thread I see you almost had the pf fall on you? I never trust that prop rod on F2K because the wide pf combined with the weight of the massive DT bank makes the pf lean too much. That DT bank can actually hold 9 drops. The same unit is used on Nineball and uses 8 drop targets. What's nice is that there's a 24 pin plug that you can disconnect and easily remove the DT bank. Did you get the new drops from PBR?
Rich

#64 6 years ago

The rec board is installed that is how I know the 5101's are bad. I never trust the prop stick, so I had it leaned up against the backbox it still fell. Luckly enough it didn't fall on me. I got the five blank drops and the decal set from Marco. I wasn't aware that PBR had them. I'll have to remember that the bank unplugs.

#65 6 years ago

When I work on F2K I used a long piece of wood to hold the up. There's a round hole under the apron that I prop it into. If you lean the pf on the head, you have to lift the bottom of the pf out and place it on the wooded slides so that the pf leans on an angle and won't fall, you have to watch that sharp parts on the pf don't scrape the wood trim on the head.

#66 6 years ago
Quoted from PapaJohn:

Flight 2000 is slow? Are you serious? Its got 4 slingshots and with a clean and waxed playfield its just about as fast as any game out there. No flow?...its got straight forward objectives with a definite flow. By the way, is speed the main factor in a pinball machine or is it fun gameplay?

Agreed. My F2K is brutally fast. Like airball cracking the glass fast. But my games have 20 coats of wax on them, new rubbers and anything fishy was rebuilt. Even if it wasn't, the F2K is an extremely fast game.

#67 6 years ago

Put in a new 5101 at U8 last night it got me back to where I was originally. The game boots, but doesn't or can't fire up a game. The soleniods don't work right now, so I'm thinking the next step is to look into the driver board.

#68 6 years ago

nm, didn't read the beginning of the thread.

Post edited by harbngr : being an idiot

#69 6 years ago

If it won't credit up or start a game, but you get the 7 flashes/chimes, and it goes into attract mode, I'd check the connectors on the MPU board. Remove them, clean them, reseat them.

If you haven't already, consider reflowing the solder on all the connector pins. Several of mine were broken loose and free floating in their holes in the board. Also, probably not a bad idea to replace all the electrolytic caps on the two sound boards and the big filter caps on the solenoid driver board. Those things did the trick for me, anyway.

Have you figured out what they were trying to achieve with that relay they put on the power supply?

#70 6 years ago

It is now "working" as far as it starts a game (cracked molex), but now when you lock two balls it kicks one out and one into the shooter lane. That isn't suppose to happen.

#71 6 years ago

The game is confused if this is happening. Sounds like a switch adjustment. There's four switches in the ball maze area. Also check the micros at the trough. The trip wires for the micros are touchy. Buzz out the switches when all 3 balls are in the trough. Also the 4 switches in the maze area have caps, so check those as well.

#72 6 years ago

When I had my F2K that big plug on the rectifier board in the cab gave me nothing but trouble. Whwn I made a new one for it the game worked perfect

#73 6 years ago

Looks like the game solved the problem for itself. It has stopped shooting out two balls. Now, to a few other issues.
One, the lower pop bumper won't fire, but it did fire once or twice today. That was really weird since I haven't ever seen it fire before. Just in case you think it is the switch it isn't. Whenever it is touched by the ball it scores points, but doesn't trigger the pop.
Next, The lower left sling if hooked up blows a fuse down in the lower. I'm thinking it might be related to why the pop isn't working, or that the coil is bad.
Lastly, All the slingshots chatter when fired or fire multiple times. I have no idea what would cause this.
Other than that the game is really coming along great. Thanks for the tips so far!

Promoted items from the Pinside Marketplace
$ 9.00
Cabinet Parts
Third Coast Pinball
$ 289.00
$ 6.00
Cabinet - Other
Siegecraft Electronics
$ 44.99
Electronics
PinballElectronics.com
From: $ 18.00
Apparel - Men
Pinside Shop
From: $ 155.00
From: $ 155.00
$ 5.00
Playfield - Decals
Doc's Pinball Shop
$ 119.95
Boards
Allteksystems
There are 73 posts in this topic. You are on page 2 of 2.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside