New! Dark mode!

Browsing Pinside at night? Getting tired of all the white? Switch to dark mode using the button in the top right (or CTRL-B)!

(Topic ID: 183390)

Bop_Switch Matrix


By Devilsmuse

3 years ago



Topic Stats

  • 62 posts
  • 6 Pinsiders participating
  • Latest reply 3 years ago by GRUMPY
  • Topic is favorited by 2 Pinsiders

You

Linked Games

Topic Gallery

There have been 26 images uploaded to this topic. (View topic image gallery).

Cherry switch back (resized).jpg
Cherry Switch 2 (resized).jpg
Cherry switch 1  (resized).jpg
Cherry switch 5 (resized).jpg
Cherry switch back 1 (resized).jpg
Cherry switch 4 (resized).jpg
switch_matrix_phantom_switches_2 (resized).jpg
sw 54 (resized).jpg
sw 51 (resized).jpg
Socket repair back (resized).jpg
CPU board back (resized).jpg
CPU board front (resized).jpg
Socket repair (resized).jpg
Header pins (resized).jpg
pins and connectors (resized).jpg
connectors J207, J209 (resized).jpg

You're currently viewing posts by Pinsider Devilsmuse.
Click here to go back to viewing the entire thread.

#1 3 years ago

I have a switch problem on my Bride of Pinbot. I have been following the test procedures of a really great article on switch matrixes by Pinballrehab http://www.pinballrehab.com/1-articles/solid-state-repair/repair-guides/146-switch-matrix-theory-and-troubleshooting#comment-362

So far I have checked the CPU board by using the jumper test on J209 and J207
I have confirmed continuity of the send and return wires of the switch matrix column 5 grn-blk.

I have tested the switches and diodes for continuity and this what I have found
Note, in my testing I first tested across the switch the send and return terminals and keeping the test leads in the same position tested the diode. I then reversed the test leads and tested again across the switch, then across the diode and recorded the results.

Column. Across switch. Across diode
SW # 1st/2nd. 1st/2nd
51 spinner. Y / N. N / Y
52 shooter. Y / N. Y / Y
53 Ur jet bmp. Y / N. N / Y
54 Ul jet bmp. Y / Y. Y / N
55 low jet bmp. Y / N. N / Y
56 jet sling bmp. Y / N. N / Y
57 left sling shot. Y / Y. Y / N
58 right slingshot. Y / N. N / Y

Any help interpreting my test results would be greatly appreciated.

#4 3 years ago
Quoted from terryb:

You mention the column line, did you also test the row for continuity?
Which switch(es) are not working?

I tested the return lines or row ( if I am understanding correctly) from switch back to the j209 (ie wht/green ) and there was continuity on all. The game used to tell me switch 54, the jet bumper is still not working. The other switches 57 ,left slingshot seem to be working but I cant tell by playing if one of the two of them is not-it still kicks out the ball. The shooter switch may or may not be working I am not sure what it does.

#5 3 years ago
Quoted from GRUMPY:

Am I understanding correctly that Y = continuity and N = no continuity? If so then switches 54 and 57 and stuck closed. The diode on switch 52 is shorted. Also the diode on switches 54 and 57 are installed backwards. Maybe when the diodes are reversed the switches 54 and 57 will not show closed all the time.

You are understanding correctly Y=continuity and N=OL no continuity. Grumpy everything you say could be the case. The electronics could very well be that messed up backwards and shorted. I bought this game as a "players game" and am restoring it for my own small collection. I have no idea how many owners it has had or who worked on it.

#7 3 years ago
Quoted from GRUMPY:

Then remove the diode on switch 52 and retest it, then replace it. Its only .05 cents. Check the diode band on 54 and 57 and see if they are going the correct way.

Sounds like a great plan. I am going to give it a try and let you know how it goes. Thanks

#10 3 years ago

We are without power going on day 4. I will get back to you both once day light comes.

#11 3 years ago
Quoted from terryb:

You mention the column line, did you also test the row for continuity?
Which switch(es) are not working?

Terryb, I finally tested the row 4, wht/yel this morning. Still no power but we have daylight!
Everything checked out for continuity, except for switch plumb bob tilt #14. I am not sure how to test it besides putting the test lead on the wht/yel wire connected to the plumb bob ring.

But get this is there something wrong with this picture of switch 58?

14892461562671629458318 (resized).jpg

#13 3 years ago

The diode crosses over the switch gap , comparing it to the other switches of this kind the diode should be connected to the center tab , not the outer one, as it now. I am not an electrical expert or claim to be anything even closed, but but with the switch wired like this doesn't it allow the flow of current even though the switch isn't closed?

#14 3 years ago

Also another note about that switch the green black wire should be on the outer far left tab , right now both the send and return are on the same side of the switch.

#16 3 years ago

Ah thanks Grumpy for the explanation, makes sense now. That switch was wired differently from the other two so I was hoping if it were rewired like the other two it would fix everything.

#19 3 years ago

Progress report , I re-jumper tested the j209 and J207 pins on the CPU board during switch edges test and everything checks out. During switch levels test I came across a closed switch, #67 Face position. I don't want to be a chicken little again , like the slingshot switches yesterday please check out the wiring on the #67 switch.

1489356426781-22626740 (resized).jpg

#20 3 years ago

This switch contradicts that really cool diagram of switch wiring that Terryb so gratiously posted.

#22 3 years ago

Hmm during switch test, it comes up as sw#67 (A) closed. Blinks and makes a sound like it's giving me the bird. Could it be a bad switch as opposed to it should be normally open?

#24 3 years ago

Thanks Pinwiz I will just keep searching then

#25 3 years ago

I have tested all the rows and all the columns everything has continuity that I have been able to test. Let me clarify some switches I cant get a reading but I am not sure why the flipper switches 11,12, coin door closed 22, start button 13, slam tilt 21, ticket opto 23, basically anything in the cabinet I am not getting any Ohm readings. Is there a trick to testing these switches? I also should mention that this is not the machines original coin door but looks like every thing is there.

#27 3 years ago
Quoted from terryb:

They should test the same as any other switch that is part of the matrix.

Oh boy I think I have problems then. I dont know how to begin to show you , other than take pictures of the switches and see if you can tell why I am not getting any continuity (either row or column). I am testing with the game off and the connector J209 ,J206 disconnected from the cpu board.

#28 3 years ago

Here are some pictures of the switches/ areas. Let me know if it makes any sense to you ,please.

1489545022197623593029 (resized).jpg

1489545078196236163187 (resized).jpg

1489545103945-1145533895 (resized).jpg

148954514682888373106 (resized).jpg

1489545197049-729479404 (resized).jpg

#29 3 years ago

I also just noticed "cabinet switches" J212 and "direct switches" J205 connectors on the CPU board. I need to test these? Do these have the same relationship , column/row that j209 and j206 have? Can these be jumper tested also? Thanks I am such a noob.

#31 3 years ago
Quoted from terryb:

The dedicated ground switches are not part of the matrix and work differently. No need to test them unless you're having trouble with those switches. The reason we want to test all of the switch matrix is to aid in troubleshooting since they are interrelated.
I didn't spot anything in the switches, but maybe someone else will (can't see images on the computer as good as I used to). I would be suspicious of a connection problem at the interconnect board since both row and column don't work for those switches.

So the interconnect board is the board on the inside left side of the cabinet, Last picture of my previous post? How would I test it? Check the continuity from the backbox to the board?

#33 3 years ago

Hello, I have retested ,very thoroughly and methodically all the rows and columns from the back box to the playfield and to the interconnectivity board A-14102 for continuity and everything checked out. I got out the schematics for th interconnect board and confirmed the correct wires went to the correct pins. Th only abnormality I found on pin 7 of J6 connector had a grn/red instead of grn/brn going to th plumb Bob tilt switch #14. This is of no consequence since row one still connects to as #14.
There was only one switch I could not find to test, switch 23 ticket opto, everything else has been tested for continuity and passed.

I don't know what to do next? Check the diodes? Also I am curious about whether the Pinitech WPC Reverse Switch tester would be a good thing for my problems. I understand there are a few still available. I might be able to snag one.

Thanks

#35 3 years ago

I have continuity on 14-18. Switches 11,12, I can't find on the matrix . The flippers are wired separately and those heavy gauge wires go directly to the power driver board , connector J109. There are no grn/brn or wht/brn or wht/red wires from the switch matrix present at the flipper switches. From the interconnect board I was able to test and confirm continuity for the matrix switches ,21,22,13,14, but no flipper switches 11,12,or ticket opto 23, listed in the switch matrix.

#37 3 years ago

Those cut wires are "ctr coin 2", pin 5 and "rt coin 3", pin6 on J3 . I don't know if they matter, this is not the original coin door I was told it was from another machine, meaning it didn't match the original. So when I first saw them I discounted them as meaning nothing but maybe they do?

#39 3 years ago

Terryb, just checked 14-18 and they come up working as well as 11, 12, 13. While I was at it I tested all the other switches of the matrix and the only two that don't register at all are 54 UL Jet bumper and now 51 spinner.

#40 3 years ago
Quoted from Devilsmuse:

I have tested all the rows and all the columns everything has continuity that I have been able to test. Let me clarify some switches I cant get a reading but I am not sure why the flipper switches 11,12, coin door closed 22, start button 13, slam tilt 21, ticket opto 23, basically anything in the cabinet I am not getting any Ohm readings. Is there a trick to testing these switches? I also should mention that this is not the machines original coin door but looks like every thing is there.

Terryb , I believe the post above is causing confusion, my fault. I posted this before I knew anything about J212 on the cpu board. After, with your help, I figured out how to test these send and return lines. I successfully got continuity on the grn/brn and grn/red send, from cpu to the interconnect board and from the interconnect board to all those cabinet switches. The same for the return lines wht/brn, wht/red, wht/org, wht/yel.

So I ran the switch test and every switch was accounted , except 54 UL Jet bumper and 51 spinner. This morning I checked continuity on column 5, grn/blk and row 1 wht/brn trying to diagnose the spinner 51 and there is continuity everywhere. This is driving me nuts- lol I am going to recheck the header pins/connections J212, J209, J207 next.

#42 3 years ago

Terryb, switches 51 and 54 both have two row wires and two column wires .

FYI , the switches in the row 1 , that only have one wire is sw.21 slam tilt( cabinet switch, one white and one grn, they all have just one wire row and column) and sw. 31, skill shot 50k (one wht/brn wire).

The switches in row 4 with one wire are sw34, one white and two grn/blk,and above playfield sw.64, 74 have one grn and one wht running to them.

Column 5 is the easy one just one switch #52 has one grn/blk and one wht/red wire running to it.

And now for the pictures.... note the cpu board that has been jumpered. I tested the header pins yesterday and they all passed.

connectors J207, J209 (resized).jpg

pins and connectors (resized).jpg

Header pins (resized).jpg

Socket repair (resized).jpg

CPU board front (resized).jpg

CPU board back (resized).jpg

Socket repair back (resized).jpg

#44 3 years ago

I do not have a logic probe, andI do not have a cpu board to swap out. I checked my Creature from the black lagoon and the boards don't match.

I was thinking of sending this board out to have it tested and have a NVram and socket installed while it was being looked at.

I am also wondering if its time to be testing the diodes or since the continuity test are all checking out- its time to check the cpu board?

#47 3 years ago

I would definitely test the diodes on the two non-working switches.
Also jumper across the switch and see if it is then sensed as being closed. Jumper from NO to NC.</blockquote

Terryb, as I have said before I'm a noob. NO to NG?

#49 3 years ago
Quoted from CUJO:

I had a very similar problem a while back with my BOP.
After months of struggling it was corrosion inside the mini connector that went to the CPU board.
I repinned/replaced it and all is still fine.
I could only see the greening inside after I took a flash pic and blew the pic size up.
I'm going to find you the thread.
https://pinside.com/pinball/forum/topic/bride-of-pinbot-motorswitch-issue#post-3244894

Thanks I will take a much closer look, thanks I really appreciate everyone's help on pinside.

#50 3 years ago
Quoted from terryb:

I would definitely test the diodes on the two non-working switches.
Also jumper across the switch and see if it is then sensed as being closed. Jumper from NO to NC.

Well jumpering NO to NC works! Both 51 and 54 closed. Checking the diodes now. I am going to resolder one leg to get the readings.

#51 3 years ago

Sw.34 reads .514 and OL the other way. Sw.54 reads .546 and OL the other way . Stripes are all going the right way.

#53 3 years ago
Quoted from terryb:

You may have two bad switches. Pretty rare, but possible. Jumper from the banded side of the diode to the Normally Open lug. That will also test the diode at the same time.

Terryb, I jumperedested it from band side to the NO lug and nothing happened in the switch edges test.

#55 3 years ago
Quoted from Devilsmuse:

Sw.34 reads .514 and OL the other way. Sw.54 reads .546 and OL the other way . Stripes are all going the right way.

Terry I mispoke I typed sw34- I meant to type 51. The switches in question are 51 and 54.

I took pictures of 51 and 54 and here are the switches you can see the diodes....

sw 51 (resized).jpg

sw 54 (resized).jpg

#57 3 years ago

Thanks I'm going to give that a try. Stay tuned...many thanks

#58 3 years ago

Terryb, While I am waiting for parts to arrive. I wanted to show you the spinner switch. You said you hadn't ever seen one quite like this. See if this makes any sense to you. I am confused. Theoretically can this even function as a switch in the switch matrix?

Cherry switch 4 (resized).jpg

Cherry switch back 1 (resized).jpg

Cherry switch 5 (resized).jpg

Cherry switch 1 (resized).jpg

Cherry Switch 2 (resized).jpg

Cherry switch back (resized).jpg

#61 3 years ago

Well I have good news. I replaced both sw.51 and sw.54 and it works! I can't say which was bad , probably a solder break , because the diodes and switches checked out when I pulled them out of the machine but I replaced them anyway. I redid all the wiring and soldering..... "She's Alive!" I_B_BOP_in Tonight! Thank you Mr Grumpy and a big thanks to Terryb , I learned so much trying to fix this problem- I not an expert but I do now know my way around the switch matrix. Cheers! I am so Happy!!!!!!!!!

Promoted items from the Pinside Marketplace
From: $ 5.00
Cabinet - Other
Rock Custom Pinball
5,000 (Firm)
Machine - For Sale
Keller, TX
£ 55.00
Lighting - Led
PinballToys

You're currently viewing posts by Pinsider Devilsmuse.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside