(Topic ID: 257911)

Bone busters MPU to boot in Genesis machine?


By zezami

64 days ago



Topic Stats

  • 4 posts
  • 2 Pinsiders participating
  • Latest reply 62 days ago by zezami
  • No one calls this topic a favorite

You

Linked Games

#1 64 days ago

A friend of mine has sent over his Bone Busters MPU board for testing since his machine is not booting. I've succesfully run through Marcos test rom and extended test rom and it all checks out ok.

The system 80b board for bone busters is configured for 2732 in prom2 socket. I have a Genesis myself which has the 2716 prom2 configuration. Would it be possible, without damaging anything, to put the bone busters mpu board with bone busters roms in to my Genesis and see if it boots?

I guess the safest test would be to rejumper the board for 2716 and put my Genesis roms in there to see if it boots, but I thought i'd ask since i don't really want to rejumper it.. Bone busters has 2732 jumpers set as well as a cut trace on the circuit side and an extra cable running on the back of the board to accomplish this 2732 config. This cut trace and cable were installed at factory as I understand it from pinwiki.

#2 64 days ago

Figured out I could double up the 2732 with Genesis 2716 image. Tried this rom in with my Genesis mpu just to verify that it works and it did.

I managed to get the bone Busters mpu to boot with the Genesis ROMs a couple of times when I had the middle left side connector disconnected, sound board disconnected and display disconnected. But most of the time, or when I had all connectors connected it doesn't boot. Any suggestions on what might cause this? Marcos test ROMs runs through everything just fine..

#3 63 days ago
Quoted from zezami:Any suggestions on what might cause this?

Insufficient voltage, perhaps. That could be caused by a number if different things; dirty connectors, lack of ground updates, failing caps...

#4 62 days ago

Back to the test bench.

I noticed that Marcos test program halted if I touched the piggy back so I removed that and put a socket in there and re soldered the pads on the piggyback. No problems touching it now.

When running Marcos extended test Tom it seems like the mpu comes to a halt after about 50s of the final riot input/output testing, the LED stops blinking. This test should run forever as far as I know. I've tried different voltages around 5v+-0.1 but it makes no difference. The whole test completed and then halts after 50s.

I've also tried to boot with the bone buster ROMs on the test bench to no success. I get no activity on the irq pin and nothing out on J4, I guess I should be able to measure attract mode LEDs here? Or is there any other way I can confirm that it has successfully booted and is running the code outside the machine?

Promoted items from the Pinside Marketplace
$ 10.00
Cabinet - Sound/Speakers
Gweem's Mods
€ 8.40
From: $ 20.00
Cabinet - Other
Rock Custom Pinball
$ 299.00
Displays
Boston Pinball Company
1,750
Machine - For Sale
Blaine, TN
From: $ 20.00
Cabinet - Other
Rock Custom Pinball
From: $ 18.00
Apparel - Men
Pinside Shop
$ 10.00
Cabinet Parts
Vandelay Industries
$ 299.00
From: $ 9.99
Eproms
Matt's Basement Arcade
$ 40.00
Cabinet - Other
ModFather Pinball Mods

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside