Black Rose Club: owners and fans welcome

(Topic ID: 112697)

Black Rose Club: owners and fans welcome


By FlippinFantastic

4 years ago



Topic Stats

  • 984 posts
  • 129 Pinsiders participating
  • Latest reply 6 days ago by DrMadd220
  • Topic is favorited by 59 Pinsiders

You

Linked Games

Topic Gallery

There have been 265 images uploaded to this topic. (View topic image gallery).

IMG_2018[1] (resized).JPG
BR (resized).jpg
7A68DA22-B6EE-414E-8D46-1E3D321F4004 (resized).jpeg
IMG_2014[1] (resized).JPG
B70B7F72-1A8D-4C6F-8C78-29A90045A744 (resized).jpeg
IMG_20190126_104732 (resized).jpg
IMG_20190126_104836 (resized).jpg
IMG_20190126_104847 (resized).jpg
69F6058A-FF9E-4C15-AB8B-B2C7F831D957 (resized).jpeg
00063XTR_00063_BURST20190112205308 (resized).jpg
IMG_20190112_202706 (resized).jpg
IMG_20190113_235307 (resized).jpg
IMG_20190113_235257 (resized).jpg
00001IMG_00001_BURST20190113235239_COVER (resized).jpg
IMG_20190112_114947 (resized).jpg
IMG_20190112_114957 (resized).jpg

There are 984 posts in this topic. You are on page 18 of 20.
#851 5 months ago
Quoted from Jon9508:

Yea I will post a pic tonight. I am just trying to find a solution. It's a pain to turn on freeplay every time you power on the game. Seems like I have replaced the common issues and it's still not saving. I did put a socket in when I added the new ram chip so adding the nvram should be easy.

Are you exiting out of the menu and allowing the game to reboot before turning the game off? Also, is that the original RAM chip?

#852 5 months ago

I am. I change the settings. Play one game. Then I power cycle it. It's a new chip. I figured the chip could have been bad.

#853 5 months ago

You may not be getting the battery voltage to the RAM.

#854 5 months ago
Quoted from Jon9508:

I am. I change the settings. Play one game. Then I power cycle it. It's a new chip. I figured the chip could have been bad.

I was having the same “reset” issue and had the NVRAM installed....no issue of that since than.

#855 5 months ago
Quoted from PinballManiac40:

You may not be getting the battery voltage to the RAM.

That's a good idea. I did check voltage to the d2 diode but I didnt follow it to the chip. I will check that tonight.

#856 5 months ago
Quoted from PinballManiac40:

You may not be getting the battery voltage to the RAM.

Yep you were right. I made a rookie mistake. When I install the battery I put the positive lead on the wrong hole so the chip wasnt getting power. Just power to the diodes. Thanks again for pointing that out.

#857 5 months ago
Quoted from Jon9508:

Yep you were right. I made a rookie mistake. When I install the battery I put the positive lead on the wrong hole so the chip wasnt getting power. Just power to the diodes. Thanks again for pointing that out.

Not really what I was expecting, but good you found that issue. NVRAM time!!

#858 5 months ago

Finally!

I got hold of a NOS cannon body complete. it cast me an arm and a leg. Looking forward to play the game.

#859 5 months ago
Quoted from Axl:

Finally!
I got hold of a NOS cannon body complete. it cast me an arm and a leg. Looking forward to play the game.

Nice! Congrats. I think you needed it more than me. At least my game is playable.
However...I STILL NEED ONE TO!
Anyone, anyone, the pm button is right there to left by my avatar. Or touch my avatar and its there also.

#860 5 months ago

Anyone got an nos (or anything really) playfield kicking around?

#861 4 months ago

How do u adjust the cannon mine will not make the 2 outside shots

#862 4 months ago

And my cannon door is bowed down in the middle any one had that problem

#863 4 months ago

I wonder if I could try heating up the middle and trying to bend It back

#864 4 months ago

Realized that I only have mylar above the flippers and in the pops. In planning for my teardown and shopout this fall, I'm thinking of clearcoating the playfield.
Mine's not a diamondplate and the mylar is perfect now.
Anyone have luck with BR?

#866 4 months ago

Any one know how to adjust cannon to make it turn more to hit the outlane

#867 4 months ago

I am a relatively new owner. Have had the game a couple of months. Very fun and highly underrated. Anyway the switch that the ball hits on the whirlpool shot fell off. When my local guy delivered me a new machine he put it back on for me. However if you hit the ramp fast it doesn’t register. However if it rolls through medium to slow it works fine. Also when an animation is playing on the DMD from a previous shot it also doesn’t seem to register. Is this normal? Anyone have any idea on how to fix this?

Also my game has a canon that won’t reach the far right outlane. It doesn’t effect gameplay much but I would prefer it work properly. Again any help would be greatly appreciated

#868 4 months ago

I'm going to convert to LED's.
Who stuck with the red/white double GI style?
It seems like a cool feature, but not sure how it'll look...

#869 4 months ago
Quoted from OTRChief:

The correct parts are: 12-6971 Gate, 10-434 torsion Spring
[quoted image]

After a lot of hassle removing the PF from the cabinet I finally got access to the backside and could add this missing spring. Boy does this spring do a lot of difference; a few shots are not able to enter due to the springs "hardness" but almost all balls to the broadside now enter and stay put in the hole instead of always bouncing out again, yay!

#870 4 months ago
Quoted from dudah:

I'm going to convert to LED's.
Who stuck with the red/white double GI style?
It seems like a cool feature, but not sure how it'll look...

It is super-cool. So dramatic when it does it when you are ready to sink a ship. Ours has white and red LEDs in the respective spots and it is awesome.

#871 4 months ago
Quoted from Duvall:

It is super-cool. So dramatic when it does it when you are ready to sink a ship. Ours has white and red LEDs in the respective spots and it is awesome.

So are there 2 sets of GI sockets? One for white and one for red?

#872 4 months ago

I almost wish you could set it so that the red only turned on during a ship cannon shot, and the rest of the time only the white strings were on. With some nice bright white LEDs you can light it up alright, no need for the red for general lighting.

2 weeks later
#874 3 months ago
Quoted from Scott8806:

And my cannon door is bowed down in the middle any one had that problem

A quick search found it by description in Australia. You can look in the manual for the part number and do an internet search, usually finds them here in the U.S.

http://shop.mrpinball.com.au/product/black-rose-cannon-door-flap/

1 week later
#875 3 months ago

Hi,

I'm trying to save my black rose. It works very well but the playfield have a big problem on SINK SHIP...
I'can't fin any overlay for this and really don't know what to do to fix it...
It's helloween so I can put this photo!
Any idea is welcome...

20181028_232553 (resized).jpg
#876 3 months ago
Quoted from Nairolf:

Hi,
I'm trying to save my black rose. It works very well but the playfield have a big problem on SINK SHIP...
I'can't fin any overlay for this and really don't know what to do to fix it...
It's helloween so I can put this photo!
Any idea is welcome...
[quoted image]

You can recreate the inserts using “waterslide decal” paper which you can print on an inkjet printer, and then Mylar over to protect them. You will need a scan of the original art though, and need to scrape off the existing insert art

#877 3 months ago

I'll take a look of "waterslide decal"... Thanks a lot!

#878 3 months ago
Quoted from Nairolf:

I'll take a look of "waterslide decal"... Thanks a lot!

Also check the Vid1900 thread about playfield restoration, there’s tons of info in there

#879 3 months ago

Lost of reading... great thanks

Added 108 days ago:

lot not lost...

3 weeks later
#880 87 days ago

Can someone please tell me what coil is mounted on your machine for the ball popper on the rear of the playfield. What I have and what is listed for parts are 2 different. I'm just seeing if updated or previous owner used what he had. thx

#881 86 days ago

Do you guys have also a lot of drains on the left and right side? I find very frustrating to loose the ball so quickly, sometimes I wish to install a metal post in front of each metal guide...

image-26 (resized).jpg
#882 86 days ago
Quoted from lanfeust:

Do you guys have also a lot of drains on the left and right side? I find very frustrating to loose the ball so quickly, sometimes I wish to install a metal post in front of each metal guide...
[quoted image]

What kind of post do you have above the outlane?

#883 86 days ago

Been bugging me for a while - at the start of "Walk the Plank" video mode Black Rose says something like "Swim, you Bill Drak." Who's Bill Drak?

#884 86 days ago

not Bill Drak..............Swim you bilge rat!!

#885 86 days ago
Quoted from zacaj:

What kind of post do you have above the outlane?

none actually, that's why sometimes, I wish there was one...I even get the bad thought to drill the playfield to install a new one when I get frustrated...

#886 86 days ago
Quoted from lanfeust:

none actually, that's why sometimes, I wish there was one...I even get the bad thought to drill the playfield to install a new one when I get frustrated...

I mean above the outlane, not above the divider/guide. There's a mounting place for one there on each side. Some Black Roses I've seen had mini-posts, some had star posts.

#887 86 days ago

I also find it strange there's no posts at the top of the ball guide wireform. I do get a fair amount of drains.

#888 86 days ago
Quoted from dudah:

I also find it strange there's no posts at the top of the ball guide wireform. I do get a fair amount of drains.

I wish it had those, but a lot of games are like that, not that strange

#889 86 days ago

Turn down the tilt and smack the shit out of it

#890 83 days ago

Does anyone have a playfield scan?
I'm looking to laser cut my own playfield protector and can reward you with a free one

#891 82 days ago

I found the original musics a bit boring and very... arcade from 80'. This pin deserved a better sound, so with a pinsound board, I made a new remix from pirates movies. That gaves a new "pirate ambience"...much more fun.

#892 76 days ago
Quoted from lanfeust:

I found the original musics a bit boring and very... arcade from 80'. This pin deserved a better sound, so with a pinsound board, I made a new remix from pirates movies. That gaves a new "pirate ambience"...much more fun.

It's a fun idea and sounds ok, but I have to say I prefer the original music.

#893 72 days ago

I've just joined the club! Apart from wear on the cannon (which I have bought a Cliffy for) any other cool things or necessary things I need to have here?

#894 72 days ago
Quoted from allsportdvd:

I've just joined the club! Apart from wear on the cannon (which I have bought a Cliffy for) any other cool things or necessary things I need to have here?

Congrats on your purchase. LED ColorDMD is another cool thing you need to add. Gameblades inner artwork look great on this game. https://www.tiltgraphicsinc.com/black-rose

#895 67 days ago

Thanks! It also seems I have the wrong pop bumper caps on mine. Which ones are supposed to be there & what color?

1 week later
#896 60 days ago

And does anyone have a lead on replacing the silver trim at the top of the backbox? Any help to my 2 question would be appreciated

#897 60 days ago
Quoted from allsportdvd:

And does anyone have a lead on replacing the silver trim at the top of the backbox? Any help to my 2 question would be appreciated

Ebay- you can buy a roll of it, from Hong Kong usually, search for chrome d strip, it is either 10 or 12 mm. Dirt cheap

#898 60 days ago
Quoted from Getaway:

Ebay- you can buy a roll of it, from Hong Kong usually, search for chrome d strip, it is either 10 or 12 mm. Dirt cheap

Fantastic thanks!

#899 60 days ago
Quoted from allsportdvd:

Thanks! It also seems I have the wrong pop bumper caps on mine. Which ones are supposed to be there & what color?

Search Black Rose parts, Little shop of games. Pop bumper caps. Top 2 are blue rings and blue cap, bottom is a white jet bumper cap.

#900 59 days ago

Okay sweet, will check Little Shop. The chrome strip is generally in 6mm or 30mm though the original is 10mm.
I bought the 20mm and will see how the extra chrome thickness looks, though that would be better than the thinner stuff

Promoted items from the Pinside Marketplace
3,500
Machine - For Sale
Fort Wayne, IN
From: $ 20.00
Cabinet - Other
Rock Custom Pinball
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
From: $ 369.95
Boards
PinSound
$ 10.00
Cabinet - Sound/Speakers
Gweem's Mods
$ 129.00
Lighting - Led
LED OCD
There are 984 posts in this topic. You are on page 18 of 20.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside