Black Rose Club: owners and fans welcome

(Topic ID: 112697)

Black Rose Club: owners and fans welcome


By FlippinFantastic

4 years ago



Topic Stats

  • 988 posts
  • 129 Pinsiders participating
  • Latest reply 3 days ago by DrMadd220
  • Topic is favorited by 59 Pinsiders

You

Linked Games

Topic Gallery

There have been 268 images uploaded to this topic. (View topic image gallery).

20190217_190021 (resized).jpg
blackrose4 (resized).jpg
IMG_2034[1] (resized).JPG
IMG_2018[1] (resized).JPG
BR (resized).jpg
7A68DA22-B6EE-414E-8D46-1E3D321F4004 (resized).jpeg
IMG_2014[1] (resized).JPG
B70B7F72-1A8D-4C6F-8C78-29A90045A744 (resized).jpeg
IMG_20190126_104732 (resized).jpg
IMG_20190126_104836 (resized).jpg
IMG_20190126_104847 (resized).jpg
69F6058A-FF9E-4C15-AB8B-B2C7F831D957 (resized).jpeg
00063XTR_00063_BURST20190112205308 (resized).jpg
IMG_20190112_202706 (resized).jpg
IMG_20190113_235307 (resized).jpg
IMG_20190113_235257 (resized).jpg

There are 988 posts in this topic. You are on page 13 of 20.
#601 1 year ago

Picked mine up today. She's as good as new.

IMG_6644 (resized).JPG

IMG_6645 (resized).JPG

IMG_6646 (resized).JPG

IMG_6648 (resized).JPG

IMG_6653 (resized).JPG

#602 1 year ago
Quoted from Ordinal:

Just joined yesterday, and I'm working out all the kinks that come with a brand new 20 year old machine. So far, I know I'm in on a return cannon wireform. Mine is not diamond plated either, so I may be looking at getting it clear-coated after a proper restoration. It's only my fourth, but I know this will be staying.

How do you know its not diamond plated? As far as I know all wpc games are

#603 1 year ago

Okay, digging mine out from a multiple game buy I picked up a few years back. Question, in the solenoid test locker ramp goes up but when select down nothing happens. Coil has power and if I ground the tab on transistor It will work? Am I missing something?

#604 1 year ago
Quoted from zacaj:

How do you know its not diamond plated? As far as I know all wpc games are

A combination of playfield wear, and the missing "This playfield is protected by Diamond Plate"

#605 1 year ago
Quoted from Ordinal:

A combination of playfield wear, and the missing "This playfield is protected by Diamond Plate"

Not all PFs have that. The Black Rose manual says they all are

#606 1 year ago
Quoted from IceMaster:

Not all PFs have that. The Black Rose manual says they all are

This question led me to do a little more research into the topic. I still don't believe mine has been Diamond Plated, since my particular playfield was manufactured by ESC, and Sun Process had the patent on Diamond Plate. Of course, I would love to be wrong, but the playfield has zero indication that it was, and this game was made 2 years before Williams stopped stamping it on the playfield completely.

http://www.flippers.be/pinball_playfields.html

#607 1 year ago

What kind of wear we talking? I've seen diamondplate worn to the wood...

1 week later
#608 1 year ago

Can someone snap a close up picture of the down ramp coil and mounting with wiring too. Thx in advance!

#609 1 year ago

Any help out there?

#610 1 year ago

IMG_20171003_151618.jpg

IMG_20171003_151607.jpg

IMG_20171003_151614.jpg

IMG_20171003_151627.jpg

#611 1 year ago

Thank You sir! is there a diode on the release coil?

#612 1 year ago
Quoted from nitrojcrawf:

Thank You sir! is there a diode on the release coil?

No. Shouldn't be on any wpc coils afaik

1 week later
#613 1 year ago

Black Rose with all incandescent bulbs with the Pinstadium kit installed. First pic is without the kit lit up.....last pic is a comparison to another machine with LEDS and no kit installed. It’s a dramatic difference!

351F54B6-6A14-4EE7-B53F-14CA320D7CF0 (resized).jpeg
70EA70E0-E741-4D38-A905-6C61CF97F8DA (resized).jpeg
EFF154BB-7A96-408E-A0FA-254FED550D16 (resized).jpeg
5DB65304-F723-4D9D-BAE0-48C367D0A4EB (resized).jpeg
A423AC8B-BF0B-4B12-AE3B-FAC61E72B6AC (resized).jpeg

#614 1 year ago

That looks cool. Any issues installing? What flasher colour did you go with?

#615 1 year ago
Quoted from pocketscience:

That looks cool. Any issues installing? What flasher colour did you go with?

I did have one issue where the driver board plug that it connected to for power had a burnt out fuse...but that was a simple fix. I went with the UV GLOW flasher option.....no color. I wasn’t sure about a color flasher so that’s the direction I went in. Installation was straightforward and simple. The amount of color options to light up the PF is quite nice.

1 week later
#616 1 year ago

need some troubleshooting help......my machine keeps telling me to check fuses 114 and 115......pulled the both, checked with meter and they are fine......any ideas? i am having 20 people over in a couple weeks and need it working

#617 1 year ago
Quoted from zerbam:

need some troubleshooting help......my machine keeps telling me to check fuses 114 and 115......pulled the both, checked with meter and they are fine......any ideas? i am having 20 people over in a couple weeks and need it working

Can be a lot of things.
http://www.pinwiki.com/wiki/index.php?title=Williams_WPC#Check_fuses_F114_and_F115_message

#618 1 year ago

I had some a while back and the fuse connectors were filthy. Cleaned them up and popped in new fuses and the message went away.

#619 1 year ago
Quoted from zerbam:

need some troubleshooting help......my machine keeps telling me to check fuses 114 and 115......pulled the both, checked with meter and they are fine......any ideas? i am having 20 people over in a couple weeks and need it working

Zacaj has you on the right path, but I'll highlight the first note on this page "The game issues this message because it cannot read the switch matrix normally" and say check your switch matrix connectors on the MPU for corrosion. Clean the connectors with a brass brush (with game off!), and replace any IDC connectors that have any corrosion.

Here's a shot after I cleaned mine up....

P1010573 (resized).jpg

#620 1 year ago

thanks I will give that a try when I get home tonight

#621 1 year ago
Quoted from zerbam:

need some troubleshooting help......my machine keeps telling me to check fuses 114 and 115......pulled the both, checked with meter and they are fine......any ideas? i am having 20 people over in a couple weeks and need it working

Check your connectors. I remember that happening on a machine I transported. One of the connectors came off

1 week later
#622 1 year ago

Black Rose has returned to plunder again.....the main culprit was the capacitor at C2 failed and took out the trace to the fuse F115.........special thanks to goggleloy for the several hours he spent troubleshooting and repairing this while trying to teach me something about electronics in my machine.

#623 1 year ago
Quoted from Whitewater:

Here is my Queen of the High Seas. I have installed an illuminated blue shark with red eyes and a flashing octopus for fun

I like the Shark! Where did you get it?

#624 1 year ago

I purchased my first Pin last week. Yep it's a Black Rose. Great game, lots of fun for everyone. I plan on doing an Led kit when it arrives (hopefully today). Everything seems to be working just fine. Love the idea of a Cliffy... I will wait until mine is a bit more worn. Apparently the seller I got this from told me he got it from a Bally employee who helped design the game. I have my doubts but its a cool story if true.

Black Rose (resized).JPG

black rose without the glass (resized).JPG

side art (resized).JPG

#625 1 year ago
Quoted from Captain-Flint:

I like the Shark! Where did you get it?

Thanks, I made it. Send me a pm if you would like me to make you one, I have one spare shark

#626 1 year ago

So I installed Cointakers LED kit... which for whatever reason didn't have enough of the 44 bulbs for the GI. I put in an order for more leds, however once I installed what I had, I have now noticed my GI doesn't light up during play. It will flash on occasion and I can get it to light up in test mode, but during the game it will flash from time to time... including the pop bumpers. I see others on youtube and the GI is nice and bright, where I have complete darkness in the back corners.

The lamps installed perfectly and work great, the flashers too. but that damn GI. Should I wait to install all of the GI? Did I put a wrong led bulb somewhere that makes the GI do nothing but blink from time to time? Are there settings I am not aware of?

Any help would be great.

#627 1 year ago

Please ignore... wire got pulled out of a molex connector. Got it fixed now.

#628 1 year ago

So I finally got tiered of the ball bouncing out of the center Broadside VUK about 75% of the time. It was almost impossible from the Canon. I've seen a few post about having and not having that metal post in the back of the VUK and I knew ours had it. So I finally pulled it out, I have a roll of Velcro I used the Loop side / soft side and wrapped the inside metal also as a cushion and now it works great even from the Canon

20171105_111916 (resized).jpg

#629 1 year ago

Just out of pure curiosity... Has anyone out there installed the Inner Cabinet Decal Mod? I am asking because I honestly would love to see an example with it installed.

ebay.com link

#630 1 year ago
Quoted from Captain-Flint:

Just out of pure curiosity... Has anyone out there installed the Inner Cabinet Decal Mod? I am asking because I honestly would love to see an example with it installed.
ebay.com link

I contemplated them, but ended up getting black mirror blades instead - they're pretty awesome.

#632 1 year ago

Put these in last week

DB2E5775-1E51-44E2-9CA0-B96629D64B8A (resized).jpeg

7302BD78-9141-49F6-8E77-71D06FBB6181 (resized).jpeg

65256054-5875-41A3-8B7C-EB35814EB22E (resized).jpeg

84D5F01C-A5C2-43FC-B9CA-026155E76554 (resized).jpeg

0ACA52B8-C4CE-4164-8AC8-2024A628475D (resized).jpeg

B0882266-FB6C-4E29-9180-AC0CE57FA009 (resized).jpeg

689D66A5-42C0-48B8-933C-EC06E2739DBE (resized).jpeg

#633 1 year ago

I dig them! Thanks for posting! Something I may end up doing for sure!

#634 1 year ago
Quoted from pocketscience:

I contemplated them, but ended up getting black mirror blades instead - they're pretty awesome.

Mind posting a pic?

#635 1 year ago

Got mine from tilt graphics. Great folks

#636 1 year ago

This is mine I think they look amazing
https://pinside.com/pinball/market/classifieds/archive/54752

#637 1 year ago

That is a clean looking machine! I do like the side decals... I may have to hit up tilt graphics.

#638 1 year ago
Quoted from Captain-Flint:

Mind posting a pic?

I'm overseas for work currently so a few thousand kilometres away from my machine. Will try remember when I'm back.

#639 1 year ago

I reached out to the ColorDMD guys a week or so back as I reckon I could give BR a crack. I've got a software engineering background and a decent eye (I think). We'll see what they say... but no response in over a week.. so just pinged them again.

#640 1 year ago
Quoted from pocketscience:

I reached out to the ColorDMD guys a week or so back as I reckon I could give BR a crack. I've got a software engineering background and a decent eye (I think). We'll see what they say... but no response in over a week.. so just pinged them again.

The research I did, sounded like Black Rose would never work with the current ColorDMD. There is no space to actually fit it. Don't get me wrong, this game screams for a nice colored DMD. I would buy it in a heart beat.

#641 1 year ago
Quoted from Captain-Flint:

The research I did, sounded like Black Rose would never work with the current ColorDMD. There is no space to actually fit it. Don't get me wrong, this game screams for a nice colored DMD. I would buy it in a heart beat.

It does fit, you just have to remove the controller board from memory. I've got one here, but haven't installed it yet. I didn't buy it until I got confirmation it could be done.

#642 1 year ago

The new LED ones should still work fine even if the LCD didn't fit, shouldn't it?

#643 1 year ago

Led fits in great. Lcd wont work. On the led panel you remove control board and install on back of white board, just enough cable length.
Heres my gilligan in color. Same style.

20170830_201708 (resized).jpg

#644 1 year ago

Here is ColorDMD (LED) installed in my BR hopefully and patiently waiting for colorization.

3504C088-60A6-49E9-BC80-AB9169A549FA (resized).jpeg

#645 1 year ago
Quoted from Duvall:

Here is ColorDMD (LED) installed in my BR hopefully and patiently waiting for colorization.

Just me but i would go with red till color.

#646 1 year ago

Yeah I should have clarified you need the LED as others have mentioned.

#647 1 year ago
Quoted from Ericpinballfan:

Just me but i would go with red till color.

Yea, I change it all the time.

#648 1 year ago
Quoted from pocketscience:

I reached out to the ColorDMD guys a week or so back as I reckon I could give BR a crack. I've got a software engineering background and a decent eye (I think). We'll see what they say... but no response in over a week.. so just pinged them again.

Strange they did not respond I would definitely buy a ColorDMD for my Queen of the High Seas...I think it would look fantastic and I'm sure you would do a great job

#649 1 year ago
Quoted from pocketscience:

I reached out to the ColorDMD guys a week or so back as I reckon I could give BR a crack. I've got a software engineering background and a decent eye (I think). We'll see what they say... but no response in over a week.. so just pinged them again.

That would be because I'm working on it.

#650 1 year ago
Quoted from epthegeek:

That would be because I'm working on it.

That's awesome news!!

Promoted items from the Pinside Marketplace
$ 28.00
From: $ 29.00
Boards
KAHR.US Circuits
From: $ 16.95
$ 40.00
Lighting - Other
Rock Custom Pinball
From: $ 369.95
Boards
PinSound
There are 988 posts in this topic. You are on page 13 of 20.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside