(Topic ID: 316579)

Black Knight won't boot after repair?

By CoinGuyNinja

9 months ago

Topic Stats


Linked Games

No games have been linked to this topic.

    #1 9 months ago

    Hey guys, I have a weird issue. Sent out my MPU for repair/lithium battery upgrade to Coinop Cauldron (clive) and during the lithium upgrade, I asked to go over the boards. Long story short, my sound header board wasn't soldered properly so I had to send that back to get it fixed properly. Before sending them off, I had a fully working game but no voice but sfx worked fine. The first time I got them back, it wouldn't boot so I sent them back to check them over. He said there was nothing with my boards and didn't find anything wrong with them, he did a burn test but said both driver and MPU were working fine. I'm getting the famous double red light and a 0, nothing on boot and nothing on the displays. This is the CPU locked up right? I feel like I'm missing something super obvious here they were both working fine before I sent them off.

    I've already tried to board reseats multiple times, and tried booting with just the upper left power plugged in and yeild the same results. Looking for some guidance here on what to check for I might be completely missing.

    #3 9 months ago

    it's worth noting that I do have an xpin power supply though and it's only a few months old too.

    I can go into test mode on the sound board, it plays all voice and sfx with no issues. According to your link, that should mean my power is ok in that regard.

    #4 9 months ago

    I'll also mention that I tried another good known replaired and working driver board and have the same issue.

    #5 9 months ago

    Figured it out! The lockout switch didn't have good connection to the MPU. After bending the connection a little, the board boots right up now! So glad it was something simple this time around


    Wanna join the discussion? Please sign in to reply to this topic.

    Hey there! Welcome to Pinside!

    Donate to Pinside

    Great to see you're enjoying Pinside! Did you know Pinside is able to run without any 3rd-party banners or ads, thanks to the support from our visitors? Please consider a donation to Pinside and get anext to your username to show for it! Or better yet, subscribe to Pinside+!

    This page was printed from https://pinside.com/pinball/forum/topic/black-knight-won-t-boot-after-repair- and we tried optimising it for printing. Some page elements may have been deliberately hidden.

    Scan the QR code on the left to jump to the URL this document was printed from.