(Topic ID: 140253)

Black Knight with Rottendog MPU suddenly won't boot

By lavmech1

8 years ago


Topic Heartbeat

Topic Stats

  • 27 posts
  • 12 Pinsiders participating
  • Latest reply 7 years ago by lavmech1
  • Topic is favorited by 5 Pinsiders

You

Linked Games

Topic Gallery

View topic image gallery

14490271912781051747185.jpg
1449027139318-1299191774.jpg
Rottendog_Installation.jpeg
IMG_20150929_212633129.jpg
IMG_20150929_212531962.jpg
IMG_20150929_212555400_HDR.jpg
IMG_20150929_212408788.jpg
#1 8 years ago

Hi all, Hoping someone can help me out here.

I have a Black Knight that came with a new Rottendog MPU 327 board. I have had no major problems for the past 2 or 3 years until recently I noticed the game settings had reset to the defaults. I assumed the battery on the MPU was dying or dead. I had to order the special button style battery and after a couple weeks they arrived. I switched the machine on in preparation for changing the battery and the machine would not boot up. No attract mode lights. No score displays. Just GI lighting.

The Rottendog board has two red LED lights that are on steady. I have checked all the fuses I can find with a meter. I have removed and replaced all the cables from the MPU and the power supply board. I disconnected the display board. I also pulled the game ROM and tried different game dip switch settings. I'm having trouble finding troubleshooting advice for my particular combination of the Rottendog and the original Williams System 7 stuff. If anyone knows some existing articles I can check out let me know. I did try searching the forum before posting. I don't know where to go from here.

*Not sure if this is relevant but I had completed the suggested rectifier mod to add a fuse for each rectifier block in the back box. The other day one of those fuses blew. I replaced it and got my ball trough solenoid to work again. I noticed a couple days later that one of those fuses was again blown and that is about the same time the "no-boot" issue appeared. I have since replaced that fuse but the no-boot issue remains.

**I also noticed some white residue around a couple of the ROM chips including the main game ROM. This stuff wipes away easily and looks almost like battery acid corrosion. The battery is a button style battery and it has never been leaking so I'm not sure what this residue is, what's the best way to clean it, and if it is affecting the game.

Any advice is greatly appreciated

Thanks in advance! , Rob

IMG_20150929_212408788.jpgIMG_20150929_212408788.jpg

IMG_20150929_212555400_HDR.jpgIMG_20150929_212555400_HDR.jpg

IMG_20150929_212531962.jpgIMG_20150929_212531962.jpg

IMG_20150929_212633129.jpgIMG_20150929_212633129.jpg

#2 8 years ago

Did you try it with the coin door open and turning the game on and off really quick a few times ?

John P. Dayhuff
Battle Creek, Mi.
269-979-3836

#3 8 years ago

Try the start up procedure that is required when first installing these Rottendog combo boards into a game for the first time.

#4 8 years ago

The coin door switch is bypassed. Is there something about that high voltage circuit that affects boot up? I would have expected it to boot up and at least be in attract mode even if no solenoids were active. I did try flicking power in and off a few times fast but no change.

I'll have to find the instructions for a new rottendog startup procedure. If anyone has that link it would be awesome!

#5 8 years ago
Quoted from lavmech1:

The other day one of those fuses blew.

Maybe you should test that rectifier.

#6 8 years ago

I will definately look at the rectifiers as its own issue. For the no-boot issue I'm thinking I may be on the right track with going through the startup procedure for the rottendog mpu. I think I let that battery die and I hadn't powered the machine up in a while. Hoping the board just reset if that's even possible. I found the setup procedure online so I'll try it this afternoon.

#7 8 years ago

No luck with the rottendog setup procedure. The two led's don't flash like they should when you remove battery and all cables except the top right and set dip switches to 1's per the diagnostuc instructions. They lights just glow steady. I will move on to the rectifiers and other voltage checks coming out of the power supply.

#8 8 years ago

Contact Rottendog for warranty repair.

#9 8 years ago

Is this what your looking for?

Rottendog_Installation.jpegRottendog_Installation.jpeg

1 month later
#10 8 years ago

Thanks, I tried the installation sequence with no luck. I'll contact Rottendog.

#11 8 years ago

Have you verified that your power supply is producing 5 and 12 volts? Checked to see if either bridge is shorted?

#12 8 years ago
Quoted from johnwartjr:

Have you verified that your power supply is producing 5 and 12 volts? Checked to see if either bridge is shorted?

+1.

I had an Alltek board that refused to boot, but a known original board booted correctly. Naturally, I assumed the Alltek board was to blame, so I contacted them to send the board in for repair. Dave suggested I should check the voltages from the rectifier board first, which I did, and they SEEMED to check out fine. Sent the board in for repair, but it still had the same symptoms when it came back. Long story short, my rectifier board was bad--even though my DMM was saying it was good, the autoranging feature "smoothed out" whatever dips in voltage there were coming from it. These new replacement boards seem to be pretty sensitive with voltages. They require a pretty rock solid supply, whereas the original boards seem to be more forgiving.

#13 8 years ago

I called the contact number listed on the rottendog website but got no answer. I checked voltage the best I could based on the schematic and it looked like its putting out 5 and 12 volts (more or less). If anyone knows a good step by step check for the system 7 power supply let me know. The bullet proofing links are great but I haven't seen one for just diagnosing. I'll do some research on the rectifiers. I need to rule them out.

#14 8 years ago

You need an oscilloscope if you really want to look at the voltages for ripple, but he reality is these games will work with drity as hell power for the most part. Looks like RDOG still uses a 680X CPU so this board should be no different.

If you have good +5v and +12v while the PCB is plugged in (check it on the rottendog board). Than i would consider the board to have an issue. Give a good visual look over. Sometimes changes in temperature can squeeze ICs out of machine pin sockets if the legs didnt get straightened well.

If you really want to get nuts, check for valid reset (p40 of cpu) valid clock (p37 of cpu). From there i would be swapping out the CPU, Display PIA, and EPROM for known good, sans some in depth diagnosing.

If this board is in warranty I would send it back to the manufacturer.

#15 8 years ago

While working with the rottendog board I noticed what looked like corrosion around some of the chip sockets and a couple resistors and connections. It looks like a fine white powder, or like dried up salt. The only battery in the board was a button battery that had no signs of leakage. Is this stuff just some sort of mold spores, or what? Does anyone think this could be interfering with the board? I'll post a couple closer pics.

1449027139318-1299191774.jpg1449027139318-1299191774.jpg

14490271912781051747185.jpg14490271912781051747185.jpg

#16 8 years ago

that doesnt look good at all. I see it sticking onto transistor legs and what not. Can you wipe it off. After wiped away is there signs of corrosion?

electrolytic caps can puke corrosive juice and so can batteries. Is the 30k cap in the head barfing up corrosive gas into the head or something?

#17 8 years ago

The powder wipes away easily. I cleaned it up and it looks fine. I replaced all the caps on the power supply but not the large blue cap mounted to the bottom of the backbox (not sure if that's the 30k cap). I suppose it could be spewing something.

I spoke to Jim at Rottendog by email (very helpful and responsive by the way). I had stated my power supply was 5v "more or less", assuming that the 4.8v it was putting out was within a tolerable range. But Jim said that will not be enough to boot. So, I have to figure out why my power supply is falling short.

#18 8 years ago

Use an external power supply on the bench to try and power it up. I am guessing it will still be locked up. 4.8v is fine as long as there is not excessive ripple.

If the powder wipes away easy, i am not sure what it could be. Left over flux that didnt get cleaned off well enough?

#19 8 years ago

I'd definitely look at getting that PSU up to 5V. With it that low, I'd be expecting resets and so forth if coils make it drop a fraction more.

That substance does look nasty. I'm currently working on a Data East display board that has corrosion damage. Strange, as there's no batteries on it? Not really, as it seems that batteries leaking will often affect other boards in the backbox. I guess it's such an enclosed space, the corrosive gases just hang around and destroy things on other boards. As barakandl mentioned, caps can do the same kind of thing, mainly cheapish electrolytics. The caps in your pic look OK (normally there'd be goo on the board around the bad cap), so I'd be suspicious about other caps in the area. I'd definitely second his recommendation to inspect all electrolytics in the backbox carefully, especially large ones. As it stands, I'd be concerned that the corrosive condensate might have damaged the IC sockets internally. It seems to have gathered around the base of the sockets... not good!

#20 8 years ago

Alkaline corrosion travels in the air. It can land on anything in a game, whether it's adjacent to a battery or not. As long as the battery is there, it can vent. I've fixed CPUs where the area around the battery holder is clean, but there's a corroded spot down the board a ways, with no connection between the two spots!

3 weeks later
#21 8 years ago

Good points on the corrosion issue. I'll look into that further and hopefully the ic sockets aren't bad. I just ordered a new switching style voltage regator (supposedly a modernized and direct fit replacement of the old linear type), the one mounted to the giant heat sink that controls the 5v side. That is one of only a few items I didn't replace when I "rebuilt" the power supply. At $8, I'm going to try it out. I also have an old computer in my basement. I will have to strip the power supply out to use as a bench testing tool. I'll see if the board boots with a clean solid 5v. BTW, I'm sorry for the long gaps between updates, I work too much and lose track of my Pinball stuff now and then. Thanks to everyone for giving me some advice and helping me learn. I will definitely post the final fix when I get there so others can also learn from it.

2 weeks later
#22 8 years ago

Installed the new voltage regulator and still no boot. In fact, there was some odd clicking as if some solenoids were attempting to close and then a slight burning smell. I have heard that clicking at random times since this problem began, but the burning smell is definitely new. It went away, but that doesn't make me feel much better. Couldn't locate the origin of the burning. I'll have to take a closer look tomorrow. I am losing hope at this point. There is just too much I don't know yet about repairing these machines. I still cannot find a good straightforward description of where to test for the different voltages that should be present at the power supply and then at the Rottendog CPU. If anyone can walk me through that part of the diagnostics I would be grateful. I really want to make sure it's a 5v issue. That burning smell has me worried. Wondering if I have a stuck solenoid somewhere, but would that cause booting issues?

1 year later
#23 7 years ago

I know this is an old post but I'm just adding that I have a brand new power supply installed and I have a brand new rottendog mpu327 plus an all in one rectifier/fuse board ready to go in. The old rottendog board was cooked. I'm looking for some guidance on what voltages should be where before I hook anything up and risk burning up my new $300 MPU. If anyone can give me a hand in checking the various key voltage pins on the MPU that would be great. This machine has been down too long

2 weeks later
#24 7 years ago

All set. New board is in and everything works great. For the record my replacement board from Rottendog was an MPU327-2 (an updated version of the one I had before) and it did not work with my Black Knight. NONE of the version 2 boards will likely work in any BK. Jim at Rottendog is working to identify the bug. So, I returned it and found a used version 1. That's what's in there now.

#25 7 years ago

Thanks for the update esp on the V-1

#26 7 years ago
Quoted from lavmech1:

All set. New board is in and everything works great. For the record my replacement board from Rottendog was an MPU327-2 (an updated version of the one I had before) and it did not work with my Black Knight. NONE of the version 2 boards will likely work in any BK. Jim at Rottendog is working to identify the bug. So, I returned it and found a used version 1. That's what's in there now.

I've heard the V-1 board has sound issues with Black Knight. Have you noticed any?

#27 7 years ago

Im pretty sure the sound issues are very limited and probably not noticable by the vast majority of BK fans. I think there's a laugh that's missing in attract mode after the BK taunts you to challenge him. The background music also runs after the game is over for a few seconds. No big deal. Not sure what else is off. Sounds good to me when I play.

Promoted items from Pinside Marketplace and Pinside Shops!
$ 69.00
Gameroom - Decorations
Pinball Pimp
 
$ 959.00
Flipper Parts
Mircoplayfields
 
3,150
Machine - For Sale
Loveland, CO
$ 160.00
Cabinet - Toppers
Sparky Pinball
 
$ 15.00
Playfield - Decals
Metal-Mods
 
From: $ 9.00
$ 1,059.00
From: $ 5.75
Playfield - Other
Rocket City Pinball
 
From: $ 90.00
Tools
Pincoder Store
 
$ 69.00
Gameroom - Decorations
Pinball Pimp
 
$ 59.95
Playfield - Toys/Add-ons
Hookedonpinball.com
 
$ 53.95
Eproms
Pinballrom
 
$ 95.00
Cabinet - Sound/Speakers
Pinball Mod Co.
 
2,430
$ 38.95
Eproms
Pinballrom
 
$ 25.00
Electronics
Yorktown Arcade Supply
 
From: $ 26.95
Playfield - Other
Hookedonpinball.com
 
$ 17.00
Playfield - Decals
Metal-Mods
 
Great pinball charity
Pinball Edu

Reply

Wanna join the discussion? Please sign in to reply to this topic.

Hey there! Welcome to Pinside!

Donate to Pinside

Great to see you're enjoying Pinside! Did you know Pinside is able to run without any 3rd-party banners or ads, thanks to the support from our visitors? Please consider a donation to Pinside and get anext to your username to show for it! Or better yet, subscribe to Pinside+!


This page was printed from and we tried optimising it for printing. Some page elements may have been deliberately hidden.

Scan the QR code on the left to jump to the URL this document was printed from.