(Topic ID: 54503)

Black Knight Club...Members Only!


By mof

6 years ago



Topic Stats

  • 2,261 posts
  • 209 Pinsiders participating
  • Latest reply 11 hours ago by BlackxDragon
  • Topic is favorited by 104 Pinsiders

You

Linked Games

Topic Gallery

There have been 786 images uploaded to this topic. (View topic image gallery).

20200520_140220 (resized).jpg
20200509_225740 (resized).jpg
20200510_110023 (resized).jpg
20200517_181220 (resized).jpg
20200517_181226 (resized).jpg
97917573_237276777724535_4680377148379234304_n (1) (resized).jpg
20200509_225815 (resized).jpg
98047235_675386119950036_2933710469896077312_n (1) (resized).jpg
96145808_686106915568522_4628929616336125952_n (resized).jpg
20200510_173945 (resized).jpg
20200510_174037 (resized).jpg
20200510_174048 (resized).jpg
20200510_112418 (resized).jpg
20200510_110128 (resized).jpg
20200510_110105 (resized).jpg
20200510_110119 (resized).jpg

You're currently viewing posts by Pinsider schwaggs.
Click here to go back to viewing the entire thread.

#793 2 years ago

Power for the flippers is not separated left and right. All flippers share the same power circuit and start on the top playfield then to the lower.

Check for power at the non-working flipper coil and report back.

Carefully inspect all the solder joints on the non-working coil looking for broken wires to power, ground and EOS.

Carefully inspect the EOS switch for proper function. With the game on, press the flipper button and manually lift the flipper and see if it stays up.

Carefully inspect the cabinet flipper leaf switch to make sure it is making solid contact and solid solder joints.

There are 2 connectors in the path that can cause problems with the ground side of the circuit. From the flipper button, the ground signal moves through the cabinet wiring, to a connector to the PF, then though the connector between the upper and lower playfields. Check the lower flipper ground wire on both these connectors.

#795 2 years ago
Quoted from jibmums:

Got a switch problem with my BK. Just got the head attached and wired up this week for the first time since I got it. Sound, lamp, and solenoid tests are all fine. NONE of the playfield switches register, although ALL other switches - plumb bob tilt, ball roll tilt, left & right coin, credit button, high score reset, flipper button - all work just fine. I know it must be something simple that I'm overlooking. Ideas?

Did you miss one of the connectors from the playfield to the backbox. Lift the PF and follow the cable harness from the PF and make sure all are connected.

#797 2 years ago
Quoted from jibmums:

That was my first thought as well, even though I was VERY careful and methodical during assembly. To eliminate any doubt, I just pulled the connectors and re-connected them again. Nope, same problem - no playfield switches work, but all other switches work.
However - here's something interesting - when I press it down, the pop bumper switch doesn't register in switch test mode, but it DOES trigger the bumper itself. What the heck is going on??

The slings and pop bumper have 2 sets of switches. One the triggers them to fire which is not part of the switch matrix and another scoring switch that is part of the switch matrix. Only switch matrix switches show up in switch test.

#800 2 years ago
Quoted from jibmums:

Yep, slings fire also but don't register in switch test. None of the fuses have anything to do with these switches, correct?

No fuses for switches, correct.

What I was trying to say, is the reason the slings and pops work but don't register in switch test is there are 2 sets of switches for these items. One that makes them fire and another that scores them and triggers sounds. It is the sling and pop scoring switches that are not working (along with all the other switches).

You need to trace the switch matrix wiring from the driver board to one of the playfield switches, checking all connectors in the path to see where the connection is broken. I'm guessing the switch matrix to playfield connector. This connector is one of the smaller neutral colored connectors with 6 green wires with colored tracers and 8 white wires with colored tracers.

#802 2 years ago
Quoted from jibmums:

Thanks guys! I got it, thanks to Schwaggs' guess. I completely missed the connectors with the green and white wires. The backbox end was hiding behind the big blue capacitor, and the bottom end behind the transformer. I knew it was something simple that I just must have missed.....boy do I feel dumb!

Awesome! Glad you found it!

2 weeks later
#805 2 years ago
Quoted from StratDoc:

One other question. When I bought my restoration Black Knight it came with an extra partially populated playfield. The playlfield and plastics are in decent shape, some wear but no planking. I am not an expert but it looks like it could be candidate for a full resotoration. Is there a market for this? If so, what would you estimate the price range to be?

There is absolutely a market for the playfield! Post up some pictures so we can help you with a value.

#809 2 years ago
Quoted from StratDoc:

Here are some pictures of the playfield and plastics.

I can't really help with the price range, have you looked in the Pinside Market Archives?

#810 2 years ago
Quoted from Mistermoberg:

Everyone, I need a favor. Just bought a Black Knight. Took off the back box to get it home.
Can't find the red white grounding lead. I have looked for hours. It is driving me insane. Where does this cable come from? Where does it split off into a single cable?
Thank you for your help. Pictures would also be helpful.
Cheers,
Eric
UPDATE: made the decision to plug the game in without the red/white grounding lead. Magnets do not work, but they did yesterday.

Here is where the Red/White wire is on mine. It's on the harness with the larger black connector as it enters the head. Magnets will not work without the Red/White wire grounded.

IMG_1653 (resized).JPG

#813 2 years ago

When the pop bumper solenoid burned, it probably blew the solenoid fuse which is why your other solenoids are not working. I would start by figuring out whats going on with the pop bumper. Look at the pop switches and make sure they adjusted correctly.

#818 2 years ago
Quoted from TicTacSeth:

Interesting, I hope that’s it! I went through all of the fuses though. Which fuse runs the solonoid s?
Also, I just completely disconnected the pop bumper for now. Would that take out the other solonoid?

The Solenoid fuse is the 2.5 amp slow blow on the power supply board. The bottom fuse in the row of 4 on the left of the board.

When you disconnected the pop bumper, how did you do that? Did you remove the wires from the solenoid? If so, there was likely one terminal that had 2 wires on it, did you keep those 2 wires connected to each other? The power supply for the solenoids daisy chains from one solenoid to the other. If you break the chain by not keeping the 2 wires together, the down stream coils will not work.

Techincally to disconnect the pop coil, all you need to do is remove one of the wires. Removing the smaller, single wire is the easiest way to do it.

1 week later
#836 2 years ago
Quoted from Yelobird:

Since I will be ordering parts, any other "yeah I would do that also" type parts? I think I have a new voltage regulator somewhere in my box o crap. Since I have all new boards including displays would it be reasonable to just get a new power board? I only ask this because this game is at a relatives house now and the thought of driving there every other week to trouble shoot a new part is a last resort I am hoping..

The rectifiers you circled are not part of the 5V supply. There is another rectifier on the power supply board itself that is used in the 12V -12V and 5V section. To make it bullet proof, I would recap the board and replace the header pins.

The GI pins and connector get toasty on BK. Should plan on replacing J8 (9 pin below the pair of fuses for 5V on the power supply board) both the connector with trifuricon crimp pins as well as the header pins.

Have a good look at the 12 pin rectangular connector on the power supply board. This is where AC enters the board and if toasty can cause problems.

There are 2 fuses for the 5V supply. Have a good look at the clips and replace if they look like they got warm (unlikely). Using a green scrubby, clean the clips (or replace) and clean the metal ends on the fuses (or replace).

While not typically a problem, you might want to plan on replacing the connectors J6 (15 pin) on the power supply and J2 (9 pin) on your combo board and with new trifuricon crimp pins and housing. This is where power leaves the power supply board and enters the CPU board.

With these updates, you should be all set!

1 month later
#867 2 years ago

Were the drop targets ever registering or is this only a problem since you have been working on the pop bumper?

The risk with messing with the pop bumper is only if you do it when the power is on. There are 2 switches on the pop bumper stack and if you short one to the other or ground out the pop switch, you can kill the driver for the switch matrix.

Frunch's procedure will help you rule out or identify the board as your problem. If it is indeed your board and you have reflowed the solder on the switch matrix headers, the most likely culprit is IC18 the 7406 hex inverter.

1 week later
#870 2 years ago
Quoted from mjvancam:

Hi guys, thanks for the suggestions. (sorry for the late response - likely would have been best to ask my question after the holidays when I had more time ),
I'm quite a novice here, so I just want to make sure I'm following frunch's suggestion properly. I assume when you say "disconnect the switch columns and row connectors on the driver board at connectors 2J2 and 2J3", you mean the connections as per the 2 images below? I believe that's 2J2 at the top and 2J3 underneath? I think so, but want to check.
To verify the board is working properly, I would run a jumper from, say column 5 (the GRN-BLK) to any of the row connectors, say row 3 (WHT-ORN). This would imitate the triggering of the top-left 3 bank upper target if I am reading the switch matrix properly. How do I verify that the switches respond? Do I need the pin on? Sorry for the stupid questions...
To answer Schwaggs' query, yes, all was working until I replaced the original piece of hardware. I had the machine plugged in, but not turned on (next time, unplug to be safe), so hope that isn't it.
Lastly, I've checked all the diodes as well, and they seem fine.
Thanks again!

Post a picture of the switch stack on the pop bumper. Include a view of where the end of the switches rest in the pop bumper mechanism. It is possible you assembled it incorrectly.

#872 2 years ago
Quoted from dalispictures:

Anyone have any reset issues with your BK? I have been trying to trouble shoot this problem. Both flippers energized reset it. Rottendog 327 X - pin power supply. Any help would be great appreciated!

Cold solder joints on the CPU and/or driver board power headers - reflow the solder or replace the header pins.

At least 2 screws in the CPU and driver boards and all the screws in the power supply board will help with the ground plane.

Bad diode on one or more of the flipper coils

If none of this helps, replace the IDC power connectors on the power supply, CPU and driver board with connectors with trifuricon crimp pins

#876 2 years ago
Quoted from mjvancam:

I looked up IC18 and it appears that it's chip 6821. Is it a simple replace? I suppose it's best to get the appropriate tool, ground myself AND to unplug the machine to replace (remembering a little of my old computer chip replacement knowledge)?
Thanks all.

IC 18 on the driver board is a 7406 hex inverter. Its right next to the switch matrix connectors. It is a 16 pin IC which is fairly easy to replace. Purchase 16 pin sockets with this chips to make future replacement easier. If you have a good wire cutter, you can cut all the legs off the chip and desolder the legs one at a time. Get some desoldering wick to clean the solder out of the holes.

1 week later
#887 2 years ago
Quoted from mjvancam:

The clouds have lifted! Schwaggs & frunch - thanks a ton! I managed to replace the hex inverter 7406 and voila, she's good as new (or refurbished).
Thanks again - I never would have known what to do once I left the electrical checking behind.

Nice! Congratulations on the fix!

2 weeks later
#918 2 years ago

If the lower flippers work but the magnets do not, its either the fuses under the playfield or most likely the ground wire is not connected to the ground lug at the bottom of the backbox. It is indeed white with red stripe and married the playfield harness with the black connector that connect at the bottom of the backbox.

https://pinside.com/pinball/forum/topic/black-knight-clubmembers-only/page/17#post-4059959

4 months later
#1025 1 year ago

Black_Knight has some good suggestions.

Do you hear any of your coils fire momentarily when you turn the game on by chance? I had a gorgar that would "wear out" the solenoid fuse over time and it was due to the blanking signal not working properly at power-up.

Also, you are using 2.5 amp slow blow fuses in F2, right? Do you know the difference between slow and fast blow fuses? (sorry, not being a jerk, just trying to be thorough and don't know your skill level )

#1030 1 year ago
Quoted from jag1:

Schwaggs and I could be neighbors!
Thanks for the tips. I’ve ran the coil tests a few times, but can’t get it to blow the fuse. I’ve done a few visuals, but didn’t see anything “obvious” to me.
When I power the game on, I only hear the click come from the coin door. I have a 2.5 amp slow blow installed.
I talked with Ernie, he said replace the 2.5 amp with a 5 amp and start sniffing! Hoping that will turn the intermittent issue into a hard failure that can then be fixed.

Indeed, welcome neighbor!

Very surprised Ernie suggested over-fusing the circuit.

Do you have a meter (DVM)? If so, go around the game with the game off and measure the resistance of every coil, and report the lowest few measurements.

#1035 1 year ago

Thanks, I was hoping one or more of them would have measured lower.

Might be a good idea to start your own thread asking for help. You will get more people looking at it vs this club thread and there might be someone that has encountered this or something similar before.

1 week later
#1064 1 year ago
Quoted from zacaj:

No guarantee at all the stops are the same depth. They switched depth and plunger length all the time. My links aren't colliding with the bracket, the stop stops them short of it. I'd love to get a measurement on PBL's replacement bases, but I don't even know where they got their measurements from.

True, various era stops have different lengths. Have a look at how many different part numbers there are for WPC and up coil stops. If you order a pair of each for spares (like I did, i'm a parts hoarder, and I admit it), you will see the difference between the stops is the length of the actual stop. Physical mounting is identical.

This being said, I have modded the flippers on a few of my system 6 and early WPC era games. I feel the change in spring to external on T2 really helped the feel of those flippers. I don't see that much differnece on System 6 and 7 era as it relates to power.

I agree with zacaj, a properly rebuilt flipper is just about as good.

I also agree with Black_Knight that if you are rebuilding the flipper completely (which means replacing the coil stop) you might as well upgrade the frame to the model with removable coil stops (its actually cheaper or the same price depending on which coil stop you need) and at that point, you are looking at about $3 in parts to upgrade to external springs.

#1068 1 year ago

I agree with black_knight , your original boards look pretty good to me. They are easily bullet proofed. New 40 pin, new ROM sockets, MOSFET lamp matrix mod, new capacitors, reflow or better (but more $) replace header pins. Not that much work and you will be set for another 30 years. Just make sure to have all your boards touched up (CPU, Driver, Power Supply, Sound and Speech).

People that have recurring issues with original boards typically DO NOT put all the needed work into them. They do the bare minimum to get them working which doesn't avoid the 80% worn out parts that will fail in a few months.

#1072 1 year ago

Looks like GI lighting for the coin door. Does it look like the coin door lights or wiring shorted out? Pins 1 and 2 on connector 7P1/7J1 on page 21 of the manual.

E7CCC681-FD16-44CC-AF35-0A451B521145 (resized).jpegF66918F3-F9F0-4780-B2C8-3384D59BB400 (resized).jpeg

#1083 1 year ago
Quoted from nerdygrrl:

OK, I finally got a chance to scope out the schematics and the connector. While this is the "cabinet wiring" and it looks like everything is coming straight from front of the cab, I noticed this on the bottom of page 21 (thanks Schwaggs). It appears there are two GI lines that originate from the upper PF and go into this connector at pins 1and 2. This makes sense given the GI from my upper PF is also cut.
If anyone has the time and could snap a pic of how these two lines run off of the upper PF GI and go to this main cabinet harness I would be super appreciative. I am guessing there has to be some other kind of disconnect in there. That are I am super off base.

Looks like those pairs of wires shoul be soldered to a GI bulb socket. You can see the hole in the upper PF in your picture, below the wires, just to the right of the switch bracket.
DD85D1A6-BA8F-4BBC-9D14-CD9F8EEE12B8 (resized).jpeg

#1096 1 year ago
Quoted from nerdygrrl:

I broke C15 when trying to get the IC out of my PS, which looks like a 470 pF cap. Does anyone know if I should order the 50V or 100V from GPE? The manual doesn't quite state.
I am so mad, I was so close to having a fully working PS. Yet another GPE order coming up.

Its a low voltage circuit (15V max), you can use either.

#1107 1 year ago
Quoted from Spacemanratso09:

Very frustrating..my extra ball up top and lower turnaround switches do not register in a switch test all looks fine
Been playing for a awhile I noticed the extra ball never comes on

Just clean them and gap them real tight. The speed of the ball during game play can be different than when testing.

#1119 1 year ago
Quoted from Troyster42:

So I have been still trying to figure out what is going on with this solenoid circuit. This is continuing from post 1097. So my Drive transistor keeps getting fried and my ball release coil locks on. I have checked and replaced the diode on the coil. I checked the ohms on the coil and I am getting 4. I checked switch 20 that triggers the coil. I’m getting no shorts in the wires and continuity from the switch to the board connectors. I took the mpu and driver board out and hooked up and old pc power supply on them. With a logic probe I took readings on IC1 Leg 9 is hi, 10 is low and 8 is low. I think that’s how this should be. I tested other legs for different solenoids and I am getting the same. I checked different voltages over components and compared them from the solenoid circuit that is having issues to a working one and I am getting matching readings. The only thing I have found different was resistance from the base of Q15 to ground, the solenoid 1 circuit I’m getting 2.1K and all others I’m getting 1.7K. Its not a big difference but I don’t know why, I thought it should be 2.7k unless the reading is coming from the predrive transistor to ground. I also checked the voltage on the predrive transistor Q14 and there is none. Again I think this is how it should be as the circuit should not be switched on at this point. Tonight or tomorrow I’m going to put the boards back in (new transistor) leave all of the solenoid connectors off the board and pull the fuse. Go in to test mode for edge test for switches and see if there is anything going on with switch 20. I also will check to see if pin 10 on IC1 is high or low. If anyone has any ideas let me know at this point I’m not sure what else to do if I get normal readings putting the boards back in.

Verify you installed the diode on the ball release coil in the correct orientation.

Have you replaced the pre-driver transistor?

Before installing the board, lift one leg of the pull-up resistor on the output to the AND gate (input to the pre-driver) and make sure it is in spec (560 ohm I believe).

Before installing the board, lift one leg of the resistor on either side of the pre-driver transistor and verify they are correct (68 ohm and 2.7k I believe).

When you put everything together, and the coil still locks on, before turning off the game, use your logic probe to test the output of the AND gate for that coil. See if the output is getting stuck HI. Could be a weak output on the AND gate.

#1130 1 year ago

This is the crimper I have. Absolutely love it. Crimps the wire and insulation at the same time. I use it for .156 Molex, .062 and .093 pin style connectors. Basically any crimp on connector you encounter.

amazon.com link »

1 week later
#1170 1 year ago
Quoted from kilmarnock1350:The starburst inserts just don’t look right on this game.
Very disappointed CPR used them.

100% agree with you. They used them on the Firepower play fields too. Just doesn't look right to those of us that spent "years of our lives" on the original games.

3 weeks later
#1263 1 year ago
Quoted from chaskett:

Hey all, I am developing some diagrams for lighting the machine with LEDs.
How are you all lighting the right side (encircled in Blue)? I was thinking of using a bulb with a matrix cord between the two right ramps and 2 4" LED strips under the blue plastics.
The area encircled in Yellow i was considering using double flex head comet lights to light the upper playfield. How are you getting extra light thrown onto the upper playfield in this area?
The pop bumper I was thinking of just throwing an Comet Opmax LED light in so it would hopefully illuminate more of the upper playfield. what's your strategy?
[quoted image]

I just used sunlight white in all the standard GI sockets and that alone really brought the playfield to life. I added a lamp socket under the dark plastic in the blue area on your picture. That helped a lot.

I used a red super bright LED in the pop bumper. It looks pretty good but doesn't add much light up there.

The arrow to the lower lock saucer should be green, not red.

You have the Extra Ball inserts (2 of them) red. Another option is to use white, yellow or orange under them to help them stand out. Might be worth it to pickup a couple extras of various colors to see what you like.

#1265 1 year ago
Quoted from chaskett:

Thanks for the suggestions! Isn't sunlight white tinted blue? Or is that natural White? Also, my lower lock insert is red for some reason.[quoted image]

Sunlight is right between Natural white (the blueish one) and warm white (the amber one). It looks the best to me personally but they make the various shades for a reason!

Also, I use frosted for all my GI, even LEDs I can't directly see. It disperses the light better in my opinion. Less chance of a visible hot spot on the plastics.

Interesting your lock insert is red! Mine is green!

#1280 1 year ago
Quoted from SpaceAce:

Hi all. Having read this thread front to back... I think it's time to add my game to the list. Unless I am missing something, I think I am in the club (being a happy owner of a Black Knight Machine). I got my machine back in 2005(ish). It was located, box top off, legs off, sitting on the floor of someone's basement. It had the wrong back glass on it (Wms. Stellar Wars), and was missing a couple of plastics (top left). They said that they had it for some time, but it wasn't working and they didn't know how to fix it. "May be it's just a fuse" they said (yeah... right). So, I bought it and have had it ever since.

Welcome to the club! If you need any board work done on your BK you are welcome to bring the boards over and we can work on them and test them out in my BK. I'm just up the road from you in Cumming.

3 weeks later
#1340 1 year ago
Quoted from Andy_B:

Made some progress back to the original problem Just reseated the ROMS and the pin will once again boot into attract mode with coin door open but only into audit mode with it closed.

The game does remember audit adjustments between power cycles whether coin door open or closed.

Clean the pins on your ROMs. Best would be to clean them and replace the ROM sockets to ensure best reliability. I've had many bad ROM sockets (worn out) on System 3-7 games.

#1343 1 year ago
Quoted from Andy_B:

Sockets have been replaced but the legs of the ROMs do look a bit grubby.
I usually replace ROMS on project games as a matter of course but these seemed to be OK.
I'll give the legs a clean but is this likely to be the cause of my problem?

I think so, yes. Especially if you are getting intermittent boot up issues and reseating the ROMs change things.

#1347 1 year ago
Quoted from Andy_B:

OK. I will order new ROMs so I should know one way or another when I get them fitted.
In the mean time could someone let me know where the red and white ground wire from the magnet relays connects in the back box. Mine is bundled with the wires that go to the black connector in the picture but is then left hanging. The schematic just shows a ground connection.
Thanks.
[quoted image][quoted image]

The white with red wire attaches under the screw and wingnut at the front of the hole in the backbox that leads to the lower cabinet. Magnets will not work unless it is attached. There is usually a ring terminal at the end of that wire. If it is missing, recommend adding one back to ensure a secure connection.

#1349 1 year ago
Quoted from SpaceAce:

So... I did the fireproofing and the bullet proofing. I added the mosfets, removed the resistors, and jumpered. I pulled the resistors, and jumpered the driverboard. I replaced the 40 pin interconnect, moved the batteries off the board, and reflowed all other connectors. I turned on the machine and saw the 2500 4. I went through the diagnostics (twice ) and then it went into attract. While I am really excited. With that excitement, I now get to work though figuring out all the little things that might be wrong. I am a little perplexed, but moving forward.
- The credits / match display has the first digit (on each number) coming in and out.
- The sound is nearly non existent. And that which is present is rreeeeeaaaalllllyy sssslllllloooooowwwwwwwwwwwwwwwwwwww (and it seems to be stuck on).
- Eventually the machine heats up (or something) and the sound starts to come in. Gritchy at first, and then it comes in nice and smooth (such a great sound).
- I am still working through some bulb replacement to see if I have a ROW issue, or, just a bunch of dead bulbs. I am however interested in how many things I am breaking just trying to change the lights.
I have a lot of things I still need to do. But I want to get the obvious items running. I will be replacing a WHOLE BUNCH of sockets.

On the sound issue, are both voices and sound effects really quiet or just one or the other?

Try moving the voice/sound balance pot on the voice card (smaller of the 2 sound cards) back and forth through it's range to see if that cleans up the scratchy-ness. Do the same with the master volume control in the bottom cabinet.

If that's no good, try reseating the ribbon cable between the sound card and the voice card.

If that's no good, or even if it is fixed, reflow the solder or better yet, replace the header pins on the sound card. All header pins need reflowing on all boards as any of them can have cold solder joints.

For the slowness, try running the sound diagnostics by pushing the test button on the sound card. Let us know if the sound test is slow or just game sounds are slow. Are voices or sound effects slow or both?

#1351 1 year ago
Quoted from SpaceAce:

Hey @schwaggs, Actually, it doesn't make any sound at all for between 20-45 minutes (silence), then all at once, it comes in (both voice and sound effects). But it's like little chirps at first. Like... you will get a glimpse of sound here and there. And then when it finally decides to kick in, it's all within about 5 minutes, and then it plays perfectly. I am working recapping and reflowing it tonight. I am not sure if I will get it finished tonight or not (because I really want to play it some more). I found a couple posts about how to troubleshoot it this afternoon, and hopefully between that and your suggestions I will figure out something. I went to Fry's tonight in search of sockets, but I am not paying that much. I will get it from Mouser, or Amazon r something.

It is nice to have Frys for emergencies, isn't it!

Good luck and let us know how you make out. Recapping is a great place to start. Don't skip the 1uf caps, they are coupling capacitors and can cause all sorts of audio quality issues. If you have time before recapping and reflowing, try pressing the audio diagnostic button on the sound board while in the first 20-45 minutes. If that doen't work, you can feel confidenty the issue is with the sound board (most likely).

#1357 1 year ago
Quoted from epeabs:

After adjusting the shooter trough switches I was able to play one actual game. But only one. Now I have my ball lock solenoid repeatedly firing upon startup. I've tried adjusting the lock switches, but it is still doing it. So the lock trough repeatedly fires or it doesn't and the shooter trough fires two balls into lane instead. If that happens the flippers don't work. It also will seem to load a second or third player. I'm perplexed. Sorry if this is confusing, its difficult to explain.

If you are sure your switches are adjusted properly and the switch blades and wiring are not shorting to other things, I would look at the switch diodes.

Remove all the balls so every switch should be open. Use you meter on Diode test to check all the switches in the trough, ball lock, etc. You can test diodes on switches without removing them as long as the switch is open.

#1362 1 year ago
Quoted from epeabs:

Well....Amazing what you find when you start looking at areas closely. I found one of my wires going to the "right" ball eject switch got pinched under the playfield metal "strap". Loosened screws and removed wire, then had to "fix" the "grounded out" wire. Once done I was able to play a game. But realized I need to adjust all my drain switches, spinner switch, etc. since none of them are registering. But the interesting part is that the pop bumper which I rebuilt is not working when hit. But I can activate it by hand, and when I do, the outhole solenoid is firing. Definitely some more work to be done.

Sounds like you have a couple issues there. First, the pop bumpers and slings are special solenoids in that the switch directly activates the transistor to activate the device. There is also a switch in the switch matrix on pops and slings that are there only for scoring the hit.

Problem 1 - the pop bumper activation switch is not adjusted properly or the special switch input or the drive transistor for the pop bumper is not working. you will see 2 sets of switches. One should be activated by the spoon (thats the one that leads to the special solenoid switch input and activates the coil) and the scoring switch that should be activated when the solenoid pulls in. Sounds like you may have the switch stack installed backwards or not setup quite right. Check your "before pictures" and double check you have it setup correctly.
Problem 2 - you have a switch matrix problem in that the CPU thinks the "Lower Eject hole" (switch 24) is closing when the pop bumper scoring switch (21) is activated. Could be a bad diode or a row/column issue.

#1363 1 year ago
Quoted from SpaceAce:

So... I got home and went to work on the machine. I was working on the sound and got all the soldering finished (well finished for now).
I put it back in the machine. I used an alligator jumper wire and clipped onto the bracket that holds the sound board (ground) and touched the connector points. It made the sounds. I went to the MPU connector and tried it there. I had sounds. So, both the connector is good, and the wires are good. Immediately the machine had sound when I turned it on. ??? Really? I played a game and reveled in the sound.
I then turned off the machine and restarted it. NO SOUND. Grrrrrrrr. What the fffffffactory settings.
So... I pressed the diagnostic button, and it played just fine (and normal, of not faster (than I am used to)). I then tried the grounding the pins, and it no longer works. This makes no sense.
So... what does work. The amp, the chips (I have both sounds and voice). I have proper positive voltages. The negative voltage is running -18v.

Great progress!

Could be IC6 like zacaj suggested. To test IC6, remove the input to the sound board (J3). With your meter set to DC volts in the 5v range, test pin 13 of IC6 (red on pin 13 and black on ground - cabinet braid is fine). It should be close to zero volts.

Then ground one of the pins on J3 (like you were doing earlier) and measure pin 13. It should be close to 5V with one of the input pins grounded.

If either test fails, IC6 is for sure the culprit. If those tests pass, we need to keep looking.

#1374 1 year ago
Quoted from SpaceAce:

So... I played for like an hour tonight. The conclusion... 1. This is a great game, and 2. I suck (though the margarita was probably not helping either).
I got up to a massive 270K tonight. The game eventually was over and then I looked up to see the default 2,500,000 flashing in between my high score.
Question 1. Is there any way reset this thing to a far lower number so I can play against myself and not a crazy impossible level that I wont reach... well for a while (cough... ever)? I found 13, which I changed, but it doesn't seem to have made a difference.
2. In watching some internets webz videos, I have noticed that a lot of people are nudging the machine. Is this an acceptable part of play? I mean I know that there's electronics at play to keep people from getting carried away, but is nudging a thing? Is it considered poor play, or just part of play?
In repair news... Interestingly when I turned the machine tonight, I had full on sound from the start. I played the crap out of it for like an hour. Not an issue. Then I turned it off as an experiment. I left it off for about 10 seconds. When I turned it on, there was no sound. So... while it was on, it was rock solid. After a brief repower, it was completely gone. That's a little odd. I will try this again tomorrow morning.

Setting 13 is the default high score setting. Set it as low as you want, reboot the machine then reset the high score table using the "reset high score" button.

I find the key to this game is keep the ball on the upper playfield and master the magnasave buttons. There are some shots on the lower playfield where using the magnasave is mandatory. The bonus multiplier loop for example.

#1377 1 year ago
Quoted from epeabs:

I'm trying to work through some of my issues. I've started by making sure the Rottendog is working, by starting from the self test and it is working properly. In coil test, all my coils fire including the pop bumper. I next went to switch test and it is stuck on left kicker #17 saying that it is stuck, but in the couple games I have played, the left kicker works fine. Currently when loading balls, it will eject them into the ball trough, but once the third ball triggers the switch it is not playing sounds as it had done, and it won't allow me to start a game. While I have had a game going I have manually tried to activate most of the switches and they do not register. Example, left and right outlanes, behind the kicker lanes, spinner, etc. (all the drop targets are working fine). Also when playing a game sometimes it will just lose flippers altogether. When clearcoating the playfield I never stripped the back of the playfield, just the top. So I haven't removed or adjusted these switches during the clearcoating. I'm not thinking that it is a matter of readjusting all these switches since the clearcoating isn't the thickness of say a "hardtop".

There are 2 sets of switches on the slings and pops.

One set on fires the solenoind through the special solenoid inputs on the driver board. These are the switches standing up behind the sling rubber. They directly trigger the drive transistor to make the sling action fast.

There is another switch mounted under the playfield that registers points. This switch is in the switch matrix and what is reported in switch test.

Modern games only have a switch in the switch matrix to both trigger the solenoid and score points. The processing speed of these early computers wasn't fast enough to build them this way.

To troubleshoot what is going on with your switches, remove all the balls from the game. Print out a copy of the switch matrix from the manual. Enter switch test and see if any switches are registering as closed. None should be closed if all the balls are removed. If any are registering as closed, adjust them so they are open.

Now go through the playfield and manually activate each switch and make sure it registers in switch test. Mark all the switches that do not work on your switch matrix printout. This will help you visualize if you have an entire row or column out.

#1384 1 year ago
Quoted from epeabs:

Haven't had a chance to delve back into these issues yet. Schwaggs thank you for the Switch Matrix diagram printout direction, it is a great way to visualize potential issues.
[quoted image]

Cool, glad it helped! I would work on clearing those 2 switches not in Row 5 first, then see if row 5 is still an issue. Is Ball Roll and Right Ramp stuck on or they will not register when you manually close them? All the switches in Row 5, are they stuck on or will not register?

If those 2 switches are not registering, have a look at the wiring on the switch and make sure the solder joint is solid. Trace the wires from the non-working switch back to the next switch in the line and see if that solder joint is solid. Lightly tug on the wires to make sure the connections are solid.

#1387 1 year ago
Quoted from epeabs:

Schwaggs I have cleared the ball roll tilt and the right ball ramp switches. At this time, column 5 is still out but I have not had a chance to look at it again. In that column none of those switches seem to be registering when I activate them.

Great! If you had an original board set, I would suspect the header pins or driver for that column. Since you have a RD board, the header pins nor driver shouldn't be the issue unless you accidentally grounded a switch in column 5. I would look at the connector at J2 (on the original driver board, not sure where it is on a RD board). Make sure the wires are seated securely in pin 5 of that connector. Maybe have someone hold a switch closed in that column and push/move the wire in the connector to see if the connection is intermittent.

1 week later
#1412 1 year ago
Quoted from SpaceAce:

Cool. Would it be totally silly just to buy a set of 40's and cut (Dremel) a few down to 28's?

Sorry about you loss.

I wouldn't get sockets from Amazon, Mouser is much better if you want to stock ($25 minimum order) up or Great Plains Electronics if you want just a few.

Agree with Zacaz and prefer the dual wipe type over machine pin. Much easier to install chips in dual wipes and they have more contact surface area. Plus, they are cheaper.

#1416 1 year ago
Quoted from epeabs:

This troubleshooting makes me feel like I'm running in circles. I have replaced the U17 switch matrix chip on the Rdog board. BK still won't start a game. Trying to go through testing. When I start into test mode, as soon as I press the advance to go into the display test, my left kicker is energizing and sticking on. It won't release until either the 2.5A solenoid fuse blows, or I shut the machine off. I just removed one leg of the left kicker solenoid diode and it tests fine so I have resoldered it back together. Any thoughts on areas of the Rdog 327-1 board to troubleshoot?

Check the playfield level switches for that sling. Make sure they are not closed. Make sure the terminals on those switches are not touching each other.

Check the wiring for that sling, make sure it isn't shorted. The 2 switches are wired in parallel and there are short jumper wires between the 2 sets of switches, make sure all that is solid.

Check the capacitor on the sling switch. Make sure it is not shorted. Remove it and try again as a troubleshooting step.

#1420 1 year ago
Quoted from epeabs:

I know. I'm almost there. So far with any of my machines, I've been able to diagnose and fix the issue with the assistance of great Pinsiders. I'm also considering (since I have the original mpu, but missing the driver board) of getting a driver board and bulletproofing them both. Then eliminating the Rdog altogether. But I'm still not positive I haven't missed something in wiring that might have gotten "tweaked" during clearcoating, etc.

Keep an eye out for an "untested driver board" on eBay or the marketplace here. Stay away from boards with overly burned up circuit board in the lamp matrix area. Burned up resistors are common and easy to replace, but if the board shows signs of burning, stay away. Also look closely for any signs of green (corrosion) solder joints or chip pins or excessively oxidized (incorrect storage) solder joints or chip pins.

These boards are not that complicated and easy to troubleshoot with a logic probe if you can read a schematic or with help from Pinside. Lots of information on common failure points (connectors, sockets, etc) and lots of people willing to help with troubleshooting tips.

Good idea to resolve all the issues with the game using the RD board in the game. That will make testing your original MPU and driver board easier!

#1429 1 year ago
Quoted from epeabs:

Playfield level switches are not closed and no terminals or wires are touching each other. Don't find any shorts in the wiring, and all wiring is solid and not loose or sketchy. I pulled off one end of the capacitor and retried the switch test but it still locks on. I think it is time to contact Rottendog about sending in the board. In the mean time I will keep my eye out for a system 7 MPU. I misspoke before and just realized I have the original driver board and a "spare" not the MPU. The original is in rough shape with some burn to it and a hack on the back. The "spare" looks initially to be in better shape and possibly a better candidate for bulletproofing.
[quoted image][quoted image][quoted image][quoted image]

Before you send it off, try disconnecting 2J13 from the board and seeing if the sling still locks on. 2J13 is where the special switches (slings, pops, etc) enter the board. If it still locks on with this connector removed, you certainly have a board issue. If it no longer locks on, you have a wiring/switch problem.

If you have a board problem, might be worth testing the driver transistor for that solenoid to see if it failed. That is an easy replacement.

Both those boards are in workable shape. Your backup will end up being a cleaner board but neither is too far gone!

#1435 1 year ago
Quoted from epeabs:

Okay. So lets recap. I spoke to Jim at Rottendog today numerous times troubleshooting over the phone. In the long run he doesn't feel it is the board and the issue is somewhere on (under) the playfield. Again, nothing is looking out of place to me but I'm figuring I am overlooking something. I just installed four new kicker upright switches which I hadn't installed yet. Now, once I was able to get through switch test without the left kicker sticking and all the switches are open. During solenoid test the left kicker did not stick, but at some point during the test, the fuse blew. The machine turns on, lights up, no sound. Add balls and now the ball launch does not send them to the right ball ramp. Just tried test again and the left kicker is sticking upon pushing advance.

I just removed 2J13 from the board and the sling did not lock up. The left kicker did not fire, the right kicker did not fire and the pop bumper did not fire. So I think I've confirmed it is not the board. But I can not find what the hell the problem is. And like most things it is probably staring me in the face.

None of the special solenoids will fire with that connector removed so what you saw is what is expected. The good news is the solenoid switch wiring is as simple as it gets. The wire runs from the sling switch to 2J13. Reconnect 2J13, desolder the wire from the switch, test again. If it still locks on, you have a short in the wire somewhere. If it does not, the problem is in your switches.

If it's in the wire, you need to trace it back and look for it to be pinched under a screw, frayed against a metal bracket or something. It won't be easy since the wire starts on sling, around the harness to the connector to the upper playfield, around the harness to the connector to the backbox. I would try disconnecting the backbox to cabinet connector, test, reconnect, disconnect the connector between the upper and lower playfields, retest. This will help you see in which area the short lies.

1 week later
#1457 1 year ago
Quoted from sethbenjamin:

So, I'm coming to the end of a BK playfield swap, and have done all the things you're supposed to do but have no power to the right flippers. I can't figure it out and it's making me nuts!
There's current going to the switches, there's equal voltage to all 4 coils, I've got good continuity from the cabinet switches to the coils. The right flippers *initially worked*, but quickly died completely. I don't have the wiring reversed (Upper right - BLUE to banded side of diode, BLK/YEL to non-banded. Lower right - BLUE to banded side, BLU/VIO to non-banded), and the flipper fuse in the backbox is fine, as are the fuses under the playfield (checked continuity through the fuse holder to be sure the old holders were getting good contact. They are.)
The boards are new. I have also done a continuity check from the power lug back to the driver board, and from the ground lug at the cabinet switch back to the board, just to be sure there wasn't a problem with the connectors themselves. Also have continuity in those places.
I am completely stumped. It's probably something dead simple staring me in the face, but I've checked through all the things I can think to. Very strange problem. Help?

Neither of the right flippers work?

Mash the cabinet flipper switch together or short the leafs with a wire to rule out the flipper switches.

When you measure continuity with a meter, it is virtually zero current. The flippers are much more current. If there is a weak connection somewhere (cold solder joint, dirty/corroded/worn connector, etc) it can measure OK with the meter but not actually work. Try reseating the all connectors one at a time, testing in between reseating each one.

#1459 1 year ago

That is a lead! The power side of the BK flippers use separate power wires back to the power supply board and common ground from the cabinet flipper switch back to the driver board. You can focus on making sure the solder joints on your cabinet switch, connector between the cabinet and backbox, and header pins and connector on the driver board is good.

#1463 1 year ago
Quoted from sethbenjamin:

OK, so, RH flippers still seem to be working, cool, and I've got the whole game re-assembled. But...now the stupid game will not start.

What was the cause?

#1479 1 year ago
Quoted from canoncitypb:

I'll give that a try.

I can occasionally save it with a slap, but not very often.
It would be interesting to hear from Steve Ritchie on this one. I'm assuming that some things are designed in and some are happy or unhappy coincidences.

If I go the other way through the loop, the ball almost always heads out the left outline and have to use magnasave to catch it.

2 weeks later
#1496 1 year ago
Quoted from epeabs:

After taking a hiatus from doing too much on the BK, I got my board back from Allan at Ardvark. It looks almost as nice as the day it was new. In the meantime I replaced all the header pins on the driver board. I will replace all my connectors when I have time, since I placed a large Mouser order for connectors and trifurcon pins. I installed the boards yesterday morning. The game started up fine and did not stick the left slingshot. But it would not start a game. In switch test there were no stuck switches. I continued to play with the trough switches which seemed troublesome before. I had a couple of the ball trough switches that were intermittent. I chased continuity through the circuit and realized that the connector from the playfield to the head is wonky. I "tweaked" the connector and spayed with DeOxit and now it is working for the most part. I have been able to play several games without any major issues. I have several switches that are still not registering, and my pop bumper and right slingshot, which were firing in coil test do not currently work during the game. I will replace at least that one connector and will probably replace a fair amount of them, before I beat my head against a wall trying to troubleshoot too deeply. I do have a question concerning what connector to order from Mouser or Great Plains. It is a 15 pin plug/receptacle connector, but I am not sure if it is the .093" size Molex?
[quoted image][quoted image]

Congrats on getting it going! The connector in your picture is a 0.062 Molex. You need crimp on pins for one side and crimp on sockets for the other.

If you want to repair a single pin or a few pins or re-use the housings, you should pick up an extraction tool. They allow you to remove the pins and sockets from the housing. https://www.greatplainselectronics.com/products.asp?cat=140

1 week later
#1519 1 year ago
Quoted from northvibe:

Pulled up the manual from ipdb. Confirmed the coil list, all flippers are the 30-750, ordering 2 to replace the two rights.
The one thing I want to confirm is the drop target springs. I can't find any info on those. Are they the standard pbl drop target reset?
https://www.pinballlife.com/drop-target-reset-spring.html
I have the sleeve kit from marco and when I do the drops. I want to pull them apart, clean and replace the spring. A few of them are not dropping easily like below

Black Knight uses part number 10-364 as the return spring. https://www.pinballlife.com/williamsbally-flipper-extension-spring.html

You can use the Planetary Pinball online parts manuals to look at exploded diagrams with part numbers of most every mechanism.

That being said, your problem more likely is from dirt and oxidation than the return spring. Disassemble and clean all the parts of the drop target. Use some metal polish or Novus 2 to clean and polish all the parts that rub. The flat tension "spring" (flat tab of metal. on the back of the drop target) being oxidized and or dirty is the #1 cause of slow/sticky drops IME in this type drop targets. Use no, none, zero lubricants when re-assembling drop targets.

1 week later
#1537 1 year ago
Quoted from epeabs:

I'm hoping to put this issue to bed. Fresh boards, and it boots up. When I credit a game, it immediately locks the jet bumper. I just replaced the lower half of the jet bumper switch that is actuated by the spoon and I have replaced the diode just in case. And it is doing the same thing. I feel I am so close to finally having a complete up and running BK. Any other thoughts?
[quoted image]

There are 2 switches on the pops (and slings). The one with the diode does nothing but add score and sound effects. The one closest to the spoon is what activates the solenoid. Make sure that switch is open when the ring is at rest (not being pressed). Make sure that silver capacitor is not shorted.

1 week later
#1550 1 year ago
Quoted from epeabs:

Yes. Although self test doesn't seem to do anything when button is pressed. Been on quick vacation with my wife and coming home tonight. Hopefully get back into this soon.

Let us know what the LED display on the CPU board is doing. Cycling through the numbers and turning off or getting stuck at a number....

#1552 1 year ago
Quoted from epeabs:

Upon powering up game the led display flashes 0 and the two led's light then display and led's go out. Pushing lower diagnostic button nothing happens, pressing higher button the 0 and the two leds come on but as soon as it is released, the display and the leds go out.

That sounds perfectly normal. Since the numeric display isn't getting stuck at a number, we can assume the board is running.

With the game running, measure the voltage at Test Point 4. This is the blanking signal. It should be 5V if all is good.

#1553 1 year ago

Also make sure the CPU and driver boards are physically mounted correctly.

#1555 1 year ago
Quoted from epeabs:

All is not good. No voltage at TP4, unless I am not grounding at a proper location. I have never tested at a test point before. This new problem didn't happen until I replaced the Q6 transistor, which makes no sense to me. I only removed the driver out of the backbox to do it and never even removed the CPU.

Any ground point should work. So if Blanking is held low, that would explain the main displays going blank....

Make sure your boards are mounted correctly. Specifically, the CPU board should be resting in the mounting slot at the lower edge of the board. Each board should have a couple mounting screws installed (helps with grounding).

Some replacement 40 pin connectors end up with a little more sticking out of the board which if the 2 boards are pushed too tightly together at the 40 pin connector can short out to the brackets. Try separating the boards (without disconnecting them) just a touch to see if anything changes.

1 week later
#1589 1 year ago
Quoted from epeabs:

Had my CPU and Driver out and on my bench tester with my Leon's test ROM. Ultimately I ended up doing a reset and put the boards back in. Diagnostics button works properly and flashes "0" with the two LED's and then "0" and LED's go out. Again while crediting a game, the jet bumper locks on. I just pulled the driver and replaced the IC6 with a new 7408. Reinstalled and it still locks the jet. I have a new 7402 I can install. Is there a way to test the 100 ohm resistor and the capacitor on the jet bumper switch (could that be a possibility)? Dang I want to get this up and running, I just got a CPR replacement plastics set for Christmas I need to install.

You can easily test the capacitor, just put your meter on resistance (ohms) and test across the cap with the power to the game off and the red lead on the plus side of the capacitor. If it is good, you should see a low resistance that increases over time. If it is bad, you will see a constant low resistance (close to zero).

Stupid question but it is hard to see from the pictures - the switch on the spoon is gaped ever so slightly open with the skirt at rest and the terminals of the switch are not touching, right?

#1596 1 year ago
Quoted from epeabs:

I have just replaced the capacitor on the jet bumper switch. I have even adjusted the switch so it doesn't contact even when the spoon is depressed. Upon trying to credit a game or going into diagnostics it locks the jet. I now adjusted the switch so that it has continuity with my DMM. The other thing I did was trim the end of the score switch for the jet bumper because it looked fairly close to the spring and I know @Crispin had an issue with his Black Knight with the end of the switch grounding out on the spring. Not sure how, but it is not locking the jet bumper anymore. But it also isn't working. I have retested Q6 and Q5 and they both test good. I can play a game, but again with no jet bumper working.
[quoted image][quoted image]

Does the pop bumper coil fire in coil test? If so, you know the driver, coil and wiring is good and can focus on the switch side of the mechanism.

1 month later
#1674 1 year ago
Quoted from topkat:

Is there a site that sells the star posts? I scoured marcos and they dont seem to be the same as what was there originally?

I don't think anyone sell the true 80s Williams posts. Best place I found to get spares is someone parting out a game on eBay.

The more modern style posts are the same physical size as the others, they just have a different texture. https://www.pinballlife.com/plastic-translucent-star-posts-1-116-tall.html

#1680 1 year ago
Quoted from MoSeS_1592:

This is interesting to me since I have also attempted to clean these posts in my Taxi with not much luck. It seems like the old dry, worn out rubbers leave a residue/grit that is just impossible to remove completely from the plastic posts. This question may belong in the restoration forums but does anyone have any tips on how to restore these things to a like-new appearance? It would be nice if it was possible to restore the original posts if someone were OCD about original parts/authenticity and such.

I put mine in a ultrasonic cleaner with some TSP in the water. Heat up the water using the ultrasonic's heater (makes the water very hot, too hot to touch for very long). Run several ultrasonic cycles, stirring the posts to give every post a chance to be shaken. Leave in the water overnight and repeat the heat and several ultrasonic cycles the next day. Take them out, rinse them off and I find that very few, if any, have rubber or wax residue on them.

1 week later
#1711 1 year ago
Quoted from northvibe:

I had a little get together to play test my BK and it would randomly do this in the pic. 2’s would scroll, one time it just ejected a locked ball and a game continued, the other time a ball got locked and then it did this but wouldn’t eject a ball. Not sure what is going on or what to look for.
[quoted image]

Are you sure you didn't hit the scoop on the lower PF with one ball locked on the upper PF? If you did hit the scoop, this is normal. If you didn't hit the scoop, I would check the switch on the lower scoop and make sure it isn't too tight.

Quoted from zacaj:

Only way to start 2 ball usually is via the bottom lock eject, I'd check that switch too

Agree, must be the switch on the lower PF scoop. That's the only way to start 2 ball multiball.

The other time 2 or 3 rolls across the displays is the bonus time at the end of a multiplayer game. The bell rings and whoever had the highest score at the end of the game gets 30 seconds of play with unlimited balls.

1 month later
#1760 1 year ago
Quoted from Brdmanstl:

I have found myself in the same situation as you, have you received any response on this or found a work around?
Jim

Rottondog makes a replacement CPU/Driver board but it has known issues with Black Knight and is not supported - so I would stay away from this option.

NW7 board like travish pointed out.

Send your boards off to be repaired - the damage may not be as extensive as you would think. There are going to be blown chips for sure but it should be repairable.

Buy rebuilt original boards from someone on Pinside or eBay.

#1763 1 year ago
Quoted from prefontaine79:

just Joined this club! excited to get to work on it. its working but needs work. Want a new playfield but this one isn't bad..some where on right magna save and on some of the black outlines of inserts. Surely the cpr version has come and gone? lol anyone got one available?

Welcome to the club!

Yes, the CPR Black Knight playfields are pretty tough to come by and if you find one, expect to pay...

While I wouldn't recommend this for a "decent condition" playfield, the Hard Top that frunch mentioned is available for Black Knight. You need to destroy the original art on playfield to install the hardtop so this is a really good option for games with a trashed playfield.

http://www.pinballgifts.com/store/p75/Pinball_Playfield_Hardtop.html

#1774 1 year ago

Those of you with F2 blowing, try turning the game on with the fuse removed, once it starts up, carefully install the fuse (there are high voltages on the power supply board) and see if it blows.

If it does not blow, you may have a problem with the blanking circuit. This circuit is supposed to disable all the solenoids and displays for a the instant the game is powering up where solenoids and such may fire inadvertently when chips are in an uninitalized state.

Also, make sure you are using slow blow fuses.

#1775 1 year ago
Quoted from prefontaine79:

Thankyou!
having sound issues currently
when i flip on the power switch the game makes a sequence of crazy sounds like its about to go into lift-off but when i push start button everything goes mute..had sound at the sellers home and during first game when i brought it home but it cut out mid game. any input helps thnx

Reseat the connectors on the power supply board and lower left of the driver board to see if that changes anything.

1 week later
#1782 1 year ago

Agreed - and to make matters worse, they fused all the GI circuits with a single 20a fuse. What appears to have happened in your case is a short on that string that caused the wiring to overheat but not draw enough power to blow the 20a fuse. Bad design used to save money, not give the best protection.

Follow the melted wires to their source. You can’t tell to which circuits or area of the game they lead because each half (4 pins each) of that 9 pin connector on the power supply board is electrically the same. One side is the transformer source, the other side is the transformer return. There isn’t a specific order to them. The hacker could have soldered the wires on each side in any order.

1 month later
#1826 1 year ago
Quoted from wolffcub:

Game did it 2 times during my first few games but as the night went on it never happened again, and that was about a few dozen games. Is Vids bulletproofing the Williams system 7 posts still the go to for updating these boards ? i noticed its quite old but still seems to have some traffic thu the topic.

Sounds like a reset problem. Could be a cold solder joint on one of the boards, or a bad 40 pin, or bad ROM sockets - basically any of the items in the bulletproofing thread. For the best long-term health of the machine, all the updates are recommended.

2 weeks later
#1868 11 months ago
Quoted from CreepyPinball:

Anyone know a comparable chip that can take the place of this one? I’m spinning my wheels trying to find one. It’s right above the battery to the left, I need to replace it or bypass if possible. The numbers on top of it are /I8223 MM74COON
Battery corrosion hit that ic pretty hard.
Thanks in advance![quoted image]

IC24 is listed as a plain old 7400 on the schematic parts list. 2 of the gates are used to debouce the diagnostic switch. I couldn't find the other 2 gates on the schematic (they may be unused). I think a NAND gate from just about any family would work there.

ebay.com link » Lot 10pcs Sn7400n 7400n Integrated Circuit Ic Usa Fast Seller Box 16

#1873 11 months ago
Quoted from Andy_B:

Dunno. Maybe I'm just being a bit anal.
[quoted image][quoted image]
In fairness it looks a lot worse in the close up pictures.

Thanks for the pictures! Good to know what people thinking of this restoration option (myself included) can expect.

Not sure how they could get around some of that. Without using spot colors, the printer will always need to blend colors with stippling. Maybe printing at a higher resolution would make it less obvoius? Not sure.

The key-lining around the in-lanes could have been cleaned up before printing, but that is a ton of work and might have raised attention to the other areas being fuzzy.

I guess, hard top truly should be used as a last resort, if theses details would bug a person.

#1876 11 months ago
Quoted from Andy_B:

This wasnt something I considered when installing the hardtop but it is definitely an issue. Occasionally a slow ball does get stuck behind the lip at the bottom of the ramp.
I will have to shim it 0.030" or 0.8mm as we like to call it here in the 21st century

Might be a good suggestion for the hardtop guys that they cut "Ramp shims" out of the waste areas of the hardtop and include them...

#1895 11 months ago
Quoted from Turdbol:

Inviting myself into my first club here! Picked this up the other day for dirt cheap. It doesn't currently work, the battery holder has a decent amount of corrosion but the boards 'appear' clean. I pulled the batteries and it boots to test mode, but upon exiting - it will appear 'ready' to start a game, but none of the attract lights work. The game boots to a 2500 03 code in test mode - with no batteries or balls in it. Before I convinced it to get into test mode, it would blow the F2 fuse for solenoid. So in test mode, the flippers work, but none of the solenoids do. I think this will be a fun project and I know NOTHING about pins - so the whole thing will be an in depth learning process![quoted image][quoted image][quoted image][quoted image][quoted image][quoted image][quoted image]

Sounds like the game is booting into audits since the batteries are not installed and the CMOS is not saving settings. Either get NVRAM to replace the 5101 or install a remote battery holder.

You can try and get it to boot by opening the coin door and turning the game off and back on as fast as you can. Sometimes it takes a few tried but that should get you into attract mode.

I assume it is no longer booting with the 0 in the display on the CPU board. That points to other issues.

1 month later
#1959 10 months ago

I put mine in the ultrasonic cleaner with a couple tbs of TSP. Use the heater to heat up the water. It gets so you can't really touch it so I'm guessing its 140+ degrees. A couple rounds of ultrasonic cleaning with stirring between and they come out spotless. Sometimes you need to clean rubber ring residue off a post or 2 but usually that comes off too. The heat, TSP and ultrasonic cleaning dissolve the wax and cleaner residue from posts without scrubbing.

#1967 10 months ago

I love my ultrasonic too!

Do not put any plastic with printing in the ultrasonic. It may take all the printing off. Heat and ultrasonic can take the paint off metal parts too.

I use the ultrasonic to clean metal parts before putting them in the tumbler (to clean the dirt and grease off the parts) and after tumbling (to clean the tumbling media dust off the parts). Heat really cuts the grease!

Clean your white or neutral plastic/nylon parts first, while the water is clean. If you try and clean light colored plastic/nylon in dirty water with heat, you can end up staining some plastics.

1 week later
#1996 9 months ago
Quoted from MultiBallMike:

I had the driver board and MPU rebuilt. Put it back together and it burned up again within about 60 seconds. Prior to doing so, I realized the bottom left drop targets were not working properly. I've confirmed the transistor that burned up is for that set of targets. I then discovered the coil for the targets was melted badly, so I replaced it, repaired the board again, and again, the same transistor started smoking within 60 seconds. I turned it off in time not to burn it up as bad. I'm not sure where to go from here since I have replaced the coil on the target that I know is related to the transistor on the board that keeps melting. Any thoughts?

Coil diode soldered in backwards? Power (often thicker, often double wire) on the banded side of the coil.

3 weeks later
#2002 9 months ago
Quoted from Michel_K17:

Thanks! The area you are referring to is for reference. I use inkspace, and these items are on a unique layer which I make invisible when sending the file to the printer. I intend to make this artwork available to the forum members once I have completed a successful print and installation.

That would be awesome of you! I for one am very interested.

I have a basket case BK that someone disassembled, trying to do a playfield swap and cabinet repaint. The paint job is not as good as I want so I was going to re-paint it but installing decals would be even better!

#2007 8 months ago
Quoted from Boise_D:

I’d like to replace the GI connectors and header. Can anyone point me to the right header? Is that just 2 pins?

The one on the power supply board?

Board side with pins:
https://www.greatplainselectronics.com/proddetail.asp?prod=15-31-1026

Wire side housing:
https://www.greatplainselectronics.com/proddetail.asp?prod=19-09-1029

Pins for wire side housing:
https://www.greatplainselectronics.com/proddetail.asp?prod=02-09-1104

#2013 8 months ago
Quoted from Michel_K17:

Hi vec-tor,
Thank you for your reply. Here are some answers:
1. Maybe to make better contact to ground?
- Although I saw someone refer them to as a "ground", they are in-fact independent of one another, and not connected to the main ground. They are more like a "return" line perhaps?

Those wires do indeed go to "main" ground. They traverse the relay which is used to disable the flippers when not in a game. From there, they use the "lamp and solenoid" ground on the driver board which is tied back to the power board which has all grounds tied together.

That mod could have been used to work around a bad set of contacts on the relay or a bad connection in the wiring/connectors from the flippers to the driver board.

#2016 8 months ago

Try this doc from the old firepower.com site. It is a system 6 board but the connections to the display didn't change.

CPUBoard.pdf
#2021 8 months ago
Quoted from Michel_K17:

Printers had to reprint the vinyls because:
1. One image did not transfer properly from the PDF (they admitted that they had to fix it); and
2. The vinyl was super-glossy even though I had asked for an egg shell Sheen
My Lessons Learned in regards to the printing & application process:
1. Make sure that you ask for a top clear layer on top of the vinyl print - it makes the vinyl thicker and protects the print from scratches
2. Ask for scrap pieces of vinyl from the print shop. It was nice to be able to practice without the stress of ruining the final print!
3. Get a roller! Even the "soft" applicator the vinyl print shop gave me tended to make scratches. I put some velcro on one side of the applicator, and even then it was not foolproof.
4. Wet vs dry. Material was 3M Controltac for which I paid more ($284 before taxes), but I was told that it the longevity is much better. This material has channels to allow the air to exit ("air egress" feature). However, no matter what I did (with the practice pieces), I would still get the occasional air bubble. The 3M instructions said to avoid the wet method because there is no means for the water to dry if any of it gets trapped, However, the print shop highly recommended the wet method anyway. Since my cabinet had a layer of clear, and it was fairly flat, I went ahead, and used the "wet" method, using a light mist of water (with 2 drops of detergent per liter). Procedure was easy: the roller allowed me to fully push out any trapped water, and after 24 hours, I can attest that the vinyl has adhered to the cabinet very well and it was fully flat with no bubbles. Generally speaking, I used the procedure from Australia shown on youtube here (except I used far less water). Trimming just shy of the corner worked well.

5. I did not need to use an assistant. Separating the film was easy, and I used a trimmed piece of underlay to grab the end, and keep the end stiffso that the corners would not fold.
6. I used the triangles at bottom of each print to align the pieces with the cabinet, and it all lined up well.
7. I did not remove the rails, and simply trimmed around them. Worked well.
8. Total time to apply the vinyl: 5 hours. This excludes removing/re-installing the legs, and playing with the practice pieces of vinyl.[quoted image][quoted image][quoted image][quoted image][quoted image][quoted image][quoted image][quoted image][quoted image][quoted image][quoted image][quoted image][quoted image][quoted image][quoted image][quoted image]

Looks GREAT!

#2033 8 months ago
Quoted from EilersPark:

Rottengog MPU327 resets - SOLVED!
I wanted to revisit this topic as several folks had had issues with the Rottendog MPU327 resetting when both flippers are energized at the same time. In my case, I had a completely working machine before adding the MPU327. I was using a Rottendog PS board with all other OEM boards. No issues. When I swapped in the Rottendog MPU, the issue started happening. I checked connectors, voltages, etc. All good.
The issue appeared to be the GND reference between the MPU and PS boards. I added a dedicated wire with U connectors on it from board to board, attaching under a mounting screw on each board. It has been bullet proof for the last 2 years. I did pass this along to Jim to let him know as well.
I hope this helps

There are 6 separate ground wires that lead directly from the CPU board to the power supply board. Since the header pins were all brand new (new boards), I wonder if the problem is the wiring harness connectors. Do you have the stock IDC connectors on the power supply and CPU harness?

#2036 8 months ago
Quoted from EilersPark:

Maybe they could have been weakened by disconnecting and reconnecting them. I have stock wiring harness connectors (original) and I suppose it is possible that it was the problem, however the problem only occurred after I changed to the Rottendog MPU, which is the same as reported by others. I could probably prove / disprove this by putting back my original System 7 boards but since it's working great I don't want to change anything. Not trying to throw Rottendog under the bus here but maybe the board does have some grounding issue. Regardless I just wanted to share my solution.

Yes, thanks for posting your solution!

1 month later
#2073 7 months ago

I would leave them. If it bugs you or is causing problems, take 100 turns of wire off the 850 and relabel it as a 750.

2 months later
#2129 4 months ago
Quoted from MoSeS_1592:

Audit/adjustment question here.
I'm trying to reset the high score to date (adjustment #13). I already cleared and reset the bookkeeping/audits and I set adjustment 13 to my desired high score to date at 600,000. For some reason no matter what i do i cannot get high score to date any lower than 2,500,000. It always defaults to that initial score until a higher score is achieved. Is this the minimum allowed or am I just missing something obvious here?
Also, will BK retain the top four highest scores and display them in attract mode or only the all time high score to date?

What do you have settings 14, 15, 16, 17 (replay levels)? Try setting those to 0 (no replay awarded) or something less than 600,000. Then press the high score reset.

3 months later
#2208 23 days ago

The driver board with the "Flash" label on it is no problem. The driver board is interchangeable with many games as long as the jumpers are added to the switch matrix, which your board has.

That "Black Knight 82" board is certainly not stock and I bet it has something to do with why your drop banks are working together.

Where do the wires lead on the A and B connectors?

Where do the white and orange wire lead that go behind the board that are in the wire nut?

You may want to start a new thread to track the investigation of this mod. There may be people on Pinside that have seen it before that are not in this club thread. I would love to know what that mod is all about!

2 weeks later
#2258 5 days ago
Quoted from HHaase:

Glad it was an easy fix! We've all done it at least twice.
-Hans

Indeed!

Promoted items from the Pinside Marketplace
$ 59.95
Playfield - Toys/Add-ons
Hookedonpinball.com
$ 8,999.00
Pinball Machine
Classic Game Rooms
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
$ 999.00
$ 399.95
Lighting - Led
Pin Stadium Pinball LEDs
$ 79.95
Cabinet - Shooter Rods
Super Skill Shot Shop

You're currently viewing posts by Pinsider schwaggs.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside