(Topic ID: 54503)

Black Knight Club...Members Only!


By mof

6 years ago



Topic Stats

  • 2,095 posts
  • 200 Pinsiders participating
  • Latest reply 9 days ago by Mtkst19
  • Topic is favorited by 102 Pinsiders

You

Linked Games

Topic Gallery

There have been 716 images uploaded to this topic. (View topic image gallery).

20191120_225849 (resized).jpg
20181027_170833 (resized).jpg
20181027_170721 (resized).jpg
20181027_170714 (resized).jpg
20190928_152257 (resized).jpg
20190928_152245 (resized).jpg
IMG_6811 (resized).JPG
IMG_6810 (resized).JPG
aa17e3eab409012e89ec02440655507d77a95c20 (resized).jpg
75567373_518463258708834_1991935845392711680_n (resized).jpg
75271454_2790113237713265_9196880901911347200_n (resized).jpg
Final Install with liftbar 01 (resized).jpg
20190929_165855 (resized).jpg
Bird (resized).png
Missing Black Highlight (resized).png
03EA4FD2-F78E-4355-AD7F-F99F6EFA6F93 (resized).jpeg

You're currently viewing posts by Pinsider jdzwir123.
Click here to go back to viewing the entire thread.

#387 4 years ago

can somebody please send me a picture of what the flipper relay looks like.
thank you

#389 4 years ago

Cool thank you. My lower right flipper is weak and not getting the ball up the left ramp. I took it apart and it looked good, the coil sleeve was really old though, and new ones are coming in a couple days. Someone
mentioned that I might be getting the right voltage but not enough current, and to check the relay. Anyone else have the same issue?

#391 4 years ago

Thank you.
Do new coil sleeves make a big difference?

#393 4 years ago

Congratulations I just picked mine up on Monday and can't wait to get it up and running.
image.jpg

#396 4 years ago

Will damaged transistors reduce current flow for flippers?

#398 4 years ago

I also found that the flipper fuse was at 10 Amp instead of the 20 amp would that reduce current flow?

#403 4 years ago

Sometimes when I turned it on the displays don't come on and sometimes they do come on. Anybody know how to fix that?

#405 4 years ago

My left kicker coil is stuck when it's connected to the driver board.
When I remove the board connector it stops so I'm pretty sure that it's a play field issue.
I'm not sure where to start looking. Has anyone had this problem?

#407 4 years ago

I read it on a forum. I did replace Q2(the larger one). The problem still persists. I know that any part can go bad but is it really common for the small ones to go bad?

#412 4 years ago

I replaced Q2, I agree I should have tested it first before replacing. I tested Q1 and found that it is really bad, went to radio shack bought a new one. I hope that is the end of this so I can play some pinball. Thank you again for your help.

#415 4 years ago

Q1 and Q2 replaced. The coil is still locked up.

#417 4 years ago

The game worked when I picked it up and now the left kicker is locked. Boards have hacks, burns and more.
I guess I'll just buy a new driver board. Any recommendations????????20150519_224241.jpg

#419 4 years ago

No. I'm new at this and not sure what that is but I have schematics. How does that work?

#421 4 years ago

Homework. Will do.

#423 4 years ago

In step 3 when I put the connector back on the coil engaged.

#424 4 years ago

In step four the coil turns on again.

#425 4 years ago

When I took the wires for the left and the right kicker coil out of the harness on 2j12 and touched the inside metal part of the back box they would ground and energize the coil and when I removed it they de energize again. So they seem to be functioning correctly on the playfield end of it.

#427 4 years ago

I'm almost wondering at this point if I would be better off buying either a rotten dog or getting a used driver board. There is a lot of black and burned resistors on the right side and I'm almost wondering if it's beyond repair because even when I take the left kicker out of the picture the flippers and other solenoids aren't working correctly. I can remove different things out of the connector and get them to function correctly by touching them on the metal 20150519_224241.jpgside of the back box. Screenshot_2015-05-20-11-43-36.png

I do appreciate all your help, I hope someday that I will be proficient enough help other people with their pins.

#429 4 years ago

I don't think the harnesses were hacked. is there any other options besides rotten dog? it looks like everything is working correctly on the playfield, its on the board where it is having issues.

#431 4 years ago

I just think replacing with a rotten dog instead of trying to refurbish it would be a better bet. I think it would just make everything perform better.

#436 4 years ago

I appreciate all your insight but I think that it's getting above my pay grade. I'm going to check in to replacing.

3 weeks later
#448 4 years ago

Thanks to chosen_s I got me some nice new drop decals!image.jpg

image-515.jpg image-279.jpg
#450 4 years ago

Is it?

#452 4 years ago

It is a fun game. Do flipper coils usually get warm during games?

#454 4 years ago

When you say scan do you just mean a good picture?image.jpg

#456 4 years ago

Is there a way to turn up just the speech volume?

#458 4 years ago

Anyone out there tell me what kind of diode has a -87 on it. It goes on one of the drop targets on the upper left side in the front? I need to get a replacement and I don't have the actual value on the diode.

#461 4 years ago

Thank you Hans

#462 4 years ago

My Black knight starts with an error, maybe, where you have to turn if off and on a couple times with the door open to get it to start. It also doesn't save high scores and such. Is there a work around for it. Has anyone had that happen?

#464 4 years ago

Ok will do

#467 4 years ago

The battery pack had corrosion so I put a new one one and that fixed it. It's awesome when things start working correctly. Thank you everybody for the advice. There is only one more issue that I've been having. The flippers work correctly but after a lot of games, in a row they stop working. The fuse isn't getting blown and after I shut it off and turn it back on after a little while they start working again. Any ideas would be awesome.
Thank you in advance

1 week later
#470 4 years ago

All of my selonoids seems really weak. The flippers, the slingshots and the kick out holes. I am going to look through the manual and schematics and see if I can find the answer but I was wondering if anybody has had this similar thing happen? Thank you

2 weeks later
#476 4 years ago

My Black Knight started resetting mid game and displaying all 1's on the displays. Has anyone experienced this before?

Promoted items from the Pinside Marketplace
From: $ 5.00
Cabinet - Other
Rock Custom Pinball
$ 75.95
Cabinet - Shooter Rods
Super Skill Shot Shop
1,900 (OBO)
Machine - For Sale
Northville, MI
2,200 (OBO)
Machine - For Sale
Lincoln, NE

You're currently viewing posts by Pinsider jdzwir123.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside