(Topic ID: 54503)

Black Knight Club...Members Only!


By mof

6 years ago



Topic Stats

  • 2,261 posts
  • 209 Pinsiders participating
  • Latest reply 11 hours ago by BlackxDragon
  • Topic is favorited by 104 Pinsiders

You

Linked Games

Topic Gallery

There have been 786 images uploaded to this topic. (View topic image gallery).

20200520_140220 (resized).jpg
20200509_225740 (resized).jpg
20200510_110023 (resized).jpg
20200517_181220 (resized).jpg
20200517_181226 (resized).jpg
97917573_237276777724535_4680377148379234304_n (1) (resized).jpg
20200509_225815 (resized).jpg
98047235_675386119950036_2933710469896077312_n (1) (resized).jpg
96145808_686106915568522_4628929616336125952_n (resized).jpg
20200510_173945 (resized).jpg
20200510_174037 (resized).jpg
20200510_174048 (resized).jpg
20200510_112418 (resized).jpg
20200510_110128 (resized).jpg
20200510_110105 (resized).jpg
20200510_110119 (resized).jpg

You're currently viewing posts by Pinsider gutz.
Click here to go back to viewing the entire thread.

#750 2 years ago

You're missing the gi connectors because it looks like someone modified the stock setup by running the gi circuits through the fuse bank on the lower right. Not a bad idea to fuse each string (instead of a single 20a protecting them all) but with this modification you bypass the gi relay! You won't have the gi flashing effect during multiball start.

#753 2 years ago
Quoted from TicTacSeth:

Hmm, that goes in the "not cool" column to me! Is there a way to get the mod to run back through the relay?
Also, good to know I have a separate booting issue. This happened at the guys house I bought it from, and is happening now. When I flip it on, the inside digit flickers 0, with the same happening to the scoreboard (a single 0 digit). Basically not booting. I read a bunch earlier and tried googling, but not seeing that same issue. Thoughts?

I posted a pic in a different thread: https://pinside.com/pinball/forum/topic/re-pinning-psb-system-7#post-3825246

The two larger yellow wires (that are nutted in the pic) go to the 2 position connector. The four wires going into and the four wires coming out of the fuse bank go in the 9 position connector.

Edit: I zoomed in on the pic and it looks like a relay was mounted a la system 6 style! Does the gi flash when you start multiball? If it's working, it wouldn't be horrible to leave it alone.

4 weeks later
#768 2 years ago

I am in the market for a unpopulated used lower playfield that is restorable, and possibly an upper. My lower playfield is too far gone, but my upper might be salvageable.

#770 2 years ago
Quoted from vec-tor:

Hopefully, there might be an overlay for the game.

That might be an option, or if they make a hard top. My preference is an original playfield, hopefully someone doing a cpr swap has decent originals they would sell

#772 2 years ago
Quoted from hawknole:

I have my old playfields, not sure if we PM'd before or not, "decent" is a relative term. My old ones would need quite a bit of work, hence the CPR swap.

I don't think we've pm'd, send me some pics of the playfields when you get time!

9 months later
#992 2 years ago
Quoted from Pintor:

Good evening! I got my BK a few weeks ago and noticed the pop bumper light doesn’t work. I’ve tried switching out the bulb with another LED but still didn’t work. The bumper otherwise works great. I posted a pic of the wireing below. I don’t see anything disconnected.
Any thoughts?
Thanks!

I'm too lazy to download your pics and circle shit

The two leads from the pop bumper lamp should go to 1) the non banded side of the diode you see mounted to the playfield to the top right of the pop bumper in the first pic 2) the double yellow wires to the left of the lock lamp in the second pic.

The pop bumper lamp is cpu controlled. It appears, for no apparent reason, someone had installed a jumper wire between the two connection points for the pop bumper light. This needs to be removed.

#995 2 years ago
Quoted from Pintor:

Haha I totally get it! How about I do the circling! So is this the wire I need to
Remove in the pic?

Yes, that wire. Is the other end shown in the next pic?

One lead from the pop bumper lamp connects to the 2 yellow wires right there.

#996 2 years ago
Quoted from Pintor:

Also am I missing a lamp wire here?
There’s some other weird wiring toonin the back box but everything else seems to work fine. Except for the glitchy displays but I haven’t cleaned the contacts yet

Is this the other end of the jumper wire from the first pic with the arrow?

This is where the second lead from the pop bumper lamp should go.

#999 2 years ago
Quoted from Pintor:

I’m super novice at this stuff so please let me know if I’m way off base...

That table is for the SWITCH matrix. Find the table for the LAMP matrix.

Edit: are you working on a different problem now?

2 months later
#1181 1 year ago
Quoted from Spacemanratso09: The timer keeps running ,expires,and resets.Nothing happens when you get them down in time.
l

sounds like one (or more) drop target switches aren't working on each of those banks. All three have to work or you can't score the bank. Take the glass off and start a game. Manually trip each target, one at a time, and figure out which ones don't score points. Then inspect the switches for those targets beneath the playfield.

4 weeks later
#1270 1 year ago

Ring terminals and crimp the wires, or use the ring terminals without the plastic and solder the wires.

1 month later
#1423 1 year ago
Quoted from Mathazar:

Looks for some technical guidance on my BK....not sure where to start. The first two two drop targets in the left bank of the upper playfield are not scoring or starting the drop target timer but the third target in that bank is working ok. All other drop targets in the other three banks are all working ok. The two targets in question work mechanically and the leaf springs are making contact. The scoring/timer doesn't start when I forcibly engage the leaf springs, either.
The problem must be electrical somewhere. If there was something electrically common between the those first two targets, I'd think other targets would also not be working? Is this just a coincidence that those first two targets are failing the exact same way?
I'm rather new at ownership, so I'm hoping someone can point me in the right direction. I have a multimeter, but not exactly sure what I'm looking for. Red arrows in the pix point to the two suspect targets.
Thanx!
Kris[quoted image][quoted image][quoted image]

Do you have a yellow jumper wire on the 2 bad switches that connects to the tab that is not connected to the diode? The green wire on the good switch needs to be jumpered to the other two switches with a single wire (typically a solid yellow wire)

It might be there, but its hard to see the wires in the photos.

#1426 1 year ago
Quoted from Mathazar:

Aha!! Can't believe I didn't see that before....the yellow wire is indeed there, and it's become disconnected from the good switch. I just need to re-solder that yellow wire to the tab on the good switch that has the two green wires then? Can't thank you enough....[quoted image]

Badabing, you got it - reconnect the jumper to the green wires

1 month later
#1506 1 year ago
Quoted from epeabs:

Make sure your 3 advance buttons are in the up position on the inside of the coin door. Shut the machine off. When you turn it back on, it should be in regular attract mode.
[quoted image]

The position of the door switches will not affect the machine upon boot up. Also, only the middle one has up/down latching positions.

Vibe - your game is booting to audit mode. Are the batteries good? Holder good? Battery power getting to the ram? Or did you install nvram?

Once in audit mode, you can turn the machine on/off quickly to get it to attract mode. Or use the coin door switches to travel through the menus. This doesn't fix the underlying issue, and you will have to do it each power up.

#1509 1 year ago
Quoted from northvibe:

Mmm no batteries...boards refurbed and the AA holder is still empty. So you’re sayin I need some batteries....

you need batteries unless the "refurber" installed nvram.

After replacing the batteries, it will go into audit mode the first power up. Turn it off for a few seconds then turn it back on. It should now always boot into attract mode (with good batteries).

ALSO - remote mount those batteries once you get the rest of the issues sorted out.

2 months later
#1646 1 year ago
Quoted from MoSeS_1592:

Please confirm... in the default settings, two or three captured balls intended to start multiball do NOT carry over each turn if multiball is not achieved before round is over, right? Meaning you need lock two/ three balls AND achieve multiball on the same round or else the locked balls don't count and the locked multiball counter resets, correct?

Confirmed, Thats how mine is set up. It might be adjustable in the menus.

8 months later
#2061 7 months ago
Quoted from Tomass:

Does anyone have a clue to what this wire is for? Orange/white, right where the head attaches. Nothing appears to be cut on any of the harnesses but it is stapled and looks as if it may have been factory.[quoted image]

It doesn't look like factory wiring to me.

2 months later
#2108 4 months ago

I think I've used this one before when I was in a similar situation: https://www.marcospecialties.com/pinball-parts/01-7036

Place the old one on top of the new, trace the fingers, then cut/grind the fingers out.

#2111 4 months ago
Quoted from jibmums:

Click on "product compatibility" and it lists Black Knight and Pinbot, so it should be usable as-is.

Not a guarantee - Black knight used different drop banks/reset plates during the production run.

Promoted items from the Pinside Marketplace
Wanted
Machine - Wanted
Dierks, AR
$ 125.00
Cabinet - Toppers
Sparky Pinball
$ 99.00
Gameroom - Decorations
Pinball Sales
$ 5,899.00
Pinball Machine
Classic Game Rooms

You're currently viewing posts by Pinsider gutz.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside