(Topic ID: 54503)

Black Knight Club...Members Only!


By mof

7 years ago



Topic Stats

  • 2,276 posts
  • 210 Pinsiders participating
  • Latest reply 6 days ago by PSchmitz
  • Topic is favorited by 104 Pinsiders

You

Linked Games

Topic Gallery

There have been 789 images uploaded to this topic. (View topic image gallery).

s-l1600 (5) (resized).jpg
s-l1600 (3) (resized).jpg
6A80CD36-6109-4778-B123-47DBAD3CD216 (resized).jpeg
20200520_140220 (resized).jpg
20200509_225740 (resized).jpg
20200510_110023 (resized).jpg
20200517_181220 (resized).jpg
20200517_181226 (resized).jpg
97917573_237276777724535_4680377148379234304_n (1) (resized).jpg
20200509_225815 (resized).jpg
98047235_675386119950036_2933710469896077312_n (1) (resized).jpg
96145808_686106915568522_4628929616336125952_n (resized).jpg
20200510_173945 (resized).jpg
20200510_174037 (resized).jpg
20200510_174048 (resized).jpg
20200510_112418 (resized).jpg

There are 2276 posts in this topic. You are on page 23 of 46.
#1101 1 year ago

I'm sorry its Pin 4, I was going from the wrong direction.

#1102 1 year ago

Have a nagging issue with my BK. When the ball lock is empty and I make a clean shot into the lock mechanism, it often times flies all the way through. Thus no lock. Other BK's that I have played don't seem to have this issue for the most part. Has anyone experienced this before and is there a fix to minimize this? Thanks.

#1103 1 year ago
Quoted from rickyray:

Have a nagging issue with my BK. When the ball lock is empty and I make a clean shot into the lock mechanism, it often times flies all the way through. Thus no lock. Other BK's that I have played don't seem to have this issue for the most part. Has anyone experienced this before and is there a fix to minimize this? Thanks.

I've seen some people who have a little bump on the metal plate over the lock to knock the ball down

#1104 1 year ago

Thanks for the responses to my thoughts on the game.Ive decided to go all the way,the more I do the better it plays and I am just in love with the game.
I haven’t touched Star Wars or walking dead since I got it.
Mayfair comes Tuesday LEDs this weekend.
Someone even gifted me a upper playfield from the first cpr run for the game.
For some reason I can help but play one,or 5 more quick games whenever I am down there..trying to beat the Knight.

The most pure fun I’ve had in my short collecting history,I like that I don’t need to watch a video to learn how to play and the feeling this game emotes. I am obsessed with fixing him
Not about the money all about THIS game

#1105 1 year ago

Just an FYI... I purchased some new flipper base plates for pbl. The coil stops on them are 0.223" tall. Hopefully that's correct, but unless one of you had a nib black knight I don't think we'll get much better info.

#1106 1 year ago

Very frustrating..my extra ball up top and lower turnaround switches do not register in a switch test all looks fine
Been playing for a awhile I noticed the extra ball never comes on

#1107 1 year ago
Quoted from Spacemanratso09:

Very frustrating..my extra ball up top and lower turnaround switches do not register in a switch test all looks fine
Been playing for a awhile I noticed the extra ball never comes on

Just clean them and gap them real tight. The speed of the ball during game play can be different than when testing.

#1108 1 year ago

Don’t ever...I mean ever send a fucking backglass with Fedex
This is what showed up when I received my Mayfair purchased from a good man in PA so freaking bummed

908F77F7-1353-4C74-8B96-FE2922D5ED33 (resized).jpeg
#1109 1 year ago
Quoted from Spacemanratso09:

Don’t ever...I mean ever send a fucking backglass with Fedex

Oh, that's so painful to see! I feel for you. That's why I'm scared to death to buy a backglass from somewhere and have it shipped...

#1110 1 year ago

Oof, now I am starting to regret not buying one from Mayfair when they were at Pintastic. I have had good luck with CPR, they pack it right. I guess it's time to file a claim.

#1111 1 year ago
Quoted from Spacemanratso09:

Don’t ever...I mean ever send a fucking backglass with Fedex
This is what showed up when I received my Mayfair purchased from a good man in PA so freaking bummed

That is heartbreaking

#1112 1 year ago

My Mayfair didn’t come from them it came from a private owner .Its insured and have filed a claim.Totally bummed
Not one god damn fragile sticker on it.
This was all fed ex.the packing was awesome someone just chucked it.
Already talked to Steve at Mayfair about getting another when I secure the claim.
Meanwhile the pile is sitting in my living room.I don’t think 3 coats of clear will fix.

#1113 1 year ago
Quoted from Spacemanratso09:

My Mayfair didn’t come from them it came from a private owner .Its insured and have filed a claim.Totally bummed
Not one god damn fragile sticker on it.
This was all fed ex.the packing was awesome someone just chucked it.
Already talked to Steve at Mayfair about getting another when I secure the claim.
Meanwhile the pile is sitting in my living room.I don’t think 3 coats of clear will fix.

There may be other options soon. CPR says they are going to be doing BK backglasses within a couple of months. Their prices are usually around the $250 USD mark. I like having choices!

#1114 1 year ago
Quoted from Spacemanratso09:

My Mayfair didn’t come from them it came from a private owner .Its insured and have filed a claim.Totally bummed
Not one god damn fragile sticker on it.
This was all fed ex.the packing was awesome someone just chucked it.
Already talked to Steve at Mayfair about getting another when I secure the claim.
Meanwhile the pile is sitting in my living room.I don’t think 3 coats of clear will fix.

I don't know, in one of my forensic classes we had to piece together a shot out window and then determine the sequence of shots. It can be done

Just trying to make light of a crappy situation. I am glad this was insured.

I have a fellow in WI right now trying to buy my near mint Astro BG and I am super reluctant to do so even with crating it.

#1115 1 year ago

So I have been still trying to figure out what is going on with this solenoid circuit. This is continuing from post 1097. So my Drive transistor keeps getting fried and my ball release coil locks on. I have checked and replaced the diode on the coil. I checked the ohms on the coil and I am getting 4. I checked switch 20 that triggers the coil. I’m getting no shorts in the wires and continuity from the switch to the board connectors. I took the mpu and driver board out and hooked up and old pc power supply on them. With a logic probe I took readings on IC1 Leg 9 is hi, 10 is low and 8 is low. I think that’s how this should be. I tested other legs for different solenoids and I am getting the same. I checked different voltages over components and compared them from the solenoid circuit that is having issues to a working one and I am getting matching readings. The only thing I have found different was resistance from the base of Q15 to ground, the solenoid 1 circuit I’m getting 2.1K and all others I’m getting 1.7K. Its not a big difference but I don’t know why, I thought it should be 2.7k unless the reading is coming from the predrive transistor to ground. I also checked the voltage on the predrive transistor Q14 and there is none. Again I think this is how it should be as the circuit should not be switched on at this point. Tonight or tomorrow I’m going to put the boards back in (new transistor) leave all of the solenoid connectors off the board and pull the fuse. Go in to test mode for edge test for switches and see if there is anything going on with switch 20. I also will check to see if pin 10 on IC1 is high or low. If anyone has any ideas let me know at this point I’m not sure what else to do if I get normal readings putting the boards back in.

#1116 1 year ago

Did you disconnect the coil in question and fire it up to see if it will trip? That would be the first step.

#1117 1 year ago
Quoted from nerdygrrl:

Did you disconnect the coil in question and fire it up to see if it will trip? That would be the first step.

I'll do that when I get the boards in. I Really didn't think about taking out just that one coil and see what happens. I have be reading your posts with your adventure too. Seems things are coming along.

#1118 1 year ago

Yeah, it's getting there. Hoping to do a few more diagnostics and then order up the remaining bits I need for the board stuff this weekend. It's slower going that I would like, but it is what it is.

I will re-read your earlier thread, but with stuff like this, start with the easiest and work your way back. Coil, diode, wiring all the way back to board...

#1119 1 year ago
Quoted from Troyster42:

So I have been still trying to figure out what is going on with this solenoid circuit. This is continuing from post 1097. So my Drive transistor keeps getting fried and my ball release coil locks on. I have checked and replaced the diode on the coil. I checked the ohms on the coil and I am getting 4. I checked switch 20 that triggers the coil. I’m getting no shorts in the wires and continuity from the switch to the board connectors. I took the mpu and driver board out and hooked up and old pc power supply on them. With a logic probe I took readings on IC1 Leg 9 is hi, 10 is low and 8 is low. I think that’s how this should be. I tested other legs for different solenoids and I am getting the same. I checked different voltages over components and compared them from the solenoid circuit that is having issues to a working one and I am getting matching readings. The only thing I have found different was resistance from the base of Q15 to ground, the solenoid 1 circuit I’m getting 2.1K and all others I’m getting 1.7K. Its not a big difference but I don’t know why, I thought it should be 2.7k unless the reading is coming from the predrive transistor to ground. I also checked the voltage on the predrive transistor Q14 and there is none. Again I think this is how it should be as the circuit should not be switched on at this point. Tonight or tomorrow I’m going to put the boards back in (new transistor) leave all of the solenoid connectors off the board and pull the fuse. Go in to test mode for edge test for switches and see if there is anything going on with switch 20. I also will check to see if pin 10 on IC1 is high or low. If anyone has any ideas let me know at this point I’m not sure what else to do if I get normal readings putting the boards back in.

Verify you installed the diode on the ball release coil in the correct orientation.

Have you replaced the pre-driver transistor?

Before installing the board, lift one leg of the pull-up resistor on the output to the AND gate (input to the pre-driver) and make sure it is in spec (560 ohm I believe).

Before installing the board, lift one leg of the resistor on either side of the pre-driver transistor and verify they are correct (68 ohm and 2.7k I believe).

When you put everything together, and the coil still locks on, before turning off the game, use your logic probe to test the output of the AND gate for that coil. See if the output is getting stuck HI. Could be a weak output on the AND gate.

#1120 1 year ago
Quoted from Schwaggs:

Verify you installed the diode on the ball release coil in the correct orientation.
Have you replaced the pre-driver transistor?
Before installing the board, lift one leg of the pull-up resistor on the output to the AND gate (input to the pre-driver) and make sure it is in spec (560 ohm I believe).
Before installing the board, lift one leg of the resistor on either side of the pre-driver transistor and verify they are correct (68 ohm and 2.7k I believe).
When you put everything together, and the coil still locks on, before turning off the game, use your logic probe to test the output of the AND gate for that coil. See if the output is getting stuck HI. Could be a weak output on the AND gate.

Thanks, I have the diode band on the hot side with the 2 red wires. I have replaced the pre-drive transistor once, still seems good but I have extra since the board is out I'll pull it. I'll check the resistors as well. I was going to check the AND gate with the coil connectors off, I figured it should still be getting a signal to go by without taking a chance. I can tell the AND gate was replaced before but unfortunately they didn't socket it. I should get to this tomorrow. I'll post the out come.

#1121 1 year ago

One of my connectors, melted to the pin on the board when I removed it. Are these .156 idc ?

https://www.pinballlife.com/index.php?p=product&id=1601

CF821216-2DA7-460E-9658-E4A94F438005 (resized).jpeg
#1122 1 year ago

Yes. Can also use crimp on (non IDC) depending on the tools you have

#1123 1 year ago
Quoted from northvibe:

One of my connectors, melted to the pin on the board when I removed it.

Quoted from zacaj:

Yes. Can also use crimp on (non IDC) depending on the tools you have

Buy a crimper and replace all of these connectors if you can. They are bound to fail at some point. PITA.

#1124 1 year ago
Quoted from northvibe:

One of my connectors, melted to the pin on the board when I removed it. Are these .156 idc ?
https://www.pinballlife.com/index.php?p=product&id=1601

Yes unfortunately

#1125 1 year ago
Quoted from dzorbas:

Buy a crimper and replace all of these connectors if you can. They are bound to fail at some point. PITA.

crimper or a punch tool?

I have the push down punch tool for this style, but wasn't the crimper over $100 for the hand tool or is there something else?
Ya, I don't mind a punch tool for a connector here or there but a full connector swap would be nice to have a better way...

#1126 1 year ago

I have a pair of $25 ratcheting crimpers from Amazon that are amazing. They are not popping up in my search, but I will try and find them for you tomorrow. They're awesome as you can set the pin in the crimper and ratchet it down and it holds it. Total game changer for me.

#1127 1 year ago
Quoted from nerdygrrl:

I have a pair of $25 ratcheting crimpers from Amazon that are amazing. They are not popping up in my search, but I will try and find them for you tomorrow. They're awesome as you can set the pin in the crimper and ratchet it down and it holds it. Total game changer for me.

oh baby, ratchet crimpers ughhhhh totally would beat a punch tool.

Does that do a "molex" connector then? so I would need a different female plug?

#1128 1 year ago
Quoted from northvibe:

oh baby, ratchet crimpers ughhhhh totally would beat a punch tool.
Does that do a "molex" connector then? so I would need a different female plug?

Yes

https://www.pinballlife.com/index.php?p=product&id=3450
https://www.pinballlife.com/index.php?p=product&id=496
https://www.pinballlife.com/index.php?p=product&id=1628

I think this is what I have, or similar...
amazon.com link »

#1129 1 year ago

rock on. I already ordered the older style, but it was like .70c. i'd rather have crimp style and now I can do that moving forward! thanks!

#1130 1 year ago

This is the crimper I have. Absolutely love it. Crimps the wire and insulation at the same time. I use it for .156 Molex, .062 and .093 pin style connectors. Basically any crimp on connector you encounter.

amazon.com link »

#1131 1 year ago
Quoted from Schwaggs:

This is the crimper I have. Absolutely love it. Crimps the wire and insulation at the same time. I use it for .156 Molex, .062 and .093 pin style connectors. Basically any crimp on connector you encounter.
amazon.com link »

+1 this is what I have as well. Ken Falta out in BC who builds repro arcade harnesses sent me a pair as a gift and they are amazing. Took a few to get the hang of it, but then it was smooth sailing. One of the best tools I own. The ratcheting aspect is so nice.

#1132 1 year ago
Quoted from Schwaggs:

This is the crimper I have. Absolutely love it. Crimps the wire and insulation at the same time.

Yup! Get some connectors and pins and go to town!

#1133 1 year ago

Hahaha you guys know how to spend my money thank you! I’ll snag those and I’ll probably order new connectors, boards are out being refurbished so it would be a good time to repin.

Do you use a handheld wire stripper as well?

#1134 1 year ago
Quoted from northvibe:

Hahaha you guys know how to spend my money thank you! I’ll snag those and I’ll probably order new connectors, boards are out being refurbished so it would be a good time to repin.
Do you use a handheld wire stripper as well?

I have a southwire stripper that I like. Mine is older so only goes to 20G which is an issue, this one says it gos to 22G. I am sure there are cheaper versions.

amazon.com link »

#1135 1 year ago

I have a pair of those ratcheting crimpers, but i can't seem to figure out the trick to making them work right. I've had a 1026-CT crimper i bought from GPE years ago that I've continued using instead. Any chance someone could school me on how to use the ratcheting crimpers, or point me to an instructional site or video?

#1136 1 year ago
Quoted from nerdygrrl:

I have a southwire stripper that I like. Mine is older so only goes to 20G which is an issue, this oe says it gos to 22G. I am sure there are cheaper versions.
amazon.com link »

Nice! thanks. I'll order these too. Stripping sucks on the small gauge wire. i saw a video of John (johns arcade) and he had a set, holy smokes that looked nice.

Quoted from frunch:

I have a pair of those ratcheting crimpers, but i can't seem to figure out the trick to making them work right. I've had a 1026-CT crimper i bought from GPE years ago that I've continued using instead. Any chance someone could school me on how to use the ratcheting crimpers, or point me to an instructional site or video?

From the reviews, it sounds like you have to mess with the pressure setting screw and you run a handful of test crimps to find the right setting for your size wire.

#1137 1 year ago
Quoted from northvibe:

From the reviews, it sounds like you have to mess with the pressure setting screw and you run a handful of test crimps to find the right setting for your size wire.

Good call, I'll give that a shot. Thanks!

#1138 1 year ago
Quoted from nerdygrrl:

Oof, now I am starting to regret not buying one from Mayfair when they were at Pintastic. I have had good luck with CPR, they pack it right. I guess it's time to file a claim.

I bought one from Mayfair a few years ago, they pack them really really well, I don't think there is any danger of it breaking in shipping. It sounds like this one was bought from a third party and not packed as well.

#1139 1 year ago
Quoted from frunch:

I have a pair of those ratcheting crimpers, but i can't seem to figure out the trick to making them work right. I've had a 1026-CT crimper i bought from GPE years ago that I've continued using instead. Any chance someone could school me on how to use the ratcheting crimpers, or point me to an instructional site or video?

100% determine the crimp size, set connector in, press until snug and holding, insert wire, crimp. It took me a handful (25-50 attempts) until I mastered in. Now it is smooth sailing. I will try and document.

Before these my crimps were a hot mess. I absolutely love mine. The same for those wire strippers. A wire company that I did consulting work for had them for lamp sets they made. As soon as I saw them in action I knew I needed them.
I will say, I forgot to note above, they are not great if you don't have a tone of extra wire. You need enough room for the jaws to move, so not good in close quarters.

#1140 1 year ago
Quoted from frunch:

I have a pair of those ratcheting crimpers, but i can't seem to figure out the trick to making them work right. I've had a 1026-CT crimper i bought from GPE years ago that I've continued using instead. Any chance someone could school me on how to use the ratcheting crimpers, or point me to an instructional site or video?

Oh hey, there is a vid.

#1141 1 year ago

Thanks for the video link! Looks like I've been using it correctly, just gotta play with the adjustment until it's working to my satisfaction. Can't wait to finally be able to use them! Would have come in handy for my most recent project where i must have done over 200 crimp terminals, lol

#1142 1 year ago
Quoted from Spacemanratso09:

Don’t ever...I mean ever send a fucking backglass with Fedex

Ditto...I just lost a Ball Evil Knievel backglass.

#1143 1 year ago

Update on my solenoid issue. I have the solenoids now working. I did check the resistors, replaced both driver and pre driver transistor. Installed the boards with the solenoid circuits not connected. Check the AND gate and it was reading low like it should. Connected the solenoid connecters with solenoid 1 desoldered and ran tests and all other solenoids fired. The coils wrapper looked tight like it might have shorted even though I was getting 4 Ohms on it. I got a box of black knight parts from Pinheads before they closed and got lucky and found a coil in there. It looked good and it had 4.1 Ohms so I swapped it out and now that is working. Thanks for the help with this. I now have 2 other issues. The right flipper wont work (Worked before) and the 1,000s digit on display 1 and 3 like to stay on as 0. I’m pretty sure that’s a connector issue as it comes and goes as I was messing with other connectors. Its getting there.

#1144 1 year ago
Quoted from Troyster42:

The right flipper wont work (Worked before)

Both of them or just one?

#1145 1 year ago
Quoted from zacaj:

Both of them or just one?

Both on the right side. I haven't really had a chance to look into it besides making sure the wires are still connected and they are making contact.

#1146 1 year ago
Quoted from Troyster42:

Both on the right side. I haven't really had a chance to look into it besides making sure the wires are still connected and they are making contact.

Since you just had the driver board out I'd suspect a connector issue on 2J12. Either bad solder joint or bad pin in the housing.

#1147 1 year ago
Quoted from zacaj:

Since you just had the driver board out I'd suspect a connector issue on 2J12. Either bad solder joint or bad pin in the housing.

I'll look at it. I did repin that connector too. Most of the 9 pin headers when I had the boards out I went and replaced them. I probably wont get to that until tomorrow. Thanks for the info.

#1148 1 year ago

Does anyone know if the early production machines or proto's have any other differences than the transformer being in the head and the system 6 power board?

#1149 1 year ago
Quoted from dung:

Does anyone know if the early production machines or proto's have any other differences than the transformer being in the head and the system 6 power board?

They switched partway through the run

#1150 1 year ago
Quoted from zacaj:

They switched partway through the run

From what I have seen they are less common than just partway. Very little reference in this thread to it. IPB says early production had this setup. I've been blowing local collector's minds sending pictures of the bottom cabinet and asking them what's odd.

Promoted items from the Pinside Marketplace
$ 210.00
Playfields
Hookedonpinball.com
$ 125.00
Cabinet - Toppers
Sparky Pinball
$ 5,899.00
Pinball Machine
Operation Pinball
$ 7.95
There are 2276 posts in this topic. You are on page 23 of 46.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside