(Topic ID: 54503)

Black Knight Club...Members Only!


By mof

7 years ago



Topic Stats

  • 2,276 posts
  • 210 Pinsiders participating
  • Latest reply 8 days ago by PSchmitz
  • Topic is favorited by 104 Pinsiders

You

Linked Games

Topic Gallery

There have been 789 images uploaded to this topic. (View topic image gallery).

s-l1600 (5) (resized).jpg
s-l1600 (3) (resized).jpg
6A80CD36-6109-4778-B123-47DBAD3CD216 (resized).jpeg
20200520_140220 (resized).jpg
20200509_225740 (resized).jpg
20200510_110023 (resized).jpg
20200517_181220 (resized).jpg
20200517_181226 (resized).jpg
97917573_237276777724535_4680377148379234304_n (1) (resized).jpg
20200509_225815 (resized).jpg
98047235_675386119950036_2933710469896077312_n (1) (resized).jpg
96145808_686106915568522_4628929616336125952_n (resized).jpg
20200510_173945 (resized).jpg
20200510_174037 (resized).jpg
20200510_174048 (resized).jpg
20200510_112418 (resized).jpg

There are 2276 posts in this topic. You are on page 16 of 46.
#751 2 years ago
Quoted from gutz:

You're missing the gi connectors because it looks like someone modified the stock setup by running the gi circuits through the fuse bank on the lower right. Not a bad idea to fuse each string (instead of a single 20a protecting them all) but with this modification you bypass the gi relay! You won't have the gi flashing effect during multiball start.

Hmm, that goes in the "not cool" column to me! Is there a way to get the mod to run back through the relay?

Also, good to know I have a separate booting issue. This happened at the guys house I bought it from, and is happening now. When I flip it on, the inside digit flickers 0, with the same happening to the scoreboard (a single 0 digit). Basically not booting. I read a bunch earlier and tried googling, but not seeing that same issue. Thoughts?

#752 2 years ago

Oh, there's also a loud humming sound from the speakers ...

#753 2 years ago
Quoted from TicTacSeth:

Hmm, that goes in the "not cool" column to me! Is there a way to get the mod to run back through the relay?
Also, good to know I have a separate booting issue. This happened at the guys house I bought it from, and is happening now. When I flip it on, the inside digit flickers 0, with the same happening to the scoreboard (a single 0 digit). Basically not booting. I read a bunch earlier and tried googling, but not seeing that same issue. Thoughts?

I posted a pic in a different thread: https://pinside.com/pinball/forum/topic/re-pinning-psb-system-7#post-3825246

The two larger yellow wires (that are nutted in the pic) go to the 2 position connector. The four wires going into and the four wires coming out of the fuse bank go in the 9 position connector.

Edit: I zoomed in on the pic and it looks like a relay was mounted a la system 6 style! Does the gi flash when you start multiball? If it's working, it wouldn't be horrible to leave it alone.

#754 2 years ago
Quoted from gutz:

I posted a pic in a different thread: https://pinside.com/pinball/forum/topic/re-pinning-psb-system-7#post-3825246
The two larger yellow wires (that are nutted in the pic) go to the 2 position connector. The four wires going into and the four wires coming out of the fuse bank go in the 9 position connector.
Edit: I zoomed in on the pic and it looks like a relay was mounted a la system 6 style! Does the gi flash when you start multiball? If it's working, it wouldn't be horrible to leave it alone.

I wish I could tell, I can't get the game to boot, it just flickers a "0" digit inside on the battery board, and on the scoreboard when I turn it on with a loud humming sound. The 0 digit happened when I bought it, and the reason I got a deal (I hope), I'm not sure if it had the humming sound though.

#755 2 years ago
Quoted from TicTacSeth:

I wish I could tell, I can't get the game to boot, it just flickers a "0" digit inside on the battery board, and on the scoreboard when I turn it on with a loud humming sound. The 0 digit happened when I bought it, and the reason I got a deal (I hope), I'm not sure if it had the humming sound though.

Have you checked for correct voltages at the power supply board and CPU boards? Game won't boot with missing/incorrect voltages.

#756 2 years ago
Quoted from frunch:

Have you checked for correct voltages at the power supply board and CPU boards? Game won't boot with missing/incorrect voltages.

I'll try to check tonight, I'm still learning so I might have questions on how to do that, but will google first to not bog down the chat.

#757 2 years ago
Quoted from TicTacSeth:

I'll try to check tonight, I'm still learning so I might have questions on how to do that, but will google first to not bog down the chat.

If you need help, you can always start another thread in the solid state tech forum (or PM me, I'd be happy to help watch you thru it)

#758 2 years ago
Quoted from frunch:

If you need help, you can always start another thread in the solid state tech forum (or PM me, I'd be happy to help watch you thru it)

Awesome, thanks Frunch. I caught a few fuses that were quite a bit different than they should be. Not that it will fix things, but I'm interested to at least see if a few more things get going. I also found someone that is more experienced and bulletproofing the boards, so might do that as well. Not sure yet, I might turn back to my Black Pyramid and finish that up so I can free up some space (and cash) to go at Black Knight.

#759 2 years ago
Quoted from TicTacSeth:

Awesome, thanks Frunch. I caught a few fuses that were quite a bit different than they should be. Not that it will fix things, but I'm interested to at least see if a few more things get going. I also found someone that is more experienced and bulletproofing the boards, so might do that as well. Not sure yet, I might turn back to my Black Pyramid and finish that up so I can free up some space (and cash) to go at Black Knight.

Any time, man. If you need pics, advice, etc let me know. I think you've got the right idea giving the boards to someone experienced who can bulletproof them for you. These old boards are still perfectly good, they often just need some attention/refreshing (especially the 40-pin connectors, certain chip sockets, etc)... Let us know how you fare!

Good luck!

#760 2 years ago

Hi, my largest display cable, the 18 pin one, is damaged and I would like to find a replacement. Any help is greatly appreciated for a source. Please PM me, thanks.

#761 2 years ago
Quoted from hawknole:

Hi, my largest display cable, the 18 pin one, is damaged and I would like to find a replacement. Any help is greatly appreciated for a source. Please PM me, thanks.

They're just ribbon cables aren't they? I'm sure great plains electronics can make you one if they don't already have them

#762 2 years ago
Quoted from zacaj:

They're just ribbon cables aren't they? I'm sure great plains electronics can make you one if they don't already have them

Nope, not the ribbon cable, the main cable that runs from the display board to the back box & then splits off into like 3.

2 weeks later
#763 2 years ago

Anyone have a spare set up of new cpr plastics they would sell?

#764 2 years ago
Quoted from Kronlar:

Anyone have a spare set up of new cpr plastics they would sell?

Looks like ministry of pinball may have a set.

IMG_3319 (resized).PNG

#765 2 years ago

They are out of stock there too. In stock items there have a button to add to cart and a qty. thanks for checking though.

Their game specific link for bk lists it as out of stock.

#766 2 years ago

New member here. While it's been on my wishlist for many years, I just purchased a Black Knight this past weekend. The boards and electronics had all been gone over and 'bullet proofed' - so everything works. Cosmetically, it's in decent shape - not much wear on the playfield, just very dirty. Cabinet is decent with some edge wear - could use some work. It came with new Mayfair backglass, so that was a bonus.

I'm going to do a full 'players level' restoration including touching up and clearing the playfield. But of course, I had to put in a few games before starting the teardown. Damn, what a great, fun game!! ...someone needs to remind me why I'm spending 6k + on new Sterns. Well, USED to spend that - I'm having a hard time justifying that price on any of the recent releases.

Anyway, I'm going to start a restoration thread, and will circle back and link it here if anyone is interested.

#767 2 years ago
Quoted from SunKing:

New member here. While it's been on my wishlist for many years, I just purchased a Black Knight this past weekend. The boards and electronics had all been gone over and 'bullet proofed' - so everything works. Cosmetically, it's in decent shape - not much wear on the playfield, just very dirty. Cabinet is decent with some edge wear - could use some work. It came with new Mayfair backglass, so that was a bonus.
I'm going to do a full 'players level' restoration including touching up and clearing the playfield. But of course, I had to put in a few games before starting the teardown. Damn, what a great, fun game!! ...someone needs to remind me why I'm spending 6k + on new Sterns. Well, USED to spend that - I'm having a hard time justifying that price on any of the recent releases.
Anyway, I'm going to start a restoration thread, and will circle back and link it here if anyone is interested.

Welcome, Black Knight is a great pin and arguably helped to keep pinball alive when it was released in 1980. I think it should definitely be in the Top 100 and am disappointed that it is not. A pic of mine with new CPR Silver Knight playfield, LEDs and custom decals. I am still working on a minor display issue which I will reach out for more help here very soon.

overview (resized).jpg

#768 2 years ago

I am in the market for a unpopulated used lower playfield that is restorable, and possibly an upper. My lower playfield is too far gone, but my upper might be salvageable.

#769 2 years ago
Quoted from gutz:

I am in the market for a unpopulated used lower playfield that is restorable, and possibly an upper. My lower playfield is too far gone, but my upper might be salvageable.

Hopefully, there might be an overlay for the game.

#770 2 years ago
Quoted from vec-tor:

Hopefully, there might be an overlay for the game.

That might be an option, or if they make a hard top. My preference is an original playfield, hopefully someone doing a cpr swap has decent originals they would sell

#771 2 years ago
Quoted from gutz:

That might be an option, or if they make a hard top. My preference is an original playfield, hopefully someone doing a cpr swap has decent originals they would sell

I have my old playfields, not sure if we PM'd before or not, "decent" is a relative term. My old ones would need quite a bit of work, hence the CPR swap.

#772 2 years ago
Quoted from hawknole:

I have my old playfields, not sure if we PM'd before or not, "decent" is a relative term. My old ones would need quite a bit of work, hence the CPR swap.

I don't think we've pm'd, send me some pics of the playfields when you get time!

#773 2 years ago
Quoted from gutz:

I don't think we've pm'd, send me some pics of the playfields when you get time!

PM sent

#774 2 years ago

Hello fellow Black Knights, I need some help with my display cable. I attempted, very poorly, to repin my 18 pin display cable that plugs into the display card on the back box door. First time for this task for me. In the process I messed up the order of the first five wires. I have purple, purple/blue, purple/orange, purple/black & purple/gray. If someone could kindly check the order of their purple wires at the top I would greatly appreciate it. Apologies for my stupidity.

IMG_0393 (resized).JPG

#775 2 years ago

Not sure if this will help you but you could always simply download the manual with schematic if not. Good Luck.

IMG_7980 (resized).JPG

#776 2 years ago
Quoted from Yelobird:

Not sure if this will help you but you could always simply download the manual with schematic if not. Good Luck.

I checked in there and didn't see the colors anywhere...

#777 2 years ago
Quoted from hawknole:

I have purple, purple/blue, purple/orange, purple/black & purple/gray. If someone could kindly check the order of their purple wires at the top I would greatly appreciate it. Apologies for my stupidity.

O.K. .....
pin 18 Violet commas 1 & 2
pin 17 Violet-Blue strb 14
pin 16 Violet-Black strb 15
pin 15 Violet-orange strb 11
pin 14 Violet-Gray strb 16

#778 2 years ago

Thanks everyone. Vec-tor yours was most helpful for the mentally challenged like myself.

#780 2 years ago

Just bought these cool ramps for our BK

https://pinside.com/pinball/market/classifieds/ad/50709

4dbe6ee218c43e6e4840f86c906a9ad87c99deb3 (resized).jpg

7be308a9e83a155330006929a27ee6d022c4a97d (resized).jpg

#781 2 years ago
Quoted from gutz:

I am in the market for a unpopulated used lower playfield that is restorable, and possibly an upper. My lower playfield is too far gone, but my upper might be salvageable.

That's funny because my lower is great and my upper is toast!

I might get the plastic playfield protector from Germany to make the surface smooth for the time being.

#782 2 years ago
Quoted from hawknole:

I have my old playfields, not sure if we PM'd before or not, "decent" is a relative term. My old ones would need quite a bit of work, hence the CPR swap.

Hey Hawk, can get get a look at the upper you have too?

#783 2 years ago
Quoted from TicTacSeth:

Hey Hawk, can get get a look at the upper you have too?

PM sent

1 week later
#784 2 years ago
Quoted from SunKing:

Anyway, I'm going to start a restoration thread, and will circle back and link it here if anyone is interested.

As promised, here's my thread: https://pinside.com/pinball/forum/topic/80-black-knight-players-level-restoration

IMG_3553 (resized).JPG

1 week later
#785 2 years ago

Playing last night when suddenly lower left flipper died. Upper left and both right side work fine. Wires appear to be connected. Has anyone else seen a similar issue? Thanks

#786 2 years ago

The uppers are wired directly to the lowers on the lower coil tabs.

The issue will be bad solder joints on the coil, the coil itself, or something mechanical.

#787 2 years ago
Quoted from Black_Knight:

The uppers are wired directly to the lowers on the lower coil tabs.

The issue will be bad solder joints on the coil, the coil itself, or something mechanical.

Also, check the connector between the playfields and the cabinet flipper switches for bad contacts.

#788 2 years ago
Quoted from vec-tor:

Also, check the connector between the playfields and the cabinet flipper switches for bad contacts.

There's also a connector between the upper and lower playfield

#789 2 years ago

Power goes to the lower flippers first then up to the others. It's related to the lower coil/mech.

#790 2 years ago
Quoted from Black_Knight:

Power goes to the lower flippers first then up to the others. It's related to the lower coil/mech.

Upper and lower are wired in parallel, but it comes from backbox to the upper playfield and then to lower, according to the schematics

#791 2 years ago

You are right it does start at the upper not the lower. I had to open mine up to check.

Check for voltage at the lower coil then make sure you check the solder job on the upper left flipper.

#792 2 years ago

Include me in.

Just picked up a project BK. A bit of a nail and paid a bit too much.
Me and many others

2 weeks later
#793 2 years ago

Power for the flippers is not separated left and right. All flippers share the same power circuit and start on the top playfield then to the lower.

Check for power at the non-working flipper coil and report back.

Carefully inspect all the solder joints on the non-working coil looking for broken wires to power, ground and EOS.

Carefully inspect the EOS switch for proper function. With the game on, press the flipper button and manually lift the flipper and see if it stays up.

Carefully inspect the cabinet flipper leaf switch to make sure it is making solid contact and solid solder joints.

There are 2 connectors in the path that can cause problems with the ground side of the circuit. From the flipper button, the ground signal moves through the cabinet wiring, to a connector to the PF, then though the connector between the upper and lower playfields. Check the lower flipper ground wire on both these connectors.

#794 2 years ago

Got a switch problem with my BK. Just got the head attached and wired up this week for the first time since I got it. Sound, lamp, and solenoid tests are all fine. NONE of the playfield switches register, although ALL other switches - plumb bob tilt, ball roll tilt, left & right coin, credit button, high score reset, flipper button - all work just fine. I know it must be something simple that I'm overlooking. Ideas?

#795 2 years ago
Quoted from jibmums:

Got a switch problem with my BK. Just got the head attached and wired up this week for the first time since I got it. Sound, lamp, and solenoid tests are all fine. NONE of the playfield switches register, although ALL other switches - plumb bob tilt, ball roll tilt, left & right coin, credit button, high score reset, flipper button - all work just fine. I know it must be something simple that I'm overlooking. Ideas?

Did you miss one of the connectors from the playfield to the backbox. Lift the PF and follow the cable harness from the PF and make sure all are connected.

#796 2 years ago
Quoted from Schwaggs:

Did you miss one of the connectors from the playfield to the backbox. Lift the PF and follow the cable harness from the PF and make sure all are connected.

That was my first thought as well, even though I was VERY careful and methodical during assembly. To eliminate any doubt, I just pulled the connectors and re-connected them again. Nope, same problem - no playfield switches work, but all other switches work.

However - here's something interesting - when I press it down, the pop bumper switch doesn't register in switch test mode, but it DOES trigger the bumper itself. What the heck is going on??

#797 2 years ago
Quoted from jibmums:

That was my first thought as well, even though I was VERY careful and methodical during assembly. To eliminate any doubt, I just pulled the connectors and re-connected them again. Nope, same problem - no playfield switches work, but all other switches work.
However - here's something interesting - when I press it down, the pop bumper switch doesn't register in switch test mode, but it DOES trigger the bumper itself. What the heck is going on??

The slings and pop bumper have 2 sets of switches. One the triggers them to fire which is not part of the switch matrix and another scoring switch that is part of the switch matrix. Only switch matrix switches show up in switch test.

#798 2 years ago
Quoted from Schwaggs:

The slings and pop bumper have 2 sets of switches. One the triggers them to fire which is not part of the switch matrix and another scoring switch that is part of the switch matrix.

Yep, slings fire also but don't register in switch test. None of the fuses have anything to do with these switches, correct?

#799 2 years ago

Check continuity from one of the switches back to the board connector. I assume you won't get any continuity though. Then start just tracing that wire till you find the problem

#800 2 years ago
Quoted from jibmums:

Yep, slings fire also but don't register in switch test. None of the fuses have anything to do with these switches, correct?

No fuses for switches, correct.

What I was trying to say, is the reason the slings and pops work but don't register in switch test is there are 2 sets of switches for these items. One that makes them fire and another that scores them and triggers sounds. It is the sling and pop scoring switches that are not working (along with all the other switches).

You need to trace the switch matrix wiring from the driver board to one of the playfield switches, checking all connectors in the path to see where the connection is broken. I'm guessing the switch matrix to playfield connector. This connector is one of the smaller neutral colored connectors with 6 green wires with colored tracers and 8 white wires with colored tracers.

Promoted items from the Pinside Marketplace
$ 75.95
Cabinet - Shooter Rods
Super Skill Shot Shop
$ 7.95
There are 2276 posts in this topic. You are on page 16 of 46.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside