Black Knight 2000 forgets it's in multiball

(Topic ID: 222024)

Black Knight 2000 forgets it's in multiball


By McSquid

51 days ago



Topic Stats

  • 10 posts
  • 4 Pinsiders participating
  • Latest reply 42 days ago by darcangeloel
  • Topic is favorited by 1 Pinsider

You

Linked Games

#1 51 days ago

I'm trying to track down the final demon in my BK2K restoration. Everything else now works perfectly, but seemingly randomly the game will forget it's in multiball after a single ball is drained. With two left in play. This happens for normal multiball AND Kings ransom. It happens about 50% of the time and I cannot determine any common circumstances that cause it. Everytime I think it might have something to do with something specific I'm proven wrong in the next test. Also, very rarely, about 2-3% of the time, the game will kick out a ball into the shooter lane when a glitched multiball's second ball is drained.

I've checked all the switches in switch test. All of them work, and none cause any weird switch behavior. No double registers, no unusual bouncing. Game works 100% other than this.

I found an old thread that mentioned one of his switches was wired wrong causing this behavior, but my game doesn't have the same wiring issues he had.

The game is running LA-2 roms until I figure out why it won't boot with my LA-4 Roms. But I can't find a change log to see if there is anything relevant.

1 week later
#2 45 days ago

I shotgun replaced all the trough switches, outhole switch, lock switches, and their diodes. Now I get consistent behavior... Consistently bad. When multiball begins, it immediately ends. With all 3 balls still in play. Jackpot never lights. If you get a ball up the ramp it counts as a lock. All switches test good, with finger and ball. At this point I'm desperately hoping getting the roms updated fixes something because this is driving me nuts.

#3 44 days ago
Quoted from McSquid:

I shotgun replaced all the trough switches, outhole switch, lock switches, and their diodes. Now I get consistent behavior... Consistently bad. When multiball begins, it immediately ends. With all 3 balls still in play. Jackpot never lights. If you get a ball up the ramp it counts as a lock. All switches test good, with finger and ball. At this point I'm desperately hoping getting the roms updated fixes something because this is driving me nuts.

Sorry I missed this . I love BK2K track down threads. I had a similar issue a while back and the issue ended up being not all three switches were registering all the time in the upper three ball lock. Humor me and eject all the balls. Restart the game and go into the switch level test and put in one ball at a time. Do all of these register as they should using a ball and not your fingers. Also those switches are micro switches attached to a small board with a connector on the end. Does that connector wiggle at all? If so reflow solder on it.

#4 44 days ago
Quoted from McSquid:

I shotgun replaced all the trough switches, outhole switch, lock switches, and their diodes. Now I get consistent behavior... Consistently bad. When multiball begins, it immediately ends. With all 3 balls still in play. Jackpot never lights. If you get a ball up the ramp it counts as a lock. All switches test good, with finger and ball. At this point I'm desperately hoping getting the roms updated fixes something because this is driving me nuts.

Yes preform the wiggle test I had this exact same issue a while back. The movement of the flipper and ball on the upper pf can cause that connector to move. Basically if memory serves if the game sees two of the switches tripped for the upper lock ( the lower and the middle) and you trip the ramp entry switch by locking a third ball it will start multiball regardless but then once started multiball will never light. One easy way to test this is to disconnect the upper ramp entry switch and lock two balls in game. Then lock a third. If once you lock it and the game just kind of sits there or starts a ball search you'll know that upper lock switch has an issue and again I would strongly suspect that connector on the little board. They are loose on alot of these. Good hunting!

#5 44 days ago

The lock switch board has been serviced already. All diodes replaced, connector reflowed. I have tested more times than I can count at this point. The switches act exactly as they should in switch test.

I'll try replacing the female connector with crimp pins.

I'll try the ramp switch disconnect though. Haven't tried that.

#6 44 days ago

Go into switch test mode and try shaking the game and see if any switches go off.

#7 43 days ago

Thats a....Great idea. I'll try that!

#8 43 days ago

Or tapping on the playfield might yield something over shaking the machine.

#9 42 days ago

So I'm tentatively calling this one solved. It seems we had a perfect storm effect at the beginning where several problems contributed to the same issue.

#1 was a faulty switch/diode somewhere in the trough, since after replacing them all the behavior became much more consistant.
#2 was a bent metal. The metal U that makes up half of the lock was bent in such a way that the switches were not in a straight line, causing the upper switch to be harder to trigger. In addition, this bend made the balls able to travel slightly left/right. the strength of the 3rd switch was enough to trigger, then push the ball away far enough to open again.

Thanks to all who helped. These demons have some insane hiding places sometimes.

Special shoutout to darcangeloel who gave me the idea to disconnect the ramp entry switch, which made the game rely on the upper lock switch to start multiball. causing me to look at it REALLY closely and play around with a stack of balls in the lock.

#10 42 days ago

Way to go man! I love when things like this get solved. BK2K is one of those games that is just plain awesome. It is some what shallow on rule set but man, the sound track, the art work, the repeatably of some of the shots (I know I'm weird).

But yeah I remember that odd situation from a while back where the three ball multi-ball would start and then all of the sudden the jackpot would just sort of disappear. If memory serves I had to hold down all three switches then I found the jackpot would stay and then I retested using the two ball lock and tripping the upper ramp entry switch to start three ball multi-ball and found that basically if the game doesn't see that any of those balls are locked it disqualifies the jackpot instantly.

Either way awesome job man! Fixed is fixed! Just remember to "Beat the black knight" and to "Gimmie your money".

Quoted from McSquid:

So I'm tentatively calling this one solved. It seems we had a perfect storm effect at the beginning where several problems contributed to the same issue.
#1 was a faulty switch/diode somewhere in the trough, since after replacing them all the behavior became much more consistant.
#2 was a bent metal. The metal U that makes up half of the lock was bent in such a way that the switches were not in a straight line, causing the upper switch to be harder to trigger. In addition, this bend made the balls able to travel slightly left/right. the strength of the 3rd switch was enough to trigger, then push the ball away far enough to open again.
Thanks to all who helped. These demons have some insane hiding places sometimes.
Special shoutout to darcangeloel who gave me the idea to disconnect the ramp entry switch, which made the game rely on the upper lock switch to start multiball. causing me to look at it REALLY closely and play around with a stack of balls in the lock.

Promoted items from the Pinside Marketplace
$ 15.00
Playfield - Decals
Metal-Mods
$ 16.00
Electronics
Yorktown Parts and Equip
$ 20.00
Electronics
Yorktown Parts and Equip
$ 29.99
Cabinet - Sound/Speakers
Lighted Pinball Mods
From: $ 16.95
$ 999.00
Flipper Parts
Mircoplayfields
$ 75.95
Cabinet - Shooter Rods
Super Skill Shot Shop
$ 18.99
Wanted
Machine - Wanted
Santa Barbara, CA
$ 76.95
Cabinet - Shooter Rods
Super Skill Shot Shop

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside