(Topic ID: 94003)

Black Knight 2000 Club - Knights of the Lightning Wheel.

By NextoPin

8 years ago


Topic Heartbeat

Topic Stats

  • 1,025 posts
  • 206 Pinsiders participating
  • Latest reply 4 days ago by Dwboca
  • Topic is favorited by 113 Pinsiders

You

Linked Games

Topic Gallery

View topic image gallery

20220619_104134 (resized).jpg
System 11B Top (resized).png
20220524_171327 (resized).jpg
20220524_192848 (resized).jpg
16519983376629181623663966151490 (resized).jpg
16519983001752576217879081235851 (resized).jpg
20220508_102244 (resized).jpg
20220508_102224 (resized).jpg
20220508_102147 (resized).jpg
20220508_102214 (resized).jpg
20220508_102129 (resized).jpg
image (resized).jpg
20220504_173710 (resized).jpg
IMG_7844 (resized).JPG
IMG_7841 (resized).JPG
IMG_7840 (resized).JPG

There are 1,025 posts in this topic. You are on page 21 of 21.
#1001 72 days ago

Scared too. Jajaja

#1002 72 days ago
Quoted from mekishiko916:

Really could use some help/Ideas on this BK2K I have been working on.
It's a friends BK2K. The entire Playfield was swapped, it worked fine before the swap.
-After the Playfield swap the game would boot and freeze after the "I AM THE BLACK KNIGHT" callout and display 00.
-Before I touched it the owner moved the CPU board to Swords of Fury, (without switching any ROM chips) The game booted and then froze, like it did in BK2K, displaying 00. (I did not see this, but I trust him, read further and you'll see why it's confusing)
-He decided it was something on the PCB after that "test", so he asked me to look at it. I found some really black diodes and some build up of corrosion on connector pins, and tons of cold/crappy looking solder joints. I replaced the fishy diodes, re-flowed the solder on the entire board, as well as emory-clothed all connector pins and the legs of each removable IC. I also installed NVRAM and removed the remote battery. Under the original battery tray there were a lot of scratches across traces but none seemed to go too deep into the green solder mask.
-When I installed the board It booted, I could add coins, and start a game. I completed an entire game and it worked fine for 2 games. I left victorious. He turned it on hours later and started a game, and the similar problem happened again, this time though in the middle of his game. Frozen and 00 displayed. From this point on it is randomly Freezing & displaying 00 or rebooting (exiting out of the in progress game and back to attract mode)
-So I came back and checked all of the connectors, re-seated everything, same issue
-Swapped the ROM chips with Swords of Fury, then swapped the PCBs (So the SOF PCB was in the BK2K with the BK2K ROMS...and BK2K PCB was in SOF with SOF ROMS) and the Game worked perfectly fine in SOF....but the exact same issue happened on BK2K with the random freeze/reboot after (or during 1-2) games. (indicating to me it was not the PCB)
*this confused me as it seemed the issue was NOT following the PCB....which contradicts the initial information the owner gave me.
-So this made me think it might be the ROM chips because that was the only constant (Besides the Playfield+CPU Chips+other PCBs) So I bought new ROMS and put them in, still the same problem using the SOF board with the BK2K chips.
-I bought new CPU chips as well (MC6802P) came in a pack of 5. when I replace U24 with the new CPU chip the game boots and has the same Freeze/Reboot issue. If I replace U15 with a new chip, the machine doesn't boot (Same thing happened in Mousin Around & SOF so it could just be the new CPU chips, however it's weird that it works fine in U24) Only if U15 has one of the original MC6802P chips will the game boot (and have the same Freeze/reboot issue)
-I have swapped every combination of PCBs and CPU chips in his SOF AND Mousin' Around and the issue Never follows the PCB or chips....I am unable to replicate his initial "The problem followed the PCB" diagnosis.
-Now I am at a loss, I have inspected tons of Diodes (I know testing them while installed isn't super reliable) but they seem Ok, I did find one on that looked toasted on the upper-playfield-target bank (and wasn't letting any current pass either direction) so I replaced that one (although it tested fine once removed)
-I have tried playing a game with the sound PCB unplugged, all of the display wires unplugged, and I went one-at-a-time unplugging each Connector from every board, booting up, starting a game (as long as the connector didn't disable the start button) and the Freeze/reboot would still happen randomly. I also tried with the upper playfield hardware unplugged (The lower PCB with J1-2-3-4-5-6-7-8 connectors), I have swapped the Power PCB, and the Aux-Power-Driver PCB with SOF & Mousin Around (ones that matched) and no luck, same Frozen and 00 display/random reboot issue on the BK2k table regardless of what known good hardware is in it from the other 2 machines.
any Ideas?

Are you sure it isn't a powersupply related problem. Have you checked back through the power wiring from the main board looking for heat stressed connectors?

#1003 72 days ago

I've got a bunch of flashers that aren't working. Looks like someone got a wild hair up their ass and decided to LED... kind of. My flipper lane guide flashers (both sides) have LEDs but won't flash. Tried new LEDs as well as incandescent, no dice. Both flashers up top are LED and they work. Most of the back box is incandescent and those appear to work. Under the uturn is incandescent and works. Most of the others on the playfield appear to not work.

Are the aux and interconnect boards the two potential problem areas or are there other places to check also?

20220413_224843 (resized).jpg
1 week later
#1004 59 days ago

Back in the club.

9127FA61-65CD-4B00-972C-D8E335053548 (resized).jpegB79E4081-7350-418B-B25F-A1CD63BC6C34 (resized).jpeg80814ADD-0301-4297-AD98-653DFA65803A (resized).jpeg4B83C0E7-A2A2-4C7F-8489-B6C61F06240E (resized).jpeg099BE3E4-D80E-465C-B4AD-787B201C6EB8 (resized).jpeg016C7AF8-CCD3-45BE-A71E-0BA90B74752A (resized).jpegCDECEA81-1036-4910-91B1-485FC012F6A1 (resized).jpeg51F7AE1C-1603-48DD-9EE5-95BABBF48D9C (resized).jpegBC780B7C-ED98-41FF-AA15-639525D71BAF (resized).jpeg
#1005 59 days ago

Removed the odd color choices in the inserts, like the purple. Also removed the cool white LEDs in the backbox and replaced with regular bulbs. Shopped and new rubbers installed and plays fantastic.

IMG_7836 (resized).JPGIMG_7838 (resized).JPGIMG_7840 (resized).JPGIMG_7841 (resized).JPGIMG_7839 (resized).JPGIMG_7844 (resized).JPGIMG_7847 (resized).JPGIMG_7848 (resized).JPGIMG_7849 (resized).JPGIMG_7850 (resized).JPGIMG_7851 (resized).JPG
#1006 59 days ago
Quoted from PoMC:

Back in the club.

Looks to be a fine example! Hang onto it this time!

#1007 59 days ago
Quoted from PoMC:

Back in the club.

No magnet wear and all of the support arms on your right ramp are intact. Nice survivor!

#1008 58 days ago
Quoted from BriPin:

No magnet wear ...

Looking at the layer errors on the lower right near the magnet, it looks to be a Mirco Replacement playfield.

#1009 58 days ago
Quoted from mastercello:

Looking at the layer errors on the lower right near the magnet, it looks to be a Mirco Replacement playfield.

No, it's original. Build date May 9, 1989

#1010 57 days ago
Quoted from PoMC:

No, it's original. Build date May 9, 1989

The machine cut factory mylar and wear at the drop point from the wireform gives it away.

1 week later
#1011 51 days ago

Got a nice knight locally

20220504_173710 (resized).jpg
#1012 49 days ago

Can someone please take a picture and give me a quick measurement or two on the latching bar that holds the upper playfield in the up position? Mine is missing. Thanks

image (resized).jpg
#1013 49 days ago
Quoted from pvogel3634:

Can someone please take a picture and give me a quick measurement or two on the latching bar that holds the upper playfield in the up position? Mine is missing. Thanks
[quoted image]

20220508_102129 (resized).jpg20220508_102147 (resized).jpg20220508_102214 (resized).jpg20220508_102224 (resized).jpg20220508_102244 (resized).jpg

16519983001752576217879081235851 (resized).jpg16519983376629181623663966151490 (resized).jpg
2 weeks later
#1014 33 days ago

Hello. My BK2K will register magnasave when hitting the right flipper button ONLY if the trouph 1 switch is active. No other switches on the magnasave or trouph 1 column or row so the same thing. If the trouph 1 switch is not active, the magnasave switch works normally (from the edges test)

Any suggestions what to check?

I've tested (and replaced for good measure) the diodes on the magna save, trouph 1, and right lane change switches. They all tested fine.

Thanks!

#1015 32 days ago
Quoted from harig:

[quoted image][quoted image][quoted image][quoted image][quoted image]
[quoted image][quoted image]

Even though I wasn't the one who asked for this - man, you went above and beyond. Thank you.

#1016 32 days ago
Quoted from attack7:

Even though I wasn't the one who asked for this - man, you went above and beyond. Thank you.

Thanks
At least someone honors the effort
as there was not the slightest 'thanks' from the requester

#1017 32 days ago

Off we go for a health check / nvram / light servicing. Probably thinning the herd a bit soon, idk.

20220524_192848 (resized).jpg

20220524_171327 (resized).jpg

That GI plug....yiiiiikes. I'll repin that while I'm at it.

#1018 29 days ago
Quoted from harig:

Thanks
At least someone honors the effort
as there was not the slightest 'thanks' from the requester

Thanks much, I may need that some day.

#1019 29 days ago
Quoted from BobLangelius:

Thanks much, I may need that some day.

You are welcome
Glad it is useful

2 weeks later
#1020 14 days ago

I have two system 11B boards ready to ship monday, one to one original board design. Upgraded transistors to not need the second set of high wattage resistors.

Check it out:

https://pinballbasement.com/products/d-11883-system-11b-cpu-board

System 11B Top (resized).png

1 week later
#1021 6 days ago

Joined the club today, also rounded out my collection of all 3 black knights

#1022 6 days ago
20220619_104134 (resized).jpg
#1023 5 days ago
Quoted from Dwboca:

Joined the club today, also rounded out my collection of all 3 black knights

Excellent!

#1024 4 days ago
Quoted from Dwboca:

[quoted image]

Nice, don't think Ive ever seen all three together.

#1025 4 days ago
Quoted from RobW:

Nice, don't think Ive ever seen all three together.

Its quite exciting. I don't think i have until we completed the set. They all play different but equally fun

Promoted items from the Pinside Marketplace
Wanted
Machine - Wanted
Elizabethtown, KY
$ 59.95
Playfield - Toys/Add-ons
Hookedonpinball.com
$ 39.99
$ 54.99
Cabinet - Shooter Rods
Lighted Pinball Mods
From: $ 5.00
Playfield - Other
Rocket City Pinball
$ 17.00
Wanted
Machine - Wanted
Carson City, NV
From: $ 349.95
Lighting - Led
Pin Stadium Pinball Mods
There are 1,025 posts in this topic. You are on page 21 of 21.

Reply

Wanna join the discussion? Please sign in to reply to this topic.

Hey there! Welcome to Pinside!

Donate to Pinside

Great to see you're enjoying Pinside! Did you know Pinside is able to run without any 3rd-party banners or ads, thanks to the support from our visitors? Please consider a donation to Pinside and get anext to your username to show for it! Or better yet, become a Pinside+ member!