(Topic ID: 145631)

Black Belts only (not really)


By jwo825

4 years ago



Topic Stats

  • 54 posts
  • 17 Pinsiders participating
  • Latest reply 1 day ago by jcar302
  • Topic is favorited by 6 Pinsiders

You

Linked Games

Topic Gallery

There have been 16 images uploaded to this topic. (View topic image gallery).

55118_1568248098500_6709240_o (resized).jpg
20181114_183554 (resized).jpg
20181114_183449 (resized).jpg
20181115_223219 (resized).jpg
1486606594326-1906407021 (resized).jpg
20170116_105310 (resized).jpg
20170116_105309 (resized).jpg
20170116_105308 (resized).jpg
20170116_105245 (resized).jpg
20170116_105307 (resized).jpg
20170116_105243 (resized).jpg
image.png
image.jpeg
image_2.jpeg
image_1.jpeg
image.jpeg

There are 54 posts in this topic. You are on page 1 of 2.
#1 4 years ago

Picked up this little gem today. Noticed there was no club so I decided to make one. Hope this can be a place to share info. This one is not working and it's my first Bally 6803. I can't wait to get it up and running!image.jpegimage.jpegimage.jpeg

#2 4 years ago

Hey, I see the gi works!! That's a good start
Congrats on your project find .
Wax on -wax off , young grasshopper ( loved the Karate Kid)
JP

#3 4 years ago

Gentle touch score very much...quirky game with super cool artwork.

#4 4 years ago

It's going to need some TLC, that's for sure. I am encouraged that some of the GI came on when I flipped the switch for a quick test. Nothing started burning either, which is another plus! Gotta track down some displays, then I can get to business with the repairs.

#5 4 years ago

Love this game! Grew up playing it in my parents basement where it still gets love at family gatherings. Love themusic progression through the belts. Really gets exciting when you wrap around to double yellow and beyond!

#6 4 years ago

Such a unique weirdo game. Love it; Enjoy!

#7 4 years ago

Fun game, but it gets repetitive after a while.

#8 4 years ago

Can any owners tell me if there is anything plugged into J6 on the power supply board. Its the 2 pin connector. I haven't got the manual yet and i'm having trouble finding a picture online. I'll investigate when I get home, but I just noticed this header had nothing on it when I was looking at lunchtime.

#9 4 years ago

Here ya go bro image.jpeg

#10 4 years ago

Well, got the new displays, changed out one PIA and one transistor and she's alive! Unfortunately, the battery is dead and the keypad disintegrated in my hands so I can't get into the menu and it won't coin up a game. I also have 3 stuck switches I need to address. Does anyone have a manual or at the very least, an explanation of using the keypad? I can't locate either anywhere. image.png

5 months later
#11 3 years ago

Looking for a backglass if anyone knows of one. Thanks!

3 months later
#12 3 years ago
Quoted from jwo825:

Well, got the new displays, changed out one PIA and one transistor and she's alive! Unfortunately, the battery is dead and the keypad disintegrated in my hands so I can't get into the menu and it won't coin up a game. I also have 3 stuck switches I need to address. Does anyone have a manual or at the very least, an explanation of using the keypad? I can't locate either anywhere.

You ever figure this all out?

1 week later
#13 3 years ago
Quoted from jwo825:

Well, got the new displays, changed out one PIA and one transistor and she's alive! Unfortunately, the battery is dead and the keypad disintegrated in my hands so I can't get into the menu and it won't coin up a game. I also have 3 stuck switches I need to address. Does anyone have a manual or at the very least, an explanation of using the keypad? I can't locate either anywhere.

I think they are on ipdb.com

2 weeks later
#14 3 years ago

If anyone parts one out I'll take the ramps and plastics

4 months later
#15 3 years ago

I'm throwing some picture out of my Black Belt as it get cleaned and shopped. Adding LEDs really make the colors pop. More pictures to come as I progress.

If anyone has ramps or plastics, please let me know. I pay above average rates for needed parts.

20170116_105243 (resized).jpg

20170116_105307 (resized).jpg

20170116_105245 (resized).jpg

20170116_105308 (resized).jpg

20170116_105309 (resized).jpg

20170116_105310 (resized).jpg

#16 3 years ago

Beautiful!

#17 3 years ago

I like what you did with the lights. I've never put LEDs in before. Do you just tie them into where the old bulb was? I just got a new ramp today. It's in way better shape than my original.

#18 3 years ago

Also I noticed your playfield was different. Do you know if yours had a new one or the original?

1486606594326-1906407021 (resized).jpg

2 months later
#19 2 years ago

Black Belt owners! Do any of you experience an intermittent weak upper-right kick out? It's reproducible by activating the right ramp switch immediately before the ball is kicked. The kick out is weak one to three times then the fourth time it kicks fine.

Three of us have the issue on another thread:
https://pinside.com/pinball/forum/topic/help-solenoid-expander-weak-right-kickback

Looking to pool resources and drill-down this odd issue or determine if it's a design flaw in the game. This 6803 does utilize the SEB (solenoid expander board).

Thanks.

#20 2 years ago

Yes -- my parents machine exhibits this as well, haven't noticed a pattern but back in the day (20 years ago) it used to work much better. Never had time to investigate, I thought the transistor was getting flakey or a weak solder connection over time?

#21 2 years ago

That's interesting. There are four of us with the same odd issue.

#22 2 years ago

I just played another at the Ann Arbor show -- same issue. Seems universal

#23 2 years ago

I am completely stumped on a Black Belt switch handling issue - https://pinside.com/pinball/forum/topic/tech-black-belt-switch-insanity

If anyone has experienced this before or has any clue as to why I might be seeing this behavior after all the troubleshooting I've done, I'd love to know your ideas. Thanks for looking!

1 week later
#24 2 years ago

Try switching U7 and U8.

1 year later
#25 1 year ago

Hi-ya! (See what I did there?) I just picked up a Black Belt last night, a local Craigslist find, so I'm excited to join the club. It powers & boots but won't coin up, though the owner claimed he had it working via the keypad thing a while back. I haven't had a chance to do any troubleshooting yet, and probably won't for a few weeks (a few other projects to finish up), but hopefully you few fellow owners are still out there -- I'll be karate chopping your inboxes for help if I need it!

#26 1 year ago
Quoted from SkyKing2301:

Hi-ya! (See what I did there?) I just picked up a Black Belt last night, a local Craigslist find, so I'm excited to join the club. It powers & boots but won't coin up, though the owner claimed he had it working via the keypad thing a while back. I haven't had a chance to do any troubleshooting yet, and probably won't for a few weeks (a few other projects to finish up), but hopefully you few fellow owners are still out there -- I'll be karate chopping your inboxes for help if I need it!

First try doing a RAM reset:

Hit "Test", to enter operator mode.
Hit "A" until "Feature Options" is displayed.
Hit Enter.
It will say "Reset Factory Is".
Hit 6, then 5, then Enter.
Hit "Game" to return to attract mode. You'll know it worked because it will take longer than usual to reach attract mode, and the display will flicker slightly as the computer clears the memory (this is normal)

#27 1 year ago
Quoted from snakesnsparklers:

First try doing a RAM reset:

Thanks for this tip! I'll get back to you in a few weeks (once the higher priority stuff is out of the way) to let you know if it worked.

#28 1 year ago

Okay, I had a few minutes to get this machine hooked up just now, and I was trying to set it up for free play and also try that Ram reset that you suggested, but both of these actions rewrite the use of the 5 button -- and it seems that none of the buttons in the middle two columns on the keyboard are responding. Here is a picture, am I missing a wire on the connector at R5 or something?

20181115_223219 (resized).jpg

#29 1 year ago
Quoted from SkyKing2301:

Okay, I had a few minutes to get this machine hooked up just now, and I was trying to set it up for free play and also try that Ram reset that you suggested, but both of these actions rewrite the use of the 5 button -- and it seems that none of the buttons in the middle two columns on the keyboard are responding. Here is a picture, am I missing a wire on the connector at R5 or something?
[quoted image]

Try unplugging and reseating the connector on the keypad. Also do this on the MPU in the backbox, connector J3 (cabinet switch) on the bottom. It is common for these connectors to corrode and cause intermittent connections and you can temporarily solve it with a reseat.

#30 1 year ago
Quoted from snakesnsparklers:

Try unplugging and reseating the connector on the keypad. Also do this on the MPU in the backbox, connector J3 (cabinet switch) on the bottom. It is common for these connectors to corrode and cause intermittent connections and you can temporarily solve it with a reseat.

Thanks. Tried this and got second column working, but still not the third. Will try a few more times.

For what it's worth, I did manage to go into bookkeeping and tell it there were 3 credits on it -- which DID allow me to start and play a game, yay! Someone said this game has ugh and oomph sounds? All I hear are ding-beeps.

#31 1 year ago

Checked the wires on J3 and it looked like some were a little loose, so I pushed them back in a little. Now the third column registers -- except it thinks it's column 2!

#32 1 year ago
Quoted from SkyKing2301:

Checked the wires on J3 and it looked like some were a little loose, so I pushed them back in a little. Now the third column registers -- except it thinks it's column 2!

That sounded like a short to me ... Sure enough, little solder flake jumping two pins under the connector. Got it out, all keyboard columns work now. Free Play set!

#33 1 year ago
Quoted from SkyKing2301:

That sounded like a short to me ... Sure enough, little solder flake jumping two pins under the connector. Got it out, all keyboard columns work now. Free Play set!

Awesome!

For the chimes vs other sounds, this is also a setting via the keypad. Page 7 of the manual, see "Sound Mode"

https://www.ipdb.org/files/303/Bally_1986_Black_Belt_Operating_Manual_with_paginated_schematics.pdf

#34 1 year ago

^ Great, thanks, I'll have a look at my next opportunity. Now that it's set up and I verified it's working, I'll be putting this game aside until I have time for clean up & maintenance.

Here's pics to show you what I've got. These are "before", as I haven't cleaned anything yet.

Bookkeeping says it have over 8 million games. Is that realistic?

20181114_183449 (resized).jpg

20181114_183554 (resized).jpg

#35 1 year ago

Yeah on reset it defaults to coin op, slingshots off, and sound to chimes which seems odd. 8mil plays sounds pretty high??

1 year later
#36 19 days ago

I realize that the last post in this post was a year ago, but maybe I can get some answers.

I picked up a pretty nice black belt and I'm almost done shopping and fixing it up.

One issue I have is insert decals, were they ever reproduced?

And what the hell is the bulb that faces the relay under the playfield (top right if the playfield is vertical)?

Thanks,
Joe

#37 19 days ago
Quoted from jcar302:

And what the hell is the bulb that faces the relay under the playfield (top right if the playfield is vertical)?

Part of the solenoid expander board wiring.

LTG : )

#38 19 days ago
Quoted from jcar302:

I realize that the last post in this post was a year ago, but maybe I can get some answers.
I picked up a pretty nice black belt and I'm almost done shopping and fixing it up.
One issue I have is insert decals, were they ever reproduced?
And what the hell is the bulb that faces the relay under the playfield (top right if the playfield is vertical)?
Thanks,
Joe

Would be shocked in the decals were made.. but if you need a new ramp pm freeplay40

#39 18 days ago
Quoted from Mbecker:

Would be shocked in the decals were made.. but if you need a new ramp pm freeplay40

Thanks Becker, I follow freeplay's post (also had a freeplay high speed ramp) . Fortunately my ramp is crack free.
The only thing I need is a few insert decals and looks like that didn't happen and isn't going to.

#40 14 days ago

I'm attempting to fix my last problems on my black belt.
Bought and installed a new mushroom target for the gentle touch thing in the shooter lane.
When it's installed the switch is open, the diode (in circuit) reads the same as other I tested to compare.
The capacitor on the switch was broken off, I resoldered it.
The switch didn't work before or after I reconnected the capacitor.
The blades of the switch show continuity when I close them.

Where do I look now?

I'd guess the mushroom that was there was broken for really long time before I fixed it.

Also, the right flipper seems a little weak
And sometimes the kicker that kicks the ball to the reversed flipper is weak too.

Thoughts?

#41 14 days ago
Quoted from jcar302:

Where do I look now?

Grab meter. Check continuity of wires from switch to board in the head.

Quoted from jcar302:

Also, the right flipper seems a little weak

Remove the coil stop, coil, check for sharp edge or mushroomed plunger, worn coil sleeve. Might need rebuilding or cleaning.

LTG : )
Disclaimer : That is an old picture of me on the right. I can post here.

55118_1568248098500_6709240_o (resized).jpg
#42 14 days ago

Thanks LTG,
So after a quick look, both coil stops are very loose and have mismatched screws. I'll take them physically apart tomorrow.
Maybe I have to stop over thinking things.

As for the switch, on the J4 connector of the board, I have continuity on the white/brown (At least i think it's brown) wire all the way to the switch, the black wires traced to 2 other switches that function and have continuity.
On the white/brown, I still have continuity on the header pin if I check with the connector pulled out a little and check to the pin itself.

#43 14 days ago
Quoted from jcar302:

As for the switch, on the J4 connector of the board, I have continuity on the white/brown (At least i think it's brown) wire all the way to the switch, the black wires traced to 2 other switches that function and have continuity.
On the white/brown, I still have continuity on the header pin if I check with the connector pulled out a little and check to the pin itself.

If you hook your meter to the wires on the connector at the board and close the switch, does it register ? If not a board issue.

LTG : )

#44 14 days ago
Quoted from LTG:

If you hook your meter to the wires on the connector at the board and close the switch, does it register ? If not a board issue.
LTG : )

Nope, no continuity.
Which parts typically fail on a bally board for a switch.
I can solder/desolder, have an fr300.
I try to avoid doing so with chips, but transistors, caps etc. i'm good with.
I have the book, still acclimating to reading it, but I have fixed system 11 and wpc boards before.
If I don't figure out the book, I usually look at the board backlit and follow circuits checking for continuity and comparing like item values with similar items.
Thanks for the help,
Joe

#45 14 days ago
Quoted from jcar302:

Nope, no continuity.

That sounds like a break from the connector to the switch then.

LTG : )

#46 14 days ago
Quoted from LTG:

That sounds like a break from the connector to the switch then.
LTG : )

I think I misunderstood what you wanted me to do.
I will retest and get back to you.

#47 14 days ago
Quoted from LTG:

That sounds like a break from the connector to the switch then.
LTG : )

So i'm 100% certain the wires are solid all the way back to the connector.
While I don't get continuity when I read across them at the board connector, I do get a reading on the meter when I close the switch (like 1100 or so), which is the same reading I get when I try it with any other working switch.

Took the kicker coil stop off, it's mushroom a little bit, but it's worse that whoever did it used a 5/16 wood screw and a panhead wood screw cut shorter, no wonder it won't say in place.

#48 12 days ago

Anyone know where I could buy the middle insert that is the red rectangle of the sun?

#49 10 days ago

https://pinside.com/pinball/forum/topic/bally-6803-black-belt-switch-matrix-problem#post-5454692

I guess I'd rather it be my dumb mistake than a real problem.
Thanks for the help LTG

#50 9 days ago

I'm looking to buy a really clean example Black Belt if anyone in the group is willing to part with one. Prefer within 6-7 hours of eastern NC but shipping possible. Want add placed in Market.Thanks.

Promoted items from the Pinside Marketplace
$ 16.00
Tools
PinballSolutions.eu
€ 3.95
Flipper Parts
Multigame
$ 10.00
Electronics
Yorktown Arcade Supply
Wanted
Machine - Wanted
Greenville, NC
$ 137.00
From: $ 18.00
Apparel - Men
Pinside Shop
From: $ 65.00
Lighting - Other
Professor Pinball
$ 149.00
From: $ 22.00
Playfield - Toys/Add-ons
ModFather Pinball Mods
From: $ 42.00
Cabinet - Shooter Rods
ModFather Pinball Mods
From: $ 22.00
$ 5.00
Playfield - Decals
Doc's Pinball Shop
$ 79.99
Cabinet - Armor And Blades
PinGraffix Pinside Shop
$ 15.00
Lighting - Led
3D MODS
$ 79.99
Cabinet - Armor And Blades
PinGraffix Pinside Shop
$ 159.99
Lighting - Other
Lighted Pinball Mods
There are 54 posts in this topic. You are on page 1 of 2.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside