(Topic ID: 285509)

Bizarre System 11 Issue. Solved, posting for others


By The_Director

9 days ago



Topic Stats

  • 4 posts
  • 4 Pinsiders participating
  • Latest reply 6 days ago by trueno92
  • Topic is favorited by 3 Pinsiders

You

Linked Games

#1 9 days ago

Got an F-14 Tomcat System 11 in from a client. The first 3 digits of the displays were completely missing on all 4 displays. Originally, I thought potentially a segment driver, but since I had a second F-14 right beside this one, I decided to narrow it down to a display or MPU issue by swapping around. The issue was on the MPU.

The board overall was very clean. However, I did noticed some minor surface corrosion on the SCRs above the battery holder. I removed the old battery holder, installed a lithium socketed and removed, cleaned up, and replaced 5 of the SCRs right above the battery holder. Powered up, no change.

With a DMM, U44 and U51 didn't have any noticeable problems. I swapped both though as it was easier than probing, I can swap a 40 pin in 5 minutes. No change and when plugged in the K1 relay was chattering. Odd...

I noticed U50, U56 and the transistor related to the K1 relay (can't remember offhand, U67?) had been replaced in the past. I double checked all of the prior work there, it was all done proficiently. Lots of continuity probing ensued just to check for any loose connections --- everything was perfect.

At this point, I noticed, the longer the game was on, some of the digitry was returning, slowly but surely. And, the K1 relay chatter when in the diagnostics menus was a come and go thing as well. So, I went through a few other tests and noticed that in all lamp test, column 2 didn't work immediately. In fact, the longer the game was on, eventually, after about 3-4 minutes, column 2 worked, the K1 relay quit chattering and all of the display digits were back! The game was fine!

Seeing as this is a drag down on multiple areas that slowly got better as the game warmed up, it had to be a power issue or capacitor that was slowly getting up to proper function.

On cold start, with a DMM hooked up, the voltage was perfect. It never faltered as the game continued to warm up and become operational. OK, what capacitors may have some connection to these bizarre failure points? C30, a 22uf, is right there near the reset section, so I pulled it out first. It did measure as bad on my ESR meter. The second I honed in on was C58 which is near the 555 timer below U42. My ESR meter is only good for 10uf and above, but I replaced it as well. Popped the board back in and everything works great even on a cold start.

I looked all over for similar issues to no avail online. So, I hope this post will help someone else down the road if they run into anything odd like this. Rather than being hours of sleuthing, it'll be a 3 minute fix for them.

#2 9 days ago

Thanks for posting the info!

rd

#3 6 days ago

Blanking signal was kicking in. I’ve seen similar behavior when I mistakenly stuffed a resistor in that circuit incorrectly.

Nice work!

Chris Hibler - CARGPB #31
Http://chrishiblerpinball.com/contact
http://www.PinWiki.com/ - The new place for pinball repair info

#4 6 days ago

Thank you for using the power of pinside for good, instead of evil.

Promoted items from the Pinside Marketplace
Wanted
Machine - Wanted
Millstone, NJ
$ 39.99
Eproms
Matt's Basement Arcade
Wanted
Machine - Wanted
Bokchito, OK
$ 85.95
Cabinet - Shooter Rods
Super Skill Shot Shop
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
$ 54.99
Cabinet - Shooter Rods
Lighted Pinball Mods
$ 17.00
$ 50.00
Wanted
Machine - Wanted
Cleveland, OH
$ 5.00
Playfield - Decals
Metal-Mods
$ 54.99
Cabinet - Shooter Rods
Lighted Pinball Mods
$ 54.99
Cabinet - Shooter Rods
Lighted Pinball Mods

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside