(Topic ID: 63757)

BIG GUNS CLUB - Save The Queen!

By Chitownpinball

8 years ago


Topic Heartbeat

Topic Stats

  • 763 posts
  • 126 Pinsiders participating
  • Latest reply 5 hours ago by ViperTim
  • Topic is favorited by 34 Pinsiders

You

Linked Games

Topic Gallery

View topic image gallery

357E078C-1B0E-483F-BCCF-80E9BFCFD9EC (resized).jpeg
8C68A665-7323-4DF2-8C1D-6AD7FC21EF29 (resized).jpeg
20211120_171807 (resized).jpg
5 (resized).jpg
12 (resized).jpg
11 (resized).jpg
10 (resized).jpg
5 (resized).jpg
8 (resized).jpg
2 (resized).jpg
3 (resized).jpg
1 (resized).jpg
pasted_imageBG (resized).png
1 (resized).jpg
Stitched Playfield LQ (resized).jpg
received_465981991179579 (resized).jpeg

There are 763 posts in this topic. You are on page 16 of 16.
#751 3 months ago

Thanks for all the help.
I am getting some spark from a couple other flipper EOSs but I cleaned the contacts and still getting some here and there during testing.
So I noticed all 3 of the other flipper coils that are working have a yellow capacitor mounted right above the EOS switch but this lower left flipper that keeps blowing the fuse does not. It has that orange capacitor attached to the coil itself.(pic attached) Same function or a problem?

5 (resized).jpg
#752 3 months ago

Your capacitor is wrong... It is not supposed to be in parallel with the coil,... It is supposed to be in series.... Rewire it like the others..... That should take care of the problem

#753 3 months ago
Quoted from Sonic:

Your capacitor is wrong... It is not supposed to be in parallel with the coil,... It is supposed to be in series.... Rewire it like the others..... That should take care of the problem

The thing about that tho is it's been setup like that since I bought it over a year ago and it's been working fine all that time till just a couple weeks ago. It's more like something has gone bad or is shorting. I need to replace or swap the coil first I guess to eliminate that as being bad. Doing so tho should I get a correct EOS capacitor (yellow) as well since I'm not so sure about that orange one that's on there now

#754 3 months ago
Quoted from TastyBlack:

The thing about that tho is it's been setup like that since I bought it over a year ago and it's been working fine all that time till just a couple weeks ago. It's more like something has gone bad or is shorting. I need to replace or swap the coil first I guess to eliminate that as being bad. Doing so tho should I get a correct EOS capacitor (yellow) as well since I'm not so sure about that orange one that's on there now

Correct - get the correct cap and coil OR swap left to right and you'll have your answer right away...

Matt

2 weeks later
#755 84 days ago
Quoted from JanS:

I get occasional 2 ball muiltiball also during game play. It will fire a ball out of one of the catapults even though you already have a ball in play. I replaced both catapult and saucer switches along with new diodes. All the other switches have their wires attached as new. Could it be a failing diode somewhere upstream in the chain?

I got this dam thing fixed. Took the whole catapult assembly apart and cleaned each one. Lots of old grease on the pivot points. Also replaced both switches on the assembly. The switches making contact was so close to either triggering the switch or not. I adjusted the switchs slightly up towards the playfield. Both locks now work!

On a side note, what angle degree you guys have yours set to?

1 week later
#756 77 days ago

*Update
As far as my issue with the Left Lower flipper blowing my F6 fuse, I bought a full flipper rebuild kit for it and new coil. After changing that out it's fixed! Love the response of the rebuild kit so much going to do my right one while I'm at it.

Quoted from MotorCityMatt:

I got this dam thing fixed. Took the whole catapult assembly apart and cleaned each one. Lots of old grease on the pivot points. Also replaced both switches on the assembly. The switches making contact was so close to either triggering the switch or not. I adjusted the switchs slightly up towards the playfield. Both locks now work!
On a side note, what angle degree you guys have yours set to?

MotorCityMatt, thanks for the advice on that issue. I will look at mine as well.
Mine is set at a 7 degree slope.

#757 76 days ago
Quoted from TastyBlack:

Love the response of the rebuild kit so much going to do my right one while I'm at it.

Always do all the flippers at the same time.

Just makes sense to do them all. If one needs to be rebuilt, they probably all do. Just the basics, sleeve, plunger, coil stop, nylon bushing. Check EOS switch and spring first to make sure they’re ok.

Always remember to leave 1-2mm of up-down movement on the flipper bat.

rd

#758 76 days ago

If anyone is looking to join the club, I have a Big Guns for sale in the Market Place.

#759 74 days ago

Where can I find a new translite? Mine is pretty faded.

#760 74 days ago
Quoted from MotorCityMatt:

Where can I find a new translite? Mine is pretty faded.

Mayfair Amusements had one some time ago. Give 'em a call.

2 weeks later
#761 58 days ago

NOS from Mayfair, beautiful.

20211120_171807 (resized).jpg
#762 58 days ago
Quoted from MotorCityMatt:

NOS from Mayfair, beautiful.[quoted image]

VERY nice!

1 month later
#763 5 hours ago

Just came home with this last night.
Pretty decent shape, needs cleaning and polish and that’s about it actually.
Mechanically solid.
8C68A665-7323-4DF2-8C1D-6AD7FC21EF29 (resized).jpeg357E078C-1B0E-483F-BCCF-80E9BFCFD9EC (resized).jpeg

There are 763 posts in this topic. You are on page 16 of 16.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside