(Topic ID: 63757)

BIG GUNS CLUB - Save The Queen!


By Chitownpinball

7 years ago



Topic Stats

  • 654 posts
  • 113 Pinsiders participating
  • Latest reply 3 hours ago by SilverUnicorn
  • Topic is favorited by 34 Pinsiders

You

Linked Games

Topic Gallery

There have been 176 images uploaded to this topic. (View topic image gallery).

20210124_091947 (resized).jpg
20210124_091857 (resized).jpg
PXL_20210116_193405412 (resized).jpg
PXL_20210110_040934628.NIGHT.jpg
16100697712324328641425392061371 (resized).jpg
4 (resized).jpg
3 (resized).jpg
2 (resized).jpg
1 (resized).jpg
image_43630_1_600x600 (resized).jpg
IMG_0435 (resized).jpg
bg (resized).jpg
D1E3264C-826E-4DC9-977C-9B14D961AB70 (resized).jpeg
D504C678-527C-46FE-9538-B970A07B0AD1 (resized).jpeg
EE9DE7F7-6AAA-4744-A519-1C943EB28C5F (resized).jpeg
20140104_163915 (resized).jpg

There are 654 posts in this topic. You are on page 11 of 14.
#501 3 years ago

So here’s an interesting little “to do”.

When I bought my Big Guns late November 2017, the guy I bought it from had the “Invinceable” light pulled out. He said “the bulb never shuts off and the heat melted the plastic so I just removed it. It doesn’t effect play.” He’s right, it never shut off, but also didn’t effect the play. The melted underside of the invincible logo wasn’t bad enough to really do major damage. Still, I want the game to be “perfect” or at least have all the intended functionality. So I did some poking around in the machine and looked up a few things in the manual. I had it narrowed down to the left underside playfield relay and/or the Q14 transistor on the CPU board.
So tonight, I pulled the board and tested the bank of transistors. Turns out the Q14 was bad. I re-flowed all the connector joints and a few others that looked questionable since I had the board out. I’m going to stop at my local electronics store tomorrow to see if they have the transistor. As a backup, I see Marco sells them for $1.69. It’s the dang shipping that always kills me.

Can someone validate the function of the flasher when working correctly? I believe I’ve seen a video before that this bulb only flashes once you’ve started multiball and loaded the designated cannon which results in the audio “Your are incinceable. Save the Queen!” And I believe the flasher will run faster and faster until the timer runs out and the audio of the scream “She’s mine now!” sounds... or you actually save the Queen. Can someone verify I have this right?

I’ll post an update if this transistor replacement completely restores the bulb function.

Thanks!

#502 3 years ago

Re flasher behavior, you are right on.

It also rings off in sequence with the ofher flashers in attract mode or when the game celebrates when you ended the game after saving the queen one or more times.
Ill see if I have any video

#503 3 years ago
Quoted from trueno92:

Re flasher behavior, you are right on.
It also rings off in sequence with the ofher flashers in attract mode or when the game celebrates when you ended the game after saving the queen one or more times.
Ill see if I have any video

Transistor is in. I’m seeing the flasher for the first time. Appears to cycle in the attract mode as well. Machine is at 100% finally!

Quick... sell it!!!

#504 3 years ago

Well done sir!!! Good job now put the glass on and step away else ur gonna try and tweak something and end up breaking 6 other things in the process!!!

#505 3 years ago

Is there a way to clear cannons after a game? Seems like they stay loaded so the next person could have 1 or 2 to start with. Didn't see the adjustment listed. Not talking a mutliplayer game, thinking after a game is complete.

Thanks

John

#506 3 years ago
Quoted from ViperJelly:

Is there a way to clear cannons after a game? Seems like they stay loaded so the next person could have 1 or 2 to start with. Didn't see the adjustment listed. Not talking a mutliplayer game, thinking after a game is complete.
Thanks
John

I thought mine always fired when a game ended, but does it really matter that much? I guess you lose a chance at a skill shot?

#507 3 years ago

Mine kicks them out when the game ends. I’m pretty sure that is what is supposed to happen. I'm not sure why your’s isn't.

#508 3 years ago

When game overz it fires out the held ballsbjust before match displays

#509 3 years ago

Yep, balls should be returning to the trough from the cannons when the game ends.

#510 3 years ago

Should be returned to the trough. I cNt remember if there is a game setting for this or not. I don’t have my machine any more to check. If you fire a new ball into the cannon does it clear the existing ball and lock the new? Canons work correctly apart from end of game clear?

#511 3 years ago

Cannons work correctly aside from end of game clear. I tested it again today and both cannons exhibit the behavior. The next game will start with the cannon loaded. The cannons fire when another ball is ready to load and they fire correctly at multiball. Strange.

#512 3 years ago

How many balls are loaded in the machine? Id check trough switches

1 month later
#513 2 years ago
Quoted from ViperJelly:

Is there a way to clear cannons after a game? Seems like they stay loaded so the next person could have 1 or 2 to start with. Didn't see the adjustment listed. Not talking a mutliplayer game, thinking after a game is complete.
Thanks
John

It should return the balls automatically by default. Check the switches in the cannon assemblies. I've had mine go out of adjustment quite often resulting in all kinds of odd behavior.

#514 2 years ago
Quoted from stumptown:

Check the switches in the cannon assemblies. I've had mine go out of adjustment quite often resulting in all kinds of odd behavior.

And if they have any pink crimp connectors, cut them off and solder direct. I cant remember if system 11 pins have them or just WPC but they can cause all sorts of headaches.

2 weeks later
#515 2 years ago

Going to do some more digging. Had a credit dot but that was jus the tower switch (very hard to get the skill shot, at least it seems that way to me). Everything seems to be working, when the new game starts the machine knows it has the cannons loaded. I wonder if I have an old ROM? Going to check tonight, thanks for the suggestions.

Thus far all switches looks good.

John

2 weeks later
#516 2 years ago

Picking up a super nice Big Guns tomorrow and super excited to get this one! Gonna fit perfect with all the other scary castle games I'm currently obsessed with. Love that friggin backbox art! Outstanding!

big_guns (resized).jpg

#517 2 years ago

Playing my Big Guns today and noticed the ADV X is not working. Knock down the drop targets and nothing happens. The timer doesn't seem to be working to pop them back up. They do reset on the next ball.

Any ideas??

#518 2 years ago
Quoted from Azfalconfixer:

Playing my Big Guns today and noticed the ADV X is not working. Knock down the drop targets and nothing happens. The timer doesn't seem to be working to pop them back up. They do reset on the next ball.
Any ideas??

Check if they're all registering in switch test

#519 2 years ago
Quoted from Azfalconfixer:

Playing my Big Guns today and noticed the ADV X is not working. Knock down the drop targets and nothing happens. The timer doesn't seem to be working to pop them back up. They do reset on the next ball.
Any ideas??

That sounds like normal behavior. You need to shoot around the back of the drop targets/ troll to get the bonus x multiplier.

#520 2 years ago
Quoted from thirdedition:

That sounds like normal behavior. You need to shoot around the back of the drop targets/ troll to get the bonus x multiplier.

I manually activated the switches and nothing. It seems like its not reading when the drop targets are down.

#521 2 years ago

So there is no flashing red arrow?

#522 2 years ago
Quoted from thirdedition:

So there is no flashing red arrow?

Mine are green arrows on each side but no they don't light. Looks like the opto broads are not reading when the drop targets are down.

#523 2 years ago
Quoted from Azfalconfixer:

Mine are green arrows on each side but no they don't light. Looks like the opto broads are not reading when the drop targets are down.

Take them out and clean the optos with a Q-tip and alcohol

#524 2 years ago
Quoted from zacaj:

Take them out and clean the optos with a Q-tip and alcohol

I've done that recently. Seems like none of the opto's are working. The manual doesn't seem to have a schematic for them.

#525 2 years ago
Quoted from Azfalconfixer:

Playing my Big Guns today and noticed the ADV X is not working. Knock down the drop targets and nothing happens. The timer doesn't seem to be working to pop them back up. They do reset on the next ball.
Any ideas??

Update: Fixed it. There is a single 2 wire connector between the playfield and back box that supply's 12v power and ground to the opto boards. It had a bad/dirty connection. Cleaned the connects and now it works good.

1 week later
#526 2 years ago

Not gonna lie, I miss my BG some times. Its just such a weird game with cool artwork. I love the bagatelle too.

1 month later
#527 2 years ago

Update to cannons not clearing after game over. It looks to be a ROM issue. New ROMs fixed it.

1 month later
#528 2 years ago

Yall will be happy to know that I took the high score of the night at my local pinball club this weekend. I do miss this machine a bit, maybe some day if the price is right.

SAVE THE QUEEN!

1 month later
#529 2 years ago

Need the upper right ramp, anyone have one for sale, or who where to find? TIA

1 month later
#530 2 years ago

We picked up a sweet BG 2 weeks ago tomorrow from a great pinsider Knapp_arcade. We had an adventure driving there and back in our long loved honda crv. Terrific playfield, steller cab. Recently had a problem with the left cannon, made the gameplay almost unbearable. Paul found the cold solder connection on switch 37, repaired it on spot and boy is it playing great now! Love System 11b funk!

#531 2 years ago

We'll go bulb by bulb of what we want in each spot. We decided to go with a color changer for the planet with the foreboding eye. We're liking the effect.
We're going to put some spots on the upper pf soon.

IMG_20181107_200031797 (resized).jpg
3 weeks later
#532 2 years ago
Quoted from Pablito350:

We decided to go with a color changer for the planet with the foreboding eye. We're liking the effect.

[quoted image]

Thats a great idea ! I think I'm gonna do the same to my BG backbox.

I havent checked a lot of other SYS11-games yet- but is it me- or does Big Guns have a heck-of-a-lot of bulbs in the backbox ?

Is there any place on this table that you guys wouldnt put LED:s ? I only see advantages with that, both cosmetically and in respect of bringing the power and heat down a notch.

#533 2 years ago

Here was my backbox arrangement. Got a lot of compliments.

BACKBOX GI
44 RED SUPERS (18)
44 GREEN SUPERS (17)
44 BLUE SUPERS (10)
44 ORANGE SUPERS (2)
44 COOL SUPERS (5)

IMG_4551 (resized).JPGIMG_4612 (resized).JPG
#534 2 years ago
Quoted from Pinasco:

Thats a great idea ! I think I'm gonna do the same to my BG backbox.
I havent checked a lot of other SYS11-games yet- but is it me- or does Big Guns have a heck-of-a-lot of bulbs in the backbox ?
Is there any place on this table that you guys wouldnt put LED:s ? I only see advantages with that, both cosmetically and in respect of bringing the power and heat down a notch.

I don't think it has any more than any other pin in the backbox.... plus or minus a few.
The only place we didn't use LED's are for the flashers. We put in new 89's, and are happy with them. Did the same on our Cyclone as well.
I know there's a modification you can do on system 11 machines so you can run LED's for the flashers, but the 89's are quite bright enough.

-Paul

#535 2 years ago

Hello fellow Big guns owners. I have removed my machine from storage. The head is removed from the body and I would be really thankful for some high resolution pictures of the backbox connectors. Thank you in advance.

#536 2 years ago

When I turn on my big guns sometimes it boots up correctly and other times just the GI lights come on, no display or anything else. When this happens it will boot up correctly but can take a few times flipping the toggle switch. Once on I never have a problem. I reseated all of the connectors and ribbon cables but it still does it. Any ideas what to look for?

1 week later
#537 2 years ago

I got a Big Guns in da house!

Any custom roms or ways to make the queens rescue value reset each game? I like that it builds player to player, but not that it builds game to game until collected.

Thanks!

#538 2 years ago
Quoted from chuckwurt:

I got a Big Guns in da house!
Any custom roms or ways to make the queens rescue value reset each game? I like that it builds player to player, but not that it builds game to game until collected.
Thanks!

I've been wanting something similar... I've got my Big Guns on location and the Queen's Rescue value storing means it can be an incredibly imbalanced game in competitive play. I'd love to have it either only store during the current game, or simply be set to a flat value.

#539 2 years ago
Quoted from Don44:

When I turn on my big guns sometimes it boots up correctly and other times just the GI lights come on, no display or anything else. When this happens it will boot up correctly but can take a few times flipping the toggle switch. Once on I never have a problem. I reseated all of the connectors and ribbon cables but it still does it. Any ideas what to look for?

How's your power supply? I'd check logic voltage at initial power up and then after a couple minutes to let it warm up, see if it's low and/or changes with a bit of warm up time. If it hasn't been recapped yet any original power board is going to have caps old enough to be suspect.

#540 2 years ago
Quoted from stumptown:

I've been wanting something similar... I've got my Big Guns on location and the Queen's Rescue value storing means it can be an incredibly imbalanced game in competitive play. I'd love to have it either only store during the current game, or simply be set to a flat value.

I found someone to make a new rom that resets the queens rescue to 500k at the start of each game. I’ll be testing it over the next few days. I’ll keep everyone posted.

4 weeks later
#541 2 years ago

I finally am able to join the big guns club!!! This has been one of my favorite system 11 pins for a long time!

#542 2 years ago
Quoted from chuckwurt:

I found someone to make a new rom that resets the queens rescue to 500k at the start of each game. I’ll be testing it over the next few days. I’ll keep everyone posted.

Rom works great!! No issues noted.

#543 2 years ago

Is that rom something you would share ? I am guessing custom codes can't be put up on ipdb but isn't there another site VP forums to hold onto custom codes that are good for tournament for safe keeping ? Just a thought

#544 2 years ago

Exciting news! Would love to get my hands on the image and install it in my Big Guns on location for further testing

#545 2 years ago

Shoot me an email here and I can forward the files. You will need to burn the Roms somehow. Also if you don’t currently have L8 Roms, you’ll need to update that one too.

Chuckwurt@msn.com

#546 2 years ago

Sent!

#547 2 years ago

Also sent.

#548 2 years ago

Does anyone have a picture of where all the bulbs are on and under the playfield and/or how many of each are used?

I am trying to put in LEDs.

Has anyone done LEDs that can tell me (or send me) a pic of your bulb order??

#549 2 years ago

I just finished putting in LEDs in my Big Guns pin. I say "finished," but I may change a handful out...I guess im 99% done.

There was one light at the very back of the playfield that I just couldn't reach. I unscrewed it from the bottom, but a wire was holding it in. Argh! I can't get to it...

I went with a lot of green in the guns at the bottom and top of the backglass, some red around the explosions and "williams" sign, purple and blue around the gunner soldiers, and i did the bagatelle kings shields in their respective colors (blue, red, white, green, and orange). The rest was done in frosted sunlight white.

Pics dont do it justice.

Here are the pics anyway:

20190204_175642 (resized).jpg20190204_175702 (resized).jpg20190204_175940 (resized).jpg
#550 2 years ago

I am slowly making some progress on my Big Guns. I am a System 11 newbie so I wonder if a switch marked on the picture should be there? Both lower flippers have the same switch and the upper ones do not have it.

BG.jpg
Promoted items from the Pinside Marketplace
From: $ 20.00
Cabinet - Other
Rock Custom Pinball
From: $ 1.00
Playfield - Other
Rocket City Pinball
$ 81.95
Cabinet - Shooter Rods
Super Skill Shot Shop
$ 12.00
Electronics
Yorktown Arcade Supply
From: $ 33.00
Gameroom - Decorations
Rocket City Pinball
From: $ 1.25
Playfield - Other
Rocket City Pinball
$ 85.00
Cabinet - Shooter Rods
Super Skill Shot Shop
From: $ 19.99
Eproms
Matt's Basement Arcade
2,400
Machine - For Sale
Brentwood, CA
$ 12.50
Cabinet - Sound/Speakers
Gweem's Mods
From: $ 20.00
Cabinet - Other
Rock Custom Pinball
$ 22.50
There are 654 posts in this topic. You are on page 11 of 14.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside