(Topic ID: 144924)

BF DMD Failure


By Sabre68

3 years ago



Topic Stats

  • 28 posts
  • 9 Pinsiders participating
  • Latest reply 3 years ago by Crash
  • Topic is favorited by 1 Pinsider

You

Linked Games

You're currently viewing posts by Pinsider sabre68.
Click here to go back to viewing the entire thread.

#1 3 years ago

Hello,
My kids were playing BF over the weekend and out of nowhere the DMD just went blank. The machine plays fine, just no display.
I'm really hoping this is something simple... any suggestions on where to start?
Thank you

#4 3 years ago

Thank you both! I read the service bulletin and I guess it is common so I went ahead and placed the order for the updated harness.
I will, Dendoc, reseat the cables this evening and hopefully that will work and I can get my kiddos off my back about fixing their favorite machine! )

#5 3 years ago

Okay I went home for lunch and reseated all the cables. I didn't see anything visibly wrong with the connections. Turned the power on and the game booted up, but still no DMD. I really hope that updated harness solves the problem. Anyone have any other ideas?

#7 3 years ago

I ordered it from Marco Specialties. The Link is listed above in FlipperMagician's post. It is scheduled to come in today via FedEx. It cost $12 plus shipping. Hopefully I get a chance to install this evening or tomorrow and I will let you know the results...

#8 3 years ago

I finally received my updated harness(Turkey Day slowed things down) and went to install it and apparently there was already an updated harness there. I could tell because the stops on the connector on the power board were already cut out like the instructions asked me to do. It looks like the negative black wire wasn't seated all the way down so I pushed it all the way down in and hooked everything back up. Turned it on and again nothing. Game fires right up and is ready to play but no DMD. Is it possible that the newer harness plugs went bad too? I couldn't see any visual damage and the pins look clean. Any suggestions at this point? Thanks and please remember this is a new hobby for me and I really have no experience with troubleshooting...

#10 3 years ago

Okay, I put the MM on the Display and it is getting exactly 5.0 volts. Any suggestions on where to go from here?

#11 3 years ago

Still looking for help with this problem. The display is getting the power it needs. Does anyone have any suggestions where to troubleshoot next? Thanks

2 weeks later
#12 3 years ago

BUMP
Still looking for advice.
Thanks

#15 3 years ago

I do not have another DMD to cross examine with. Wish I did. If it ends up being a dead DMD, then does anyone know where to get a new one? Are color ones available? My kiddos really miss this machine, I only own three.
Thanks

Quoted from falco:

The common failure that causes this seems to be the HV supply on the DMD board itself failing. That's what I'd check first.

I will check this ASAP

#20 3 years ago
Quoted from Crash:

check for these two voltages at the display's header pins that connect to the board. Also check for 5v at the display driver board that piggybacks on top of the display itself.

I checked these at the header pins and got 5v and 21v. The one on top, piggy backing, also showed 5v. 4.99 to be exact.
So I checked the connector and still had the same results. 5v and 21v.
Crash, if it only is supposed to be getting 12v, then how could it possibly be getting 21?
Also I switched the small ribbon cable and started it up and we actually has some (random) lights on the DMD for a little bit...then they disappeared and we couldn't get anything to show up again, repeatedly switching the small ribbon cable(as someone had suggested earlier)
And Crash, if my DMD is dead, then I would love to build another but I have very little electronic skills being that I've only been into this crazy hobby for less than a year...

1 month later
#23 3 years ago

Okay, someone suggested replacing the ribbon cable that goes from the top board to the bottom board on the DMD. It's a short 14 pin connector. I purchased a new one and put it on. The DMD now shows life but all you see is jumbled and gargled lights. Before it was completely blank. Does anyone know what this means and where to go from here? I really do appreciate all the help to this point but I'm getting ready to throw in the towel on this machine.(or seek a professional who can come to my house and properly fix the problem)
BTW, The header pin on the bottom board looks like it has been replaced before...I guess you guys refer to as a "hack"?
Thanks again

#25 3 years ago

I live in Clarksburg, West Virginia. If anyone knows of a traveling repairman(if that exists) I would be glad to hear about him. I have two pins and a video game out of service at the moment.
Does anyone know where I can get that header pin located on the bottom board of the DMD?

#27 3 years ago

Where do I get this DMD extender? I had heard the guy doesn't make them anymore...

Promoted items from the Pinside Marketplace
From: $ 9.99
From: $ 369.95
Boards
PinSound
$ 224.99
From: $ 9.99
$ 399.95

You're currently viewing posts by Pinsider sabre68.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside