(Topic ID: 128466)

Baywatch Flipper Controls INOP


By Zenomorp

4 years ago



Topic Stats

  • 6 posts
  • 3 Pinsiders participating
  • Latest reply 4 years ago by Zenomorp
  • Topic is favorited by 1 Pinsider

You

Linked Games

#1 4 years ago

Hey all. Mike here. Trying to repair a Baywatch for a friend. It had a lot of issues when he got it and I've got everything licked except for one last problem. It's not major, but it does make the game someone incomplete, playability wise. Here's the issue.

The flipper-controlled options don't work. What I mean by that is each time you start a new ball, you have the option to choose which lane you think the ball will go down for the skill shot and you choose the lane by using the flippers...but it doesn't work.

Same thing during the video modes. You have to use the flippers to move the rescue swimmer/character left or right to avoid obstacles and such...but it doesn't work.

Same thing when you get a high score. You have to use the flippers to enter your initials...but they don't work.

The flippers themselves work fine for regular functionality. It's just the above type of situations where they don't do what they are supposed to. I have done everything I can think of including slaving in a new MPU thinking it was some sort of logic issue...but to no avail. The problem remains.

This is the last issue that I'd like to get solved for my friend. He's anxious to get the machine 100% up and running. If anyone has any ideas or can point me in the right direction, it would be greatly appreciated.

Many thanks - Mike.

#2 4 years ago

I should add that I was told that they used to work just fine and then stopped working shortly after he got the machine. The machine was in pretty rough shape when he got it but it was fully working with no issues. He called me over to clean it up and do a full shop on it because he knew nothing about doing such things himself. He told me that everything used to work fine but the flipper issue developed shortly after he got it.

I installed a full LED kit, disassembled most of the playfield, shopped it, cleaned/waxed it, installed new balls, and set everything up the way he wanted it. The only issue that remained was the flipper selection problem. I did check the contacts on the flipper stacks and they are not burned through or anything like that. They look pretty good actually. The flippers work fine for normal gameplay and register in the test menu but I don't remember if I made sure to check if they were registering for the secondary contacts.

Either way, something is phooey because he told me they used to work and now they don't. Something crapped out and I thought it might have been the MPU, so I slaved a known good one in and it didn't fix anything. Here's a quick video just for reference. You're supposed to be able to choose which lane you want with the flippers but...

#3 4 years ago

Do they work in the service menu? (I assume not.)

Following that, i'd do some continuity checks on the circuit that contains those switches. The signal to flip the flippers and the signal to the logics are on separate circuits: check that!

#4 4 years ago

Baywatch has a third flipper board - left side of the cabinet under the playfield - check if the led lights or has power.

#5 4 years ago

Thanks guys. I don't have access to the machine right now, but I'll check out the flipper board and run some continuity checks when I get back over to my friend's house. He's a lawyer and has some unpredictable free time. It's possible the flipper board simply took a crap because a lot of the parts and pieces from this machine were obviously robbed from other machines to get this one up and running before it was sold to my friend. None of the boards were secure and a lot of the connectors were not snapped in/seated all the way.

1 week later
#6 4 years ago

Just updating this thread with the solution to the problem. Got back over to my friend's house tonight and got to working on the machine again. It turns out that one of the playfield quick disconnects that rests on the bottom of the cabinet was not fully seated together with it's counterpart. It must have been making intermittent contact which is why the secondary flipper controls used to work, then stopped. I took the connector apart, inspected it for issues (corrosion, bent pins, etc) and it was all good. I re-connected it and made sure it was fully seated and...problem solved.

Thanks.

Promoted items from the Pinside Marketplace
$ 16.00
$ 50.00
2,975 (OBO)
Sale Pending!
Maricopa, AZ
From: $ 9.99
Eproms
Matt's Basement Arcade
$ 175.00
Lighting - Interactive
Professor Pinball
From: $ 40.00
Lighting - Interactive
Professor Pinball
$ 15.00
Playfield - Plastics
Pinball Haus
From: $ 40.00
Cabinet - Other
Rock Custom Pinball

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside