(Topic ID: 167576)

Batman 66 - Official Club Thread

By TigerLaw

5 years ago


Topic Heartbeat

Topic Stats

  • 17,672 posts
  • 718 Pinsiders participating
  • Latest reply 1 day ago by Pinboy
  • Topic is favorited by 273 Pinsiders

You

Linked Games

Topic Gallery

View topic image gallery

20220519_201122 (resized).jpg
Screen Shot 2022-04-27 at 9.01.52 AM (resized).png
E2303FFC-82E1-4E57-A964-4ED9CAE3B832 (resized).jpeg
2FEA79FF-ED26-464C-9DBD-7CE03FCC6980 (resized).jpeg
C01149DE-66D3-4040-98BE-1DF27373495B (resized).jpeg
8F4986BF-1F4F-4406-84E9-71D5876C2031 (resized).jpeg
D9EF815B-4CDC-4237-90BB-2A29294A9DC4 (resized).jpeg
15DDF504-87FB-4FC8-97C3-A82E76DD331C (resized).jpeg
0C4AAA39-7D7F-4FC5-8D3C-26469B20269F (resized).jpeg
3EF54934-7DB4-40ED-95DD-1A1BF07EF9D5 (resized).jpeg
32F25EE3-EC38-4BFB-A328-EA4290EC8F35 (resized).jpeg
186889bab33105b63b6858df8df2505f597fcb13 (resized).jpg
F40033F3-3D25-4556-BF23-D6BAEF583140 (resized).jpeg
38ae9d3e948224b077dbaa535519affea3138876 (resized).jpeg
8f28b2d98d4495e5af3de645a909c96d9e7f7fcf (resized).png
B4E8A13E-E016-49B6-92BC-13E121B56D18 (resized).jpeg

Topic index (key posts)

48 key posts have been marked in this topic, showing the first 10 items. (Show topic index)

There are 17,672 posts in this topic. You are on page 345 of 354.
#17201 4 months ago
Quoted from Durbin:

But besides always showing all 4 players scores the LCD display is the same as previously?

Yep!

#17202 4 months ago

Not bad...

20220119_181240 (resized).jpg
#17203 4 months ago

I have quite enjoyed the insider Connect achievement logos using the artwork for the game, but batmans are super disappointing, none of them use the amazing artwork such a shame.

#17204 4 months ago

I bought a Batman 66 in December. I bought it from a distributor and I was told it's a display model. Not quite sure exactly what that is but I'm assuming it was at an event or something to that extent. I'm overseas for work and haven't been able to unbox the game or look at it. Does anyone know if this game should have insider connect or not?

#17205 4 months ago
Quoted from splitcms:

I bought a Batman 66 in December. I bought it from a distributor and I was told it's a display model. Not quite sure exactly what that is but I'm assuming it was at an event or something to that extent. I'm overseas for work and haven't been able to unbox the game or look at it. Does anyone know if this game should have insider connect or not?

Do you know the build date? From my understanding all of the December 2021 builds were built with connect.

#17206 4 months ago
Quoted from dts:

Batboat looks good here, the lights illuminate from above it and the color blends in. Might look good with a small flat red LED at the siren.
[quoted image]

How did you mount the Batboat?

#17207 4 months ago
Quoted from Scottn63:

Do you know the build date? From my understanding all of the December 2021 builds were built with connect.

Thank you for the response. I’m not sure of the build date but I would have to assume December since that is really the only time these went back into a short production run after a long hiatus. I was just wondering because I wanted to order an insider connect kit if there isn’t one already built into the game. I guess I’ll find out in a couple of months

#17208 3 months ago
Quoted from jfh:

Nice to see flipper power adjustment added, but doesn’t seem to have much/any updates to game play.

Not having DJ Mixer is a disappointment since the music is awesome! I think it needs to be in there.

Rob

#17209 3 months ago
Quoted from Rob_G:

Not having DJ Mixer is a disappointment since the music is awesome! I think it needs to be in there.
Rob

I got an anonymous direct message, presumably from someone in the know, that it would be coming eventually. This was after my previous post speculating that maybe it was held up due to licensing issues with the main theme. They said that the priority of this release was the IC integration.

Not sure if this mystery person would really be privvy to inside information, though, so take that with a grain of salt.

10
#17210 3 months ago

I know there is a separate thread for Lyman but he deserves a post in this thread RIP Lyman F Sheats Jr. Thank you for giving us so much!

149508E3-FD38-43A5-810E-3715196F58C0 (resized).jpegE847D316-82BA-4A25-ADFB-DE57CE799A9A (resized).png
#17211 3 months ago
Quoted from JStoltz:

I got an anonymous direct message, presumably from someone in the know, that it would be coming eventually. This was after my previous post speculating that maybe it was held up due to licensing issues with the main theme. They said that the priority of this release was the IC integration.
Not sure if this mystery person would really be privvy to inside information, though, so take that with a grain of salt.

There will probably be more updates coming anyhow for all games as they introduce more IC features.

I have to sell my BM66 as I've committed to another hobby. Mixed feelings now...

Rob

#17212 3 months ago
Quoted from TonyScoots:

I know there is a separate thread for Lyman but he deserves a post in this thread RIP Lyman F Sheats Jr. Thank you for giving us so much!
[quoted image][quoted image]

OMG what happened?? This is so sad and out of the blue I’m floored.

Sad.

If I’m listing my heroes of pinball for Mt Rushmore he’s there on pole position.

#17213 3 months ago
Quoted from JStoltz:

I got an anonymous direct message, presumably from someone in the know, that it would be coming eventually. This was after my previous post speculating that maybe it was held up due to licensing issues with the main theme. They said that the priority of this release was the IC integration.
Not sure if this mystery person would really be privvy to inside information, though, so take that with a grain of salt.

I’m kind of surprised they didn’t do an EHoH40 type edition for the final run of BM66. The Dec run just didn’t have much fanfare if that was *actually* the last run.

#17214 3 months ago

Anyone have a spare cliffy set for BM66 that they are willing to sell, or maybe at least the penguin hole and mystery hole (Riddler) protectors?

If so please PM me

Thanks

#17215 3 months ago
Quoted from insight75:

Here is a pic. Real basic splitter.
[quoted image]

Its a monoprice:

amazon.com link »

I think anything with 8P8C should work. I've ordered something from amazon here in the UK that arrives today will let you know.

#17216 3 months ago

So I found a bat signal that wasn't marked up 8-12 times the price. It's the full base version which obviously won't fit on my LE. I searched and searched and couldn't find converting it to a LE version. Trying to get my son's favorite game (which the build date is the same day as his birthday) "finished" with the bat signal.

Or maybe someone has a LE mountable version that's stashed away I could trade for?

IMG_1928 (resized).jpgIMG_1929 (resized).jpgIMG_1930 (resized).jpg
#17217 3 months ago
Quoted from MichaelBic38:

So I found a bat signal that wasn't marked up 8-12 times the price. It's the full base version which obviously won't fit on my LE. I searched and searched and couldn't find converting it to a LE version. Trying to get my son's favorite game (which the build date is the same day as his birthday) "finished" with the bat signal.
Or maybe someone has a LE mountable version that's stashed away I could trade for?
[quoted image][quoted image][quoted image]

PM sent

#17218 3 months ago
Quoted from DeathHimself:

Anyone have a spare cliffy set for BM66 that they are willing to sell, or maybe at least the penguin hole and mystery hole (Riddler) protectors?
If so please PM me
Thanks

I Just ordered a full set from Cliffy, he’s a few weeks out but still selling them

#17219 3 months ago

Does anyone else have an issue with the Ball Saved coming out during play post the update? If I drain one of the balls it ejects after the Ball Save activiates the game will continue playing so I am wondering if it is a software issue that was released in the newest code drop.

#17220 3 months ago
Quoted from chewiec:

Does anyone else have an issue with the Ball Saved coming out during play post the update? If I drain one of the balls it ejects after the Ball Save activiates the game will continue playing so I am wondering if it is a software issue that was released in the newest code drop.

Haven't seen this one as of yet, but I did notice the magnet does release the ball as quick when its being held for answering the phone, and the game starts a ball search in like 10 secs. I even just replaced all the balls assuming its a magnetized issues and still no luck sits there like a golfball on a tee.

So now I was assumed a magnet dimple was catching it but with the game powered off the ball wont stay and just rolls right off. "shrug"

#17221 3 months ago
Quoted from DeathHimself:

Haven't seen this one as of yet, but I did notice the magnet does release the ball as quick when its being held for answering the phone, and the game starts a ball search in like 10 secs. I even just replaced all the balls assuming its a magnetized issues and still no luck sits there like a golfball on a tee.
So now I was assumed a magnet dimple was catching it but with the game powered off the ball wont stay and just rolls right off. "shrug"

I noticed a ball search during game play when the ball wasn't even stuck(i just didnt hit a switch for a while). I haven't noticed the ball saved issue yet but only played a couple of games.

Quoted from JStoltz:

I got an anonymous direct message, presumably from someone in the know, that it would be coming eventually. This was after my previous post speculating that maybe it was held up due to licensing issues with the main theme. They said that the priority of this release was the IC integration.
Not sure if this mystery person would really be privvy to inside information, though, so take that with a grain of salt.

This is an interesting quote. any other info/context?

#17222 3 months ago
Quoted from tjc02002:

I noticed a ball search during game play when the ball wasn't even stuck(i just didnt hit a switch for a while). I haven't noticed the ball saved issue yet but only played a couple of games.

This is an interesting quote. any other info/context?

Weird, also noticed turn table sits after answering jokers call, phone rings but don't turn. So when ball drops and I hit it then it moves. But moves fine all other times it seems.

#17223 3 months ago

I have an issue where 2 balls keep entering the shooter lane. I had this issue in the beginning and it resolved itself. I've tried reconnecting wires at the optos and nothing. Anything I can try before contacting Stern? Machine is from the latest run.

#17224 3 months ago
Quoted from insight75:

I have an issue where 2 balls keep entering the shooter lane. I had this issue in the beginning and it resolved itself. I've tried reconnecting wires at the optos and nothing. Anything I can try before contacting Stern? Machine is from the latest run.

Check the ball trough opto board, sounds like maybe the first opto isn't working

#17225 3 months ago
Quoted from DeathHimself:

Check the ball trough opto board, sounds like maybe the first opto isn't working

Yeah I think its the board itself. I've tried reseating everything and the path is clear. I've contacted Stern to see if they can send a replacement.

#17226 3 months ago
Quoted from tjc02002:

This is an interesting quote. any other info/context?

Guess it doesn’t hurt to paste the message here, if I don’t share who sent it…

“Not to worry, you will get DJ mixer in a future update, the priority was to get the IC support to everyone first.”

#17227 3 months ago
Quoted from JStoltz:

Guess it doesn’t hurt to paste the message here, if I don’t share who sent it…
“Not to worry, you will get DJ mixer in a future update, the priority was to get the IC support to everyone first.”

It was probably Gary Stern...

Rob

#17228 3 months ago

Greetings,

Long time lurker, first time posting. I have the Batman 66 with insider connect. I've been playing the heck out of it.

Today, the turn table decided to quit working. I have images of my diagnostics. I can't seem to find node 4. After power cycling the game. The turn table some how started working but only temporarily. I did open the game up and I couldn't find any loose wiring issues. I did run a bus test and the system found no errors, however when I navigate directly to the board test. Board 4 is flashing and getting a runtime info message. Testing the turntable motor is not possible due to the Too Many Consecutive errors.

This is my 2nd pinball machine so I'm relatively new to the hobby so any help would be greatly appreciated. I did search before posting and while some posts were close to my situation. I couldn't find a solution to my problem. If there are any photos I could provide, please let me know.

Thanks in advance.

Node 4 (resized).jpgTurnT1 (resized).jpg
#17229 3 months ago
Quoted from Citizen69:

Greetings,
Long time lurker, first time posting. I have the Batman 66 with insider connect. I've been playing the heck out of it.
Today, the turn table decided to quit working. I have images of my diagnostics. I can't seem to find node 4. After power cycling the game. The turn table some how started working but only temporarily. I did open the game up and I couldn't find any loose wiring issues. I did run a bus test and the system found no errors, however when I navigate directly to the board test. Board 4 is flashing and getting a runtime info message. Testing the turntable motor is not possible due to the Too Many Consecutive errors.
This is my 2nd pinball machine so I'm relatively new to the hobby so any help would be greatly appreciated. I did search before posting and while some posts were close to my situation. I couldn't find a solution to my problem. If there are any photos I could provide, please let me know.
Thanks in advance.
[quoted image][quoted image]

I was having a Node Board 4 issue as well as another issue with Node Board 24. This is was Stern sent me:

Hello,

The latest code for Batman 66 was just released on the 18th. Can you update the game and re-test everything ?

The code before this latest version did not have the Insider Connected software, and caused issues with node 4 and node 24 since node 4 is the QR Scanner. Updating the code should at least get rid of those two errors. Since everything communicates through the serial channel, we should clear up that before digging into the other issues.

I hope this helps. If you update the latest game code it may resolve your issue.

#17230 3 months ago
Quoted from Citizen69:

Greetings,
Long time lurker, first time posting. I have the Batman 66 with insider connect. I've been playing the heck out of it.
Today, the turn table decided to quit working. I have images of my diagnostics. I can't seem to find node 4. After power cycling the game. The turn table some how started working but only temporarily. I did open the game up and I couldn't find any loose wiring issues. I did run a bus test and the system found no errors, however when I navigate directly to the board test. Board 4 is flashing and getting a runtime info message. Testing the turntable motor is not possible due to the Too Many Consecutive errors.
This is my 2nd pinball machine so I'm relatively new to the hobby so any help would be greatly appreciated. I did search before posting and while some posts were close to my situation. I couldn't find a solution to my problem. If there are any photos I could provide, please let me know.
Thanks in advance.
[quoted image][quoted image]

I don't believe Batman has a node 4 board. Shut the machine down and on reboot immediately go into diagnostics, game, turn and see in which direction the turn table is hanging up on.

However before doing so, remove all the balls and then lift the playfield and first inspect that there are no taught wires being snagged. Then do the above and see where is hanging if its free from tight wires. Mine was hanging up on a Molex that dropped down that I didn't see at first from the switches going to the bat computer.

#17231 3 months ago
Quoted from MachineGunGuy:

since node 4 is the QR Scanner.

LOL, that explains why I have no node 4 board I'm not connected.

#17233 3 months ago
Quoted from Citizen69:

Greetings,
Long time lurker, first time posting. I have the Batman 66 with insider connect. I've been playing the heck out of it.
Today, the turn table decided to quit working. I have images of my diagnostics. I can't seem to find node 4. After power cycling the game. The turn table some how started working but only temporarily. I did open the game up and I couldn't find any loose wiring issues. I did run a bus test and the system found no errors, however when I navigate directly to the board test. Board 4 is flashing and getting a runtime info message. Testing the turntable motor is not possible due to the Too Many Consecutive errors.
This is my 2nd pinball machine so I'm relatively new to the hobby so any help would be greatly appreciated. I did search before posting and while some posts were close to my situation. I couldn't find a solution to my problem. If there are any photos I could provide, please let me know.
Thanks in advance.
[quoted image][quoted image]

update to the latest code.

#17234 3 months ago
Quoted from MachineGunGuy:

I was having a Node Board 4 issue as well as another issue with Node Board 24. This is was Stern sent me:
Hello,
The latest code for Batman 66 was just released on the 18th. Can you update the game and re-test everything ?
The code before this latest version did not have the Insider Connected software, and caused issues with node 4 and node 24 since node 4 is the QR Scanner. Updating the code should at least get rid of those two errors. Since everything communicates through the serial channel, we should clear up that before digging into the other issues.
I hope this helps. If you update the latest game code it may resolve your issue.

I'll give it a try and report back. I did open up the play field to see if anything was loose or dangling. The turn table went out after 575 plays. Hard to believe an update is the solution but what the heck.

#17235 3 months ago

In this case it’s more logical than not that the code update is the fix.

Your other option is to disconnect the IC board from the chain.

#17236 3 months ago

quick question I looked through several pages and searches and still dont see what I need.
Are Batman 66 and the catwoman version the same but for graphics on the translite and sides of head ?Same Game and value ? thanks this will help me choose.

#17237 3 months ago
Quoted from Jamesays:

quick question I looked through several pages and searches and still dont see what I need.
Are Batman 66 and the catwoman version the same but for graphics on the translite and sides of head ?Same Game and value ? thanks this will help me choose.

Yes same gameply experience.

Same value depends on who you ask. Some might value Catwoman more since there were less of them made than a standard premium version and some like the art package more.

#17238 3 months ago
Quoted from Citizen69:

Greetings,
Long time lurker, first time posting. I have the Batman 66 with insider connect. I've been playing the heck out of it.
Today, the turn table decided to quit working. I have images of my diagnostics. I can't seem to find node 4. After power cycling the game. The turn table some how started working but only temporarily. I did open the game up and I couldn't find any loose wiring issues. I did run a bus test and the system found no errors, however when I navigate directly to the board test. Board 4 is flashing and getting a runtime info message. Testing the turntable motor is not possible due to the Too Many Consecutive errors.
This is my 2nd pinball machine so I'm relatively new to the hobby so any help would be greatly appreciated. I did search before posting and while some posts were close to my situation. I couldn't find a solution to my problem. If there are any photos I could provide, please let me know.
Thanks in advance.
[quoted image][quoted image]

The “too many consecutive errors” message happens when the turn table is physically not able to turn. It works when you cycle the game going one direction, then gets stuck coming back the other way. I saw this on my friends game and it was alignment issue underneath that was a bitch to troubleshoot. We could observe what the problem is with the playfield upright. In his case the game had lost one of the three leveling bolts for the turntable, other adjustments had been made, and everything was out of whack.

#17239 3 months ago
Quoted from JStoltz:

Guess it doesn’t hurt to paste the message here, if I don’t share who sent it…
“Not to worry, you will get DJ mixer in a future update, the priority was to get the IC support to everyone first.”

I got the exact same PM as a reply to my post.

Finger's crossed!

#17240 3 months ago
Quoted from Citizen69:

I'll give it a try and report back. I did open up the play field to see if anything was loose or dangling. The turn table went out after 575 plays. Hard to believe an update is the solution but what the heck.

Added the update and what do you know. Everything is working fine. I did have to re attempt to install the update but that wasn't a big deal.

Thanks everyone for the speedy help. This site is awesome! I do have some other minor quarks but I will investigate more before I post about them.

Thanks again everyone!

#17241 3 months ago

Okay so, Is anyone else finding that at version 1.06 the turn table is hesitant to turn to the bat-phone when its ring to start the major villain mode? And if I hit it with a ball then it's like oh shit I have to move lol.

#17242 3 months ago
Quoted from DeathHimself:

Okay so, Is anyone else finding that at version 1.06 the turn table is hesitant to turn to the bat-phone when its ring to start the major villain mode? And if I hit it with a ball then it's like oh shit I have to move lol.

pretty sure there is an adjustment to change the speed of the rotation...Correct me if I'm wrong.

#17243 3 months ago
Quoted from Plungerboy:

The “too many consecutive errors” message happens when the turn table is physically not able to turn. It works when you cycle the game going one direction, then gets stuck coming back the other way. I saw this on my friends game and it was alignment issue underneath that was a bitch to troubleshoot. We could observe what the problem is with the playfield upright. In his case the game had lost one of the three leveling bolts for the turntable, other adjustments had been made, and everything was out of whack.

Looks like I spoke too soon. The game’s turntable and crane are no longer working. I’d be willing to troubleshoot further but not seeing a lot of “how to videos” on troubleshooting this game. I guess I’ll reach out to the retailer to arrange a service call. I’m sure it’s 75 an hour but at least I can peak over his shoulder and learn.

#17244 3 months ago
Quoted from bicyclenut:

pretty sure there is an adjustment to change the speed of the rotation...Correct me if I'm wrong.

You are correct, there is a motor lag setting. Default is 1250 I even lowered that to 700 with no luck. This issues I find isn't the speed of the table moving, the table gets stupid and doesn't realize to move.

In diagnostics mode, works beautiful. I might just try to reinstall 1.06 from a full SD image and see if that clears anything up. I should have kept 1.05 on my HDD but nope I was an idiot lol.

#17245 3 months ago
Quoted from DeathHimself:

I might just try to reinstall 1.06 from a full SD image and see if that clears anything up. I should have kept 1.05 on my HDD but nope I was an idiot lol.

Ha! I learned that lesson a while ago after doing an update that was dubious at best. Ever since, I just make new SDs so that if anything is amiss or not to my liking I can just pop the other one back in.

#17246 3 months ago
Quoted from DeathHimself:

I should have kept 1.05 on my HDD

PM sent

#17247 3 months ago
Quoted from EightBitWhit:

Wanted to check in with the club and see if anyone has experienced this... I recently noticed that the "Turntable Arrow" RGB LED (the arrow above Batman's head) that leads the way to the turntable targets has lost the color Red. Blue and Green still work fine.
[quoted image]
I tried the "Single LED Test" in the service menu, and sure enough, when set to "R", the arrow itself is not lit up. When I proceeded to the "G" test, the arrow lit green, and the arrow lit blue for the "B" test.
[quoted image]
Tracing this back, it looks like this arrow is lit by one of the RGB LED's on the "Node board LED left upper Stern SPIKE II" with a SPN of 520-7028-00. I looked at the board, and it's all SMT, so that rules out me being able to fix it on my own right now.
My game is 9 months old, and I'm a bit surprised this single portion of a LED would "go out" so soon. Has anyone else experienced anything similar and are the LED node boards susceptible to failure? If so, what's the general consensus on how to guard against this (have spare boards on hand??...that's an expensive endeavor) or is there someone (outside of Stern) who does node board repair?
I've contacted Stern support to see what my options are and I'll report back here as to progress in case anyone runs into this in the future.
Thanks for any insight (and/or moral support).
Regards,
Whitney

Hi Whitney

I also own this pinball machine and just noticed exactly the same issue with the red color on the same arrow. Did you finally solve it? Got any answer from Stern? Thanks

#17248 3 months ago
Quoted from Citizen69:

Looks like I spoke too soon. The game’s turntable and crane are no longer working. I’d be willing to troubleshoot further but not seeing a lot of “how to videos” on troubleshooting this game. I guess I’ll reach out to the retailer to arrange a service call. I’m sure it’s 75 an hour but at least I can peak over his shoulder and learn.

Have you reseated connections on all boards? Step 1…..

#17249 3 months ago
Quoted from Plungerboy:

Have you reseated connections on all boards? Step 1…..

I didn’t “re-seat” but I made sure all the connections that I saw were pushed in and seated. After inspecting the underside of the play field. I powered the game back on. The crane and turntable seem to be working but don’t last an entire game. Powered off the game. Gave the game several minutes to deplete the capacitors. Powered back on. Turntable starts to reset itself back the start position. Play another game. Crane and turntable functions still can’t last a whole game session. Powered off again. Several minutes later, powered back on. Turntable goes back to start position.

Check me if I’m wrong but this is starting to sound like a main board issue or code. Thinking about reinstalling 1.06 but not a quick install this time.

Thoughts?

10
#17250 3 months ago

Hopefully all of Lymans games get updated with one of these!

32432665-BBAD-43C5-9AA5-AA9E9E13343A (resized).jpeg
Promoted items from the Pinside Marketplace
18,500 (OBO)
Machine - For Sale
Chattanooga , TN
$ 6.00
Cabinet - Other
Pin Monk
$ 26.50
$ 8.50
$ 19.95
Cabinet - Other
Pin Monk
$ 30.50
Playfield - Toys/Add-ons
The MOD Couple
There are 17,672 posts in this topic. You are on page 345 of 354.

Reply

Wanna join the discussion? Please sign in to reply to this topic.

Hey there! Welcome to Pinside!

Donate to Pinside

Great to see you're enjoying Pinside! Did you know Pinside is able to run without any 3rd-party banners or ads, thanks to the support from our visitors? Please consider a donation to Pinside and get anext to your username to show for it! Or better yet, become a Pinside+ member!