(Topic ID: 167576)

Batman 66 - Official Club Thread


By TigerLaw

3 years ago



Topic Stats

  • 14,614 posts
  • 547 Pinsiders participating
  • Latest reply 22 hours ago by Budman
  • Topic is favorited by 213 Pinsiders

You

Linked Games

Topic Gallery

There have been 3,163 images uploaded to this topic. (View topic image gallery).

IMG-20191013-WA0034 (resized).jpg
IMG_20191013_184145 (resized).jpg
BA97A0F8-107D-4077-B3DF-98CD6827EF76 (resized).jpeg
CB6F95C0-4BAF-4A09-BD55-A26D728BB77A (resized).jpeg
37C12AEF-440E-4127-B25A-9220071DEBBA (resized).jpeg
30339673-5806-4FEA-AA6A-BAFBC579FE9D (resized).jpeg
20191006_153609922_iOS (resized).jpg
20175E4A-6449-45AB-8077-2DFC194618A5 (resized).jpeg
6D8EF379-11FC-4DB8-A72C-DF6691EA4F2E (resized).jpeg
3E4CA27E-CE4F-4BF0-A25B-33C12E89C4E8 (resized).jpeg
AE5EB170-C0A3-482E-AD5A-6A2465812D12 (resized).jpeg
FF00B1F8-789F-4ACE-B754-1B32C991BF35 (resized).jpeg
3AC42BAD-DC26-48C4-8A2D-781E06576AD5 (resized).jpeg
C3A04D9E-3B23-4F8F-A5A1-6CF3054795E9 (resized).jpeg
44CB95D6-EAC9-44FB-80EE-BCE17F893BF4 (resized).jpeg
020B3070-E15C-4851-902D-9C5870B937DB (resized).jpeg

Topic index (key posts)

47 key posts have been marked in this topic, showing the first 20 (Show topic index)

There are 14614 posts in this topic. You are on page 253 of 293.
#12601 7 months ago

I'll be in the club soon, but I may have to wait til after the March run. Apparently, it sold out real quick. I'll be using my IFPA discount for this one, but it took a while to sell my Ghostbusters which is where the majority of the funds came from. I've pre purchased the die cast vehicles that appear on the SLE to add to mine. I got to play Mike at the Louisville show and won a Munsters translight.

#12602 7 months ago

Stern of the Union states:
Batman ’66 – There is a new Batman update in the works.

Looking forward to seeing it.

#12603 7 months ago
Quoted from Macca101010:

Stern of the Union states:
Batman ’66 – There is a new Batman update in the works.
Looking forward to seeing it.

Maybe they will have preview code at TPF? They've done that in prior shows.

#12604 7 months ago
Quoted from docquest:

Maybe they will have preview code at TPF? They've done that in prior shows.

Oooh I hope so. First time to TPF for me

#12605 7 months ago
Quoted from Macca101010:

Oooh I hope so. First time to TPF for me

Me too!

#12606 7 months ago

My initial game has been on point lately. Not looking forward to erasing them all

#12607 7 months ago
Quoted from johnnyutah:

My initial game has been on point lately. Not looking forward to erasing them all

Pinball Browser is your friend

#12608 7 months ago

who is going to TPF? we need to find a batman and get a photo of us all!

#12609 7 months ago

Has anyone had a villian video mode updating/needs updating error message on the tv screen on the rotating playfield? I don't remember the wording exactly, but can look tonight.

#12610 7 months ago
Quoted from NeilMcRae:

who is going to TPF? we need to find a batman and get a photo of us all!

Great idea. I’m in.

#12611 7 months ago
Quoted from NeilMcRae:

who is going to TPF? we need to find a batman and get a photo of us all!

In like Flynn........

#12612 7 months ago
Quoted from Breger1:

Has anyone had a villian video mode updating/needs updating error message on the tv screen on the rotating playfield? I don't remember the wording exactly, but can look tonight.

I've seen it twice ... I did a google / pinside search on the text but couldn't find anything related to it. Rebooting the game certainly fixes it and doing something like testing the node board in the diagnostics fixes it.

I'd love to see more about this; it's pretty odd.

#12613 7 months ago
Quoted from Breger1:

Has anyone had a villian video mode updating/needs updating error message on the tv screen on the rotating playfield? I don't remember the wording exactly, but can look tonight.

If you can get the text of the message please send it to Stern.

#12614 7 months ago
Quoted from Breger1:

Has anyone had a villian video mode updating/needs updating error message on the tv screen on the rotating playfield? I don't remember the wording exactly, but can look tonight.

I had it come up the other day, It seems to come on now after a game, I haven't had time to look into it, but I did snap a picture of it. I am still on 1.00 code. It clears it if I test node board 10 (I think). Has come back very often after a game. (Pardon the dirt/dust )

20190303_134300 (resized).jpg20190303_134303 (resized).jpg
#12615 7 months ago
Quoted from PinsOnly:

I had it come up the other day, It seems to come on now after a game, I haven't had time to look into it, but I did snap a picture of it. I am still on 1.00 code. It clears it if I test node board 10 (I think). Has come back very often after a game. (Pardon the dirt/dust )[quoted image][quoted image]

That’s a weird one.

#12616 7 months ago
Quoted from PinsOnly:

I had it come up the other day, It seems to come on now after a game, I haven't had time to look into it, but I did snap a picture of it. I am still on 1.00 code. It clears it if I test node board 10 (I think). Has come back very often after a game. (Pardon the dirt/dust )[quoted image][quoted image]

How many plays on your BM66? Did you level that turntable with the main playfield?

Rob

#12617 7 months ago
Quoted from Rob_G:

How many plays on your BM66? Did you level that turntable with the main playfield?
Rob

I'm seeing the same thing. It's happened twice on 1.02 code, both times at the start of multi ball. I've got about 200+ plays on the machine. And I didn't need to level the turntable - but I don't quite understand how that might relate.

#12618 7 months ago

It's pretty level, but it does kind of wiggle around a bit, but always stays level on the front. It looks low in that picture, but it really isn't. I talked to Chaz at Stern about it back when I got it and he didn't seem to concerned about it, also looked at another one here and talked to someone else about it, no one really seemed like it was out of the ordinary. Do other turntables wiggle a bit or are they mounted solidly? Not sure how many plays on it, there have been so many updates.

Regardless, How would this relate to that "Villain Vision Update is Available" screen??

#12619 7 months ago

Sorry if this has been covered.

But, have any of you had the phone ringing, but the turntable isn’t rotated to the phone. I have never seen it before, but it happened twice last night.

When this occurs, I am unable to answer the phone and must wait for it to timeout.

Any help is greatly appreciated.

#12620 7 months ago

I'm selfishly hoping "Villian Vision" will actually have a Villian taunting me at some point on the screen w future code. Just seems too natural for it not to be....

#12621 7 months ago
Quoted from Breger1:

Has anyone had a villian video mode updating/needs updating error message on the tv screen on the rotating playfield? I don't remember the wording exactly, but can look tonight.

Theres a tab in the service menu where you can manually check for Villain Vision updates.

#12622 7 months ago
Quoted from thundergod76:

Theres a tab in the service menu where you can manually check for Villain Vision updates.

I wonder what that does?? I'll have to go check when I get back there.

#12623 7 months ago
Quoted from PinsOnly:

It's pretty level, but it does kind of wiggle around a bit, but always stays level on the front. It looks low in that picture, but it really isn't. I talked to Chaz at Stern about it back when I got it and he didn't seem to concerned about it, also looked at another one here and talked to someone else about it, no one really seemed like it was out of the ordinary. Do other turntables wiggle a bit or are they mounted solidly? Not sure how many plays on it, there have been so many updates.
Regardless, How would this relate to that "Villain Vision Update is Available" screen??

Sorry, it's just that your(?) magnet edge seems to be wearing on your game. I wondered how many plays were on it to get like that.

As for the turntable, when I had mine apart to fix issues with it, I noticed that the main node board in the middle of the turntable has the same weak legged diode(?) that there is a tech bulletin about. Except on this smaller board there is nothing to secure it to. Not to mentioned that the wiring is packed pretty tightly and there's lots of connectors. There might even be another node board for the TV display itself? I think you guys should call Stern tech support for answers because anything I say is just a guess. Bad connection or bad RJ45 cable? I don't know.

Rob
large (resized).JPG

#12624 7 months ago
Quoted from MK6PIN:

I'm selfishly hoping "Villian Vision" will actually have a Villian taunting me at some point on the screen w future code. Just seems too natural for it not to be....

Or Villain Vision could show you how many shots are left to light a super jackpot during the main multiball. I'm not sure what the original intent was with Villain Vision or if what is there is just what it is. Most of the time the TV is at the back of the playfield anyhow - it's only normally at front during main multiball and when you don't have a major villain running. So that would be the best times to have it do something special I guess....

Or it could show secret messages while turned away from the player....

Rob

#12625 7 months ago

heard on the pro circuit tour stream that Lyman updated the code again....oh boy

#12626 7 months ago

Has also be announced in the Stern of the union address march 2019

Batman ’66 – There is a new Batman update in the works.

#12627 7 months ago
Quoted from kidchrisso:

heard on the pro circuit tour stream that Lyman updated the code again....oh boy

Let's hope for a preview at TPF like they did last year.

#12628 7 months ago

Hi all-

Tonight I ran into another issue with my Batman 66. I put on a playfield protector when I first received the game, and it has worked great. However, tonight I noticed it was lifting near the turntable, right above the magnet area. Upon inspection, the magnet was pretty warm (not extremely hot), but warmer than I would expect it to be. I went into the settings and disabled it, but it still feels warm even though it is never activated.

Any thoughts on this? Is it normal for the magnet to be a little warm even when not activated? If not, any recommendations on what I should check?

Any help is greatly appreciated!

#12629 7 months ago
Quoted from raz0red:

Hi all-
Tonight I ran into another issue with my Batman 66. I put on a playfield protector when I first received the game, and it has worked great. However, tonight I noticed it was lifting near the turntable, right above the magnet area. Upon inspection, the magnet was pretty warm (not extremely hot), but warmer than I would expect it to be. I went into the settings and disabled it, but it still feels warm even though it is never activated.
Any thoughts on this? Is it normal for the magnet to be a little warm even when not activated? If not, any recommendations on what I should check?
Any help is greatly appreciated!

After examining the game again today, I think this is normal behavior. It was a pretty long session last night and the protector started to lift due to the heat of the magnet. This morning the protector is laying flat again, and the magnet does not get warm (due to being disabled).

#12630 7 months ago

Hey fellas I just got BM66 about a week ago and got it all set up I came across a multiball problem when all 3 balls get lock it seems it won’t register the 3rd ball lock and the Playfield starts searching for the ball. Crane moves, Turntable spins around etc, eventually all 3 balls get release from the lock but it’s not treating as multiball. I search around found people with the same problem but no solution here’s the link
https://pinside.com/pinball/forum/topic/batman-66-lock-problem-no-multiball

#12631 7 months ago
Quoted from Blackzarak:

Hey fellas I just got BM66 about a week ago and got it all set up I came across a multiball problem when all 3 balls get lock it seems it won’t register the 3rd ball lock and the Playfield starts searching for the ball. Crane moves, Turntable spins around etc, eventually all 3 balls get release from the lock but it’s not treating as multiball. I search around found people with the same problem but no solution here’s the link
https://pinside.com/pinball/forum/topic/batman-66-lock-problem-no-multiball

What happens when you test the switches back there?

#12632 7 months ago
Quoted from Blackzarak:

Hey fellas I just got BM66 about a week ago and got it all set up I came across a multiball problem when all 3 balls get lock it seems it won’t register the 3rd ball lock and the Playfield starts searching for the ball. Crane moves, Turntable spins around etc, eventually all 3 balls get release from the lock but it’s not treating as multiball. I search around found people with the same problem but no solution here’s the link
https://pinside.com/pinball/forum/topic/batman-66-lock-problem-no-multiball

At least 1 switch is not closing when the balls are in the lock. The same happened on my game because the bracket holding the switches in place was slightly loose (stripped wood screws). Once I fixed the loose bracket, it was all good. Your switch bracket probably isn't loose, but the switch arms are likely not pressing down enough from the balls sitting on top of them. You may need to slightly bend the switch arms up a bit.

Go into test mode, manually put 3 balls in the lock. Make the the turntable is in the position with the batcave facing the player. You can use the game turntable diagnostics to put it in place. Then go into switch test and see what switch isn't working right. Start by just adjusting that switch. Hopefully that is all it takes.

Rob

#12633 7 months ago
Quoted from Rob_G:

At least 1 switch is not closing when the balls are in the lock. The same happened on my game because the bracket holding the switches in place was slightly loose (stripped wood screws). Once I fixed the loose bracket, it was all good. Your switch bracket probably isn't loose, but the switch arms are likely not pressing down enough from the balls sitting on top of them. You may need to slightly bend the switch arms up a bit.
Go into test mode, manually put 3 balls in the lock. Make the the turntable is in the position with the batcave facing the player. You can use the game turntable diagnostics to put it in place. Then go into switch test and see what switch isn't working right. Start by just adjusting that switch. Hopefully that is all it takes.
Rob

Yeah I was just doing the above it's not registering on the 3rd roller switch so I added some blue tape to beef it so the leaf switch can click much easier.. I cut the tape nice fit between the button and the lever heres a picture... hope this helps someone else..
Thanks ROB for the reply and help
Cheers

20190310_172852 (resized).jpg20190310_172905 (resized).jpg
#12634 7 months ago
Quoted from Blackzarak:

Yeah I was just doing the above it's not registering on the 3rd roller switch so I added some blue tape to beef it so the leaf switch can click much easier.. I cut the tape nice fit between the button and the lever heres a picture... hope this helps someone else..
Thanks ROB for the reply and help
Cheers
[quoted image][quoted image]

Good to hear you got it sorted out. It was switch 3 on my game too that wasn't registering. I disassembled the turntable on my game to fix other issues and could not remember if you can get at the switches without some disassembly or not. It's a daunting task disassembling that thing for the first time, but it's actually not that bad. Stern (or somebody with skills) should post a video on how to do this.

I wish I could mount the turntable forward about 1mm because the gap sometimes interferes with the ball and hopefully main playfield edge not be prone to chipping in the future. Could we use a Cliffy here? However I just don't want to mess with it any more. I already had a lot of trouble adjusting it so it was level across all 3 positions. Eventually I put a cardboard shim under one of the 3 mounting places where the round playfield mounts on a large triangular plate. Now, I hear stories of people being told by Stern that the mini playfield isn't supposed to be the same level across all 3 positions, but that doesn't make sense. You absolutely do not want it even a fraction higher than the main playfield or it's going to cause a lot more airballs.

Rob

#12635 7 months ago

Today, my check gets mailed out for my Batman Premium. Ghostbusters took longer to sell, so I'm pushed to the April run, but woohoo, BM66 will be mine.

#12636 7 months ago

I’m hoping those code updates hit soon.

#12637 7 months ago
Quoted from cbdarden:

I’m hoping those code updates hit soon.

I didn't notice too many differences in the code (1.02.11) while watching the Stern Pro Circuit Finals, I did notice that Shame is now grayed out after failing him. In 1.02 when they made subsequent Shames single ball timed modes and it wouldn't gray him out after a failed attempt.

I didn't really notice if any of the lighting was changed, but I thought I saw new video clips in stage 2 of "enter Batgirl, exit Penguin".

#12638 7 months ago

Just a routine inspection of my BM66 and I find the VUK is missing a coil sleeve. Going through my old parts bins I find something I can maybe use and also find 2 CFTBL hologram motors. I know both motors are good, but one gearbox is apart because of a stripped gear.

Chances are slim, but I am going to inspect all the other coils to make sure there are sleeves installed.

Rob

20190312_170051 (resized).jpg

#12639 7 months ago
Quoted from Jahkub:

I didn't notice too many differences in the code (1.02.11) while watching the Stern Pro Circuit Finals, I did notice that Shame is now grayed out after failing him. In 1.02 when they made subsequent Shames single ball timed modes and it wouldn't gray him out after a failed attempt.
I didn't really notice if any of the lighting was changed, but I thought I saw new video clips in stage 2 of "enter Batgirl, exit Penguin".

Just watching some of that now on youtube. An interesting observation is that someone was playing their second Shame and it was still a multiball.

Rob

#12640 7 months ago

Were did you see that? I watched the youtube link and did not see anyone playing mad hatter to replay shame.
Of course you have 2 shames, each of them is a multiball the first time. But indeed now greyed out (like it should) until you play mad hatter. Then both should be single ball.

#12641 7 months ago
Quoted from Blackzarak:

Yeah I was just doing the above it's not registering on the 3rd roller switch so I added some blue tape to beef it so the leaf switch can click much easier.. I cut the tape nice fit between the button and the lever heres a picture... hope this helps someone else..
Thanks ROB for the reply and help
Cheers
[quoted image][quoted image]

Same problem form me. I bent the switch arm too far and snapped it. Had to replace with a new switch. After that things are working well.

#12642 7 months ago
Quoted from DavidPinballWizz:

Were did you see that? I watched the youtube link and did not see anyone playing mad hatter to replay shame.
Of course you have 2 shames, each of them is a multiball the first time. But indeed now greyed out (like it should) until you play mad hatter. Then both should be single ball.

I misunderstood the code change that was made then. I thought 1st Shame was multiball and any Shame after that wasn't.

Rob

#12643 7 months ago

I just ordered a B66 from Marco and won't get until after the Golden State Pinball Festival the weekend of May 17. I will take it home after the show. I've already been buying all kinds of mods and add on's for the game. Can someone educate me on the Batman and Robin topper? Are they not available for purchase? Or are they not making them anymore? Does anyone have one for sale?
Thanks

#12644 7 months ago
Quoted from bicyclenut:

I just ordered a B66 from Marco and won't get until after the Golden State Pinball Festival the weekend of May 17. I will take it home after the show. I've already been buying all kinds of mods and add on's for the game. Can someone educate me on the Batman and Robin topper? Are they not available for purchase? Or are they not making them anymore? Does anyone have one for sale?
Thanks

The Batman and Robin topper were exclusive to the LE and SLE versions of the pin; alas, these were not available as a separate purchase.

#12645 7 months ago

And if you happen to find an LE/SLE owner to sell you their topper you need them to sell you the control board (found only on the LE/SLE games) in the backbox to run it.

#12646 7 months ago
Quoted from jfh:

And if you happen to find an LE/SLE owner to sell you their topper you need them to sell you the control board (found only on the LE/SLE games) in the backbox to run it.

I think it's one of the best toppers Stern ever did. I don't have funds though even if they were available

Rob

#12647 7 months ago
Quoted from DavidPinballWizz:

Were did you see that? I watched the youtube link and did not see anyone playing mad hatter to replay shame.
Of course you have 2 shames, each of them is a multiball the first time. But indeed now greyed out (like it should) until you play mad hatter. Then both should be single ball.

I thought it was interesting in a tournament environment that the strategy was still to go for Shame first. But, considering the difficult setup of the game it was the obvious safest thing to do. Play the Shame multiballs and then maybe stack an Egghead with the main multiball later, but I don't think anyone got that far.

Rob

#12648 7 months ago

Problem now with the game is:

at home you play the bookworm/freeze combo and then go for some tuts and blow up your score
in competition you never play the above because the chance to succeed is too low. So you choose safety for a minimum of points you get with a shame + major

So it needs some balancing for the game to offer a better balance in usage of the minors to be a good competition game. Cause now it's played the same by everybody in competition.

#12649 7 months ago

My BM66 has lost the lower left side GI.
For the last few months it had been flickering on and off but after two or three games it would come back and stay on.
It is now completely dead. Left slings and outlanes are the only thing affected. Any ideas or thoughts?
This game was purchased April of 2017 and have updated the nodes per Sterns tech bulliten.

#12650 7 months ago
Quoted from Lilpro66:

My BM66 has lost the lower left side GI.
For the last few months it had been flickering on and off but after two or three games it would come back and stay on.
It is now completely dead. Left slings and outlanes are the only thing affected. Any ideas or thoughts?
This game was purchased April of 2017 and have updated the nodes per Sterns tech bulliten.

Are you certain its the entire GI string? Seems like every owner has had issue with the GI bulbs (specifically under the left sling) breaking, coming loose, or simply popping out. Before you get into technical trouble shooting at least try replacing those bulbs and test via the lamp test.

Promoted items from the Pinside Marketplace
$ 48.00
Cabinet - Other
ModFather Pinball Mods
There are 14614 posts in this topic. You are on page 253 of 293.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside