(Topic ID: 78709)

The Addams Family Club (TAF) | Members & Fans Welcome


By mima

6 years ago



Topic Stats

  • 3,566 posts
  • 401 Pinsiders participating
  • Latest reply 4 days ago by monkfe
  • Topic is favorited by 252 Pinsiders

You

Topic Gallery

There have been 1,140 images uploaded to this topic. (View topic image gallery).

TAF Thing Board Comparison Small (resized).jpg
82CB50C0-2701-4BF6-BF3D-AB51CB5FE2AB (resized).jpeg
800px-WPCPowerBoxInside (resized).jpg
IMG_20200122_221943955 (resized).jpg
Photo Jan 19, 7 26 12 PM (resized).jpg
Photo Jan 19, 7 11 27 PM (resized).jpg
Photo Jan 19, 7 11 16 PM (resized).jpg
Photo Jan 19, 7 05 09 PM (resized).jpg
Photo Jan 19, 6 49 21 PM (resized).jpg
Photo Jan 19, 6 49 11 PM (resized).jpg
Photo Jan 19, 6 50 04 PM (resized).jpg
7f336f318d27168fa5d871dc54a92f9b (resized).jpg
BD080232-B757-427E-B9CA-2CF78D5F8CE7 (resized).jpeg
20200104_095014 (resized).jpg
20200104_095006 (resized).jpg
B083B26C-FEC2-4CE8-B4DF-F57F916C6A8E (resized).jpeg

You're currently viewing posts by Pinsider fiberdude120.
Click here to go back to viewing the entire thread.

#157 5 years ago

4 months later
#240 4 years ago

Love the legs on the CFTBL. Where did you get them?

5 months later
#367 4 years ago

trab where did you get that uncle fester with the elwire? That looks great.

3 weeks later
#370 4 years ago

trab, I got the idea from you and this is what I came up with. I think it look great.20150916_125209_resized.jpg

1 month later
#408 4 years ago

I would rather have a stock one so if I was to add anything it would be what I want.

#411 4 years ago
Quoted from wantdataeast:

I have an impossible time removing this piece the phone is attached to (the blue plastic assembly).
It is held in by two Phillips head screws which are tough to reattach once you have removed the plastic assembly.
Any advice on dealing with the bugger is appreciated.

Magnetic screw driver and a little tweaking is how I got mine done.

2 months later
#464 4 years ago
Quoted from Ckykedworld:

Tomorrow color dmd and fester mod.

20150916_125209_resized_(resized).jpg

1 week later
#484 4 years ago
Quoted from lllvjr:

Can I just buy this done

I already had lester so I built this one with some elwire I had laying around. The wire cost me less than ten dollars. It is a great mod and goes with the game well.

2 weeks later
#526 4 years ago
Quoted from hawkmoon:

I'm asking cause mine has been upgraded to gold and i'd like to "make it so " Thanks!!

There is no updating to gold, it either is a gold or it is not.

2 weeks later
#545 3 years ago
Quoted from nightsearcher:

Who sells Blitz wax?

A lot of places,the pinball suppliers and on line like amazon and some auto parts stores.

3 weeks later
#614 3 years ago
Quoted from delt31:

2) My divider on the ramp when triggered by a ramp shot violently turns and hits the side of the wall (left side). How do I make it so the mechanism when turning to the left (which allows the ball to go down the left side ramp and out the ball hole, to not hit the wall?

Mine does the same. I have owned mine for some 15years and I thought that was normal.

1 month later
#711 3 years ago
Quoted from JasonJoe:

Currently has no mods..... Suggestions?

Don't go overboard. Its nice just the way it is.

1 week later
#719 3 years ago

Very nice,it looks great.

1 week later
#742 3 years ago
Quoted from Miguel351:

Could be just an intermittent thing.

2 weeks later
#762 3 years ago
Quoted from TigerLaw:

Does the color DMD not work with original ROMs?

It works with either ROMs.

2 weeks later
#821 3 years ago
Quoted from KornFreak28:

Hello guys!
Have any of you here installed the inner cab decals on AF?
Can you please tell me how you did it?
Does the PF absolutely have to be removed from the cabinet in order to install them?
Thanks!

I don't believe you have to take the playfield out but you could probably do a better job without it there.

1 week later
#843 3 years ago

I use a small allen wrench and put that thru the alignment hole on the play field so you don't have to look at the flipper you just hold it in place. You could also just tape it to the allen wrench and just tighten it from the under side.

2 weeks later
#968 3 years ago

My pf has a little play and when I put it down I make sure it is lined up for the shooter. You should be able to adjust it a little to make it work.

#985 3 years ago
#1000 3 years ago
Quoted from KornFreak28:

Hello!
By any chance, anybody know the part number for the flipper coil tubing? I searched in the manual and it does not list the part number. Thanks!!

If you are talking about the sleeve just go to marco and it will be easy to find.

6 months later
#1354 3 years ago
Quoted from AlexSMendes:

Just saw this TAF for sale down here... wtf is up with that dmd/speaker? What an f***ing ugly "mod"!?

I believe thats a Big Dots DMD from Boston pinball.

2 weeks later
#1362 2 years ago

Has the cabinet art ever been redone?

1 month later
#1397 2 years ago
Quoted from RussMyers:

I have definitely been able to remove and re-mount that assembly without removing the playfield.
I'll agree, it's a very narrow space to work in.
I can't remember what tools I used to do it, but it is possible.
I'm sorry that's not much help.
RM

I have been able to do it also but its been a long time. If I remember the plastics flex a bit and you can get it with a thin driver.

1 month later
#1453 2 years ago
Quoted from Syco54645:

Having a problem that if I shoot the bear kick ramp cleanly the ball will come off of the wire form every single time. I just shopped the game out and when I got the game the diverter was not working so I am not sure if it has always done this. I see no way to adjust it either. Anyone have any tips here? I have tried everything I can think of including adjusting the mounts for the wire form above the sling/swamp to putting a piece of double sided tape to act as a spacer behind the diverter plunger so that when it is at rest it is not too far into the ramp.

I would try adjusting the flap. It may be bent a little and throwing the ball off. Can you post a pic of the flap while at rest?

#1456 2 years ago

Checked your pictures and it looks like the flap is allowing the ball to hit the corner of the ramp and not allowing a nice flow for the ball. I would try to adjust the flap a little towards the right and see how that works.

1 week later
#1471 2 years ago

I am looking for some help. My TAF went from working great one game and than the next game it started resetting,the DMD is all garbled up,and the sound is messed up. Sitting alone it keeps going on and off by itself. I have a Khar daughter board in my tool box so I tried that but it does nothing to help.Also before it went out the flippers got real weak. Any thoughts would be great.I have had this game for over 15 years with no problems.

Thanks in advance.

#1475 2 years ago

Thank you Ericpinballfan. I will get parts and reply back when complete. Thanks again.

#1483 2 years ago
Quoted from Ericpinballfan:

The grey disk wears out and wont hold power flow properly. Since your in the box, not always easy to unscrew and get out and off, might as well replace both.

Quoted from fiberdude120:

Thank you Ericpinballfan. I will get parts and reply back when complete. Thanks again.

Got the parts today,installed and the game works like a champ. Thanks Eric that saved me a lot of headaches.

2 months later
#1625 2 years ago

My level has 5 lines on it and the clear ramp is a replacement. I wish I had a clear ramp,they look better than original.

1 week later
#1637 2 years ago
Quoted from drummermike:

I am going to cut mine and bend up the corner.

Years ago I just bent a piece of stainless steel and riveted it in place and worked great.

#1639 2 years ago
Quoted from drummermike:

I thought about that also. The Mantis was cut, bent then welded. I think it will work without the weld. The ball does not drop in hard.

I agree

3 weeks later
#1677 2 years ago
Quoted from SeaLawyer:

So my lower left GI lights were out. F110 fuse was fine. Wiggled the J120 connector a little and they came on dimly, but were flickering. Disconnected the connector a couple of times and then reseated, and the lights are no longer flickering, but definitely dimmer on the left side. Faulty connector?

You could try looking for a solder joint around the pin on the board. Sometimes a crack around the pin can cause a drop in voltage.

1 month later
#1812 2 years ago
Quoted from jimmyb:

WANTED. Addams Family head. Need a head as mine is hurting. Empty or full is fine. Also need the cloud. Any out there? Thanks.

If all you need is the head you may be better off building the head or getting one of those flat pack ones you put together yourself.

1 week later
#1826 2 years ago

The bookcase rubber can also be cleaned and than put a decal over it.

1 month later
#1921 2 years ago

No interest here.

1 month later
#1983 1 year ago
Quoted from Svend:

Hi guys, I've got an issue with my recently aquired TAF which I can't quite figure out. This is a 'normal' 1992 TAF which runs the LX3 Gold Roms (I purchased it this way).
When I open the coin door, the service buttons/volume buttons do not work. You can hear the noise/beep when you press them, but the display reads 'open coin door to use service buttons'.
My first guess was that there would be acid damage. I drilled out the backbox lock (keys were lost) and yes there are leaking batteries (batteries from June 2015), but it does not seem to have affected the board. I attached a photo of this. The battery holder will of course be removed asap.
Also, after removing the batteries and starting the machine (factory defaults) the coin door buttons work, once. I can change settings and save them as normal. After leaving the adjustmens/test menu's however, it's back to the 'open coin door' message (coin door buttons still generate a sound).
Now, I've checked for a coin door switch but this does not seem to be present in my 1992 TAF. So now I'm wondering, do perhaps the TAF Gold roms expect a coin door switch to be present and be activated for the service buttons to work? Do I need to install a jumper somewhere in order to fake this coin door switch?
All ideas are welcome. Thanks!

Check all the connecters under that battery mess you have going. Mine did the same and I found some bad pins in the connecters.

1 month later
#2095 1 year ago
Quoted from SeaLawyer:

$6K? Maybe 2-3 years ago? Now, no way. $6K for a basket case, MAYBE. Agree with MMR: $7K min for nicely shopped TAF if you get REALLY lucky, but more realistically, $8K+.

$8K? I think mine would be on a truck heading to the lone star state as we speak.

#2098 1 year ago
Quoted from mmr61184:

What condition is it in is the key?

I have had mine for about 15 years and I paid $900 for it back then. Its in really nice shape. Are they really going for $8k now? I dont think I have seen that.

1 month later
#2183 1 year ago

Heres mine

20150916_125209_resized (resized).jpg

3 weeks later
#2214 1 year ago
Quoted from Frax:

Okay, a sawed off screwdriver now that's some funny sh... LMAO!

Those are not sawed off drivers. They come with a little handle to turn them,they come in very handy.

#2218 1 year ago
Quoted from Frax:

Okay, but I could theoretically make one by sawing off a screwdriver. More seriously though, is there a part number for those things?

http://www.monotaro.sg/g/00213094/

1 month later
#2240 1 year ago

Yes the swamp drains the ball.^^^^^^^

#2247 1 year ago
Quoted from SeaLawyer:

Installed my latest mod last night:

How did that panel mod work on TAF? I didnt think it would work for that game with the thing lights across the bottom.

1 month later
#2304 1 year ago

Help needed. My chair kick out coil will not kick the ball out once shot into chair. I have been checking everything I can think of,when I ground the coil it fires as it should,I have 70 volts at the coil and the tip36c trans tests good. I have checked the wires from the coil to the boards and they seem good. All fuses are good and I am at a loss at this point. Any help would be fantastic. Thanks in advance.

#2306 1 year ago
Quoted from LTG:

I'd use a meter and check them to figure out which wire has a break, from coil to board.
LTG : )

Did that LTG and the wires all test good.

#2308 1 year ago

Perhaps I should pull the board and check joints.

#2309 1 year ago

I am going to pull a ribbon cable from another machine and try that

#2310 1 year ago

swapped known good ribbon and still not working.

#2312 1 year ago

When I ground the tip120 it fires the coil can I assume that it is good?

#2313 1 year ago

Does the tip120 tell the tip36c to fire and the tip36c could be bad?

#2318 1 year ago
Quoted from LTG:

Transistor legs to coil is good. That test doesn't mean transistor is good or anything upstream from it is.
LTG : )

Quoted from dnaman:

Have you checked the switch? Never looked to see whether it is a switch or opto

Quoted from pintechev:

It’s a switch. Game will only eject the ball if the switch says to.

Transistor went bad. Took board out found bad transistor replaced it and it is good to go. Thanks for all the help.

#2322 1 year ago

Does anybody know where to get a clear ramp? Marcos says they are out of stock for 2 or more weeks.

#2324 1 year ago

Thank you LTG, all ordered.

1 week later
#2339 1 year ago

I have mine wired to the left side as described above.

20150916_125209_resized (resized).jpg
#2345 1 year ago

That would drive me crazy. I would try the freeze method and see how that works. Go easy until you are off the insert decal or you could lose them.

1 month later
#2473 1 year ago

It looks to have a line around the whole mansion perhaps a decal?

1 week later
#2527 1 year ago
Quoted from fatality83:

Can anyone who did the uncle lester mod tell me where they got theirs from. I bought one from some vendor at the white rose show this year. I got him home and noticed the LED in his mouth is white instead of yellow and that the figure himself is a hard plastic instead of the rubber I heard the other ones are. I installed him and after having him fall out of the chair several times I tried double sided tape but he wouldn't stick to that. To make matters worse, he got decapitated by a ball after falling out the chair the last time. Can anyone give me insight on what their uncle lester is made out of, where they got him from and how they attached him to the chair?

I got mine from a seller on ebay a couple of years and he is made of hard rubber. He is a tight fit in the chair and doesnt fall out. I will see if I can find where I got him from and PM you.

3 months later
#2724 1 year ago
Quoted from PTHermes:

I just installed Judge Dread's beautiful rose shooter rod.... now the ball won't make it all the way up the ramp. Anyone else have that problem? I am guessing I need to order a stiffer spring to compensate for the heavier shooter rod, just looking for advise on what stiffness to order.

Check the length of the new rod compared to the original.

1 week later
#2751 12 months ago
Quoted from Ericpinballfan:

Anybody getting the CPR mirrored backglass for Addams, 3 versions available.?

Had no idea that there was one.

1 week later
#2796 11 months ago

Hi guys could anybody tell me the wire gauge for the switch wires that plug onto j208? I think its 22 but just wanting to be sure before ordering the plug. Also the plug spacing.
Any help is appreciated.

1 week later
#2821 11 months ago
Quoted from pghpinfan:

Anyone put a new playfield in their TAF? If so where did you purchase? Is it worth getting a Gold playfield instead of the Silver or bronze levels?

If you are getting a gold I believe CPR is out of them but there are other places to get one. If I was going to do the swap I would get the best I could find. I have a very nice gold that I am thinking of letting go. If interested PM me.

2 months later
#2968 9 months ago
Quoted from Lhyrgoif:

One of my flashers for the cloud in the topbox won't work. Looking at the PCB for the twist-socket the contact points looks very worn. I've tried to find someone selling these PCBs but can't find them.
An ugly solution would be to simply solder the two cables directly to the black lamp socket, but that feels like a last resort.
I'm guessing trying to flow some solder over the missing parts won't work at all; perhaps wrapping tin-foil to replace the missing parts? I'm hoping someone here have a better fix for my problem.
[quoted image]

I would try re flowing the solder on the board first.

2 weeks later
#3018 8 months ago
Quoted from Extraballz:

I’m owned TAF in the 90s. Nice machine. I paid 2K for it and yes I wish I held onto it.

I paid $600 for mine back in the late 90s and still have it.

1 week later
#3049 8 months ago

Help needed please, My TAF wont boot up anymore. When I turn it on LED 19 and 21 light but it stops at that and nothing lights on the playfield. Sometimes LED 20 will flash one time like there is a rom problem but not all the time. I swapped ribbon cables with no luck and I even tried another set of roms that I believe are good with no luck. The game worked great last time it was turned off. Any help is much appreciated, thanks.

#3054 8 months ago
Quoted from Lhyrgoif:

My uppermost target switch at the swamp entrance is constantly being bent backwards (into the swamp) quite a bit. The switch registers but it's annoying to bend it back all the time and it looks bad when bent.
The two lower switches doesn't seem to have the same problem (guess it depends on ball angle/velocity for the different targets and the fact that the lowest one have the steel assembly directly behind it to act as a stop).
I know there are reinforced targets but I can only find oblong ones and the swamp targets are round. I've been thinking about making a sturdy metal piece (with drilled holes to fasten using the target screws) to put behind it and act as a stop. Anyone recognize this problem and have any good solutions?[quoted image]

It should have the same metal back as the others to keep it in place.

3 weeks later
#3087 7 months ago
Quoted from jetmechinnc:

Ordered a new opto board for thing and book shelf as well as some wire harnesses for both thing and the book case. Game is frustrating me and sorry at times I bought it. Game played great the first couple of months. Now thing sometimes doesn't pick up ball. Then I test it, optos work, game plays fine. Then stops again and in thing test, opts don't work. 1 opto went out in the bookshelf right after I bought it. Figured I was OK with that, but now thing is acting up. Plus, at time you start a thing multi ball, book shelf opens, ball is kicked out either at swamp or shooter lane, then book shelf closes, no multi ball. CPU issue? Game rom I think is L4. Maybe need new board with updated chips? Coming really close to selling at a loss even after replacing so much stuff.

I feel your pain, sometimes I feel the same way.

3 weeks later
#3144 6 months ago
Quoted from Durzel:

Where does the blue pad go? Any photos?

On the bookcase so when the ball hits it ,it is not striking the hard plastic.

1 week later
#3176 6 months ago
Quoted from jp1985:

Can anyone recommend specific mirror blades for TAF? Pictures would be helpful too.

I put a set of Power Blades on mine and they look great. I believe they were the Metallica creeping death ones.

3 months later
#3409 76 days ago
Quoted from Walamab:

Hello everyone!
I'm not a member yet but hope to be soon. I am gathering parts and pieces in anticipation of restoring a project machine (That I do not yet own).
Does anyone have a source for the 2 5/8" switch bracket (01-9476-4) that is part of the ramp assembly? Marco has a listing but it has been out of stock for a long time https://www.marcospecialties.com/pinball-parts/01-9476-4 . Is there a way to modify/use the 2 1/4" switch bracket (01-9476-2) that is also a part of the ramp assembly? (Since it is shorter I would think not).
Thanks in advance for any advice you can provide!

if you dont have a machine yet, how do you know you need that?

1 week later
#3429 63 days ago
Quoted from Skyemont:

Can we see pics of inter side Art? Like mirror blades. I can’t find any I like.

I put a set of power blades on mine and love it.

#3434 63 days ago

I was just going to post a pic but with the thumbs down I think I will let you figure it out for yourself.

1 week later
#3456 53 days ago
Quoted from Ericpinballfan:

I have Metallica creeping death powerblades they're pretty damn cool.

I have the same ones in mine and love them.

#3457 53 days ago
Quoted from fiberdude120:

I have the same ones in mine and love them.

I did have to customize the cabinet a little to make them work. There are no holes in the power blades to except the pivot bolts for the head. Instead of cutting the power blades and risking destroying them I recessed the bolts into the wood inside the cabinet. The only problem is to remove the brackets if I needed to would be to remove the blades first. It is a fairly easy job and worth the results.

#3461 52 days ago
Quoted from SeaLawyer:

I've seen that video. But that doesn't show me what it looks like in a TAF...

It looks the same just with an Addams family playfield next to them.

#3476 48 days ago
Quoted from Skypilot:

6K in it hard costs. This one was never about the bottom line. I just wanted to let the people at my Brewery enjoy a restored classic. I will not get hurt on this but profit,well we will see.

Well done its not always about the money, the journey is half the fun.

1 week later
#3496 36 days ago

Just came across this picture. Its cousin It during filming back in the 60s showing his face on set.

7f336f318d27168fa5d871dc54a92f9b (resized).jpg
1 week later
#3526 26 days ago

Any help here will be appreciated. One min my TAF worked fine and now when switched on I get a garbled dmd and all the leds on the boards stay lit. No action on the playfield at all. Any thoughts before I start to dig in? Thanks in advance.

#3528 26 days ago
Quoted from drummermike:

Reseat ribbon cables.

Already tried that and tried new ones to no avail but I am going to try again. I will report back.

#3530 26 days ago
Quoted from robgo777:

Here is where I would start.. this is pulled form Clay's troubleshooting steps for a Non-Booting machine...
Dead CPU Step One: Remove the Ribbon Cables.
Before you do anything, turn the game off and remove all the ribbon cables from the
CPU. This will issolate the CPU from the driver board, the dot matrix display board,
the sound board, the fliptronic board (if your game has one), and any other
connecting boards. The ribbon cables are at connectors J201, J202, J211, and J204
(on some games). While you're at it, you might as well remove the switch
connectors at J205 to J209, and J212. The only connector still attached is J210 (the
power connector).
After everything is removed but connector J210, turn the game on. If the CPU board
boots correctly, the lower LED (+5 volts) should be on, the middle LED (diagnostics)
should be blinking continually, and the top LED (blanking) should be off. If this is the
case, turn the game off and replace the ribbon cables, one at a time, and turn the
game back on.
Start with replacing the the driver board to CPU board ribbon cable first. Chances
are good the CPU board will still boot with this cable connected. Next try the other
ribbon cables. If connecting the other ribbon cables stops the CPU board from
booting, chances are good the TTL chips across the top of the CPU board are the
problem (U1,U2,U3 on all WPC revisions).

With all that said it seems with all the ribbon cables plugged up, the CPU will not boot but when I unplug the ribbon to the dot matrix control board #601 it boots but will not start a game and the display is dark.

#3531 26 days ago

I think I can swap my CPU with my FT to check and see if that works.

#3533 26 days ago
Quoted from robgo777:

That or you can try swapping the display board with the FT to see if it boots.

I tried the display board with no change. I will try the FT CPU but will have to change the chips also. I need to change just the one chip correct?

#3538 24 days ago
Quoted from robgo777:

If connecting the other ribbon cables stops the CPU board from
booting, chances are good the TTL chips across the top of the CPU board are the
problem (U1,U2,U3 on all WPC revisions).

Is there a guide on testing these with a DMM?

#3540 24 days ago
Quoted from robgo777:

Did you swap out the MPU from your FT? If so, are you getting the same results?
Rob

yes I did and I also took the boards and put them in FT and with the same results.

#3542 24 days ago
Quoted from robgo777:

Not sure I follow...
So you pulled the MPU out of the FT, replaced ONLY the game rom, and put it in TAF with everything connected and still won't boot correct?
Then you put what "boards" from TAF into your FT to cause it to not boot? What happens when you only put the MPU from TAF into the FT after installing the FT rom on it?
Rob

I took the dmd board from TAF and put it in FT and all was good. Then I swapped game ROMs and installed TAF CPU in FT and it gave me the same issues I had when they were in TAF. Swapped everything back and FT works again. One of the legs on TAF game ROM broke putting it back in so I ordered a new one and I will have it this week. I was hopping I could somehow check U1,U2 and u3 in the meantime. Is there a better way to go about this? I am all ears.

#3547 23 days ago
Quoted from robgo777:

Were you ever able to try the FT MPU with just the TAF game rom in the TAF to see if it would boot or did your ROM break before you were able to test that?

Yes the leg broke when I removed it so I did not have the chance to try the FT board in TAF. The new ROM came in the mail today so I will try the FT board in TAF in the morning.

When I put the FT rom in TAF board it acted just like it did in TAF non working.

#3548 23 days ago
Quoted from Ericpinballfan:

Maybe its time to check the voltage at the power box. The first part of any restoration IMO, is to replace the termistor and varistor in power box. They are old in 99% of all machines, old originals. Many problems with the dmd board and display come from low current at those 2 safety features in power box.
Image is from pinwiki.[quoted image]

I had a problem a year or so ago and I changed them and that took care of that.

#3551 22 days ago
Quoted from robgo777:

That means the other TAF game ROM isn't the culprit.
Did you try swapping U4 and U8 and re-seating U9 to see if you can get it to boot in the FT?

Narrowed it down, I got the new rom and installed it on my FT cpu and TAF fired up and plays as it should. Put the new rom in the original TAF cpu and the problem is still there. I guess its time to send the old board out for repairs.

#3553 22 days ago
Quoted from robgo777:

Maybe... maybe not. Did you try my suggestions about U4, U8 and U9?

No I did not but I will try that. I do not have the tool for the u9 but I can check the other 2,u8 is an nvram but I do have a few new extras laying around. Is there any safe way to remove u9 without the proper tool?

#3555 21 days ago
Quoted from robgo777:

I wouldn't advise it... here is one from Amazon though..
PHONSUN PLCC IC Chip Extractor Motherboard Circuit Board Component Puller and U Shape IC Chip Extractor Puller ROM Extraction Tool Kit + PHONSUN Portable Cellphone Holder USA amazon.com link »

Ordered, will report back in a day or two.

Promoted items from the Pinside Marketplace
From: $ 149.00
Playfield - Toys/Add-ons
Sparky Pinball
From: $ 20.00
Cabinet - Other
Rock Custom Pinball

You're currently viewing posts by Pinsider fiberdude120.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside