(Topic ID: 296199)

Bally Strikes and Spares...Flipping makes lights dim then blows 5a

By kgodwin333

5 months ago



Topic Stats

  • 5 posts
  • 4 Pinsiders participating
  • Latest reply 5 months ago by kgodwin333
  • No one calls this topic a favorite

You

Linked Games

No games have been linked to this topic.

    #1 5 months ago

    Hi. I'm putting my Strikes and Spares back together after a playfield swap. I have Alltek lamp driver and solenoid driver boards. When I flip the flippers the switched lights and the GI flicker, do it a couple of times and it blows 5a lamp fuse. It doesn't do it when the pop bumpers go so I don't think its a vibration thing.

    Any help would be appreciated.

    Kevin

    #2 5 months ago

    A lamp socket or wire to a lamp socket could be touching the flipper mounting baseplates.

    #3 5 months ago

    One or both of the End Of Stroke flipper switches might not be opening at full stroke.

    #4 5 months ago

    you say a 5A 'lamp' fuse is going open, but the 5A fuse is for the 43VDC being F4, for the coils.

    the 2 lamp fuses are F1 = 10A for switched lamps & F5 = 20A for the general illumination.

    check the voltage & amp ratings on all your fuses.

    #5 5 months ago

    Fixed !
    There was 2 separate problems, I hadn't gapped the the EOS and thats why the 5A coil fuse blew.
    I had 10 LED lights, when I swapped them out the flickering stopped. I checked the power hookup on my ALLTEK lamp board and I have it connected to the common side of the switched lights as they instruct, and I read voltage where I attached it. I have 4.9 volts at the transformer for the switched lights. Not sure why I can't run the LEDs.

    thanks to those who replied, saved me a lot of pain.

    Hey there! Got a moment?

    Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside