(Topic ID: 258868)

Bally/Stern mpu power?


By Nihonmasa

3 months ago



Topic Stats

  • 7 posts
  • 3 Pinsiders participating
  • Latest reply 89 days ago by oldschoolbob
  • Topic is favorited by 2 Pinsiders

You

Linked Games

You're currently viewing posts by Pinsider nihonmasa.
Click here to go back to viewing the entire thread.

#1 3 months ago

Hi there,

Have a Stern Lightning that refuses to boot.
When testing, the 5v is generated fine on the power board, but there is no 5v at the MPU.

I have seen in the schematics that this comes from connector J4 on the MPU; can someone lead me to where is the other side of this connector?

Thanks a lot

#3 3 months ago
Quoted from zacaj:

Probably J3-14 on the driver board. There should be a page in your schematics that lists every connector pin and what it connects to though.

Haven't seen it, using the ones from ipdb

No continuity with J3-14

#6 89 days ago

thanks both, solved Cold solder !

Now moving onto solving why all the displays are missing half of the segments

Promoted items from the Pinside Marketplace
$ 5.00
Playfield - Decals
Doc's Pinball Shop
From: $ 15.00
From: $ 18.00
Apparel - Men
Pinside Shop
$ 6.00
Cabinet - Other
Siegecraft Electronics
$ 44.99
Electronics
PinballElectronics.com
$ 119.95
Boards
Allteksystems
$ 149.95
Boards
Allteksystems
From: $ 155.00
$ 149.00
From: $ 140.00
$ 89.99
Playfield - Toys/Add-ons
Lighted Pinball Mods
$ 3.00
$ 54.00
Playfield - Toys/Add-ons
Lermods
From: $ 9.99

You're currently viewing posts by Pinsider nihonmasa.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside