(Topic ID: 35347)

Bally SS Mata Hari goes almost dead


By PinsRfun

6 years ago



Topic Stats

  • 52 posts
  • 13 Pinsiders participating
  • Latest reply 6 years ago by bestofthebunch
  • Topic is favorited by 1 Pinsider

You

Linked Games

Topic Gallery

There have been 2 images uploaded to this topic. (View topic image gallery).

bally_mpu_board.JPG
SDC10271.JPG

There are 52 posts in this topic. You are on page 1 of 2.
#1 6 years ago

When I power up the game, it will boot fine. I can play a game but if I let it sit in attract mode, the GI will be the only thing left on. No controlled lamps, can't start a game, no displays. I have to power off and on to get the game to boot up again. It has a replacement power supply board. The mods are done on the solenoid board. Do I have a flaky MPU board?

Sam

#2 6 years ago

Could be a lose socket on U10 on the MPU board.

Try re-seating it, carefully.

If that does the trick, replace the socket.

#3 6 years ago

Is the upper right header and connector repinned on the solenoid board? That particular connector needs to be clean and tight, and if you have not repinned it it is very likely that a gentle tug on the individual wires might pull one right out if it is very near completely failing.

How about the condition of your MPU...did it ever have corrosion from battery?

#4 6 years ago

I'll repin the headers on the solenoid board. The MPU board didn't appear to have corrosion damage. There has been some repairs done but I'll have a second look.

Thanks for the tips.

Sam

#5 6 years ago

By replacement power supply board I assume you mean rectifier board? What voltage to you have on TP1 of the SDB?

If it goes down after being on for a while I would think heat issue with connectors. The +5v is pretty critical so I would check everything that is in that string. Re-pin: J3-8 on the rectifier board, J3-12 on the SDB, maybe J3-25 on the SDB but this is not usually an issue, and J4-16 and 17 on the MPU. That will take care of all of the connections for the +5v from start to finish. Also, measure the AC component across C23 on the SDB, anything above 250mv and it should be replaced.

#6 6 years ago

C23 is replaced just due to age. The appropriate pins are done. Game is on and I'll let it go for a few hours and see how that goes and report back.

Sam

#7 6 years ago

Still went dead. TP3/TP1 is at 5.2V. I'm gonna concentrate on the MPU board next.

Sam

#8 6 years ago

Ground mod at J4-18, 19 on the MPU. I would start suspecting chip sockets.

#9 6 years ago

I'll do the ground mod on the MPU tomorrow. If that doesn't work, then it's sockets next.

Sam

#10 6 years ago

Connectors good on rectifier board? the 20 pin connector in particular. May want to remove the PCB from the heat sink & backplate and reflow the solder on every connector pin.

#11 6 years ago

The rectifier board is brand new. I could replace the IDC connector though down the road. The 5V seems to be good.

Sam

#12 6 years ago

Try twisting any IC in its socket and see if it kills or resets the game, if it does, replace socket.

See if you can pull any IC out with your fingers, if you can - even a little bit, replace socket.

See if any socket says SCANBE, if is does, replace socket.

#13 6 years ago

If your -17 MPU has the orangish brown sockets they are garbage and need to be replaced.

They are also a bitch to desolder. I wouldnt attempt this unless you can desolder very well. Need to pull the entire socket off at once, no pulling one pin at a time on this design.

#14 6 years ago

Ok, did the ground mod on the MPU. No help. Haven't replaced the sockets yet since I don't have them yet. I saw a strange behaviour though. The game would boot properly with 7 flashes everytime but a couple of times, after the 7th flash, a coil would lock on. I would have to power off. The game did this twice before it got into attract mode.

#15 6 years ago

That's funky...Bally's don't usually lock on coils unless the transistors are shorted. Vid has good advice for testing the sockets.

#16 6 years ago

I tried twisting the chips while the game was on to see if it would cause a reset and nothing. The chips are in there pretty good.

#17 6 years ago

Expanding on Vid's suggestion, gently tap on the MPU in various places, especially near the corrosion zone, to see if you can get it to lock up.

#18 6 years ago

I wiggled everything on the MPU, SDB, LDB, RB and no reset. I'm leaving the light board open with no backglass to see if the better ventilation has any effect on it.

#19 6 years ago

I'm watching the display alternate between the high score and the last game's scores and the timing (delay) between them seems to change over time. I don't know if that is just my perception. I watched it die once. There's no reset or anything. It just hangs. Could it be the 555?

Sam

#20 6 years ago

The 555 almost never fails. Infact i do not think i have ever seen one bad on a bally board. I only ever replace them when they are corroded.

What i would suspect....

Low 5v
Bad 12v / 5v filter cap (measure 12v on rectifier and driver board should be same and slightly high)
failing ground input to the driver board for the 5v regulation (tie this to master ground like shown in clay's guide)
Battery damage causing high resistance somewhere on mpu
U9, U7, U8 sockets failing. Once get warm connection breaks.
Failing IC that overheats. I have seen a 6800 and a 6810 get very warm and hang the software.
Try swapping around ICs

#21 6 years ago

Here is just one more possibility:
"Q5 gets Cooked by R11, and the Game Re-boots Intermittently.
Another strange problem relates to transistor Q5 (2N4403). This transistor is also part of the reset circuit (along with Q1), and is located right below R11, an 82 ohm 2 watt power resistor. The problem here is resistor R11 gets HOT, and is sometimes touching Q5. The heat is transfered to Q5, and this can cause the MPU board to suddenly stop running, and reboot the game. To fix this, provide an air gap between Q5 and R11. You should also probably replace Q5 too. If you replace R11, make sure you leave some "air" between R11 and the MPU board."

There can be many possibilities, and these intermittents can take a while to find. This page is full of great information:
http://techniek.flipperwinkel.nl/ballyss/rep/index2.htm

#22 6 years ago

The rectifier board is new. Tp1 and Tp3 on the SDB is 5.2V at the start and also when the game hangs. Tp5 on the SDB is 14V. I'll look at Q5 and R11. I'll report back again.

Sam

#23 6 years ago
Quoted from barakandl:

The 555 almost never fails.

I've had issues with C16 though, which controls the interrupt timing for the 555. I had a couple of games with flickery displays, and changing C16 eliminated the flicker. C16 is the 'chicklet' cap near the 555.

Also the timing for the 6800 is done at U16. There are two caps (C14,C15 I think) and two resistors near that chip that set up the timing for the 9602.

#24 6 years ago

I wouldn't chase anything else until you replace all of those sockets.

#25 6 years ago
Quoted from Xenon75:

I wouldn't chase anything else until you replace all of those sockets.

this.

#26 6 years ago

Are they the orange / brown sockets? If so i can almost guarantee that is your problem.

Q5 getting toasted by the 82ohm 2watt resistor is another good one to check. Every bally board i touch gets that resistor replaced.

C16 and a resistor (1k i think) control the display interrupt timing. They get chewed up by corrosion and i have even seen a bad C16 cause the game to run slow due to it flooding the cpu with interrupts.

#27 6 years ago

If your sockets look like these, brown/tan, that are crap and need to be replaced. You need to measure the AC component across C23 on the SDB and make sure it is below 250mv, 175mv or less is typical. I know you replaced the cap but you should still confirm the voltage.

SDC10271.JPG

#28 6 years ago

My sockets are black. Q5 was touching the resistor and I have separated the two for now. I will replace the transistor later (don't have a spare). Letting it sit in attract mode to see if separating Q5 from the resistor will help.

Sam

#29 6 years ago

Interested to see how this concludes. I have similar issues with my silverball.Was planning on repinning boards(have the parts,just have not done anything more) and doing the ground mods.My symptoms are similar other than on reboot it changes some settings like replay score and game credits at random.My MPU did have an acid issue before I got it.I attempted to change credits via dip switch but it would not change the setting
Good luck.

#30 6 years ago

It still died. I have the parts on order so once it arrives, I'll replace the sockets, various caps and transistors and see where it ends up. I'll report back.

Sam

#31 6 years ago

What's the best way to measure the voltage ripple with a cheap 20 dollar multimeter? I tried with setting it on AC and it read 30V. lol.

#32 6 years ago

i'm reading your thread and i had exactly the same problem and it was driving me nuts.

on my machine (space invaders) i did 3 things and one of those fixed the problem and still working great .

changed the chip at u8 (scm5101e-3).
changed Q5 transistor pnp (mps-3702) i saw one of the legs had a small crack, not completly broken.
unplugged all the connectors on the mpu board and checked every wires on those connectors. i doubt it was the problem.

did work for me, could work for you, hey you never know.

bally_mpu_board.JPG

#33 6 years ago
Quoted from PinsRfun:

What's the best way to measure the voltage ripple with a cheap 20 dollar multimeter? I tried with setting it on AC and it read 30V. lol.

Yea, I doubt it had 30v across it. Depends on what setting your meter has. If it just has standard scaling then you will probably look for something below .250 volts which is 250mV. Put one lead one each of the cap leads and then read the voltage, it is AC so the red/black orientation doesn't matter.

#34 6 years ago

I'll try q5 first as I don't know how long it has been in contact with the R11 and may be cooked. Then move to sockets and stuff. My multimeter only has 2 settings for AC. 200v and 700v. May not be capable of providing an accurate reading for mV.

Sam

#35 6 years ago

Could it have been .30v? If so that cap is on its way out and needs replaced.

Q5 fails all the time and i find them replaced at least one time on most bally boards. Probably from getting cooked by that resistor.

#36 6 years ago

I don't know if it means .30VAC without having a good reference. The cap is brand new. I can measure other caps to see if I get the funny readings.

Sam

#37 6 years ago

I set the multimeter on AC and put the two probes on GND and TP3 on the SDB. It gave a reading of 10VAC. I assume the readings are just invalid.

#38 6 years ago

I had a similiar issue and solved with Q5

#39 6 years ago

It honestly doesn't matter if you have the scanbe, RN or a particular color of socket. If you want a -17/-35 Bally game to be reliable change all of the sockets. The -17 boards are almost 40 years old now! Yes the caps/resistors/corrosion do cause issues but you have to have a rock solid base to start with before you start replacing individual components.

#40 6 years ago
Quoted from Xenon75:

It honestly doesn't matter if you have the scanbe, RN or a particular color of socket. If you want a -17/-35 Bally game to be reliable change all of the sockets. The -17 boards are almost 40 years old now! Yes the caps/resistors/corrosion do cause issues but you have to have a rock solid base to start with before you start replacing individual components.

This

#41 6 years ago

That's at least 4 people, maybe more didn't count..., saying sockets. Myself included.

Time to drink the cool-aid pinsrfun!

#42 6 years ago

After the cool aid, check TP1 and TP3 on the sdb. They both should 5vdc.

If not, the read this:

http://pinside.com/pinball/forum/topic/vids-guide-quick-bally-driver-board-repair-bulletproofing

Also, when it goes "almost dead" does the LED on the MPU still look like its lit (very dimly) or is it out completely?

When my Silverball mania was doing this, the led would go out completely. Re-seating U10, and ultimately replacing the incorrectly aligned SIP machine pin strips fixed the issue.

#43 6 years ago

Ok ok, I will replace the sockets too. Have to wait for the parts to arrive. When it hangs, the led is dimly lit. And the bulletproofing on the SDB has been done except C26 (part coming).

Sam

4 weeks later
#44 6 years ago

Sockets were replaced (6800, 6821's) but I don't get a fourth flash anymore. Replaced 6821 at u10 and same result. Traced every pin at the sockets and they all check out. I found a post where a bad ROM would give the first flash but fail at the fourth so new Roms are now on order with more mods necessary.

#45 6 years ago

Double check your U10 soldering work.

Flash 4 is u10, flash 5 is u11.

I doubt the ROMs are the issue as there checked first.

Also, make sure you didn't mistakenly swop the J1 connectors on the MPU and lamp driver. It can happen, they look the same...(per ninja) although I don't see how that's possible.

#46 6 years ago

I've checked the soldering a number of times and can't find anything wrong even with the schematics in front of me. That's why I am suspecting the Roms.

j1 is not the issue since I haven't touched the lamp driver at all.

Sam

#47 6 years ago

Did u use sockets, or machine pin strips?

Also, check for bent pins on the u10. It happens...

#48 6 years ago

If it was booting before and now after replacing some sockets it is not, recheck your work. Ring out every pin on the socket in all directions. Lesson 1 trouble shooting: "what was the last thing I messed with".

#49 6 years ago

The best method is divide and conquer. You really need to be certain that the problem is the MPU board first. A known good MPU that works in your game will verify that the wiring, connectors PSU etc... is all good and the problem is isolated to the MPU board.

If CERTAIN it is an MPU problem then there are some careful steps before willy nilly replacing sockets and making the problem worse if you don't have the knowledge of what your are doing.

#50 6 years ago

It is not going to be the roms. you likely have a soldering mistake at U10.

Now you need the test rom. With the test rom probe all the PIA outputs. Look for one stuck high or low. If you find one stuck high or low trace out that line and look for a short.

If None of the outputs are going high and low then one of the data or address lines is probably floating.

Use you DMM and check continuity from U10 to another IC.

Promoted items from the Pinside Marketplace
From: $ 45.00
Displays
PinballSolutions.eu
From: $ 140.00
From: $ 159.95
1,800
Machine - For Sale
New City, NY
From: $ 13.00
Electronics
Third Coast Pinball
There are 52 posts in this topic. You are on page 1 of 2.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside