(Topic ID: 154094)

Bally Special Force Flipper Flutter

By mtgedney

5 years ago


Topic Heartbeat

Topic Stats

  • 25 posts
  • 8 Pinsiders participating
  • Latest reply 5 years ago by Nokoro
  • No one calls this topic a favorite

You

Linked Games

Topic Gallery

View topic image gallery

image_(resized).jpeg

#1 5 years ago

My Special Force right flipper started machine gunning or fluttering when the button is engaged. It looks like the thin wire off the coil has separated thus not allowing the eos switch to do its job. Should I replace coil or can this wire be soldered back on? If so, where does it go?

#2 5 years ago

image_(resized).jpeg

#3 5 years ago

Resolder the wire. Which flipper is it? Take a pic so we can tell you which wire goes where. Probably don't need a coil as they rarely go bad.

#4 5 years ago

Same thing happened to me. I resoldered the wire and created a short that blew the fuse. Eventually bought a new coil. Maybe your skills are better than mine but if not just get a new coil. They're cheap.

#5 5 years ago

I just dealt with this, except the wire had broken and was too short to reach the lug. My tech delicately soldered on an extension, which didn't hold. We ended up replacing the coil.

If you've got plenty of coil wire to reach the lug, try soldering it back down. If not, get a new coil.

#6 5 years ago

My assumption is it needs to be soldered to the bottom most lug in the image above. It is the only one where there is no longer a connection. Solder it anywhere on the lug? Looks like there maybe a thin plastic coating on the wire from coil. Will this burn off enough to stay? Not a lot of experience with solinoids. Thx for your help. If this does not work I will replace entire coil.

#7 5 years ago

Yes there should be a connection on the bottom lug (banded end of diode). The other thin wire connects to the middle lug. You'll need to strip the coating very carefully. Too thin to use wire strippers and diagonal cutters typically cut right through the wire when trying to strip. You'll probably need to run it across the edge of a knife or sharp scissors.

#8 5 years ago

I have one lead from coil that is loose. Very thin. No thin wire to middle lug or bottom lug. I think I may be better off buying new.

#9 5 years ago
Quoted from mtgedney:

I have one lead from coil that is loose. Very thin. No thin wire to middle lug or bottom lug. I think I may be better off buying new.

Definitely

#10 5 years ago
Quoted from mtgedney:

I have one lead from coil that is loose. Very thin. No thin wire to middle lug or bottom lug. I think I may be better off buying new.

Yeah, those coils don't break the bank, and it can avoid a lot of frustration trying to solder that tiny wire back on properly.

#11 5 years ago

Well this is frustrating. So the back story to this fluttering flipper is I turned on the machine and due to a blown fuse the drop targets would not pop back up. I believe the machine was giving errors of weapon dt, top dt, etc... I replaced the fuse and restarted the machine. That is when the right flipper started fluttering. Then I noticed the thin wire and hence the thread (no pun intended). I replaced the coil and it worked once. Both flippers went dead. I restarted the machine to get the very same errors. Drop targets are not popping up. No flipper action. No solinoids. All fuses look good. I have not checked playfield yet. Any ideas?

#12 5 years ago

Do you have voltage at the coils?

Did you check the fuse mounted under the playfield?

#13 5 years ago

All playfield fuses good. I guessing something is wrong on the main board. All fuses are good. You cannot start a game when you get those errors for drop targets.

#14 5 years ago

Ok. I am worried something more concerning is going on with This machine. All fuses checked out. In self test not one solenoid fired. There is no power to any of them. I doubt all transistors are bad. Could it be a relay or other common item that has failed?

#15 5 years ago

Well I got it running for about a day. There was a common wire with bad solder job near top of the playfield. It may have been first in the line and prohibited current to other coils.
On to the next issue. Lost all coils with exception to flippers. Found playfield fuse blew. Replaced and now flippers are weak. I honestly haven't investigated further b/c I am nearly spent in these 6803s. So problematic. Hoping someone has idea where to start to tackle this issue...

#16 5 years ago

Were the flippers strong before? Check spacing of EOS switch. Also check other common weak flipper issues. Vid has a guide.

#17 5 years ago

Had almost the same set of problems on my 6803. Probably not pinside approved but my solution to the power supply issue was to clip and strip the wires back a bit and use a wiring nut to tie them together instead of using solder. Haven't had an issue since

#18 5 years ago

I am fairly certain it no longer has anything to do with the flippers. Blew the same fuse again tonight (1 amp playfield). Replaced and checked power at all coils. All good readings at 43 to 44vdc besides the weapons drop target coil. Reading like 2 vdc. Could it be a short in the coil? Seems like too much stuff to go wrong all of a sudden.

#19 5 years ago

diodes all hooked the right direction? just one wired backwards will send you into a spiral of chasing your tail. I had to have a friend bring his entire playfield over (yes there's 2 of these awesome machines in rapid city) and we plugged his playfield into my machine, and it worked no prob. hooked mine back up and popping fuses and giving errors. 1 diode. replaced backwards.

#20 5 years ago

It is doing all kinds of crazy stuff. I cannot get the coils to engage when grounded. They show 43 vdc. This should have nothing to do with transistors or the MPU. If you have 43 volts and is grounded, why nothing?

#21 5 years ago

If you have 43V and you're grounding the non-banded lug of the coil and it's not firing I can only think of two things. Bad ground or bad connector somewhere that can't handle the current.

#22 5 years ago

I also tried to fire them by touching the transistors on MPU. Still nothing? Has anyone ever heard of such a thing?

#23 5 years ago

I would check connectors for burnt pins and especially check the playfield fuse holder to see if the clips are loose or oxidized. Even the fuse itself could be bad and still test good.

#24 5 years ago

I am idiot. J6 connector upside down. Fixed.

#25 5 years ago

Glad you figured it out.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside