(Topic ID: 25089)

Space invaders Owners Club And Restorations Fans Also Welcome.


By Hellfire

8 years ago



Topic Stats

  • 416 posts
  • 88 Pinsiders participating
  • Latest reply 1 hour ago by GKW
  • Topic is favorited by 38 Pinsiders

You

Linked Games

Topic Gallery

There have been 277 images uploaded to this topic. (View topic image gallery).

IMG_20200808_141153615 (resized).jpg
IMG_0005[1] (resized).JPG
IMG_0003[1] (resized).JPG
IMG_0002[1] (resized).JPG
IMG_0001[1] (resized).JPG
IMG_0014[1] (resized).JPG
IMG_0013[1] (resized).JPG
IMG_0012[1] (resized).JPG
IMG_0011[1] (resized).JPG
IMG_0010[1] (resized).JPG
IMG_0009[1] (resized).JPG
IMG_0008[1] (resized).JPG
IMG_0007[1] (resized).JPG
IMG_0006[1] (resized).JPG
IMG_0005[1] (resized).JPG
IMG_0004[1] (resized).JPG

There are 416 posts in this topic. You are on page 8 of 9.
#351 1 year ago

After 5 months of getting to me. Its arrived. As Lara Croft would say... Jobs to do!

20200205_183132 (resized).jpg20200205_183204 (resized).jpg20200210_163918 (resized).jpg20200210_163925 (resized).jpg20200210_164006 (resized).jpg20200210_164419 (resized).jpg
#352 1 year ago

Yikes! Whatever is going on inside that lower cab is truly frightening. Who does that?!?!?!?!?!?!

A reimport? Wow. Check everything. And then check it again.

Shawn

3 weeks later
#353 11 months ago

Question, I bought a Space Invaders backbox a few years ago. Had it light up in the back but never had the chaser lights to work. Looking into that but the previous owners had decided to remove the wiroing, so I only have 2 wires. I need to test if all lights then burn. What if I would like to restore the wires.
How many wires are coming from that box? And are these going to the Auxilary lamp Driver? If I would buy a Aux lamp driver board, power that up and restore wiring would then the chaser light work. Or just go an arduino way of solution?

#354 11 months ago

The chaser light are run by an aux lamp board. You need one power wire that runs daisy chain style to each lamp and then individual wires that run to each lamp.

#355 11 months ago

Ok great, each light has it's own wire? That means 32 cables plus 1 power wire is going to that frame? Or is it divided by 4 sides so 1 wire adresses 4 lights Like the first, the second, third.....untill the eight of each row (with 4 rows). That would mean 8 cables plus 1 black one.

#356 11 months ago
Quoted from PeterG:

Ok great, each light has it's own wire?

It's 2 lots of 8 cables (16 individual lamp wires - 2 lamps share a wire). Refer to the Auxiliary Lamp Driver Board schematic. Note the blue wire in the door frame marked as ground should really be feature lamp 6.5VDC supply that's daisy chained to all lamps.

SpaceInvadersAuxLampBoard.jpg

#357 11 months ago

That's right, my mistake. What he said. (I was too lazy to look at the schematics and running off of memory.)

#358 11 months ago

Anyone ever had their game lock up, emit a long tone and then reset randomly? My game has been doing this as of late. When the tone is being played, only the GI lights and all the lights in the backbox with exception of the strobing lights are on. It has an Altek MPU board that came with the game when I got it last year.

#359 11 months ago
Quoted from ElCid95:

Anyone ever had their game lock up, emit a long tone and then reset randomly? My game has been doing this as of late. When the tone is being played, only the GI lights and all the lights in the backbox with exception of the strobing lights are on. It has an Altek MPU board that came with the game when I got it last year.

I would make sure the +5 regulator circuitry is stable.
From the transformer through the voltage reg. solenoid
driver board down to the input to the cpu.

#360 11 months ago
Quoted from ElCid95:

Anyone ever had their game lock up, emit a long tone and then reset randomly?

When you say "emit a long tone", is it two alternating tones like an alarm? If yes, what you're describing is a slam tilt condition which causes the game to reset.

#361 11 months ago

Quench, it is a single tone.

#362 11 months ago
Quoted from ElCid95:

Quench, it is a single tone.

Then it could be a power/connector issue as vec-tor was getting at.

2 months later
#363 9 months ago

Sorry for taking so long to reply to this thread with an update. I checked the wires and all seemed good on the transformer and I had previously repined the connectors on J3 on the solenoid/high voltage board and J2 that plugs into the Altek MPU board. What seemed to work was vacuuming out dust/debris on the transformer board and reseating J3. I keep the game on for about 30 minutes and played it a few times without any problems. Now to tackle my last problem of the right extra ball lane rollover to working. At least I know from the switch matrix that A4J2 -9 and A4J2-4 have been repined, so it's not that. Must be the actual switch or something in the wiring...

#364 8 months ago

Greetings!! Need help from any of you.

Could someone please send me closeup pictures of connectors on the lamp board, aux lamp board and sound board?
Manual its not accurate and it's missing the sound wiring diagram.

Need to determine if I have the correct color cables in order on those connectors from those boards, thank you in advance!!

#365 8 months ago
Quoted from arqpuebla:

Greetings!! Need help from any of you.
Could someone please send me closeup pictures of connectors on the lamp board, aux lamp board and sound board?
Manual its not accurate and it's missing the sound wiring diagram.
Need to determine if I have the correct color cables in order on those connectors from those boards, thank you in advance!!

Hope this helps
First 2 pics are of the auxiliary light board
The next 3 are light board
Last one is sound board
The connectors I had to remove to photograph are in the proper orientation top to bottom or side to side with the pins in the background.
Good luck!

20200605_200002 (resized).jpg20200605_200100 (resized).jpg20200605_200215 (resized).jpg20200605_200259 (resized).jpg20200605_200449 (resized).jpg20200605_201351 (resized).jpg
#366 8 months ago

I’m looking for a game to restore if anyone
Knows or thinking of selling one

#367 8 months ago
Quoted from PinZig:

Hope this helps
First 2 pics are of the auxiliary light board
The next 3 are light board
Last one is sound board
The connectors I had to remove to photograph are in the proper orientation top to bottom or side to side with the pins in the background.
Good luck!

OMG.!!!! thank you is not enough!!! I'm finishing my restoration and rebuild all connectors, but I suspect on those!! thank you thank you thank you. For taking the time.

best regards

#368 8 months ago

Greetings folks. I’m having an issue and it has me baffled. I just rebuilt all the flippers on my Space Invaders. When I fired it up it worked for a minute then died. Found that I blew a fuse. Replaced it and found the switch that wasn’t adjusted properly that caused the fuse to go. Fixed and adjusted. Now neither of the upper flippers will hold. They flip once then return to resting position. I’ve checked all the switches and fuses and still nothing. Any ideas? Thanks in advance.

#369 8 months ago

For having made 11,000 games I don’t see these for sale much ? Is $900 a fair price for a non working game but mint Backglasses

1 week later
#370 8 months ago

My game is missing what I think is a red 1 1/8 inch post to the left of the 3-bank drop targets. While I’ve got a replacement post, I would like to know what kind of screw attaches it to the play field.

B1B23DB3-A843-450D-A36F-5EA8CD1DC3EA (resized).jpegF5F9A007-8FCA-46DD-BDC2-1849FE323398 (resized).jpeg
#371 8 months ago

I don't have that post on mine, but to answer your question - look under the playfield - if the hole does not go through, its a regular wood screw about 1.5 ". A machine screw will have a nut on the underside. I think they are number 6 screws.

1 week later
#372 8 months ago

Well, I have been out of the loop for a few months...MOVING through this whole COVID thing. I am settled in to my new home and waiting for the game room/shop to be built so I can resume my SI rebuild. So, a few more months before I can work on anything again. My mind is going crazy so I actually started an electronics class to keep busy and hopefully increase by skills. The good news is that my 4 other pins have been cleaned and shipped and cliffy’s installed. So hopefully I can hit the ground running in a few months!

#373 8 months ago
Quoted from Damagio:

Well, I have been out of the loop for a few months...MOVING through this whole COVID thing. I am settled in to my new home and waiting for the game room/shop to be built so I can resume my SI rebuild. So, a few more months before I can work on anything again. My mind is going crazy so I actually started an electronics class to keep busy and hopefully increase by skills. The good news is that my 4 other pins have been cleaned and shipped and cliffy’s installed. So hopefully I can hit the ground running in a few months!

Keep me in mind if you want to move it on after you finish and start another project, been looking for a real nice one for a while now and LA is where i can get one on a boat to me.

1 month later
#374 6 months ago

I recently purchased my first pinball machine and it was one of my favorites as a teenager, Space Invaders. I noticed that some of the fuses were the wrong amps so I ordered a fuse kit to replace all the fuses. The kit came with 10 fuses, but I can only find a place for 8 of them. The 2 that I have left over are a 5A slow blow and 10A. Does anyone know where the go or if they are even used in this machine?

#375 6 months ago

Only noticed 8 fuses when I took a quick look in the manual (section XI. Parts List). 1A slo Playfield. 3/16A Sol. Driver/Voltage Reg., Rectifier 3/4A slo & 4A & 5A & 20A & 3A slo. And I only have seven fuses that I can find in my cabinet, which has the Stern SDU-100 solenoid driver board (no fuse!).

You have good taste. SI was my first solid state pinball.

#376 6 months ago

Thanks, this was my favorite to play as a teenager in the 80's. I've always wanted my own pinball and this is the one I wanted most

20200726_204423 (resized).jpg

20200803_191332 (resized).jpg
#377 6 months ago

I just finished adding LEDS and also added a light chasing sound syncing light strip to the under cab and back box

20200808_200810 (resized).jpg
#378 6 months ago

Sorry, but if you are going to use led on this machine use only warm white. Just my opinion. The colors are to much.

#379 6 months ago

First take, wow, also thinking too much color for my tastes. But I like the alien on the backglass, the way it really pops out. Imagine if the arcade had it looking like that back in the day.

Quoted from PeterG:

Sorry, but if you are going to use led on this machine use only warm white. Just my opinion. The colors are to much.

#380 6 months ago

I love the black and white look of spacies. That takes the best feature of the art away.

3 weeks later
#381 5 months ago

FYI, it appears that CPR has Space Invaders playfields back in stock
CPR_SI_FB (resized).png

1 week later
#382 5 months ago

The first game I bought! The last I would ever sell. From my cold dead hands.
Love seeing all your pictures. Such a rad game and back box.

Message from the Freek Kingdom.

#383 5 months ago

Been looking for a nice one for more than a year now.

#384 5 months ago

Yeah, they got played to death in the arcades.
I know guys that bought 2 or 3 NIB, it was so popular.

Message from the Freek Kingdom

#385 5 months ago

I've had it for 8 years plus now, not one failure! It's an FFing tank. I love it so...

Message from the Blue Pinscore Freeeek Kingdom.

20200920_193238 (resized).jpg
#386 5 months ago

Do any of you have ideas on this plug? I have replaced almost everything. Lamp board, aux lamp board, rectifier board, solenoid board. Resoldered all pins new crimped ends and plugs. But still cannot get all of the infinity lamps to light and some play field lights to light. All bulbs checked good bulbs to ground all light. My last resort is a new MPU board. I have resoldered all of those pins And reseated all chips. However the plug in the picture only has a blue wire on one side and not on the other. It does have power from the back glass side however. Any thoughts on my problems?

0B46A06C-C72B-42F4-8CD4-0BA760C39CB5 (resized).jpeg55DE17D4-6B92-497D-AD55-080E59E3F2C0 (resized).jpeg591D5640-122B-4419-8D2D-72558A56FB4C (resized).jpeg
#387 5 months ago

My plug is the same.
I'm no pro at diagnosing the Bally boardset, but from what you've said, the only things that really remain are checking the MPU, checking the wiring, checking fuses or looking for broken wires.

#388 5 months ago

Thanks for the info. A new MPU board will show up in two days. I will post my findings.

#389 5 months ago

Ok after replacing the MPU board. I finally found one broken wire in the j1 connector on the MPU board that fixed everything.

7F5EAF95-CECC-4976-AEF2-9A8B9ADFEC43 (resized).jpeg
#390 5 months ago

Glad you got it working again!

1 month later
#391 3 months ago

Hi guys, I’m looking for a decent space invaders playfield, I would like all of the art to be intact, or at least 95% of it.

I missed out on the cpr run, but would love to have a nice example I could restore

Please message me

1 week later
#392 3 months ago

anyone got an apron in good condition knocking about?

#393 3 months ago

I recently got a Space Invaders pin to repair for an operator who never used it on location. It is in excellent condition
and has no playfield wear. The mpu board has a lot of battery acid damage and the acid dripped down to the
lamp driver board below it. The corrosion prevents me from being able to desolder the corroded SCRs to replace
them. The game is also missing the solenoid driver board. I already have the replacement boards so that's
not a problem. In return for repairing the game, the operator gave me a LOT of boards, parts, manuals, rubber
rings, fuses, lamps, etc. He is retiring so he doesn't this stuff anymore. He might decide to sell the game. I already
have 2 widebody games (Paragon and Future Spa) so I really don't have room for this game. Still, I might make
room for it because this is the best Space Invaders I've seen in the last 20 years.

#394 3 months ago
Quoted from candyman:

I recently got a Space Invaders pin to repair for an operator who never used it on location. It is in excellent condition
and has no playfield wear. The mpu board has a lot of battery acid damage and the acid dripped down to the
lamp driver board below it. The corrosion prevents me from being able to desolder the corroded SCRs to replace
them. The game is also missing the solenoid driver board. I already have the replacement boards so that's
not a problem. In return for repairing the game, the operator gave me a LOT of boards, parts, manuals, rubber
rings, fuses, lamps, etc. He is retiring so he doesn't this stuff anymore. He might decide to sell the game. I already
have 2 widebody games (Paragon and Future Spa) so I really don't have room for this game. Still, I might make
room for it because this is the best Space Invaders I've seen in the last 20 years.

Looking for an exceptional one here if you decide to sell it. The agent ships out of LA is all though....

2 weeks later
#395 87 days ago

Just got one which has always been on my wish list.
Going to do a full resto, anyone have a new playfield they are willing to sell? If not I'll wait for next Cpr run.

USER_SCOPED_TEMP_DATA_MSGR_PHOTO_FOR_UPLOAD_1606547349621_6738347974705040043 (resized).jpeg
#396 87 days ago

Out of the blue just now I checked CPR for a new playfield ... and one showed up. That’s it. One. They’re sold out again. I’ve been waiting years for one. Mind blown.

9B828A06-4DF0-4ABB-96F3-9AD1404256D1 (resized).jpeg
#397 86 days ago
Quoted from pinster68:

Out of the blue just now I checked CPR for a new playfield ... and one showed up. That’s it. One. They’re sold out again. I’ve been waiting years for one. Mind blown. [quoted image]

Nice, I should have bought one a month ago, just don’t have a game to put it in. Some of my favorite art

#398 81 days ago

Does anyone know the type of back box lock SI uses.
I had to drill out the original one.

#399 80 days ago
Quoted from candyman:

I recently got a Space Invaders pin to repair for an operator who never used it on location. It is in excellent condition
and has no playfield wear. The mpu board has a lot of battery acid damage and the acid dripped down to the
lamp driver board below it. The corrosion prevents me from being able to desolder the corroded SCRs to replace
them. The game is also missing the solenoid driver board. I already have the replacement boards so that's
not a problem. In return for repairing the game, the operator gave me a LOT of boards, parts, manuals, rubber
rings, fuses, lamps, etc. He is retiring so he doesn't this stuff anymore. He might decide to sell the game. I already
have 2 widebody games (Paragon and Future Spa) so I really don't have room for this game. Still, I might make
room for it because this is the best Space Invaders I've seen in the last 20 years.

Got any pics?

#400 78 days ago

Well that was fast ... the new playfield has arrived from CPR.

BA777346-36E6-435C-B3D8-67F81F93006F (resized).jpeg
Promoted items from the Pinside Marketplace
From: $ 150.00
$ 10.00
2,650
Machine - For Sale
Forest Hill, MD
$ 149.95
Boards
Allteksystems
$ 84.95
Cabinet - Shooter Rods
Super Skill Shot Shop
$ 5.00
Cabinet - Other
UpKick Pinball
From: $ 170.00
From: $ 1.25
Playfield - Other
Rocket City Pinball
There are 416 posts in this topic. You are on page 8 of 9.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside