(Topic ID: 145350)

Bally playboy blowing fuses (Issue Resolved)


By DnDPins

3 years ago



Topic Stats

  • 39 posts
  • 9 Pinsiders participating
  • Latest reply 3 years ago by Shoot_Again
  • Topic is favorited by 5 Pinsiders

You

Linked Games

Topic Gallery

There have been 3 images uploaded to this topic. (View topic image gallery).

bally-color-codes.gif
playboy-wiring.gif
fuse-Breaker.jpg

You're currently viewing posts by Pinsider DnDPins.
Click here to go back to viewing the entire thread.

#1 3 years ago

I am very appreciative of those experienced technicians who respond to these tech help posts. In order to be considerate of their time, I have used Vids post as a template to provide the required information:

1) Bally Playboy 1978
2) Bought as a project pin and I am not aware of the last time it worked
3) Since it blows fuses, I cannot run diagnostics
4) Bought from a collector who took it in on trade. Based on the ball swirl, it was obviously routed
5) It does not appear that any mods were done
6) There are no aftermarket boards installed
7) No obvious battery corrosion
8) Incandescent lighting
9) No smell
10) No obvious past work performed...not even changing the rubber rings
11) I do have a Volt Meter
12) I can solder but am I little hesitant to solder on the boards. My brother does that for me though
13) I am in central NJ
14) I will post pictures tonight

Details on work we performed to date:
1) Repined J1, J2 and J3 going to the rectifier board (Most of J1 was showing connector burn and the first pin or two on J2 also had some burn)
2) Installed a new rottendog bridge rectifier board and verified all fuses
3) Plugged in only J2 and confirmed each test point had proper voltage
4) Checked under playfield to see if there were any visible issues. None found
No issues up to this point

Next re-connected all boards and the following fuses blew: (did get a green light on the MPU)
F3 4A, F4 5A and F5 20A (I heard a humming noise before the fuses blew)

Replaced the fuses and unplugged all connectors except J3 and J4 on the solenoid driver board and blew F3 and F4.

Other boards I have:
Since I have several Bally early SS machines using the same boards; MH, SnS, HG I have know good boards. Additionally, I have a spare Alltek MPU.

I have got additional fuses and am ready to continue troubleshooting, what are the best next steps? How do I narrow down the source of the blown fuses?

Thanks,
Dave

#5 3 years ago

I followed Cody's advice:

1) I unplugged everything from the rectifier board except J2 and only replaced fuse F3
2) Unplugged all connectors from the solenoid driver board (there are no connections anywhere on any other boards)
3) Turned on the power and F3 did survive
4) I installed a known good solenoid driver board and only connected J3 on the driver board. I connected J2 on the rectifier board and F3 survived
5) I now installed fuse F4 and F5. I connected both J2 and J3 on the rectifier board and J3 and J4 on the power driver board
Results:
Fuse F4 (5Amp) blew instantly all other fuses are fine

What next?

Thanks,
Dave

#8 3 years ago

Thanks guys.

1) Where do I get what I need to make / purchase the circuit breakers?
2) I was very careful and did confirm the cable codes when repining J1, 2 and 3 for the rectifier. I will now verify the pins on the connectors going to the power supply.

Note about POST:
When I first connected everything before I blew F3,4, and 5, I got a green light on the MPU. Also the coin door coin slot lamps were light.

How do I continue on with the SDB (known good) without blowing fuses; leave F4 out? I was not sure if F4 was needed to be in place. What should be my order of operations to continue through to post?

#11 3 years ago

OK...made some progress:

It turns out that I reversed two orange and green wires on J2 and J3 on the rectifier connectors. Once I fixed that I systematically plugged in all the connecters to all boards and no fuses blew. Additionally, everything works except ALL solenoids. I have verified the voltages at the rectifier board and they are all good and the SDB is a known good one. I was also able to run the diagnostics and no solenoids fire during that test. I also verified that the playfield fuse is good.

Is there any thing which globally disables all solenoids on the game?

Thanks,
Dave

#12 3 years ago

Bump for a little help!

#14 3 years ago

I measured all voltages at the test points on the rectifier board and they were good. I also confirmed that 45v is getting to the coils.

#15 3 years ago

Bump for a little help!

#17 3 years ago
Quoted from WonkoTSane:

Is the game fully booting? Do you get the correct flashes on the MPU? When you press the diagnostics button, does it go through the display tests, sound tests, etc correctly

The game does fully boot
I get 5 or 6 green flashes before it goes solid
I can get fully through the diagnostics. Everything...however when I get to the solenoid test, none are activated.

#20 3 years ago

Previously I was able to get the MPU to boot with 6 flashes and then the game would go into attract mode. If I started the game, none of the solenoids would fire but everything else worked. If the game failed to complete it's boot, would it still get to attract mode? I was able to run the diagnostics however none of the solenoids would fire.

Current status:
After swapping MPUs and SDB, I now have an MPU with the LED locked on. Even when I switch to a different MPU, the LED is still locked on. What does that tell us??? I would think it is not reset circuitry since it is the case on multiple MPUs.

OK...I think I have it narrowed down to 2 issues:
1) I get a little over 6v on TP1 on the rectifier board however on the SDB the 5v test points read a little over 4v. What could cause the voltage to drop 2v between the rectifier test point and the SDB? Bear in mind that the MPU was previously able to boot so therefore the 5v must have been good. I did have to remove the connectors a lot in the process.
2) I get 45v on TP 5 of the rectifier board and about the same to all coils (I did not check every one) on the playfield however for some reason I do not think the MPU is recognizing the 45v

All of this seems to point to connectors / cable issue. I already re-pinned all connectors going to the rectifier board and will order the smaller connectors so I can pin the others as well but for now, can someone point me to which pins on which connectors allow the MPU to read 43v and which one carries the 5.4 from the rectifier board to the SDB?

Help with this would be greatly appreciated!

Thanks,
Dave

#21 3 years ago

Bump for a little help.

1 week later
#22 3 years ago

Update:

I resolved the fuse blowing issue as I found 2 of the same color wires were swapped on 2 rectifier connectors. Once I repined and plugged everything in (except the sound card) the game plays perfectly. As soon as I plug in the sound card and power on the machine, the right sling solenoid fires and sticks on. I was able to clear that condition by unplugging everything and plugging back in without sound card however once I plug it back in, the right sling gets stuck on again.

I have verified all of the wires on the connector going to the sound card but I have not yet repined that connector. Is it possible that the connector could be causing this issue???

Thanks,
Dave

#23 3 years ago

Bump for "a little help here" (in my best Homer Simpsons voice)

#26 3 years ago

Thanks Vid and Cody I will check the sound board. I did swap in my Alltek MPU board and it works fine. Does that point to a chip on the original MPU? Which chip should I probe or order. (I am going to order a probe tomorrow)

Thanks,
Dave

#28 3 years ago
Quoted from dothedoo:

There have been so many fixes you need to state what's going on with the MPU. If the LED is locked on, try shorting pins 39 and 40 on the CPU U9 together.

The current state:
If the sound card is not plugged in, the game boots and plays without a problem. As soon as I plug in the sound card, the next time I power on the machine, the right sling shot sticks on (I quickly turn the machine off)

I can clear the stuck condition by unplugging all the cables and then as soon as I plug in the sound card again, the same thing happens. Seems like the problem is stemming from the sound card however I swapped the MPU with an Alltek board and it now plays fine. So seems like a logic problem on the MPU which is triggered by the sound card???

Thanks,
Dave

#30 3 years ago

Re-pinned J3 going to the solenoid driver board and now none of the solenoids fire (and I do not get the 7th flash at boot up) however the flipper work when a game is started.

Is there one or two pins I should specifically check to continue troubleshooting?

Thanks,
Dave

#32 3 years ago
Quoted from vid1900:

Did you try swapping the sound card with your HGT card?

When I swapped with my HGT sound card the same thing happened.

Quoted from cody_chunn:

That sound card uses the solenoid address data as control signals. Something is fouled up on that sound board causing one of the address lines to lock active.
Do you have a logic probe? Sound board J1 pins 1, 2, 3, 4, and 12 should all be pulsing...or around 2.5VDC measured with a meter.
What do you measure on those pins?

Since the same thing happened with the HGT sound card it would seem the problem is not the card. So what else can it be? Soundboard Connector? Other .156 connectors going to SDB?

BTW...I have a logic probe on order.

#34 3 years ago
Quoted from cody_chunn:

Fascinating. If it's not the sound board itself it's something to do with the inter-relationship between it and the other boards. When you tried the HGT board, did you mount it? I ask because isolating it from that back plane ground affects the circuitry. Have no idea why.
You posted earlier that you installed a alltek board and then the game worked properly? With the sound board connected? Is that accurate? And with the original MPU the problem recurs?

I mounted the board in the backbox in place of the original.

Since there have been a few phases of issues, I will review:
1) After replacing rectifier board with new Rottendog one and repining connectors, was blowing fuses. This issue stemmed from wires of the same color within 2 connectors being reversed. Once the reversal was corrected, the fuse blowing issue was resolved.

2) For a time, I had a case where I was getting a little over 6v on TP1 on the rectifier board however on the SDB the 5v test points read a little over 4v. I noticed that if I messed with J3 on the SDB the voltage increased and the MPU booted. This led me to believe the J3 SDB connector had an issue so I repined it. It seems that proper amount of voltage is constantly present now for the MPU to boot.

3) Current State - I swapped in known good SDB, MPU and Sound Boards in various combinations and have inconsistent results. Some times the games plays perfectly including sound. (with the exception of significant hum) With the game playing fully, I began to systematically re-introduce the original boards and as I do, a coil (different ones at different times) is locked on at machine start up. The fascinating thing about this is the issues spans boards. I figured, oh my solenoid is locked on in the logic but then as I swap the MPU, that same lock issue re-occurs with the different board....so I guess it is not logic. Then I swap out the SDB and again the same issue. Eventually, the condition clears and everything works until I try to swap boards again.

This seems to defy logic...my logic that is...

Thanks,
Dave

1 week later
#37 3 years ago

Something made me decide to open up the plug on the power cord and it turns out the ground wire was disconnected. I bet this is the cause of the odd behavior however once I start swapping boards again, I will be sure. For now I am marking this as resolved. Thanks to all for your help!

Dave

Promoted items from the Pinside Marketplace
From: $ 155.00
$ 21.00
2,500 (OBO)
Machine - For Sale
Fort Ann, NY
From: $ 18.00
Apparel - Men
Pinside Shop
From: $ 5.00
Cabinet - Other
Rock Custom Pinball
$ 10.00
Electronics
Third Coast Pinball

You're currently viewing posts by Pinsider DnDPins.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside