(Topic ID: 73629)

Bally Paragon no flash at mpu on power up. Solved.


By newtoit

7 years ago



Topic Stats

  • 16 posts
  • 6 Pinsiders participating
  • Latest reply 6 years ago by Deckmanmark
  • Topic is favorited by 1 Pinsider

You

Linked Games

#1 7 years ago

Im having trouble getting this paragon working. It turns on and the gen illumination lights but nothing else. No flash from the led on the mpu. I rebuilt the rectifier board but their is no voltage at tp3 all other test points are correct on the rectifier board.
I have also converted the roms U1/U2 & U6 and replaced U9.
Where does the 11.9v at tp3 come from... where should I check next?

#2 7 years ago

If I unplug J1 & J3 from the rectifier board tp3 has 13v.

#3 7 years ago

There is an orange wire on the 20pin rectifier connector that always burns up. I bet that is your problem as it carries 12v return. Repin the rectifier board. Probably need male and female redone.

#4 7 years ago

Check fuse F3 on your rectifier board also. Barakandl is probably right, guy knows his stuff, but you might get lucky with an easy fix.

#5 7 years ago

I repaired the whole rectifier board. New pins fuse clips rectifiers... everything. I did not replace tj3 the 20 pin connector. The orange wire doent look burned but ill replace the connector and get back to you. Thanks for the help

#6 7 years ago

Replace all fenale and male connections to the rectifier board. Nothing changed. I have correct voltage on all test points on the rectifier board except tp3 which should be 11.9 but it reads .4.

#7 7 years ago

Open fuse, open diode in bridge, open ac input wire from transformer

#8 7 years ago

Pardon my ignorance. By open do you mean broken?
Is the problem on or before the rectifier board? Could it be sometging else after the rectifier b oard because it reads correct boltage when j3 is unplugged.
Ill check everything you mentioned thanks for the help.

#9 7 years ago

The PinWiki guides are very helpful when trying to diagnose power/MPU issues. http://www.pinwiki.com/wiki/index.php?title=Bally/Stern

#10 7 years ago

Maybe there is a ton of resistance somewhere so when there is a load (j3 plugged in) the voltage drops way down (fuse clips, connectors, wiring hanging on by a thread). Maybe something j3 is connected to is shorted (the c23 filter cap on driver board perhaps) and dragging voltage down.

Isolate as much as you can with connectors so you can narrow your focus.

#11 7 years ago

I ordered a cap for c23 and c26. They should be here by the end of this week.

I have followed the pinwiki guide thus far. Rebuilding the rectifier board. Their next step says to replace c23. I'm on the right track. I will update once the new cap is installed.

#12 7 years ago

Well that was a no go. Installed the caps and no luck. Still no flash on the mpu led when I turn the power on. I measured the voltages with the wires plugged in and unplugged. Here arw my test point results. Some seem to differ from my previous tests

With only J2 plugged in rectifier board
tp1 - 4.5
tp2 - 150
tp3 - 2
tp4 - 6.7vac
tp5 - 44.5

With all connectors plugged in J1 J2 J3.
tp1 - 4.7
tp2 - 162
tp3 - 0
tp4 - 6.7vac
tp5 - 44

#13 7 years ago

Jut to be clear these are the test points on the rectifier board?

#14 7 years ago

1:00 am and I got it to boot. The white/black wire from the transformer directly to the back of the rectifier board was connected but had no continuity to the board. The wire is at E11 on the rectifier board. I resoldered it, turned it on Mpu flashed 7 times sound works and I was able to start a game. Its got other issues but ill leave that for another day and another post. Thanks for all the help.

Keep an eye out for my next post. Itll prob have to do with the displays. They would dim when I pressed the flippers.

4 months later
#15 6 years ago

This gives me great hope as I have (hopefully had) a similar problem. Waiting on a new board because the solder job was a hack job and probably ruined the card. Plus I had burnt connectors, so once all that is repaired I'm now highly optimistic.

#16 6 years ago

Arrgh. No dice. Brand new board AND I have a voltage on TP 3, where you did not. I guess I'll have to dig a little deeper.

Promoted items from the Pinside Marketplace
From: $ 12.00
$ 149.00
From: $ 5.00
Cabinet - Other
UpKick Pinball
From: $ 150.00
From: $ 1.25
Playfield - Other
Rocket City Pinball
From: $ 170.00
From: $ 20.00
Cabinet - Other
Rock Custom Pinball

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside