(Topic ID: 299190)

Bally Night Rider - one last glitch ugh

By AlexF

53 days ago



Topic Stats

  • 7 posts
  • 3 Pinsiders participating
  • Latest reply 51 days ago by AlexF
  • No one calls this topic a favorite

You

Linked Games

Topic Gallery

View topic image gallery

pasted_image2 (resized).png
Night 1 (resized).JPG
night2 (resized).JPG
pasted_image (resized).png
Bally_Night_Rider_Schematic.pdf (PDF preview)

You're currently viewing posts by Pinsider AlexF.
Click here to go back to viewing the entire thread.

#1 53 days ago

Ok I thought I had this thing all dialed in and now it's in a spot that requires me to move a bunch of stuff to service. Of course that's when it would develop a new issue. Ugh.

The problem occurs when playing a game and the ball drains. Sometimes after the bonus unit will count down, the drops will reset and then try to reset again. Even though they are up and ready. Some balls are fine with no issue. Other times it may try to reset 3 times before kicking the ball out. Sometimes it will also advance an additonal ball in play. Example advance from ball 4 to 5 after already advancing from 3.

I'm sure it's a slightly mis-adjusted switch somewhere. I checked the drop target reset relay, drop target unit switches and bonus unit switches. The bonus unit pulses also when this happens.

I suspect a score motor switch as that's where my last issue was discovered. Can you schematic guys school me once more. Sorry I'm not more intuitive with them.

Bally_Night_Rider_Schematic.pdf
#4 53 days ago

Awe man I played around and thought I had it. If I manually activated the outhole relay it would sometimes kick out and reset the drops and sometimes it would do it twice. Ugh. But if I held it in with a little pressure it would work every time. So I inspected that relay a bit closer. Switch adjustment looks pretty good but I discovered a loose screw in the switch stack. Tightened it down thinking that was going to be it but no dice. I'm frustrated and took a break. Have to dig a bit deeper some time this week.

My gut is the outhole relay needs a bit more fine tuning or a score motor switch isn't engaging long enough. I looked at 3A. Doesn't seem to be it.

#5 52 days ago

For follow up and future reference. Found this post on RGP that covers the same issue. Looks like I need to inspect score motor switch 8B.
https://groups.google.com/g/rec.games.pinball/c/mru-v3_aSc0/m/mH97UWK1QxMJ

#7 51 days ago

Score motor switch 8B adjusted and problem solved. So happy.

You're currently viewing posts by Pinsider AlexF.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside