(Topic ID: 155886)

Bally Lady Luck light problems


By Matt3200492

3 years ago



Topic Stats

  • 28 posts
  • 2 Pinsiders participating
  • Latest reply 3 years ago by Matt3200492
  • Topic is favorited by 1 Pinsider

You

Linked Games

Topic Gallery

There have been 2 images uploaded to this topic. (View topic image gallery).

image_(resized).jpeg
image_(resized).jpeg

#1 3 years ago

I have a Bally Lady Luck pinball I recently got and only half of lights are working on playfield. I looked in the schematics and it looks like only phase b lights are working and no phase a lights. Any help..

#3 3 years ago

There are two separate fuses for each phase from the transformer on the power regulator board in the head. May also be a cold solder or bad connection at one of those connectors.

#4 3 years ago

The fuses fu4 and fu5 look good. I checked voltages at tp6 and tp7. Tp6 is only getting 8.5 volts and tp7 is getting 11 volts as it should.

#5 3 years ago

Try checking down on the common wires for the two phases on the playfield. One with lights that work, the other with ones that don't.

If the unlit have no power, start tracing back that wire up to the head. I don't have the schematic to look at right now so I am not sure if the test points are before, or after the fuse clips. I suspect either bad fuse clip or bad pin in the playfield connector for the dead phase.

#6 3 years ago

Ok thanks. I checked the power before at the lights that were not working on the playfield and was getting around 8.5 volts and around 11 volts at the lights that were working. I measured at the wire going into light socket and then ground next to lamp sockets.

#7 3 years ago
Quoted from Matt3200492:

Ok thanks. I checked the power before at the lights that were not working on the playfield and was getting around 8.5 volts and around 11 volts at the lights that were working. I measured at the wire going into light socket and then ground next to lamp sockets.

If you measured voltage across the actual light socket like that, then the light bulb should be lit. 8.5 should still be enough to light a 6.3v bulb even though it's only one during half of the AC phase.

Any chance those bulbs are burned out?

#8 3 years ago

Yes I measured it at the wire going into back of light socket and the ground strap next to the socket. I have replaced all bulbs so it is not the bulbs. All of the phase a lights are out which is half of the lights on the playfield. I was told that the sockets should always have power but the ground is turned on and off to them. So not sure what I should be looking at now

#9 3 years ago

Well, yes, the common braid that chains from socket to socket should always have power but that would be in reference to ground ( like the lock down bar). The single wire to the socket is that bulb's ground and would get grounded by the cpu to turn that bulb on.

I haven't ever had to do this but you could try jumpering the single wire of one if those lamps to ground to see if it lights. That would prove you have power to the sockets with enough current to light a light. You DVM needs almost no current to read voltage.

#10 3 years ago

I just jumped one of the wires to ground and then took leads off and almost all lights are working now...

#11 3 years ago

It had fixed it for about 10 mins now those lights aren't working again

#12 3 years ago

Sorry. I an not understanding what you did with jumper. I wanted you to take a jumper and connect it to the single wire that goes to one of the Dead lights (not the main power braid that chains from socket to socket). And touch the other end of the jumper to the lock down bar (temporarily grounding that one light). That should have made that one light turn on (probably much brighter than normal).

Is that what you did and then all the dead lights came back for a while?

#13 3 years ago

I connected one lead to the wires going into the one side of the socket and then other lead to that ground strap that runs to the string of lights. Then almost all lights started working for like 5 mins and then it went back to just the lights that were working to begin with. I tried to jump it again to see if they would go back on and all playfield lights stopped working. Now game will not start and displays aren't working. On the sound board it looks like one of the resistors blew up. So all I have now is the general illumination and game will not start.

#14 3 years ago

The common braid to the light sockets is not ground, that is phase A or B light power. So if you jumpered a lamp return wire (single wire at a lamp socket) to that common braid, you probably fried one lamp SCR and it may have ultimately blown one of the 8 amp fuses.

#15 3 years ago

Ok it didn't blow any fuses but it blew up a resistor on the sound board. So I will have to replace that and hopefuly the game will be able to run again and then I can figure out the lights

image_(resized).jpeg

#16 3 years ago

Any ideas why they were all working then the first time I jumped the light like that. Almost all the lights on the phase that weren't working before started working and flashing like they were suppose to for like 5-10 mins and was able to play a game and they were all working before they went out and then I jumped a light again and fried something and game would no longer boot on to play and all playfield lights were out including displays. Thanks

#17 3 years ago

No. If you shorted out lamp power to ground, I don't know why it would suddenly start working.

Unplug the sound board and try swapping FU4 and FU5. See if the game will come up.

#18 3 years ago

I unplugged sound board. Checked fu4 and fu5 fuses they are good. I get 7 flashes on led on cpu. The game will not start and only general illumination lights. If I wiggle some of the wiring harnesses going into the boards I can get displays to come on but there in and out and breaking up.

#19 3 years ago

I believe this game uses a lot of IDC style connectors. Also, as I recall, the male headers on the board are the style without any kind of retainer (nothing but solder holding the pins into the pcb). You may have a cold solder to a male pin, and/or, some wires coming out of the V's in the IDC pins in the female connectors.

#20 3 years ago

Yeah I don't know what's going on now. The led on the cpu flashes 7 times when you turn game on. Then it seems like if I push on the power board when game is on it will flash again and then displays will come on but no game. If I wiggle wires and wiggle power board I can get some lights to flash a little on playfield.

#21 3 years ago

Ok so follow up. I got the pinball working again. Replaced some resistors on power board that were bad and replaced resistor on sound board. Also resoldered a point on the power board for one of the connectors that had almost no solder it was in line with one of the fuses for one of the phases for playfield lights. Game is working and have almost all lights working except for about 10 random lights that I believe are transistors that need to be replaced on control board. Another problem I am having is that when you hit a drop target the corespoding card is not staying lit like it's not registering. Any idea how to fix this? Thank you

#22 3 years ago

Well, first you need to go into switch test and verify the drop target switch is being seen by the computer.

Not sure on these 6803 games but earlier Ballys will only show you the lowest switch number currently closed. So you need to make sure you have all targets up, no ball in the outhole and then you should see a flashing 00 indicating all switches are open.

You do know it will only award the card for which suit is currently lit. If you are missing those lamps, it will be hard to tell what card you should be getting.

#23 3 years ago

Yes I know. It seems that the 3 middle targets when hit do not keep the corresponding cards lit that are flashing. The card lights work just not registering right. Is there a switch that needs to be adjusted for that by the drop targets?

Thanks

image_(resized).jpeg

#24 3 years ago

Again, go into switch test and confirm that when you press on the drop target leaf switch, the CPU sees the correct switch. Then, try dropping the target and confirm it triggers the switch.

#25 3 years ago

Ok I so when I go into switch test and I push on j-q-k-a drop targets and they drop it does not register on switch test. Drop target 10 does register but not the rest.

#26 3 years ago
Quoted from Matt3200492:

Ok I so when I go into switch test and I push on j-q-k-a drop targets and they drop it does not register on switch test. Drop target 10 does register but not the rest.

What about when you just use your finger to push the leaf switch for each Drop Target? Do they register then? Have you tried cleaning the points with a business card or carbboard sheet. DO NOT File or flex stone the points. They are gold flashed points and you will destroy them.

#27 3 years ago

Yes they register when you push on the leaf switches. So when the drop targets go down its just not pushing them enough to make contact. It looks like they need to be bent so they make contact.

#28 3 years ago

Ok so I bent the ones that weren't making contact and have them registering right now minus one or 2 that act up intermittently might need to clean contacts. Thanks for your help!

Promoted items from the Pinside Marketplace
$ 13.00
Electronics
Yorktown Parts and Equip
From: $ 16.95
€ 3.95
Flipper Parts
Multigame
$ 137.00
$ 49.95
From: $ 18.00
Apparel - Men
Pinside Shop
$ 14.50
Electronics
PinballElectronics.com
$ 21.00
$ 48.00
Cabinet - Other
ModFather Pinball Mods
$ 24.99
Lighting - Led
Lee's Parts
From: $ 15.00
Electronics
nvram.weebly.com
$ 89.99
Lighting - Led
Lighted Pinball Mods
$ 12.00
Playfield - Decals
Flashinstinct
$ 69.99
Playfield - Toys/Add-ons
Lighted Pinball Mods
$ 18.99
$ 149.00
$ 149.00

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside