(Topic ID: 222645)

Bally Fireball II outhole kicker does not serve ball to shooter alley

By graab

5 years ago



Topic Stats

  • 8 posts
  • 5 Pinsiders participating
  • Latest reply 5 years ago by graab
  • Topic is favorited by 1 Pinsider

You

Linked Games

#1 5 years ago

Hi All. Our beloved Fireball II has grown a glitch - when you turn on machine (passes boot/self test) and add a credit to start a new game the outhole kicker does not fire (serve) a ball in to the shooter alley. If you run through diagnostics all silenoids fire including outhole kicker and all switches pass the test.

Suggestions?

#2 5 years ago

Are your switches that register the balls in the out hole OK? I know it has to recognize all 3 balls to function correctly.

#4 5 years ago
Quoted from pinkid:

Are your switches that register the balls in the out hole OK? I know it has to recognize all 3 balls to function correctly.

All test good at switch and through self test and appear to recognize that balls are there - if you power pb down, remove all 3, power up it recognizes that all are out during boot and will not turn on backbox lights and go to ready state until you drop them in.

The odd thing is that the solenoid fires during self test, but when you hit the credit button to start game/add player it plays the 'ready tune' for the start of the game, but doesn't fire the outhole kicker, but thinks player one is good to go and enables flippers and will rack up points.

My husband says he vaguely remembers there being a specific sequence we had to load the balls in when we first set it up b4 it would recognize the balls as in the ready position, but we've both read the FB2 manual and searched Pinside as well as google and can find no reference to a particular sequence to follow.

G.

#5 5 years ago

Have you checked the fuse under the playfield? It should be located around the flipper mechanisms or thereabouts. I believe it's a 1.5 amp slo-blow. If this fuse is blown, your ball will not be served to the shooter lane.

#6 5 years ago

Since the coil pulls in self test it's not a coil or solenoid driver issue. I would suspect a swich problem but you seem to be all over that.
Since it's not playing the correct sounds it could be a problem with the pin selects.
Try checking the J4 connections on both the MPU and the solenoid driver. Could be a loose wire or a pin needs to be reflowed. start by unplugging the sound board. It could be mucking up the signalling.

#7 5 years ago
Quoted from shock_me:

Have you checked the fuse under the playfield? It should be located around the flipper mechanisms or thereabouts. I believe it's a 1.5 amp slo-blow. If this fuse is blown, your ball will not be served to the shooter lane.

Tested fuse was good, but tried new one, no change in status. Just to be doubly sure swapped for new fuse, still doesn't kick out the ball.

#8 5 years ago
Quoted from BigAl56:

Since the coil pulls in self test it's not a coil or solenoid driver issue. I would suspect a swich problem but you seem to be all over that.
Since it's not playing the correct sounds it could be a problem with the pin selects.
Try checking the J4 connections on both the MPU and the solenoid driver. Could be a loose wire or a pin needs to be reflowed. start by unplugging the sound board. It could be mucking up the signalling.

Yeah have definitely been circling around the switch. We've checked, double checked, verified connection is solid on each, did some basic pm since we were there and had some dust.

Regarding sound, it is working as should and only fails to sound off on boot if balls are not queued, which from all I've read is what it should do. Once you load them in it sings and chirps as it should - as soon as they trigger the switches. So at least the switches function at that base level. Am going to check the jumpers as suggested. We noticed that once the balls are queued and game started not only does it not trigger the solenoid for the outhole, but if you manually bring ball in to the lane and play the ball (scoring and sound effects work appropriately) that when it drains at the end of the turn it doesn't acknowledge the return of the ball. Ran through diagnostic again still not failing on any solenoid, passes all switches, and sound test was fine as well.

Tomorrow is a packed schedule kind of day but hope to check connections to J4 on both boards tomorrow evening.

Thanks for the insight.

G

Promoted items from Pinside Marketplace and Pinside Shops!
2,600 (OBO)
Machine - For Sale
Freeland, MD
From: $ 2.99
2,600
Machine - For Sale
Collegeville, PA
$ 18.95
Eproms
Pinballrom
 
$ 18.00
Electronics
Yorktown Arcade Supply
 
£ 195.00
From: £ 110.00
$ 30.00
Lighting - Led
Pinballrom
 
$ 22.95
Eproms
Pinballrom
 
Hey modders!
Your shop name here

Reply

Wanna join the discussion? Please sign in to reply to this topic.

Hey there! Welcome to Pinside!

Donate to Pinside

Great to see you're enjoying Pinside! Did you know Pinside is able to run without any 3rd-party banners or ads, thanks to the support from our visitors? Please consider a donation to Pinside and get anext to your username to show for it! Or better yet, subscribe to Pinside+!


This page was printed from https://pinside.com/pinball/forum/topic/bally-fireball-ii-outhole-kicker-does-not-serve-ball-to-shooter-alley and we tried optimising it for printing. Some page elements may have been deliberately hidden.

Scan the QR code on the left to jump to the URL this document was printed from.