(Topic ID: 284604)

Bally Fireball ii - Lifted up playfield, will not boot now help please

By CadeDudeNW

3 years ago


Topic Heartbeat

Topic Stats

  • 16 posts
  • 5 Pinsiders participating
  • Latest reply 3 years ago by Guppy1977
  • No one calls this topic a favorite

You

Linked Games

Topic Gallery

View topic image gallery

pasted_image (resized).png
Inkeddamaged braided cable_LI (resized).jpg
under PF (resized).jpg
AS-2518-54 (resized).png
ground strap (resized).jpg
image_2020-12-28_125132 (resized).png
20201227_230724 (resized).jpg
#1 3 years ago

I have had a working fireball ii pin for a few months now. I wanted to replace some lamps, so I replaced one on the top of the playfield (when it was off). Turned it back on, and the lamp worked. I then moved the playfield in the service position to replace more lamps, in that process, it slipped a bit, a little wood chipped. So I carefully put it back in place, and turned it on to make sure everything was ok. (note, the lamp on the top of the playfield was 555 but the one I took out was 444. I realized after the fact.)

When I turn it on, the MPU light turns on, the squawk and talk board makes a quick noise, the scoreboard lights light up, two playfield lights briefly light up and the squawk and talk board LED flashes green for a second. I then noticed a ground strap was not connected to the speaker (pic attached) so I screwed it on to the speaker and used a multimeter to make sure it was grounded. Powered it on, no difference. I checked the bottom of the playfield for damage, I did not see anything. I checked all of the molex connectors to see if anything came loose, no luck. I also re-seated some of them. Where should I go from this point?

Thanks in advance!

20201227_230724 (resized).jpg20201227_230724 (resized).jpg
#2 3 years ago

Hello, I've the same pin, mine is a Bally, it's a very good pinball from this era . Is yours a Bell Games as mentionned in the "Linked Games" section ? Or a Bally ? It may be important for the repair, I don't know if the Bell Game is technically different.

About this :

Quoted from CadeDudeNW:the MPU light turns on,
How many times the green mpu led flashs? It's supposed to blink 7 times.

Check the ground in the backbox? Maybe the screw went loose?

Last thing, it's not clear in my memories, but there is a lamp hidden under the playfield or under the apron. If this lamp is broken or taken off, the pin won't work. I must check this info, but I have to mention it in case you've changed this particular lamp.

image_2020-12-28_125132 (resized).pngimage_2020-12-28_125132 (resized).png
#3 3 years ago

How many flashes of the MPU LED?
If only 6 I'm thinking you accidently shorted the 43v coil bus to ground and that would blow a fuse and stop the game from booting.

#4 3 years ago

Good morning Guppy1977 its a Bally. I accidently set that as one of my pins, I changed it. Good catch. I did not replace any lamps under the playfield. I simply lifted it up. But, I did notice where a lamp missing. I did not see any lamps fall out. BigAl56 On the MPU self test I get one blink followed by 5 rapid blinks, so 6 in total. I will go ahead and make sure none of the fuses blew out.

I attached a photo of the ground strap. It is nice and snug. This is the ground strap, correct? It looks like it is just a braid screwed onto the ground. It is nice and snug. I gave it an inspection to see if it ripped as well.

Also, are the 555 lamps ok to use in place of the 444 lamps? They fit but I do not want to damage anything.

Thanks guys!

ground strap (resized).jpgground strap (resized).jpg
#5 3 years ago

BigAl56 Would the fuse be on this board under the playfield? I looked at them, and none of them look blown (no black tinge and the coils inside appear to be intact.

Thanks

AS-2518-54 (resized).pngAS-2518-54 (resized).png
#6 3 years ago
Quoted from Guppy1977:

it's not clear in my memories, but there is a lamp hidden under the playfield or under the apron. If this lamp is broken or taken off, the pin won't work. I must check this info, but I have to mention it in case you've changed this particular lamp.[quoted image]

If you mean the solenoid expander board lamp, I believe if the bulb was burned out/missing the game would still boot (but after that the game would have problems firing certain coils during play or in solenoid test.)

I would pull the fuses and check for continuity to make sure, can't necessarily tell by their appearance.

#7 3 years ago

The 444 and 555 seems to be the same, except 444 is more resistant to vibration.
http://iobium.com/

Your grounds is correctly screwed.

To test a fuse, you’ll need to get it out from card, then test it with your multimeter.

Quoted from BigAl56:

If only 6 I'm thinking you accidently shorted the 43v coil bus to ground and that would blow a fuse and stop the game from booting.

If a fuse (F4, I think ) is burned and blows again when replaced, check under your playfield, you will probably find the culprit. A unleaded cable, or something touching a metal part, or a coil...

Some usefull reading if needed : http://techniek.flipperwinkel.nl/ballyss/rep/index1.htm#pd

Good work with your FBII

#8 3 years ago

Having owned two of these, check the wiring running on the bottom sides of the PF. It's a tight fit and I had one fail to boot when it got pinched.

#9 3 years ago

Thanks tomdrum if a fuse isn't blown, i'm thinking a pinched cable or a loose connection under the PF may be the case.

One mention though folks, when you lift up the playfield, there is a braided ground cable close to where it slides when you pull it up. that was damaged but not 100%. I saw other parts of the machine that had solder on some parts of the braided cable. Looks like that may have happened and it was repaired that way. I put some soldier on the damaged part of the cable. Its all held in place well, I gave it a gentle jiggle to make sure it was on there good. I tested it with a multimeter and it was ok. But I am not sure if that braided ground cable shorted something out. I circled where I put solder. As you can see, looks like someone else did the same thing. They used a pretty big glob of solder.

tomdrum The cables are a tight fit. Is the cable I circled the ones you were talking about? A multimeter tested the same as you would on a non damaged part so I think I should be good.

Inkeddamaged braided cable_LI (resized).jpgInkeddamaged braided cable_LI (resized).jpgunder PF (resized).jpgunder PF (resized).jpg
#10 3 years ago

****update****

F4 fuse is blown. My eyes apparently are not as efficient as a multimeter when it comes to checking fuses. Lesson learned. I'm hoping I can snag one from home depot instead of having to order one. I miss Radio Shack

Guppy1977 you nailed it.

You guys are both gentleman and scholars. I appreciate the help! ***FIREBALL AWAITS YOU.......*** lol

#12 3 years ago

When I lookup AG fuses, they are fast blow. But this fuse looks like a slow blow. Maybe someone accidently put it in?

E-00133-0005 is the bally part number for the F4 fuse.

http://www.actionpinball.com/parts.php?item=FUSE5A I looked up the bally part number and saw this. Which is a fast blow. The manual for FBii describes the them as AG, which I believe is quick blow. Super confused at this point.

pasted_image (resized).pngpasted_image (resized).png
#13 3 years ago

I put a low blow fuse in there and it fired right up. I just went off of exactly what the documentation asked. Which is 5amp 32 volts. Case closed.

Thanks BigAl56 Guppy1977 tomdrum frenchmarky for your help!

#14 3 years ago

It's confusing in deed.

Here http://techniek.flipperwinkel.nl/ballyss/rep/index1.htm#pd, one can read :

"F4 = 5 amp fast-blo (solenoids, if game has 2 flippers)
F4 = 6 amp fast-blo (solenoids, if game has 3 flippers)
F4 = 7 amp fast-blo (solenoids, if game has 4 flippers)"

So, there would be a mistake in the FB2 manual, it must be a 6 amp fast blow and not a 5 amp fast blow, because it has 3 flippers.

An explanation could be, your 5 Amp Slow Blow you've put in it is more or less equivalent to the 6 amp fast blow recommanded?

Anyway, good job

Have fun with your pin !

#15 3 years ago

Guppy1977 I was pretty tired when I posted. Correction, I put in a 5 Amp 32v fast blow per the fireball ii manual. I have the original documentation. So I went with that. I did see that the whitepaper you sent said 6 Amp fast blow.

Someone had put in a 5 Amp 240v slow blow (the one that I posted). So I was like, whatever, won't hurt to put a fast blow in place, and the documentation says that's what it wants.

I've had it for about 3 months now. Finally serviced it. Sqaulk and talk is recapped and working now, replaced about 20 lamps, all new rubber rings, cleaned the playfield and glass. I play this thing more than my new Stern that is worth 3x more. By far my favorite pin. Last thing I need to do is fix the fireball bonus. That's another rabbit hole I'll be diving into.

#16 3 years ago

Thanx for the correction, I now understand.

About the FBII, I can't agree more, it's a great pinball, as good as the popular Fathom. Centaur may be superior but I never had the chance to play it.

Have fun and stay safe

Reply

Wanna join the discussion? Please sign in to reply to this topic.

Hey there! Welcome to Pinside!

Donate to Pinside

Great to see you're enjoying Pinside! Did you know Pinside is able to run without any 3rd-party banners or ads, thanks to the support from our visitors? Please consider a donation to Pinside and get anext to your username to show for it! Or better yet, subscribe to Pinside+!


This page was printed from https://pinside.com/pinball/forum/topic/bally-fireball-ii-lifted-up-playfield-will-not-boot-now-help-please and we tried optimising it for printing. Some page elements may have been deliberately hidden.

Scan the QR code on the left to jump to the URL this document was printed from.