(Topic ID: 296441)

Bally Eight Ball "ones" digit out on all displays

By poolpin

1 year ago

Topic Heartbeat

Topic Stats

  • 11 posts
  • 4 Pinsiders participating
  • Latest reply 1 year ago by poolpin
  • No one calls this topic a favorite


Linked Games

#1 1 year ago

I'm stepping through my first rebuild as a total noob and I have an issue where each display has no "ones digit"? The odds of all displays being corrupt are pretty great, so i'm thinking MPU. I have re-flowed all MPU board pins, but no joy. Has anyone seen this issue before? The ones digit does flicker faintly, so i'm still thinking its a connector issue... so I will step through that while waiting for some insight.

thanks in advance for any and all input!

#2 1 year ago

yep connector is most likely... it's the very first pin on that connector too, so it gets a lot of stress.

#3 1 year ago

Steves site has a ton of info on the displays and repairing them.....great pop bumper repair info for that Bally too! I printed that section out and have it in a binder - someplace.......


#4 1 year ago

try 'wiggling' J3 on the solenoid driver board....also as you are starting from scratch I suggest doing board upgrades, essentially the solenoid driver.


#5 1 year ago

Thanks for all the leads thus far on this! I tried a little brain storm on MPU J1, figured i'd swap crimp 1 and 2 because they go to ground through the same value of resistor and cap. and lo and behold my ones digits all worked and the tens are all went dark. So next step is replace the resistor at J1 and maybe even the cap.

looking through my resistor stash right now!

I'll update on my progress....

#6 1 year ago

nice work, well done!

1 week later
#7 1 year ago

Back to the drawing board....

After replacing the resistor and cap, my MPU (AS2518-35) refused to boot! Just sat there staring at me with its little green LED eye! So, I pulled it again and ran voltage to it on my bench. Still the no-boot-glow. Next I pulled every socketed chip and cleaned the pins one by one, test powereing each time. That lead me to a 6 flash boot up on the bench. When reinserting the board into the back box and firing it up, I got all of the LED flashes that one would normally expect and then to my shock and horror, the startup chime tune began playing with solenoid accompaniment! So i'm thinking bad chip. Given the original as of yet unresolved "ones digit" display issue, does anyone have a logical guess as to which one (or more) of these chips may be the likely culprit?

#8 1 year ago

if socketed, swap U10 with U11 and see if there is a difference

#9 1 year ago

Rikoshay, Thanks for the suggestion! I did the swap and now have what appears to be normal startup diagnostics and chimes. The displays are now wackier than ever, but I believe that is to be expected seeing how I've been bird-dogging a display issue from the start. I ran the self test through its paces and the lamp test, solenoid test stepped through as expected. The score displays however are now dark on more digits than the "ones". But it seems logical that if i have a corrupt 6821 that display would be a direct symptom at this point. So I have replacements from Big Daddy in my cart as I type this!

Thanks again for the pointers to you and all who have weighed in! I'll post an update when the chips arrive!

2 weeks later
#10 1 year ago

Update for anyone interested...

After chasing my tail swapping U10, U11, then replacing the U9, U10 & U11 chips, the green eye of failure returned. I replaced the socket at U11 and got my start flashes back under the work bench power. So back into the back box with normal sequence of flashes. Alas, no joy for my displays! So long story short, I pulled my -35 back out and pulled the U2 and U6 chips once more for a visual and this time I used a gum eraser/cleaner block combined with magic eraser to clean the pins. This time they came out shinning like new. Popped them back in and applied power at the bench. All good signs, so back into the back box. Fired it up and this time I everything started correctly AND all display digits now have life! Next I will step through the playfield targets to check score value accuracy, but I'm feeling pretty confident at this point.

I will post at least one more update on my progress soon!

4 weeks later
#11 1 year ago

HI All,

At this point I'm going to call this issue resolved, but in observation. I have another issue with points (10 of them) being scored with less than 100 percent sync with flipper action. Either flipper side will do it.

I'll persur this one in another thread.... thanks again to All!

Promoted items from the Pinside Marketplace
$ 45.00
$ 99.00
$ 199.95
From: $ 150.00
$ 25.00
Apparel - Men
Pinside Shop
$ 12.00
Playfield - Toys/Add-ons
UpKick Pinball
From: $ 10.00
Playfield - Protection
UpKick Pinball
$ 179.00
Cabinet - Other
Pinball Pimp
$ 10.00
1,000 (OBO)
Machine - For Sale
Smyrna, GA
$ 69.99
Cabinet - Shooter Rods
Pinball Shark
Shooter rods


Wanna join the discussion? Please sign in to reply to this topic.

Hey there! Welcome to Pinside!

Donate to Pinside

Great to see you're enjoying Pinside! Did you know Pinside is able to run without any 3rd-party banners or ads, thanks to the support from our visitors? Please consider a donation to Pinside and get anext to your username to show for it! Or better yet, subscribe to Pinside+!

This page was printed from https://pinside.com/pinball/forum/topic/bally-eight-ball-ones-digit-out-on-all-displays?hl=poolpin and we tried optimising it for printing. Some page elements may have been deliberately hidden.

Scan the QR code on the left to jump to the URL this document was printed from.