(Topic ID: 187246)

Bally displays acting up

By JReedie

7 years ago



Topic Stats

  • 2 posts
  • 2 Pinsiders participating
  • Latest reply 7 years ago by zacaj
  • Topic is favorited by 2 Pinsiders

You

Linked Games

No games have been linked to this topic.

    #1 7 years ago

    When putting my Xs and Os into the display test I have players 1s display cycling 0s to 9s perfectly. However player 2, 3 & 4 all cycle 0s to 2s and occasionally gets to 3s and then repeats.

    When in attract mode all displays show 00 for the last games scores then player 1s display briefly goes out, all 3 other displays show 2222222

    Then as the current high score to date light comes on player 1s display shows the correct score and the other 3 displays show 230000.

    Any ideas what the problem may be as I'm totally stumped!

    #2 7 years ago

    It sounds like your displays aren't getting the signal for the high bit of the digit from the MPU. Have you reflowed the connector pins on all the displays? Take special note of pin 16 on each display board (connects via R52 to pin 4 of U1).

    Reply

    Wanna join the discussion? Please sign in to reply to this topic.

    Hey there! Welcome to Pinside!

    Donate to Pinside

    Great to see you're enjoying Pinside! Did you know Pinside is able to run without any 3rd-party banners or ads, thanks to the support from our visitors? Please consider a donation to Pinside and get anext to your username to show for it! Or better yet, subscribe to Pinside+!


    This page was printed from https://pinside.com/pinball/forum/topic/bally-displays-acting-up-1 and we tried optimising it for printing. Some page elements may have been deliberately hidden.

    Scan the QR code on the left to jump to the URL this document was printed from.