(Topic ID: 175644)

Bally Centaur - LED Issues

By dtown

2 years ago

Topic Stats

  • 33 posts
  • 7 Pinsiders participating
  • Latest reply 2 years ago by dtown
  • No one calls this topic a favorite


Linked Games

Topic Gallery

One image has been uploaded to this topic. (View topic image gallery).

IMG_0672 (resized).JPG

You're currently viewing posts by Pinsider dtown.
Click here to go back to viewing the entire thread.

#1 2 years ago

Power supply is fixed so, instead of starting a new thread, I changed this one. LED Problems.

I'm working on a Bally Centaur which hasn't been powered on in a long time. Before connecting the boards and playfield I wanted to check the power at the module board in the bottom of the cab. I reflowed all the pins along with replacing the bridges and 5v rectifying diodes. When I switch the game on I get the wall voltage (116v) all the way to the connector leading into the transformer. But, with my black lead on the ground and my red at any of the test points, set to DC, I'm not getting anything. Am I missing something? I added a pic of what I have connected. All the fuses are good too including the one in the tube. I did add a new line cord with the smooth wire at the hot and the ribbed one on neutral but what would that matter if they should be reversed? It's AC voltage anyway. Advice would be appreciated. Thanks.

IMG_0672 (resized).JPG

#3 2 years ago

I wired it just like I have done to the EM's in the past. The cords are from PBR and, I thought, the smooth is the hot and ribbed one is neutral. I matched them up to the outgoing wires from voltage box mounted in the cab. I measured some of the points in the outgoing connectors going into the board. They do change voltage when I flip the power switch but are still low, in the 2v range. Is there a specific point on the transformer I could measure outgoing voltage?

#4 2 years ago

I did switch the leads and it didn't matter. Same results.

#6 2 years ago
Quoted from Billc479:

I know this may sound silly, but verify you have ground going to ground. You should read zero ohms between the ground on the board and the ground braid. I went through something like that on a Bally rectifier board in the head. Someone had cut off the ground braid running from inside of the cabinet to the ground braid in the head, and I could not get anything near the correct voltages on the test points. Basically, there was no ground to the rectifier board, so the voltages were floating.

The ground point and the braid do buzz out as having connectivity BUT I don't have it attached to the head yet because, other than aux lamp driver none of the boards are in there yet. Also, none of the other connectors are hooked up that would connect the head to the cab or playfield. Will any of this cause the problems I'm having? Should I hook up everything and just pull the playfield and backbox connectors from module board and try again?

#8 2 years ago
Quoted from Billc479:

I would at least connect the ground braid from the cabinet to the ground braid in the head and check the voltages again. I don't think you need to hook everything up -when testing my Centaur, I did not have anything hooked up other than the ground braids tied in the head. The high voltage may not seem right until it has a load, at least on mine.

I will try that tomorrow. I had to buy a couple new boards and want to be very careful before running power to them. Especially since I never saw this game run. Two fuses were blown when I got the game. The coil and the display fuses. I'm assuming the coil one blew when somebody misaligned the EOS switch for one of the flippers and it NEVER opened. The display fuse I'm not too sure about other than maybe some shorted glass.

#11 2 years ago

Well, I seemed to have forgotten to check some of the other components on this board. Probably took for granted that if the diodes and resisters looked good, they were. I'm getting a dead short at two of the high voltage diodes, the one small resistor and the smaller cement resistor. I have the diodes but had to order the other parts. I even ordered the large cement resistor because, why not? At this point I might as well have replaced all the components on the module board. I did order a varistor as well although mine looks fine. Don't they turn black or get a hole in them if they blow? Anyway, I was buzzing ground at one of the bridge's AC pin along with the F2 fuse. I'm sure all this has got to be causing an issue. I'll get back after I finish rebuilding the rest of the board.

#12 2 years ago

While waiting on my parts, I thought, "I should still be getting the proper AC voltage at the GI even if I have failed components on the module board." So, I looked at the input plug by the 3A tube fuse just to see if it was wired properly. I compared it to a pic from one of HEP's restorations and found that one of the line voltage in pins was misplaced. It was in the wrong hole. So, I moved it and, voila, now I have the correct power going to the module board. Now, just waiting on the parts to try and finish this problem.

I can understand a lot of issues with a game but I really hate it when somebody fucks up the wiring.

1 week later
#13 2 years ago

Alright, the game is working.

Power Module is completely rebuilt. Every component has been replaced. And, yes, Baraka, I had a varistor that was burning up. I was watching it fry and turn black even though nothing else on the board was causing the issue.

So here's what we got.

A rebuilt power supply
A Squawk and Talk unit with all caps replaced.
A new Say it Again board. I replaced the caps on the old one but it's not working properly and I'm getting a ton of feedback through the speaker while using the old board.
A new MPU
A new Solenoid Driver Board
A new lamp driver Board
All header pins have been reflowed on the older boards including the aux lamp driver and all the display boards.

Existing problems

The lane change lights are not moving. These look like they're controlled by the aux board. The lanes ARE changing but the lights are not corresponding. Changing from LED's are not having any effect. I'm suspecting a blown transistor on the board which I'll check tomorrow BUT will look into any advice given.

Fourth Player Display is not working. Changing the connector from, say, player three has no effect. Am getting proper voltage to the board BUT, I had a feeling that this display was f'd. I can see through the back of it. The glass looks toasted.

Otherwise, the game is working. One thing I learned. Everything needed to be connected with four balls in the trough and one in the outhole for Centaur to start properly.

#15 2 years ago
Quoted from Mk1Mod0:

Not sure about the lane change lights, but if you can see even a little glow inside the 4th player glass than it is likely to be the control chip. If there is no glow at all, it is probably out gassed. Lots of alternatives there if that is the case. As for testing it, fully swap between another player and see that the known working display does work in the fourth player position, not just that the fourth display does not work in another position. That will confirm it is just the display and not anything else.

Tried it. Player 1,2, or 3 work fine with the fourth player connector. Either the board has an issue, which I doubt, or the glass is done. I'm getting proper voltage on the board's test points too.

As far as the lane change lights go, I know they're controlled by the aux lamp board which is the factory one. Also, the sling GI lights are controlled by this board as well. Shouldn't they flash when the slings are activated like the pops do? This is my first Bally game so I'm seeing the differences in that they don't use transistors in the way that Williams did. I tried changing out the LED's in the lane lights along with the slings with 555's and it didn't make a difference. Are the other LED's possibly causing an issue with the lights that are controlled by the aux board?

#17 2 years ago

Ok, so here's the question. Can I try a method I saw Clay Harrell use on a Gamatron where he used resistors for a few lights to get the LED's to work right? I'm just trying to get some of the one's controlled by the aux board to work correctly AND without having to send Alltek another hundred bucks for the aux board as well.

#22 2 years ago
Quoted from HHaase:

An incandescent on one lamp circuit shouldn't be affected by an LED on a different circuit. If an incandescent isn't working right there's an issue causing that problem to manifest.
If you want, I still have an assembled prototype of my LED adapters for the AUX board in Centaur. I'd be willing to send it your way if you want to give it a try. Basically does the resistor trick for you, right at the aux board, plug and play. And if it doesn't help, or you don't need it, it's completely non-permanent. Just yanks right back off.

Ok. So I shoved incandescent bulbs in the three lane change lights along with the two sling "GI's" Once again, I know these are controlled by the aux board because, if I pull the connector on this board, these lights go out. Even with regular bulbs in there, they don't work right. They ARE on but, the slings don't multiplex and the lanes don't move when the flippers are pressed. So, maybe, a chip issue on this board?

#24 2 years ago

Chamber lights 2,3, and 4 will cycle when the star rollovers are closed in front of them. The thumpers do flash on and off when they're actvated. Otherwise they're on. All the lights do work but the slings do not click on and off when fired and the lane change lights do not shut on or off when the the corresponding lane is closed even though the MPU recognizes them as activated.

#26 2 years ago
Quoted from vec-tor:

Chamber #1?bottom???????

Yea. The set closest to the captive ball. They don't strobe with the rest. Don't know if they're supposed to or not.

#29 2 years ago

Thanks for helping. Because I think that video is the easiest to show a problem, I uploaded one of the game during start up. It also shows that only lights 3 and 4 are strobing in the queen's chamber. Also, the issue I'm having with the lane change lights as well as the slings not flashing when activated. The pops work fine.

I do not have a scope to examine chip issues. Only your typical DMM. Let me know if this helps or you need to see something else.

Thanks again

#31 2 years ago
Quoted from vec-tor:

Did you check the back of the board for any cold solder joints?
Make sure you have solid voltages of +5volt and ground.
Make sure all of the data lines have continuity from the main lamp connector.
Make sure Aux lamp strobe has continuity from the CPU A4J1-8
If all connections are good and the voltages are good then
replace MC14013 U1 and see what happens.
Top left lane is the one that is working correctly.
The other rollover lanes should not have been lit when the
game was in game mode. Finally, you did not show the
right slingshot kicker lamp, is it working O.K.
I would also get the MC145558 (QTY2) just in case you
have to replace them also.

The right sling works the same as the left. It flashes during attract mode but just stays on during gameplay. I ordered all three chips for the aux lamp board because they're cheap and i have sockets to use. I'll post again after I get them, along with a new score display, and share the results.

#33 2 years ago

I replaced all three chips on the aux lamp board and socketed them. The rollovers work now as they should as do the queens chambers lights and the slings flash off and on when hit. I don't know which of the chips it was and I did them all at once since they were cheap. Thank you, everyone (especially vec-tor) for your help.

Also, I did get a Pinscore display which I stuck in player one while moving that one to player four. All work now. I looked at the price of a used replacement 7 digit Bally display and it wasn't much less so I just went the LED route.

Promoted items from the Pinside Marketplace
From: $ 155.00
$ 69.95
Cabinet - Shooter Rods
Super Skill Shot Shop
$ 279.95
From: $ 169.95
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
Machine - For Sale
San Leandro, CA

You're currently viewing posts by Pinsider dtown.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside